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Copyright and Trademark 


CCooppyyrriigghhtt  


This manual is propriety information of Impro Technologies (Pty) Ltd.  Unauthorized reproduction of any portion of this 


manual is prohibited.  The content of this manual is for information purposes only and is subject to change without 


notice.  Impro Technologies assumes no responsibility for incorrect information that this manual may contain. 


 


TTrraaddeemmaarrkkss  


Impro and ImproX are registered trademarks of Impro Technologies (Pty) Ltd in South Africa and/or other countries.  


Other brands and products are trademarks or registered trademarks of their respective holders and should be noted as 


such. 
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At a Glance 


 Part 1 – Hardware—provides a limited overview of related Hardware compatible with the 


IXP220 System.  This section also includes a breakdown of the available Hardware 


combinations and System size limits.  


 Part 2 – Software—provides an overview of the IXP220 System, including the basic steps 


for installation and pre-configuration.   


 Part 3 – General Configuration—provides the nuts-and-bolts procedures for IXP220 


Software configuration.  The numbered headings indicate the steps critical to the initial 


configuration as well as the performance sequence.  Everyday tasks are also described in 


detail in this section. 


 Part 4 – Reports—provides an overview of the Reports available in the IXP220 System, the 


application of these to single or multiple Sites, and the basic steps for running the Reports. 


 Part 5 – Advanced Configuration—outlines ―advanced‖ tasks not covered in Parts 1, 2, 3 


and 4.  Much of the information in this Part is not required for everyday configuration. 


 Part 6 – IXP220 Software Modules—Software Modules form the core of the IXP220 


Software and provide control of everyday and other important functions.  Part 6 contains 


information on the various additional Software Modules not covered in Parts 1, 2, 3 and 4. 


 Part 7 – Utilities—contains information on the IXP220 Utilities that let you to perform 


administrative and maintenance tasks for the core IXP220 components. 


 Part 8 – Integration Modules—outlines the steps required when integrating other 


supported systems with IXP220. 
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Introduction 


This manual is intended to assist the installer during the installation and configuration stages of 


the IXP220 System.  It is not designed as an operational manual for the end-user.   


This manual is structured to assist the installer with configuring the basic components of the 


System first, followed by advanced features and functions. 


 


Document Conventions 


The following conventions are used in this document: 


 


 


Note—indicates additional information about a topic 


 


 


Tip—indicates suggestions and alternative methods to perform tasks 


 


 


Important—indicates important information 


 


 


Warning—indicates potential danger to you or the product 


 


Terminology 


The following terminology is used in this document: 


 


IImmpprroo--SSppeecciiffiicc  TTeerrmmiinnoollooggyy  


 IXP220—the commonly used name of the IXP220 Series Software Suite.  The term 


describes an access solution as a whole; it encompasses all Hardware, Software, and third-


party applications. 


 ImproX Hardware—the hardware units comprising an IXP220 System.  The major ImproX 


components are Controllers, Terminals, and Tag Readers. 


 Tag—the passive, proximity component used as a unique identifier in an IXP220 Access 


Control System. 
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CCoouunnttrryy--ssppeecciiffiicc  TTeerrmmiinnoollooggyy  


Different countries use different words to name or describe the same thing.  Table 1 lists the 


International terms and their American equivalents used in this document. 


 


International American British 


Lift Elevator Lift 


Ground/Grounding Ground/Grounding Earth/Earthing 


Tag Card Tag 


Registration Enrollment Registration 


Registration Reader Enrollment Reader Registration Reader 


Screen/Screening Shield/Shielding Screen/Screening 


Table 1 – Area-specific Terminology 


 


 


In some cases, terms are used inter-changeably. 


 


Supported Software and Firmware Versions 


This release of the IXP220 Software Installation Guide applies to the following Impro Software 


and Firmware versions, as well as any later versions that do not affect the contents of the 


Guide.  This Guide will be updated when significant changes occur. 


 


IXP220 Software Suite ................................................................................................ V1.86 


ImproX IXP220 Controller ........................................................................................... V5.00 


ImproX (ISR) IXP220 Registration Interface ............................................................... V1.18 


ImproX (ISR) IXP220 USB Registration Reader ......................................................... V1.18 


ImproX (RS) Registration Interface ............................................................................. V1.18 


ImproX (iTT) Intelligent Twin Antenna Terminal .......................................................... V4.02 


ImproX (iTRT) Intelligent Twin Reader Terminal ......................................................... V4.02 


ImproX (MfT) Multi-function Terminal .......................................................................... V7.24 


ImproX (MDTA) Multi-discipline Time Attendance Terminal ........................................ V1.12 


ImproX (TA) Time Attendance Terminal ...................................................................... V7.26 


ImproX (DBv) 125 kHz Vertical Mount Drop Box ........................................................ V7.18 


ImproX (DBv) 13.56 MHz Vertical Mount Drop Box .................................................... V7.24 


ImproX (LR) Long Range Terminal ............................................................................. V7.16 


ImproX I16 Input Terminal  .......................................................................................... V7.24 


ImproX O16 Output Terminal....................................................................................... V7.24 


ImproX (XFM) Multi-mode 13.56 MHz Remote ........................................................... V3.08 


ImproX (TAR) Time Attendance Remote Reader ........................................................ V3.06 


ImproX Multi-discipline Readers ................................................................................. V2.14 


ImproX B-SHO USB Fingerprint Enrollment Reader .................................................. V1.04 


ImproX B-SHO Fingerprint Terminal ........................................................................... V1.26 


Wiegand 125 kHz Passive Proximity Readers ............................................................ V1.08 
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IXP220 Hardware Components 


ImproX Units for use in an IXP220 System 


IInntteerrffaaccee  DDeevviicceess  


Unit Description Part Number 


ImproX ISR IXP220 Registration Interface ISR901-1-0-GB-XX 


ImproX ISR IXP220 USB Registration Reader ISR900-1-0-GB-XX 


ImproX RS Registration Interface XRS902-1-0-GB-XX 


ImproX RRA 125 kHz Registration Antenna Reader XRR901-1-0-GB-XX 


ImproX RRM MIFARE® 13.56 MHz Registration Remote 


Reader 


XRM901-4-0-GB-XX 


Wiegand Registration 


Reader 


Wiegand 125 kHz Passive Proximity 


Deskmount Registration Reader   


WRR900-1-0-GB-XX 


ImproX MDE Multi-discipline Enrollment Reader MDE900-5-0-GB-XX 


ImproX B-SHO USB Fingerprint Enrollment Reader IBT900-4-0-GB-XX 


ImproX B-SHO USB BioMini Fingerprint Enrollment Reader IBT902-0-0-GB-XX 


 


CCoonnttrroolllleerrss  


Unit Description Part Number 


IXP220 Stand-alone 


Controller 


Controller in the IXP220 System ISC960-1-0-GB-XX 


IPS960-1-0-GB-XX 


IPS961-1-0-GB-XX 


IXP220 System 


Controller 


Controller in the IXP220 System ISC962-1-0-GB-XX 


IPS962-1-0-GB-XX 


IPS963-1-0-GB-XX 


 


TTeerrmmiinnaallss  


Unit Description Part Number 


ImproX LR Long Range Terminal XLR900-1-0-GB-XX 


ImproX MfT Multi-function Terminal XEA931-1-0-GB-XX 


IPS930-1-0-GB-XX 


ImproX iTRT Intelligent Twin Reader Terminal  XRT910-0-0-GB-XX 


XRT920-0-0-GB-XX 


IPS920-0-0-GB-XX 


IPS921-0-0-GB-XX 


ImproX iTT Intelligent Twin Antenna Terminal  XTT910-1-0-GB-XX 


XTT920-1-0-GB-XX 


IPS910-1-0-GB-XX 


IPS911-1-0-GB-XX 


ImproX MDTA Multi-discipline Time Attendance Terminal XTA920-5-0-GB-XX 


XTA291-5-0-GB-XX 
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Unit Description Part Number 


ImproX DBv 125 kHz Vertical Mount Drop Box XDB902-1-0-GB-XX 


XDB903-1-0-GB-XX 


ImproX DBv 13.56 MHz Vertical Mount Drop Box XDB904-4-0-GB-XX 


XDB905-4-0-GB-XX 


ImproX I16 Input Terminal XIT900-0-0-GB-XX 


ImproX O16 Output Terminal XOT900-0-0-GB-XX 


ImproX B-SHO Fingerprint Terminal IBT910-4-0-GB-XX 


ImproX B-SHO Keypad Fingerprint Terminal IBT920-4-0-GB-XX 


 


AAnntteennnnaa  RReeaaddeerrss    


These Readers are also used with other compatible units – see the section entitled Remote 


Reader and Antenna Reader Compatibility. 


  


Unit Description Part Number 


ImproX MMA Mullion Antenna Reader XTT901-1-0-GB-XX 


ImproX MA Micro Antenna Reader XTT902-1-0-GB-XX 


ImproX MHA Metal Antenna Reader XTT903-1-0-GB-XX 


ImproX KHA Metal Keypad Antenna Reader XTT904-1-0-GB-XX 


ImproX KMA Mullion Keypad Antenna Reader XTT905-1-0-GB-XX 


ImproX RA Rod Antenna Reader XTT906-1-0-GB-XX 


ImproX KA Keypad Antenna Reader XTT907-1-0-GB-XX 


ImproX DPA Door Entry Panel Antenna Reader XTT908-1-0-GB-XX 


ImproX CA Conduit Antenna Reader XTT909-1-0-GB-XX 


 


RReemmoottee  RReeaaddeerrss    


These Remote Readers are for use with the ImproX iTRT, ImproX TA and ImproX MfT – see the 


section entitled Reader Compatibility for more information. 


 


Unit Description Part Number 


ImproX MDR Multi-discipline Reader MDR900-5-0-GB-XX 


ImproX MDK Multi-discipline Reader MDK900-5-0-GB-XX 


ImproX XFMp Multi-mode 13.56 MHz Plastic Remote XRT901-4-0-GB-XX 


ImproX XFMpk 
Multi-mode 13.56 MHz Plastic Keypad 


Remote 


XRT902-4-0-GB-XX 


ImproX XFMm Multi-mode 13.56 MHz Metal Remote XRT903-4-0-GB-XX 


ImproX XFMmk 
Multi-mode 13.56 MHz Metal Keypad 


Remote 


XRT904-4-0-GB-XX 


ImproX TAR Time Attendance Remote Reader XTA905-1-0-GB-XX 


 


WWiieeggaanndd  RReeaaddeerrss    


These Wiegand Readers are for use with the IXP220 Controller, the ImproX iTRT, ImproX MfT 


and ImproX RS – see the section entitled Reader Compatibility for more information.  


 


Unit Description Part Number 


Wiegand Plastic Non-keypad 125 kHz Passive Proximity Reader WPR900-1-0-GB-XX 
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Unit Description Part Number 


Wiegand Plastic Keypad 125 kHz Passive Proximity Reader WPK900-1-0-GB-XX 


Wiegand Metal Non-keypad 125 kHz Passive Proximity Reader WMR900-1-0-GB-XX 


Wiegand Metal Keypad 125 kHz Passive Proximity Reader WMK900-1-0-GB-XX 


Wiegand Junction Box 125 kHz Passive Proximity Reader WJB900-1-0-GB-XX 


 


RReecceeiivveerrss  


Unit Description Part Number 


ImproX IR Infrared Receiver ITR900-0-0-GB-XX 


ITR901-0-0-GB-XX 


ImproX RF 4-Channel UHF Receiver UHR903-0-1-GB-XX 


 


OOtthheerr  


Unit Description Part Number 


ImproX OSCAR ImproX OSCAR Door Control Unit IBT930-0-0-GB-XX 


Table 2 – ImproX Units Compatible with the IXP220 System 


 


RReeaaddeerr  CCoommppaattiibbiilliittyy  


Some ImproX units are designed to interface with several types of Readers. Details follow: 


 


Unit Interfaces With 


IXP220 Controller two ImproX Antenna Readers 


or two Wiegand Readers 


ImproX MfT one Third-party hardware device and two ImproX Antenna Readers  


or two ImproX Remote Readers 


or one Wiegand Reader and two ImproX Antenna Readers 


ImproX iTRT two ImproX Remote Readers 


or two ImproX Receivers 


or two Third-party hardware devices 


or two Wiegand Readers 


ImproX iTT two ImproX Antenna Readers 


ImproX TA One Remote Reader  


or one Receiver  


or one third-party hardware device 


or one Wiegand Reader 


ImproX DBv 125 kHz One ImproX Antenna Reader 


ImproX DBv 13.56 MHz One ImproX Remote Reader 


or one ImproX Receiver 


or one Third-party hardware device 


or one Wiegand Reader 


Table 3 – Reader Compatibility 


 


 


Other IXP220-compatible units are under development. 
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Hardware Combinations and System Size Limits 


SSyysstteemm  PPaarraammeetteerrss  


Description IXP220-1 


Single APB Door or 2 
non-APB Door System 


IXP220-2 


4 APB Door System 


IXP220-3 


256 APB Door System 


IXP220-4 


Multi-site System (256 
Doors per Site) 


Total Number of Tags 1 000 2 000 10 000 10 000 


Total Buffered Transactions 100 000 100 000 100 000 100 000 


Sites per System 1 1 1 1 000 


Controllers per Site 1 4 64 64 


Terminal Fixed Addresses per 


Controller 


2 2 2 2 


Terminal Fixed Addresses per 


Door (Location) 


2 2 2 2 


Doors (Locations) per Zone 1 4 32 32 


Zones per Site 1 4 32 32 


Doors (Locations) per Controller 2 4 32 32 


Tags per Tagholder 4 4 4 4 


Tagholder Access Groups (per 


Site) 


64 64 64 64 


Operating Voltage 18 V DC – 32 V DC 


16 V AC – 24 V AC 


18 V DC – 32 V DC 


16 V AC – 24 V AC 


18 V DC – 32 V DC 


16 V AC – 24 V AC 


18 V DC – 32 V DC 


16 V AC – 24 V AC 


Controller Communications Baud 


Rate 


100 Mbps when using 


TCP/IP 


100 Mbps when using 


TCP/IP 


100 Mbps when using 


TCP/IP 


100 Mbps when using 


TCP/IP 


Terminal Communications Baud 


Rate 


NA 38 400 38 400 38 400 


Digital Inputs – per Controller (not 


used for Access Control) 


1 1 1 1 


Digital Inputs – per Controller 


(used for Access Control) 


4 4 4 4 


Onboard Relays – per Controller 3 3 3 3 


Lift (Elevator) Control (per Site) 


(up to 32 floors per Lift (Elevator)) 


NA NA 8 (Unlock Code 


Required) 


8 (Unlock Code 


Required) 


Maximum  Fixed Addresses 


Supported (per Site) 


2  8  512  512  


Maximum Fixed Addresses 


Supported - APB Doors (per Site) 


2  4  256  256  


Host PC Communications RS232, RS485, USB or 


TCP/IP 


RS232, RS485, USB or 


TCP/IP 


RS232, RS485, USB or 


TCP/IP 


RS232, RS485, USB or 


TCP/IP 


Controller Bus Communications No RS485 RS485 RS485 


Terminal Bus Communications No RS485 RS485 RS485 


Input or Output Devices (per Site) NA NA 18 18 


Actions 1 1 300 300 


Tag Registration USB Registration 


Reader or Any Reader 


USB Registration 


Reader or Any Reader 


USB Registration 


Reader or Any Reader 


USB Registration 


Reader or Any Reader 


Maximum Number of Holidays 


(per Site) 


40 40 40 40 
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Description IXP220-1 


Single APB Door or 2 
non-APB Door System 


IXP220-2 


4 APB Door System 


IXP220-3 


256 APB Door System 


IXP220-4 


Multi-site System (256 
Doors per Site) 


Access Time Patterns to each 


Access Group 


8 8 8 8 


Access Groups per Tag 1 1 1 1 


Reason Codes (per Site) 99 99 99 99 


Maximum Number of Tagholder 


Messages  (per Site) 


100 100 100 100 


Maximum Number of Messages 


on Building Management 


150 150 150 150 


Database Firebird 2.1 Firebird 2.1 Firebird 2.1 Firebird 2.1 


Table 4 – System Configuration Parameters 


 


 


IXP220-3 and IXP220-4 Systems are restricted to 10 000 Tags per System regardless of the number of 


Sites.  In addition these Systems are also restricted to 10 000 Tags per Site.  This restriction includes 


Tagholders (Tags) from other Sites with access to the original Site.  In other words, Site A can have up 


to 10 000 Tags, Tagholders from Site B with access to Site A are therefore included in Site A’s total 


Tag count. 


 


 


In IXP220-3 and IXP220-4 the Input or Output Devices (per Site) figure represents the total number of 


input or output devices for use across Lift (Elevator) Control and Building Management. 


 


 


In IXP220-1 and IXP220-2 the Actions figure represents the input and output available on the IXP220 


Controller Printed Circuit Board (PCB).  


 


 


In IXP220-3 and IXP220-4 of the 300 Actions allowed, you may only allocate 100 of these as Time 


Triggered Actions. 


 


 


A Terminal with two Fixed Addresses, such as the ImproX iTT, is treated as two separate Terminals.  In 


the same way, a Terminal with 3 Fixed Addresses (that is the ImproX MfT), is treated as three 


Terminals by the Software. 


 


 


All figures provided are the maximum. In some cases interdependence between parameters; that is the 


maximum number of Zones per Controller depends on how many Terminals are used per Location. 


 


 


Unlock System IXP220-3 for up to 1 000 Sites per System and 8 Lifts (Elevators) using the Multi-site 


and Elevator Control Licences.   


 


USER NOTES 
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USER NOTES 
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Introduction 


This Part of the manual provides an overview of the IXP220 System, and the basic steps 


required for software installation and pre-configuration. 


 


Minimum PC Specifications 


Consider a number of factors when determining the correct PC specifications for different 


scenarios:  


 


 Number of Doors 


 Number of Tagholders supported by the System 


 Whether the Base Application and Firebird Database will reside on the same PC 


 


Description IXP220-1 IXP220-2 IXP220-3 IXP220-4 


Description Single APB Door or 2 


non-APB Door System 


4 APB Door System 256 APB Door System Multi-site System (256 


Doors per Site) 


Processors 


A high performance model 


released within the last 


three months 


1 Desktop Processor 1-2 Server Processor(s) 2 or more Server 


Processors 


2 or more Server 


Processors 


Free Memory 


Available for use by the 


Database Server only 


1 GB 2 GB 4 GB 4 GB 


Free Hard Disk Space 


Needed for Database 


storage, backups and 


archived copies 


80 GB 160 GB 320 GB 320 GB 


Display 


Monitor and graphics 


accelerator 


1 024 x 768 1 024 x 768 1 024 x 768 1 024 x 768 


Operating System 


Validated Operating System 


platforms 


Microsoft Windows 


Server 2008 64-bit. 


Microsoft Windows 7   


32-bit and 64-bit  


(Professional, Enterprise 


or Ultimate); 


Microsoft Windows Vista 


32-bit ONLY (Business or 


Ultimate); 


Microsoft Windows XP 


32-bit ONLY 


(Professional)   


Microsoft Windows 


Server 2008 64-bit. 


Microsoft Windows 7   


32-bit and 64-bit  


(Professional, Enterprise 


or Ultimate); 


Microsoft Windows Vista 


32-bit ONLY (Business or 


Ultimate); 


Microsoft Windows XP 


32-bit ONLY 


(Professional)   


Microsoft Windows 


Server 2008 64-bit. 


Microsoft Windows 7   


32-bit and 64-bit  


(Professional, Enterprise 


or Ultimate); 


Microsoft Windows Vista 


32-bit ONLY (Business or 


Ultimate); 


Microsoft Windows XP 


32-bit ONLY 


(Professional)   


Microsoft Windows 


Server 2008 64-bit. 


Microsoft Windows 7   


32-bit and 64-bit  


(Professional, Enterprise 


or Ultimate); 


Microsoft Windows Vista 


32-bit ONLY (Business or 


Ultimate); 


Microsoft Windows XP 


32-bit ONLY 


(Professional)   
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Description IXP220-1 IXP220-2 IXP220-3 IXP220-4 


Database Server 


Supported Database 


platforms 


Firebird 2.1 Firebird 2.1 Firebird 2.1 Firebird 2.1 


Table 1 – Minimum PC Specifications 


 


 


The volume of transactions per Site affects the performance of the Database Server PC.  Adjust the 


specification allowing for rapid Database growth and Reports that work with large result sets. 
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IXP220 Applications 


The IXP220 Software incorporates a collection of Modules and Utilities.  The Modules form the 


core of the IXP220 Suite and provide control for everyday and important functions.  The Utilities 


provide support for advanced configuration and system maintenance.  This section provides a 


brief description of IXP220‘s Modules and Utilities. 


 


IXP220 Modules 


BBaassee  AApppplliiccaattiioonn  MMoodduullee  


The Base Application is the communication, configuration and Tag enrollment module for the 


IXP220 Software.  This user-friendly Module, allows for systematic installation and configuration 


of the System using wizards where possible.    


 


The IXP220 Base Application performs a number of important functions including: 


 


Communication 


 Monitors the Database for edits made by for example, the Base Application and the Web 


Enrollment Module.   


 Communicates details of all changes or edits made to the relevant Controllers. 


 Polls the Controllers for transactions, then logs the transactions to the Database. 


 Runs the web server. 


 Opens socket connection ports for Modules such as ImproTouch (which make a direct 


connection to the Base Application). 


 


Site and Host configuration 


 Auto-ID—reports detected Hardware to the IXP220 System Software, and configures the 


Hardware for communication purposes. 


 Site Configuration—allows configuration of your site. 


 Controller Configuration—allows configuration of the installed Controllers. 


 Door Configuration—allows configuration of the installed Terminals. 


 Access Group Configuration—the key element of access control, this setting allows 


configuration of when (Access Time Patterns), and where (Areas) Tagholders have access. 


 Tagholder Configuration—allows configuration of Tagholder details. 


 Holiday Configuration—allows configuration of Holidays affecting your site. 


 Reason Code Configuration—allows configuration of Reason Codes. 


 Message Configuration—allows configuration of personalised messages. 


 Batch Tag Registration Configuration—allows enrollment and configuration of batches of 


Tags. 


 Input and Output Devices Configuration—allows configuration of Input and Output 


devices connected to your IXP220 System for use in Building Management. 


 Actions Configuration—allows configuration of event driven or time triggered actions for 


use in Building Management. 
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The Base Application is a ―scaled‖ software suite, therefore, features ―unlock‖ based on the 


unlock codes (feature licences) purchased.  The Base Application Unlock Code options include 


the following: 


 


 Support for up to 256 doors 


 Multiple Site support 


 


WWeebb  EEnnrroollllmmeenntt  MMoodduullee  ((GGeenneerraall))  


This Module requires an unlock (Web Tagholder Enrollment License) and has a maximum of 50 


seats.  It is intended for use by an operator using a PC at a location remote from the System‘s 


Base Application (Host PC).  This Module requires no extra IXP220 software installation, simply 


installing Java Runtime Environment V1.60 Update 20 or above allows any member of your staff 


(provided they have a valid username and password) access to the Module.     


 


The Module‘s basic function is enrolling Tags so employee Tagholders may access selected 


areas at named times.  As this is an enrollment Module, each PC running the Module must 


connect to a Registration Reader.  The benefit of running this now entirely web-based Module is 


less bandwidth usage promoting improved network speed.  You may use the Web Enrollment 


Module with Windows® Internet Explorer 8 (and above) or alternatively Firefox 3 (and above).   


 


WWeebb  EEnnrroollllmmeenntt  MMoodduullee  ((VViissiittoorr))  


This Module requires an unlock (Web Visitor Enrollment License) and has a maximum of 50 


seats.  It is intended for use by an operator using a PC at a location remote from the System‘s 


Base Application (Host PC).  This Module requires no extra IXP220 software installation, simply 


installing Java Runtime Environment V1.60 Update 20 or above allows any member of your staff 


(provided they have a valid username and password) access to the Module.     


 


The Module‘s basic function is enrolling Tags so visitor Tagholders may access selected areas 


at named times.  As this is an enrollment Module, each PC running the Module must connect to 


a Registration Reader.  The benefit of running this now entirely web-based Module is less 


bandwidth usage promoting improved network speed.  You may use the Web Enrollment 


Module with Windows® Internet Explorer 8 (and above) or alternatively Firefox 3 (and above).   


 


IIXXPP222200  RRiicchh  CClliieenntt  MMoodduullee  


The IXP220 Rich Client Module lets you configure Doors (Locations) and Tagholders from a 


separate PC (not running the IXP220 Base Application).  In theory, you would use this Module 


where you need feature flexibility not offered by the Web Enrollment Module.  These instances 


could include but are not limited to:  


 


 During Biometric enrollment. 


 Where you need to change Door (Location) configuration patterns (on a PC away from the 


Base Application) without stopping the IXP220 Base Application. 


 


TTrraacckkeerr  MMoodduullee  


The Tracker Module keeps you advised as to the whereabouts of selected Tagholders 


(maximum 10 Tagholders per site) as they move about the Site.  Alternatively, you may use the 
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Tracker Module to monitor events at a selected Reader (maximum 10 Readers per Site).  Both 


these facilities allow for better end user site management, by displaying the 20 transactions for 


today only, in time order per your group (Tagholders or Readers) selected.    


 


  


In instances where a single Tagholder (Reader) returns more transactions than others it may happen 


that some Tagholders (Readers) do not appear in the list of transactions.  It must be emphasized that it 


is the most recent 20 transactions for the group, not the most recent for each individual Tagholder.  


Achieve best results with this Module by narrowing your range for monitoring to your exact 


requirements.    


 


On opening, the Tracker Module remains discreetly minimized as an icon in the System Tray 


(Notifications Area).  As Tracker receives Tagholder transactions or events from Monitored 


Readers, notification pop-up windows display in the Notification area. 


 


By default the Tracker Module refreshes every 10 seconds, this is the recommended setting.  


The refresh rate is, however, user configurable where you need a faster or slower refresh rate. 


 


VViissuuaall  DDoooorr  CCoonnttrrooll  MMoodduullee  


The Visual Door Control Module CCTV integration solution allows for better end user site 


management.  In areas with rising crime, the operator can from a safe location monitor and 


control up to 4 Doors (Locations) (4 Cameras) at a time, per site. 


 


The Module also allows tracking of up to 30 Tagholders at a time on a per site basis.  The 


Tagholder monitor refreshes every 5 seconds giving you a near real time Tagholder tracking 


solution. 


 


You may use the Visual Door Control Module with Windows® Internet Explorer 8 (and above) or 


alternatively Firefox 3 (and above).  The Module is designed for use with the Axis 210 and 213D 


range of cameras.  


 


IImmpprrooTToouucchh  MMoodduullee  


The ImproTouch Module requires an unlock (ImproTouch License) and has a maximum of 1 


seat.  This Module facilitates the integration and configuration of various third-party Biometric 


Readers for use with the IXP220 Software.  These systems currently include various Sagem 


Fingerprint Readers integrated with the IXP220 Software via the Biometric Server Software.  


The Server Software also allows for the direct enrollment (registration) of Tagholders and 


related biometric data at those Biometric Readers from within the IXP220 Software. 


 


The introduction of biometric access control greatly increases the access control capabilities of 


IXP220 Systems where you need extra security measures.    


 


CCaarrdd  DDeessiiggnneerr  MMoodduullee  


The Card Designer Module requires an unlock (Card Designer License) and has a maximum of 


1 seat.  This Module lets you design templates for use with Credit Card Tags.  These templates 


can then be used to print information on to these Tags, such as company name, Tagholder‘s 


name, ID number, employee number, department, barcode, and so on, as well as a photograph 


of the Tagholder.   
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WWeebb  RReeppoorrttss  MMoodduullee  


The IXP220 Software lets you compile Reports on functions and transactions within the IXP220 


System.  As these Reports are essentially Web Reports, so you can compile Reports for one or 


more Sites over LAN or WAN networks.  The Reports Software allows selection of single or 


multiple Sites, allowing management of both.   


 


Filters readily displayed on the screen, let you select parameters for running your Report.  


These filters may consist of information fields (occasionally), drop-down menus, checkboxes or 


calendars.   


 


WWeebbssttoorree  MMoodduullee  


The Webstore Module allows for the on-line purchase of unlock codes that provide added 


software features and hardware functionality. 


 


The Hardware System 2 Upgrade upgrades your IXP220 Controller from a Stand-alone 


Controller (with a locked Terminal Bus), to a System Controller.  As a System Controller, you 


have support for up to 32 Anti-passback doors (dependent on your System type).      


 


The Software unlock facility enables purchase of the following feature licenses (for use with 


System 3 and System 4 only):   


 


 Web Tagholder Enrollment License 


 Web Visitor Enrollment License 


 Impro-Touch License 


 Multi-site License 


 Card Designer License 


 Elevator Control License 


 Input/Output Control License 


 Notification License 


 


IXP220 Utilities 


DDiissccoovveerryy  UUttiilliittyy    


This Utility allows the following actions: 


 


 Detection of Controllers on the network. 


 Detecting of IP Terminals (Door Controllers) on the network. 


 Configuration of the network address settings. 


 Configuration of the Controller‘s settings. 


 Configuration of the Terminal‘s settings. 


 


UUnniivveerrssaall  DDaattaa  EExxppoorrtteerr  UUttiilliittyy  


The Universal Data Exporter Utility lets you extract transaction (including time and attendance) 


records from the IXP220 Database for use by third-party applications.  The Exporter Utility 


makes use of user defined templates (created in Design Mode) that specify the data for 


extraction and the export format.   
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Using the Run Mode, you have the choice of exporting the records interactively or as scheduled 


(using Windows® Scheduler).  Command line arguments specify the Mode and other 


parameters. 


 


On installation of the IXP220 Software V1.80 (and upwards), two additional Utility shortcuts 


appear on the Programs Menu.  These are Universal Data Exporter (Designer) (used for 


Design Mode) and Universal Data Exporter (used for Run Mode).    


 


 


This Utility requires advanced knowledge of SQL.   


 


AAuuttoommaattiicc  DDaattaabbaassee  UUppggrraaddee  UUttiilliittyy    


After completing the login action, the Automatic Database Upgrade Utility checks the IXP220 


Database version.  If the Utility confirms the IXP220 Database is older than that needed by the 


IXP220 Software, a Warning dialog tells you an upgrade is needed.  If you do not upgrade the 


Database immediately, the IXP220 Software closes. 


 


DDaattaabbaassee  CCoonnvveerrssiioonn  UUttiilliittyy  


The Database Conversion Utility converts existing IXP120 or IXP200 Databases for use in 


IXP220.  The Conversion Utility uses the same ImproX RS constraints as the IXP220 Software 


itself.  This means the Utility checks for an ImproX RS and then checks the IXP220 System 


itself, confirming the number of allowed Tagholders and so on.   


 


Note, the Utility does NOT move information such as Doors (Locations), Terminals, Controllers 


and so on.  The Utility does move information such as Tagholder details, Tag information, 


Holidays, Messages, Reason Codes, Door Mode Patterns, Access Groups and Access 


Patterns.  Therefore, at start-up, perform an Auto-ID of your Hardware and configure and link 


Doors (Locations) to Access Patterns. 


 


FFiirrmmwwaarree  UUppggrraaddee  UUttiilliittyy  


The Firmware Upgrade Utility lets you perform the following actions: 


 


 Identify Firmware versions of connected Hardware. 


 Selection and configuration of Communications Port. 


 Ping the connected Hardware (provides confirmation that Hardware is connected and 


working). 


 Perform in-field Firmware Upgrades to connected Hardware. 


 


IIBBCCoonnssoollee  UUttiilliittyy  


IBConsole is a third-party database configuration and administration tool.  You can use 


IBConsole to perform advanced configuration and administration tasks on the IXP220 


Database. 
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TTrraannssllaattee  UUttiilliittyy  


This Utility facilitates changing field names in the Database to another language.  The Utility 


requires that you manually enter the replacement text.  


 


DDaattaabbaassee  AArrcchhiivvee  UUttiilliittyy  


This Utility lets you archive transactions (Normal, Status and Alarms), placing the transactions in 


a separate archived Database.  We recommend that you run the Archive Utility on a regular 


basis.  Running the Utility regularly keeps your Database below the maximum recommended 


database size of 2 GB.  This action has the following major benefits: 


 


 Manages the size of the Database, freeing up space on the PC. 


 Keeps a cleaner, uncluttered Database. 


 Keeps Database performance at optimum speed. 


 


DDaattaabbaassee  PPuummpp  UUttiilliittyy  


The Database Pump Utility lets you flush out and correct a ―muddled‖ or overloaded Database.  


When executed, the Pump takes ALL data and pumps this into a fresh Database. 
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IXP220 Network Specifications 


The IXP220 Suite is designed to run over a network in Client-Server Mode.  However, it can 


also run successfully on a single PC. 


 


Architecture 


CClliieenntt--SSeerrvveerr  


Client-Server architecture consists of users‘ PC‘s (Clients) connected via a network to a central 


host (Server).  In most situations, Client PC‘s are workstations that access files or databases, or 


applications running on one or more Servers. 


 


In IXP220, the following are Server components: 


 


 IXP220 Base Application 


 Database 


 


The rest of the applications are Client components. 


 


SSooffttwwaarree  CCoonnnneeccttiioonn  RReellaattiioonnsshhiippss  


Figure 1 shows the relationship between the IXP220 Database and IXP220 Client applications.   


 


Socket connections enable communication between PC‘s.  Database connections enable 


communication between PC‘s and the IXP220 Database.  Jaybird is an interface component 


installed with IXP220, facilitating database interaction. 


 


NNeettwwoorrkk  HHaarrddwwaarree  


An IXP220 compatible network requires the following hardware: 


 


 CAT5 or CAT6 UTP cabling 


 100 Mbps or faster, TCP/IP enabled Network Interface Cards (NICs) 


 


RRoouutteerrss  


If routers or switches are used, they must conform to the following: 


 


 TCP/IP protocol 


 100 Mbps or faster 
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Figure 1 – Software Connection Relationships Diagram 


 


IXP220 Modules in a Network Environment 


The IXP220 Software is designed to run over a network in Client-Server architecture.  However, 


all Modules can run on a stand-alone PC.  The following components are important when 


running IXP220 over a LAN or WAN: 


 


 IXP220 Database 


 Firebird Database Server 


 IXP220 Base Application 
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IIXXPP222200  DDaattaabbaassee  


By default, IXP220 uses a Firebird Database.  Firebird installs with the IXP220 Software, during 


the software installation process.  The default location for the Database is as follows: 


 


 C:\IXP220\Database\DB220.FDB 


 


 


DB220.FDB is the name of the database file. 


 


 


Firebird is an open-source product—it has no licensing fee.  For more information refer to the following 


websites: http://www.opensource.org and http://www.firebirdsql.org/. 


 


FFiirreebbiirrdd  SSeerrvveerr  


Firebird Server is a Database Server program that facilitates connections between the IXP220 


Database and the IXP220 Base Application. 


 


 


Install Firebird Server on the same PC as the IXP220 Database. 


 


IIXXPP222200  BBaassee  AApppplliiccaattiioonn  


The IXP220 Base Application functions primarily as a Communication Server.  It performs the 


following functions: 


 


 Retrieves transactions from IXP220 Controllers. 


 Facilitates configuration of the IXP220 System. 


 Monitors the IXP220 Database for changes. 


 Communicates Database changes to the IXP220 Controllers. 


 Runs the Web Server. 


 


The Web Enrollment and Web Reports Module process and report information real-time.  To 


do this, they use TCP/IP socket connections to connect to the Base Application.  


 


Socket connections are also used to send messages to the Base Application.   


 


General Network Requirements 


The following requirements are essential for IXP220 to operate over a network: 


 


 Network hardware must support the TCP/IP protocol. 


 The network must support 100 Mbps bandwidth or greater. 


 


  



http://www.opensource.org/

http://www.firebirdsql.org/
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Running IXP220 across a LAN 


Figure 2 illustrates the network configuration for running IXP220 Software across a Local Area 


Network (LAN). 


 


 
Figure 2 – IXP220 Configuration across a LAN 
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Running IXP220 across a WAN 


Figure 3 illustrates the network configuration for running IXP220 Software across a Wide Area 


Network (WAN). 


 


 
Figure 3 – IXP220 Configuration across a WAN 


 


 


Communication across a WAN is generally slower than across a LAN.  Therefore, carefully 


assess your WAN before implementing IXP220. 
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MMiinniimmuumm  WWAANN  RReeqquuiirreemmeennttss  


The Base Application and the Controllers (the Base Application communicates with) need a 


minimum throughput of 1 MBps.  For example, a WAN capable of 2 MBps bandwidth, must 


assign at least 1 MBps for exclusive use by the Base Application and Controllers. 


 


Properties Files 


The IXP220 Base Application stores its connection settings in editable text files called 


Properties Files.  These files contain URLs that specify the location of the Database Server.  If 


the URL is incorrect, the application will not function. 


 


Configuring IXP220 Modules for a Stand-alone (Single PC) System 


This section provides the requirements for installing all IXP220 Modules, including the Database 


Server, on a single PC. 


 


CCoonnnneeccttiinngg  ttoo  tthhee  DDaattaabbaassee  


The IXP220 Suite installs by default to C:\IXP220.  The URL in the Base Application‘s 


Properties File points to the following default Database location: 


 


 C:\IXP220\Database\DB220.FDB 


 


 


If you move the Database to another location on the PC, you must change the URL in the Properties 


file to point to the new Database location.   


 


 


For security reasons, we recommend that you do not share the Database folder. 


 


The following extract shows the default format for the Database URL: 


 


ixp220.database.Interbase.URL.0=C:/IXP220/Database/DB220.FDB 


 


If you move the Database, you must update this URL to reflect the new location.  For example, if 


you move the DB220.FDB file to a folder called Site1 on drive D, you must change the URL to 


the following: 


 


ixp220.database.Interbase.URL.0=D:/Site1/DB220.FDB 


 


 


If you install other IXP220 Applications on the Database Server, the URLs in each Client 


Properties File must use a local path (for example “Localhost”), not a network path. 


 


Configuring IXP220 Modules for a LAN (Firebird) 


If you distribute IXP220 Modules across a LAN, at the IXP220 Logon dialog, edit the Server 


Name and Database URL accordingly.  Modifying these fields automatically modifies the 


Properties file. 
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Configuring IXP220 Modules for a WAN 


Running IXP220 across a WAN is similar to running IXP220 across a LAN.  However, WANs 


generally have slower performance.  IXP220 has options to minimize the resources required by 


a slower-than-usual architecture. 


 


AAddvvaanncceedd  BBaassee  AApppplliiccaattiioonn  SSeettttiinnggss  


Figure 4 shows the Communications Configuration Dialog.   


 


 
Figure 4 – Communications Configuration Dialog 


 


Edit the following settings as required to compensate for the Base Application running across a 


WAN: 


 


 Timeout (Controller)—is the duration for which the Base Application waits for a reply from 


a Controller.  Increase this if using a WAN, a slow connection, Radio Modems, and so on.  


(For example, use a setting of 5 000 for EtherPADs).  Also increase this setting if you 


receive many ‗Controller Timeout‘ messages. 


 Drop Time (Controller)—the duration for which the Controller will be dropped if it times out.  


This setting rarely requires changing. 


 Additional Timeout (Controller)—an extra timeout value for increasing timeouts on the 


Controller bus.  Increase this when fast polling Controllers across a WAN, a slow 


connection, Radio Modems, and so on.  (For example, use a setting of 500).  Ideally, 


disable fast polling for a WAN, a slow connection, Radio Modems, and so on. 


 Additional Timeout (Terminal)—an extra timeout value for increasing timeouts on the 


Communication bus.  Set this when Terminals are on a different network to the Controller. 


For example, when a controller connects to a Terminal across a WAN. 


 Inter Poll Delay—the delay between successive polls.  Use this to poll less often thus 


reducing network traffic over EtherPADs on a WAN (for example, use a setting of 2 000). 


 IC Port—displays the inter-controller communications port number, that is the port used 


when controllers communicate with one another. 


 







Part 2 – Software 


20  February 2012 


 Respond Address—displays the IP Address the IP Terminals use to communicate with the 


Controller. 


 


Figure 3 on page 17 illustrates a possible IXP220 Configuration where a second site is 


connected via a WAN.  In this type of scenario, it is important to determine how much bandwidth 


is available to the Base Application Server.  If resources are limited, we recommend editing the 


advanced Base Application settings to further reduce the bandwidth that IXP220 requires to 


operate efficiently. 


 


Using Routers Configuration 


The following factors affect bandwidth when a router is used: 


 


 Number of hardware devices configured in the Base Application. 


 Number of Tagholders. 


 Existing WAN load usage. 


 Number of IXP220 client applications that access data via a router. 


 


RRoouutteerr  CCoonnffiigguurraattiioonn  


WAN routers must enable pass-through communication on the port that the Database Server is 


using for connection.  This is essential if the router has a built-in firewall. 


 


FFiirreebbiirrdd  PPoorrtt  


Firebird uses Port 3050 by default.  Therefore, ensure that WAN routers have TCP/IP enabled 


for network traffic sent to Port 3050. 


 


BBaannddwwiiddtthh  RReeqquuiirreemmeennttss  


Every IXP220 installation will have different bandwidth requirements.  For example, a Base 


Application that uploads 200 Tags to a single Controller can do so through a 64 k ISDN line.  


However, a Base Application that has to upload 5 000 Tags to five Controllers needs at least a 


768 k dedicated ISDN line.   


 


It is impossible to specify the exact requirement for a WAN.  However, we recommend a 


minimum WAN connection bandwidth of 1 MBps.  For optimal performance across a WAN, we 


advise you to consider a connection with at least 2 MBps of bandwidth. 


 


 


Perform bandwidth-intense activities such as uploading Tag data to Controllers after-hours, thereby 


reducing network load during normal hours. 
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System Concepts 


System Architecture Concepts 


An IXP220 Access Control System comprises the following elements: 


 


 Sites 


 Controllers 


 Doors (Locations) 


 Zones 


 


The IXP220 System Architecture is illustrated elsewhere in this Manual. 


 


Sites 


Each System consists of one or more Sites.  Sites are independent of each other.  Each Site 


can have only one Host.  The Host is the Base Application Module for a particular Site. 


 


CCoonnttrroolllleerrss  


An IXP220 Site supports up to 64 IXP220 Controllers.  Each Controller supports up to 64 


Terminals (Fixed Addresses). 


 


DDoooorr  ((LLooccaattiioonn))  


A Door (location) is a physical access control point.  It comprises a group of Terminals servicing 


an access control point.  A Door (location) supports up to two Terminals for the following 


functions. 


 


 Door Entry 


 Door Exit 


 


ZZoonneess  


A Zone is a group of Doors (Locations - access control points).  Entry and exit to and from a 


Zone is achievable via its Doors (Locations) only.  Generally, a Zone is a physically bounded 


area containing one or more Doors (Locations). 


 


System Building Blocks 


IIXXPP222200  SSooffttwwaarree  SSuuiittee  


The IXP220 Software Suite is designed to run on Microsoft Windows® XP (Professional), Vista 


(Business or Ultimate) and 7 (Professional, Enterprise or Ultimate).  These limitations are 


important for the efficiency and reliability of the System. 
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SSuuppeerrvviissoorryy  EElleemmeennttss——HHoosstt  PPCC  


Each Site requires a Host PC for control and supervision of the Site.  Alternatively, multiple PC‘s 


can be used for the same function. 


 


On a typical Site, the following functions are performed by the Host PC: 


 


 Database Server—dedicated to the Site Database. 


 Base Application—dedicated to processing communications between the Database Server 


and the Controllers.  It also performs a polling function from the Server to the Controllers. 


 Client Workstation—dedicated to supervisory aspects.   


 


SSyysstteemm  BBuusseess  


The IXP220 System offers a choice of the following system busses: 


 


 TCP/IP Bus—links the System Controller and Host PC to the LAN or WAN.   


 USB—links the System Controller to the Host PC.   


 The Controller Bus—this RS485 bus links the System Controller to the Host PC. 


 The Terminal Bus—this RS485 bus connects each Controller to its Terminals.  There is 


one Terminal Bus per Controller, with support for up to 64 Fixed Addresses. 


 


SSeerriiaall  PPeerriipphheerraall  PPoorrttss  


Some hardware units have an RS232 Serial Peripheral Port.  They can be connected to a single 


peripheral device. 


 


PPeerriipphheerraall  HHaarrddwwaarree  


IXP220 uses the following peripheral hardware devices to perform Tagholder registration and a 


Software unlocking function.   


 


 Device Description 


 


The ImproX (ISR) IXP220 Registration Interface allows 


registration of 125 kHz and Mifare® (13.56 MHz) Tags into the 


IXP220 System using a third-party reader. 


 


The ImproX ISR connects direct to the PC and is powered by 


USB.   


 


The ImproX (ISR) IXP220 USB Registration Reader allows 


for Web-based enrollment or Base Application (in Systems 


IXP220-3 and IXP220-4) enrollment of 125 kHz Tags. 


 


This Registration Reader does not support Impro Standard 


Tags or third-party Tags. 


 


This external Registration Reader connects direct to the PC 


via USB.   
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 Device Description 


 


The ImproX (RS) Registration Interface performs as follows: 


 
 Stores Hardware and Software license information. 


 Reads 125 kHz Tags when used with the ImproX (RRA) 


Registration Antenna Reader, (XRR901-1-0-GB-XX). 


 Reads MIFARE® 13.56 MHz Tags when used with the 


ImproX (RRM) Registration Remote Reader         


(XRM901-4-0-GB-XX). 


 Reads Wiegand Tags when used with the Wiegand 


Registration Reader (WRR900-1-0-GB-XX). 


 


The ImproX RS connects direct to the PC and is powered via 


USB.   


 


The ImproX (MDE) Multi-discipline Enrollment Reader 


allows for Web-based enrollment or Base Application (in 


Systems IXP220-3 and IXP220-4) enrollment of 125 kHz and 


13.56 MHz frequency Tags. 


 


This external Registration Reader connects direct to the PC 


via USB.   


 


The ImproX B-SHO USB Fingerprint Enrollment Reader 


and ImproX B-SHO BioMini USB Fingerprint Enrollment 


Reader are external enrollment readers that connect direct to 


the USB Port of the PC.   


 


These Enrollment Readers allow for registration of 


fingerprints for use by ImproX B-SHO Fingerprint Terminals.  


For more information on the use of these products with the 


IXP220 System, refer to Part 8 – Integration Modules. 


Table 2 – Peripheral Hardware 


 


 


Both the ImproX MDE and ImproX RS are supported on a single IXP220 system. 


 


 


 


 


 


 


 


 







Part 2 – Software 


24  February 2012 


Software Installation Procedure 


 


The IXP220 Software does NOT support Windows® 95, 98, 2000 or NT.   


 


 


Windows® Vista users must disable the User Account Control before installing the IXP220 Software.  


Disable the control as follows: 


 


1. Select Start>Control Panel. 


2. Select the User Accounts icon. 


3. Select the Turn User Account Control On or Off option. 


4. Deselect the Use User Account Control (UAC) to Help Protect Your Computer option. 


5. Click the OK button. 


6. Click the  button. 


 


 


Log on to Windows® with Administrator privileges to install the IXP220 Software. 


 


New IXP220 Installation 


The IXP220 Software Suite is supplied on an installation CD-ROM.  Before you install it, ensure 


you have read the following: 


 


 
Figure 5 – IXP220 Software Installation Flowchart 
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PPCC  HHaarrddwwaarree  RReeqquuiirreemmeennttss  


Refer to the section Minimum PC Specifications on page 5. 


 


IInnssttaallllaattiioonn  SSeeqquueennccee  


The IXP220 Installation CD uses an automated, interactive Installation Wizard to guide you 


through the installation process.  The Wizard prompts you at various stages to select installation 


options.  This makes it possible to customize the IXP220 Software Suite.   


 


Install the IXP220 Software in the following sequence: 


 


1. Database Sever—this is ESSENTIAL.  Refer to the section, Installing the Database Server 


below.  


2. Applications—Modules and Utilities. 


3. Database—installed with the Base Application. 


4. USB Driver—only required if your System makes use of USB Enrollment Readers or 


Controllers. 


 


Installing the Database Server 


 


 


A Database Server is required to host the IXP220 Database.  If you install the IXP220 Software to 


a single PC, the Database Server installs automatically.  However, if using more than one PC to 


host the IXP220 Software, install the Database Server manually. 


 


 


Firebird automatically prompts to install, if a previous version is not detected. 


 


Any PC on the network can host the Database Server.  IXP220 uses Firebird 2.1 as its 


Database Server.  To install Firebird manually, proceed as follows: 


 


IInnssttaalllliinngg  FFiirreebbiirrdd  


1. Select a PC to host the Database Server.  


2. Insert the IXP220 Installation CD in the PC‘s CD-ROM drive. 


3. Browse to the \database\firebird directory on the IXP220 Installation CD. 


4. Double-click Firebird.exe. 


5. In the Select Language Setup dialog, from the drop-down menu, select your preferred 


language. 


6. Click the OK button. 
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Firebird Installation Wizard 


1. At the Welcome dialog, review and follow the on-screen instructions.  


2. Click the Next button. 


3. At the Licence Agreement dialog, select the I Accept the Agreement radio button. 


4. Click the Next button. 


5. Review the Information dialog, and then click the Next button. 


6. In the Select Destination Location dialog, select the Destination Directory—we 


recommend that you use the default location of C:\Program Files\Firebird\Firebird_2_1. 


 


 
Figure 6 – Firebird Select Components 


 


7. From the drop-down menu, select the Full Installation of Super Server and Development 


Tools option. 


8. At the Select Start Menu Folder screen click Next. 


 


 
Figure 7 – Firebird Select Additional Tasks 


 


9. On the Select Additional Tasks screen:  


 Select the Use the Guardian to Control the Server? option. 
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 Select the Run as a Service? option. 


 Select the Start Firebird Automatically Everytime You Boot Up? option. 


 Select the ―Install Control Panel Applet?‖ option. 


 Select the Copy Firebird Client Library to <System> Directory? option. 


 Select the Generate Client Library as GDS32.DLL for Legacy app. Support? option. 


10. Click the Next button. 


11. Click the Install button. 


12. Review the Information dialog and then click the Next button. 


13. Click the Finish button. 


 


IXP220 Installation Procedure 


To install the IXP220 Software Suite on a single Host PC proceed as follows: 
 


1. Insert the IXP220 Installation CD into the CD-ROM drive. 


2. Select the Install IXP220 Suite option. 


 


 


If the CD does not start up automatically, browse the CD in Windows® Explorer and double-click 


Setup.exe. 


 


3. Select English as the language option. 


4. Click the OK button. 


 


 


If no Database Server is present, one is installed. Follow the onscreen instructions for this. 


 


5. At the Introduction screen, click Next.  


6. At the Licence Agreement screen, select the I Accept the Terms of the Licence 


Agreement radio button. 


7. Click the Next button. 


8. At the Choose Install Folder screen, click Next. 


 


 


If you change the installation directory file path, ensure that you enter text only, NO spaces. 
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Figure 8 – Install Set Menu 


 


9. At the Choose Install Set screen, from the Install Set drop-down list, make your preferred 


installation type selection. 


 


 


An Install Set is a collection of pre-selected applications suitable for specific scenarios.  Customize an 


Install Set option by selecting or de-selecting applications from the list.   


 


10. Click the Next button.  


11. Click the Install button. 


12. At the Install Complete dialog, click the Done button. 


 


 


By default Windows® XP (SP2 and SP3) installs a firewall.  If you wish to keep this Firewall, ensure 


that you unblock the TCP Ports thereby allowing functionality of the IXP220 Software.  Continue as 


follows: 


 


1. Select Start>Control Panel. 


2. Select the Windows Firewall icon. 


3. In the Windows Firewall Settings dialog, select the Exceptions tab. 


4. Click on the Add Port button. 


5. Unblock the TCP Port in the Add a Port dialog, by completing the Name (any name for 


example Impro) and Port Number (use 10005 for Ethernet  Controllers) text boxes. 


6. Select the TCP radio button. 


7. Close the Add a Port dialog, by clicking the OK button. 


8. At the Windows Firewall Settings dialog, again click on the Add Port button. 


9. Set the Ethernet Firebird Port by completing the Name (any name, for example Firebird 


Service) and Port Number (use 3050 for Ethernet communication). 


10. Select the TCP radio button. 


11. Close the Add a Port dialog, by clicking the OK button. 


12. Close the Windows Firewall Settings dialog, by clicking the OK button. 
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When using separate PC’s for the Base Application (Host PC) and Database (Server PC) 


installation, continue as follows: 


 


1. On the Host PC, install the IXP220 Software as listed under the section IXP220 Installation 


Procedure. 


2. Stop the Firebird Server Software. 


3. On the Server PC, install Firebird Server as listed under the section Installing the Database 


Server.  Ensure that Firebird automatically runs as a service and that it has started. 


4. Copy the Database file from the Database folder on the Host PC to the NEW Database folder 


on the Server PC. 


5. Re-name the original Database file that remains on the Host PC to prevent you selecting it by 


mistake later. 


6. Install the IB Console Utility on the Server PC,  by copying the Utility from the 


C:\IXP220\Tools folder on the Host PC. 


 


DDaattaabbaassee  EEnnccooddiinngg  


The default database uses UNICODE-FSS encoding.   


 


Install the USB Driver for the USB Registration Reader Interface 


The IXP220 Software uses a USB Registration Reader Interface to read Tags.  Some Interface 


versions also provide an RS485 communication link to the Controllers.   


 


The IXP220 Installation CD includes a USB driver for the USB Registration Reader Interface.  


You can find the USB driver in the following locations: 


 The USB_Device_Driver directory on the CD. 


 The IXP220\USB_Device_Driver folder on the Host PC. 


 


To install the driver, proceed as follows: 


 


 


If there are pre-existing ImproX USB Device Drivers on the PC, delete them before installing the 


provided driver. 


 


 


On some PC’s, the New Hardware Found wizard displays every time you plug in a USB Registration 


Reader Interface with a new USB Serial Number (Fixed Address).  If this happens, choose the option 


to automatically install the unit; the New Hardware Found wizard will not display again.  


 


1. Plug the USB Registration Interface into a USB port on the PC.  The Found New 


Hardware Wizard displays. 


2. Select the Locate and Install Driver Software (Recommended) option. 


3. Select I don’t have the Disk. Show me Other Options. 


4. Select the Browse My Computer for Driver Software (Advanced) option. 


5. Click the Browse button. 


6. In the Browse for Folder dialog, select the IXP220\USB_Device_Driver folder. 


7. Click the OK button. 


8. Click the Next button. 


9. At the Windows Security dialog, select the Install this Driver Software Anyway option. 


10. Click the Close button. 
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You will notice that the Wizard pops up twice, installing two drivers; one for the USB 


Registration Reader and one for the COM Port to USB Bridge.   


 


Upgrading an Existing Installation 


1. Backup the existing IXP220 Database to a folder for safekeeping. 


2. Copy the Properties files if running IXP220 on a LAN or WAN, to the folder for safekeeping. 


3. Make a backup copy of the Security2.fdb file to the safekeeping folder.  In a default 


installation you will find the Security2.fdb file at C:\Program Files\Firebird\Firebird 


2.1\security2.fdb. 


4. Uninstall the existing IXP220 Software. 


5. Install the NEW IXP220 Software. 


6. Ensure that the Database Server is Firebird 2.1.  If not, uninstall the existing version and 


replace it with the newer version. 


7. Move the backup Security2.fdb file to the new Firebird installation folder. 


8. On installation of the Software, an empty Database automatically installs.  Move the backup 


IXP220 Database file to the new Database folder, overwriting the empty Database file. 


9. Upgrade the Controller and Terminal Firmware if necessary. 


10. Upgrade the IXP220 Database if necessary. 


 


 


Ensure that you configure your IXP220 Controllers correctly before proceeding further with your 


IXP220 installation.  Refer to Part 7 – Utilities for configuration information. 
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Pre-configuration Procedure 


 


It is critical that there are no communication problems prior to Software configuration.  Otherwise, the 


System will not function. 


 


 


Ensure that the Unit Location Chart is correctly filled in when installing the Controllers. 


 


After installing all the 220 Software components, perform the Pre-configuration Procedure.  


This procedure ensures that the hardware communication infrastructure functions correctly. 


 


RS485 Communications Infrastructure 


1. Using the supplied USB Cable, connect the ImproX RS to the PC. 


2. Using the IXP220 Controller‘s RS485 Controller Port, connect the IXP220 Controller to the 


ImproX RS. 


 


USB Communications Infrastructure 


1. Plug the IXP220 Controller into a USB port on the PC.  The Found New Hardware Wizard 


displays. 


2. Select the Locate and Install Driver Software (Recommended) option. 


3. Select I don’t have the Disk. Show me Other Options. 


4. Select the Browse My Computer for Driver Software (Advanced) option. 


5. Click the Browse button. 


6. In the Browse for Folder dialog, select the IXP220\USB_Device_Driver folder. 


7. Click the OK button. 


8. Click the Next button. 


9. At the Windows Security dialog, select the Install this Driver Software Anyway option. 


 


 


Take note of the COM Port number displayed by the Driver Software Installation dialog. 


 


10. Click the Close button. 


 


TCP/IP Communications Infrastructure 


 


 


For IXP220 Controllers and Terminals installed on the LAN (that is the local Subnet of the Host 


PC), make use of the Discovery Utility integrated with the IXP220 Base Application.  For IXP220 


Controllers and Terminals installed on a WAN (that is the non-local Subnet of the Host PC), make 


use of the stand-alone Discovery Utility (local to the Controller or Terminal) and export the 


configuration settings to the Host PC.  The Host PC runs the IXP220 Base Application. 
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Ensure the PC running Discovery is on the SAME subnet as the IXP220 Controllers or Terminals for 


viewing. 


 


VViieeww  AALLLL  AAvvaaiillaabbllee  IIXXPP222200  CCoonnttrroolllleerrss  aanndd  TTeerrmmiinnaallss  oonn  tthhee  LLooccaall  SSuubbnneett  


1. Using your chosen method, open the Discovery Utility: 


a. From the IXP220 Base Application, from the Menu Bar, select Hardware>Unit 


Discovery.   


b. Alternatively, start the stand-alone Discovery Utility from Windows® by going to 


Start>All Programs>IXP220>Utils>Discovery Utility. 


2. On the Menu Bar, go to Network>Search Local Subnet. 


3. If the Utility fails to find any Devices, at the Device Not Found dialog, click the OK button. 


4. On the Menu Bar, go to Network>Advanced Local Search. 


 


By selecting Advanced Local Search, you may select the correct Network Interface (only 


displayed where more than one exists) and enter the correct Subnet Mask.  If the search 


returns Controller or Terminal details, the Utility (while running) retains the Network Interface 


and Subnet Mask information for further searches.  You may however, use Advanced Local 


Search again during the session for further searches using different search criteria. 


 


5. Select the relevant Network Interface, if more than one displays. 


6. Click the OK button. 


7. In the Input dialog, in the textbox, enter the Subnet Mask for your network. 


8. Click the OK button.  Wait for the Controllers and Terminals to display. 


 


 


Sort the information displayed in either ascending or descending order by selecting the column header.   


 


VViieeww  aa  SSPPEECCIIFFIICC  CCoonnttrroolllleerr  oorr  TTeerrmmiinnaall  


1. On the Menu Bar, go to Network>Search IP. 


2. In the Enter IP Address dialog, enter the IP Address of the Controller or Terminal you‘re 


searching for. 


3. Click on the  button.  Wait for the Controller or Terminal to display. 


 


On display of Controllers and Terminals, the following icons appear: the  icon represents 


unlinked Controllers.  The  icon represents Terminals and the  icon represents 


Controllers with linked Terminals.  On expanding the Controller tree, the  icon displays, with 


the linked Terminals displaying below. 


 


SSeeccuurree  LLooggoonn  


1. In the Device Password dialog, enter your password.  The default password is 


masterkey, for improved security we recommend that you change this password. 


2. Click on the  button. 


 


Change the Secure Logon 


1. From the Menu Bar, select Configuration>Change Password. 


2. Logon if requested. 
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3. In the Enter New Password textbox enter a new password (not exceeding 16 characters) 


for the selected Controller or Terminal.   


4. In the Confirm New Password textbox re-enter your chosen password. 


5. Click on the  button. 


  


GGrroouuppiinngg  CCoonnttrroolllleerrss  aanndd  TTeerrmmiinnaallss  


On display of Controllers and Terminals, the following icons appear: the  icon represents 


unlinked System Controllers.  The  icon represents Terminals and the  icon represents 


System Controllers with linked Terminals.  On expanding the System Controller tree, the 


icon displays, with linked Terminals displaying below. 


  


Creating the Group and Adding Controllers 


 


 


There is no need to give a group name to a Controller if it has no IP Terminals. 


 


1. Select the Controller and the Terminal’s it should control. 


2. On the Menu Bar, go to Configuration>Add to Group. 


 


 


Alternatively, right-click and select Add to Group from the pop-up menu. 


 


3. In the Enter Group Name dialog, enter a suitable group name for the selected Controllers.  


4. Logon if requested (see page 32).  A password is required for each Controller and Terminal 


being added to the Group. 


5. Click the  button.  


 


Adding Terminals to Existing Controller Groups 


1. Select the Terminal(s) to be added to the Group. 


2. On the menu bar, go to Configuration>Add to Group. 


 


 


Alternatively, right-click and select Add to Group from the pop-up menu. 


  


3. In the Select the Group Name dialog, double-click on your chosen group name row. 


4. Logon if requested (see page 32). 


5. Click the  button.  
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CCoommmmuunniiccaattiioonn  CCoonnffiigguurraattiioonn  ––  CCaassee  LLooccaall  


Configure the Controller or Terminal’s Static IP Address (Ethernet)  


 


 
Figure 9 – Case Local—Configure the Controller or Terminal’s Static IP Address (Ethernet)  


 


 


If a DHCP server is present, IP Addresses are dynamically assigned initially.  Obtain a suitable IP 


Address from your Network Administrator.  A private static IP Address is essential for the Controller or 


Terminal because a DHCP Server may assign a new IP Address resulting in the Software losing 


communications.  


 


 If the Controller or Terminal is NOT on the DHCP Server, ensure the PC is on the same IP Range as 


that of the Controller or Terminal.  If the PC’s IP Range differs, you cannot change the Controller or 


Terminal’s settings. 


 


1. From the IXP220 Base Application, from the Menu Bar, select Hardware>Unit Discovery. 


2. In the Discovery Utility window, select the Controller or Terminal for configuration. 


3. From the Menu Bar, select Network>Configure IP. 


4. Logon if requested (see page 32).                 


 


 
Figure 10 – Configuration Settings Dialog 
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By assigning an invalid IP Address, the Controller or Terminal may no longer communicate.  


Refer to the Hardware Installation Manual for information on restoring factory defaults. 


 


5. In the Device IP Address textbox, enter a Device IP Address. 


6. Tick the checkbox to set the IP Address to Static. 


7. In the Gateway IP Address textbox, enter a Gateway IP Address.   


8. Tick the checkbox to set the Gateway IP Address to Static. 


9. Continue with ONE of the procedures (Subnet Mask or Subnet Host Bits) that follow: 


 


Subnet Mask 


a. Select the Subnet Mask radio button. 


b. In the textbox, alongside, enter the Subnet’s Address.   


c. Tick the checkbox to set the Subnet Mask to Static. 


 


Subnet Host Bits 


a. Select the Subnet Host Bits radio button. 


b. Enter the number of bits in the textbox. 


 


10. If necessary, amend the supplied Device Name.  Use the same site prefix to name devices 


belonging to the same site.  For example: ―Site_1–Factory‖, ―Site_1–Testing‖ and so on. 


Changes to the IP Configuration result in the Controller or Terminal rebooting on acceptance 


of the change.  The Configuration Settings dialog remains open while allowing the Controller 


or Terminal to reboot.  On closure of the dialog, the Utility again searches for the Controller 


or Terminal and if successful, displays the updated details. 


11. Ensure the Force Update checkbox is UNCHECKED.  If the Force Update checkbox 


remains unchecked, the Controller or Terminal changes the IP Address testing 


communication on the new Address.  If successful, the update becomes final; if not, the 


Controller or Terminal reverts to its old settings. 


12. Click the Update button. 


 


After detection and configuration it‘s not necessary to assign a Logical Address, as the IXP220 


Auto-ID process does this.  It is not necessary to export the settings to a file. 
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CCoommmmuunniiccaattiioonn  CCoonnffiigguurraattiioonn  ––  CCaassee  RReemmoottee  


Option 1:  Configure the Controller or Terminal’s Static IP Address (Ethernet)  


 


 
Figure 11 – Case Remote—Configure the Controller or Terminal’s Static IP Address (Ethernet)  


 


Use the stand-alone Discovery Utility on the same local Subnet as the IXP220 Controllers or 


Terminals for configuration.  You may temporarily install and pre-configure the Controllers or 


Terminals on any convenient Subnet, local to the PC running the Discovery Utility.  After 


configuration, move the Controllers or Terminals to the remote location.  Alternatively, install the 


Discovery Utility on a PC on the remote Subnet.  Export the settings to a file for manual entry 


into the IXP220 Base Application.     


 


 


If a DHCP Server is present, IP Addresses are dynamically assigned initially.  If the Controller or 


Terminal is NOT on the DHCP Server, ensure the PC is on the same IP Range as that of the Controller 


or Terminal.  If the PC's IP Range differs, you cannot change the Controller or Terminal's settings.  A 


public static IP Address is essential for the Controller or Terminal because the Controller or Terminal is 


destined for a WAN.   


 


1. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


2. In the Discovery Utility window, select the Controller or Terminal for configuration. 


3. From the Menu Bar, select Network>Configure IP. 


4. Logon if requested (see page 32).                
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Figure 12 – Configuration Settings Dialog 


 


 


By assigning an invalid IP Address, the Controller or Terminal may no longer communicate.  


Refer to the Hardware Installation Manual for information on restoring factory defaults. 


 


5. In the Device IP Address textbox, enter a Device IP Address. 


6. Tick the checkbox to set the IP Address to Static. 


7. In the Gateway IP Address textbox, enter a Gateway IP Address.   


8. Tick the checkbox to set the Gateway IP Address to Static. 


9. Continue with ONE of the procedures (Subnet Mask or Subnet Host Bits) that follow: 


 


Subnet Mask 


a. Select the Subnet Mask radio button. 


b. In the textbox, alongside, enter the Subnet’s Address.   


c. Tick the checkbox to set the Subnet Mask to Static. 


 


Subnet Host Bits 


a. Select the Subnet Host Bits radio button. 


b. Enter the number of bits in the textbox. 


 


10. If necessary, amend the supplied Device Name.  Use the same site prefix to name devices 


belonging to the same site.  For example: ―Site_1–Factory‖, ―Site_1–Testing‖ and so on. 


 


 


If the Force Update checkbox remains UNCHECKED, the Controller or Terminal changes the IP 


Address testing communication on the new Address.  If successful, the update becomes final; if 


not, the Controller or Terminal reverts to its old settings. 


 


Changes to the IP Configuration result in the Controller or Terminal rebooting on acceptance 


of the change.  The Configuration Settings dialog remains open while allowing the Controller 


or Terminal to reboot.  On closure of the dialog, the Utility again searches for the Controller 


or Terminal and if successful, displays the updated details. 


11. Ensure the Force Update checkbox is CHECKED when assigning an Address on an 


external subnet.  The Controller or Terminal changes the IP Address and reboots.  If the 


Address points outside the Local Subnet, the Controller or Terminal is not found until it‘s 


physically moved to the new location. 


12. Click the Update button. 


13. From the Menu Bar, select File>Export IP Config. 
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14. In the Save dialog, click the Save button (by default this file is named discovery.txt, you 


may however change this file name). 


15. Exit the Discovery Utility. 


16. Send a copy of the exported Discovery file (discovery.txt) to the Host Location. 


17. If locally pre-configured, move the Controller or Terminal to its remote location. 


 


 


After installing the Controller or Terminal in its new location, you can find it by going to 


Network>Search IP. 


 


Option 2:  Configure the Controller or Terminal’s Public Host Name (Ethernet)  


Use this option where you install your IXP220 Controller or Terminal behind a Router with a 


public hostname resolved to an IP Address.  In this scenario, the Router is setup (by your 


Network Administrator) to route data to the separate Controllers or Terminals via the port 


numbers uniquely associated with them.  Detection of Controllers or Terminals using the 


Discovery Utility is only done locally, that is on the Local Subnet, behind the Router.  To address 


the Controller or Terminal from the world beyond the Router, the local IP Address of the 


Controller or Terminal must change to the Router‘s public hostname.  


 


 
Figure 13 – Case Remote—Configure the Controller or Terminal’s Public Host Name (Ethernet)  


 


1. Select a UNIQUE Communication Port Number for the IXP220 Controller or Terminal.  


2. Program the Router to direct all data destined for that port to the Controller or Terminal.  


3. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


4. In the Discovery Utility window, select the Controller or Terminal for configuration.   


5. From the Menu Bar, select Network>Configure IP. 


6. Logon if requested (see page 32).                 


7. Allow the DHCP assigned addresses to remain and set as static or obtain a static address 


from your network administrator. 


8. If necessary, amend the supplied Device Name.   


 


 


Change the Secure Logon and Clear the Controller or Terminal’s memory as required. 


 


9. Change the Communication Port Number to the unique port number set up on the Router. 
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10. From the Menu Bar, select File>Export IP Config. 


11. In the Save dialog, click the Save button (by default this file is named discovery.txt, you 


may however change this file name according to your needs). 


12. Exit the Discovery Utility. 


13. Send a copy of the exported Discovery file (discovery.txt) to the Host Location. 


 


In the IXP220 Software now add a new communication channel to your selected Site, either 


manually or by importing the file you exported earlier (discovery.txt).  If the file is imported, the 


Port Number is correct and you need only change the IP Address to the Router‘s public 


Hostname.  Auto-ID continues as normal.  See Part 3 – General Configuration for full details on 


this procedure. 


 


Option 3A:  Configure the Controller’s Mobile Settings (GPRS) for GPRS and SMS 


 


 


This connection option is not supported where you have Controllers connected (by RS485) to the 


GPRS enabled Controller. 


 


 


When configuring the GSM Module for GPRS and SMS ensure that you obtain a PUBLIC Access Point 


Name (APN) from your Mobile Service Provider. 


 


 


When using a Hostname instead of an IP Address, ensure that you have access to a PC with an active 


Internet connection. 


 


 


This option only applies to the IXP220 Controller fitted with a GSM Module. 


 


 


Pre-configure the Controller with the Controller connected to the local LAN.  After pre-configuration, 


remove the network connection from the Controller. 


 


Pre-configuration, get the following from your Mobile Service Provider: 


 


 Buy a SIM Card (you will need the PIN and PUK numbers for this SIM Card). 


 Get a public Access Point Name (APN). 


 Confirm details for the SMS Service Centre. 


 Have the Username and Password for the Access Point Name (APN) available (only 


needed in some instances). 


 


And from a Dynamic Domain Name Service Provider, get the following: 


 


 Select one of the supported Providers, namely changeip.org, dyndns.com or no-ip.com. 


 Register a Hostname for your IXP220 Controller with your chosen Provider. 


 Register a Username and Password for your IXP220 Controller. 


 Register a Hostname for the PC hosting the IXP220 Software, or use a public static IP 


Address. 


 


 


Both Hostnames must resolve to a public IP Address, they cannot remain blank. 


 


1. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


2. In the Discovery Utility window, select the Controller for configuration.   
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3. From the Menu Bar, select Network>Configure Mobile Settings. 


4. Logon if requested (see page 32).  


 


 
Figure 14 – Configure Mobile Settings Dialog 


 


 


The Signal Strength icon on the Status bar indicates the signal strength being experienced by the 


Controller’s GSM Module.  5 Bars indicates maximum signal strength. 


 


5. Complete the fields under the header Mobile Service Provider: 


 SIM PIN—this is the Personal Identification Number (PIN), a numerical combination of 


up to 5 digits, supplied with your SIM Card.  Wrong entry of the PIN (more than 3 times) 


locks the SIM Card.    


 SIM PUK—this is the PIN Unlock Key.  This number offers protection of the device and 


SIM Card with the PIN.  Entry of the wrong PUK (more than 10 times) permanently 


blocks the device, a new SIM Card is then required.     


 SMS Service Centre—the contact number for the repository that stores messages for 


delivery to the destination user when they are available.  Stored on the SIM Card, this 


number may not come into sight until you activate your mobile settings.  If you wish to 


use the service and the number does not finally appear, contact your service provider 


for assistance. 


 







 Part 2 – Software 


 


February 2012  41 


 Access Point Name (APN)—this is the name used to identify a public (free) GPRS 


bearer service in the GSM mobile network.  The Access Point Name (APN) defines the 


type of service provided in the packet data connection.  


 APN Username—possibly needed for the Access Point Name (APN). 


 APN Password—possibly needed for the Access Point Name (APN).         


6. Ensure the Configure for GPRS and SMS radio button is selected (default).    


7. Under the header Dynamic Domain Name Service, From the Dynamic DNS Provider 


drop-down list, select one of the supported Providers. 


8. In the Dynamic DNS Hostname textbox, enter the registered IXP220 Controller‘s 


Hostname. 


9. In the Dynamic DNS Username textbox and Dynamic DNS Password textbox, enter the 


registered Username and Password respectively for your IXP220 Controller. 


10. In the Host PC IP Address textbox, enter the public static IP Address. 


 


 


When using a SIM Card with a single static IP Address, enter the public static IP Address of the Host 


PC, not the Hostname.  Contact your Mobile Service Provider for more information on your SIM Card. 


 


11. Click the Apply button.   


 


The Discovery Utility captures the configuration information and forwards the information on to 


the Controller for activation.  The Controller starts the process of establishing a GPRS 


connection.  The Discovery Utility queries the Controller for status until the Utility gets a result. 


During the verification process there is an approximately 60-second time-out.   


 


The Discovery Utility decides on the success of the configuration.  At the end of the verification 


process, the Status bar at the bottom of the Configure Mobile Settings dialog, displays the 


status of the configuration.  Possible status messages include:   


 


 Listening—this is the desired status message. 


 GSM Module Not Present—indicates the GSM Module is removed or uninstalled. 


 GSM Module Present—Controller is aware the GSM Module is connected; however 


the Controller is busy going through the connection process. 


 SIM PIN or PUK Error—indicates you have captured the wrong PIN or PUK number. 


 GPRS Network Error—indicates the GSM Module cannot connect to the Network. 


 APN Error—indicates the wrong APN Name was captured.  This message also 


appears however, where you have exceeded your data cap or you have no available 


airtime on your SIM Card.    


 DDNS Error—indicates there is an error with the captured DDNS parameters. 


 Connected—connected status only occurs if a Controller was already configured and 


currently connected by GPRS to the IXP220 Software while still connected by Ethernet. 


 


 


If the connection is not established, the Controller may begin the verification process again.  In an 


instance where the verification process times out, click the Query Status button manually requesting 


the status.   


 


 


If you do NOT get the status Listening, correct any errors and then press the Apply button again. 


 


On acceptance of the settings, the GPRS parameters are written to the DiscoveryGSM.txt file. 


The IXP220 Software automatically imports this file for permanent storage in the Database (in 
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case of Hardware replacement). 


12. On achieving the Listening status, close the Configure Mobile Settings dialog. 


13. Export the configuration file, from the Menu Bar, select File>Export IP Config. 


14. Click the Save button. 


15. Exit the Discovery Utility. 


16. Send both the DiscoveryGSM.txt and Discovery.txt files to the Host PC (ensuring you 


place both files in the same destination folder) before beginning the Auto-ID process. 


17. Disconnect the IXP220 Controller from the LAN. 


18. Reboot the Controller.   


19. Continue with the Auto-ID process (see Part 3 – General Configuration for more information 


on this process). 


 


Option 3B:  Configure the Controller’s Mobile Settings (GPRS) for SMS Only 


 


 


A public Access Point Name (APN) is NOT required for SMS only. 


 


In instances where your Controller connects by Ethernet, but you still require SMS capability, 


continue as follows: 


 


 
Figure 15 – Configure Mobile Settings Dialog 


 


 


The Signal Strength icon on the Status bar indicates the signal strength being experienced by the 


Controller’s GSM Module.  5 Bars indicates maximum signal strength. 


 


1. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


2. In the 220 Discovery Utility window, select the Controller for configuration.   


3. From the Menu Bar, select Network>Configure Mobile Settings. 


4. Logon if requested (see page 32).  


5. Ensure the Configure for SMS Only radio button is selected.  


6. Complete the fields under the header Mobile Service Provider: 


 SIM PIN  


 SIM PUK  


 SMS Service Centre  


7. Click the Apply button. 


 


 


Your setup is complete and working correctly when you receive the Status message SMS 


Configuration Completed.  We recommend that you test the connection by clicking the Test SMS 


button.  Where called for by your country and or your service provider, precede the recipient’s mobile 


number with the country code.     
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Configuration Overview 


Using the IXP220 Base Application 


The following parts comprise the IXP220 Base Application’s interface: 


 


 A—Menu Bar 


 B—Page Tabs 


 C—Configuration Pane 


 D—Viewer Pane 


 


 
Figure 1 – IXP220 Base Application User Interface 


 


 


The IXP220 Base Application only displays as shown in Figure 1 where you select the standard  


Windows® 7 (Professional, Enterprise or Ultimate), Windows® Vista (Business or Ultimate) and XP 


Professional themes.  Using other non-standard themes results in IXP220 displaying incorrectly.      


 


MMeennuu  BBaarr  


The Menu Bar contains drop-down menus that let you navigate between different operations in 


the IXP220 Base Application.  These menus include:  File, View, Hardware, Configuration, 


Tagholder, Wizard, Web and Help Topics. 
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PPaaggee  TTaabbss  


The Page Tabs let you switch between the different configuration settings, for example: 


 


 Site Configuration 


 Controller Configuration 


 Door  Configuration 


 Access Group Configuration 


 Tagholder Configuration 


 Building Management Configuration  


 Notification Configuration 


 


CCoonnffiigguurraattiioonn  PPaannee  


The Configuration Pane lets you adjust various settings based on your selection from the Page 


Tabs or Menu Bar.   


 


VViieewweerr  PPaannee  


 


 


Click the  button (placed alongside the Page Tabs) to adjust the Base Application’s layout: 


 


 First Click—Closes the Viewer Pane, opening the Configuration Pane in Full Screen Mode. 


 Second Click—Opens the Viewer Pane in Full Screen Mode. 


 Third Click—Returns the Base Application to Split-screen Mode, showing both the 


Configuration Pane and the Viewer Pane. 


 


Alternatively, adjust the layout as follows: 


 


1. From the Main Menu, select View. 


2. Make your selection from the following: 


 Split Display— shows both the Configuration Pane and the Viewer Pane. 


 Configuration View—closes the Viewer Pane, opening the Configuration Pane in Full 


Screen Mode. 


 Monitoring View—opens the Viewer Pane in Full Screen Mode. 


 


The Viewer Pane consists of Tabs showing the following information: 


 


 Transaction Viewer—gives a live real-time view of all types of transactions in the System.  It 


displays the names of the Doors (Locations) and details of Tagholders who have entered or 


exited these Doors (Locations).   


 Alarm Transaction Viewer—gives a live real-time view of all alarm transactions in the 


System.  It displays the names of the Doors (Locations) and details of Tagholders who have 


entered or exited these Doors (Locations).   


 Communications Status Viewer—indicates the status of the IXP220 Controllers 


communicating with the IXP220 System. 


 Door Status Viewer—indicates the status of the Doors (Locations) forming part of the Site.  


You may physically unlock Doors (Locations) displayed here, using the IXP220 Software.  
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UUssiinngg  WWeebbHHeellpp  


The IXP220 System has integrated WebHelp.  Information not covered in this guide is covered 


in detail in the WebHelp.  Activate the WebHelp from the Menu Bar as follows: 


 


1. In Windows®, go to Start>Programs>IXP220>IXP220. 


2. From the Menu Bar select Help Topics>Online Help. 


 


The Context Sensitive WebHelp provided with the IXP220 Software works with your 


positioned Mouse Pointer (or cursor) on your screen.  For example if you place your Mouse 


Pointer in the Viewer Pane, WebHelp opens Context Sensitive WebHelp specific to the Viewer 


Pane.  If, however, you want WebHelp specific to the active Configuration Pane, continue as 


follows: 


 


1. Move your Mouse Pointer into the Configuration Pane.  


2. Anchor your Mouse Pointer by clicking the left-hand mouse button giving the Pane focus. 


3. Press the F1 key on your keyboard. 


 


Key Assist 


The IXP220 Base Application also includes Key Assistance.  Selecting the Key Assist option 


opens an area on the right-hand side of the Base Application’s desktop.  This area displays a list 


of keyboard shortcuts letting you quickly move between the Page Tabs.  The final option in the 


Key Assist Area (System Navigation) opens the System Navigation dialog.  This dialog allows 


quick navigation through System related functions. 


 


Get Key Assistance as follows: 


 


1. In Windows®, go to Start>Programs>IXP220>IXP220. 


2. From the Menu Bar select Help Topics>Key Assist. 


 


Support Diagnostics 


The Support Diagnostics Bundle assists you by supplying Technical Support Staff with 


information about your System.  This helps them to solve your problems quickly and efficiently.   


 


Create a Support Diagnostic Bundle as follows: 


 


1. From the Main Menu, select Help Topics>Support Diagnostics. 


2. Select the Included in Bundle tab. 


3. The Diagnostics Bundle includes the following information by default.  Customize the 


information sent by de-selecting the checkbox alongside: 


 Transactions (Last 500)—selecting this sends the last 500 transactions in the System 


including access, status and alarm transactions. 


 System Log Files—sends the System Log files. 


 Firebird Log (Database Server)—sends the Database server log if the Database is 


installed on the default directory. 


 Site Summary—includes information such as the number of Tagholders with access 


and the number of Doors configured on a Site.  Also provides hardware configuration 


data like how the Base Application communicates to the Controller as well as 


information about connected terminals and their configuration. 


 Holiday Data—sends information about Holiday configuration. 
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 Host PC Information—includes information such as PC specifications, processes 


running on the PC and results from a netstat (a command-line tool providing information 


on network connections, routing and other network interface statistics). 


4. Select the Contact Information tab. 


5. Fill in your contact information as necessary. 


6. Create the Diagnostic Bundle using one of the following methods: 


 


Sites WITH Pre-configured Notifications  


 


 


For e-mail setup information please refer to the section Preference Configuration (System Notification 


Tab) on page 63. 


 


1. Click the Generate Bundle button. 


2. If you have an existing reference number, complete the Reference No. textbox. 


3. Complete the Support E-mail Address textbox. 


4. Click the E-mail Bundle button. 


5. Click the  button. 


 


Sites WITHOUT Pre-configured Notifications 


 


1. Click the Generate Bundle button. 


2. Click the  button. 


3. Browse to C:\IXP220. 


4. Locate the zip file diagnosticBundle_(date generated)_(time generated). 


5. Attach the zip file to an e-mail. 


6. Send the e-mail to the Technical Support Staff. 


 


Common Interface Controls 


The following types of controls let you interact with the IXP220 Base Application interface: 


 


BBuuttttoonnss  


Carries out a role when clicked on, these roles could include for example adding or deleting 


information, searching, opening or closing a dialog or window.  As a rule Buttons normally 


appear in dialogs, or on the Configuration Pane.  Button examples include: 


 


  


 


IIccoonnss  


Icons are similar in function to buttons except that Icons are located in the Page Tabs.  Icon 


examples include: 
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RRaaddiioo  BBuuttttoonnss  


Use Radio Buttons when selecting an option.  You may only select one radio button at a time.  


Click to enable or disable. 


 


 


 


CChheecckkbbooxxeess  


Use Checkboxes to select multiple options.  Any number of checkboxes in a group can be 


selected.  Click to enable or disable. 


 


 


 


TTeexxttbbooxxeess  


Textboxes let you enter text such as a name.  Click the checkbox and type some text. 


 


 


 


TTeexxtt  AArreeaass  


Same role as a textbox, except a text area displays multiple lines of text. 


 


 


 


DDrroopp--ddoowwnn  LLiissttss  


Use Drop-down Lists to select an option from a list.  Click the button with the arrow to display 


the list.  Then, click a list item to make your selection. 
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RReeccoorrddss  


Records are rows of information displayed in a grid format.  A record is a collection of fields 


compatible with a column name. 


 


 


 


 


This Manual displays screenshots of various screens in the IXP220 Base Application Software.  Some 


of the details displayed in a screenshot may not be available in your copy of the IXP220 Software.  This 


is because some details are dependent on the hardware installed and licenses activated. 
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System Configuration Parameters 


SSyysstteemm  PPaarraammeetteerrss  


Description IXP220-1 


Single APB Door or 2 
non-APB Door System 


IXP220-2 


4 APB Door System 


IXP220-3 


256 APB Door System 


IXP220-4 


Multi-site System (256 
Doors per Site) 


Total Number of Tags 1 000 2 000 10 000 10 000 


Total Buffered Transactions 100 000 100 000 100 000 100 000 


Sites per System 1 1 1 1 000 


Controllers per Site 1 4 64 64 


Terminal Fixed Addresses per 


Controller 


2 2 2 2 


Terminal Fixed Addresses per 


Door (Location) 


2 2 2 2 


Doors (Locations) per Zone 1 4 32 32 


Zones per Site 1 4 32 32 


Doors (Locations) per Controller 2 4 32 32 


Tags per Tagholder 4 4 4 4 


Tagholder Access Groups (per 


Site) 


64 64 64 64 


Operating Voltage 18 V DC – 32 V DC 


16 V AC – 24 V AC 


18 V DC – 32 V DC 


16 V AC – 24 V AC 


18 V DC – 32 V DC 


16 V AC – 24 V AC 


18 V DC – 32 V DC 


16 V AC – 24 V AC 


Controller Communications Baud 


Rate 


100 Mbps when using 


TCP/IP 


100 Mbps when using 


TCP/IP 


100 Mbps when using 


TCP/IP 


100 Mbps when using 


TCP/IP 


Terminal Communications Baud 


Rate 


NA 38 400 38 400 38 400 


Digital Inputs – per Controller (not 


used for Access Control) 


1 1 1 1 


Digital Inputs – per Controller 


(used for Access Control) 


4 4 4 4 


Onboard Relays – per Controller 3 3 3 3 


Lift (Elevator) Control (per Site) 


(up to 32 floors per Lift (Elevator)) 


NA NA 8 (Unlock Code 


Required) 


8 (Unlock Code 


Required) 


Maximum  Fixed Addresses 


Supported (per Site) 


2  8  512  512  


Maximum Fixed Addresses 


Supported - APB Doors (per Site) 


2  4  256  256  


Host PC Communications RS232, RS485, USB or 


TCP/IP 


RS232, RS485, USB or 


TCP/IP 


RS232, RS485, USB or 


TCP/IP 


RS232, RS485, USB or 


TCP/IP 


Controller Bus Communications No RS485 RS485 RS485 


Terminal Bus Communications No RS485 RS485 RS485 


Input or Output Devices (per Site) NA NA 18 18 


Actions 1 1 300 300 
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Description IXP220-1 


Single APB Door or 2 
non-APB Door System 


IXP220-2 


4 APB Door System 


IXP220-3 


256 APB Door System 


IXP220-4 


Multi-site System (256 
Doors per Site) 


Tag Registration USB Registration 


Reader or Any Reader 


USB Registration 


Reader or Any Reader 


USB Registration 


Reader or Any Reader 


USB Registration 


Reader or Any Reader 


Maximum Number of Holidays 


(per Site) 


40 40 40 40 


Access Time Patterns to each 


Access Group 


8 8 8 8 


Access Groups per Tag 1 1 1 1 


Reason Codes (per Site) 99 99 99 99 


Maximum Number of Tagholder 


Messages (per Site) 


100 100 100 100 


Maximum Number of Messages 


on Building Management 


150 150 150 150 


Database Firebird 2.1 Firebird 2.1 Firebird 2.1 Firebird 2.1 


Table 1 – System Configuration Parameters 


 


 


IXP220-3 and IXP220-4 Systems are restricted to 10 000 Tags per System regardless of the number of 


Sites.  In addition these Systems are also restricted to 10 000 Tags per Site.  This restriction includes 


Tagholders (Tags) from other Sites with access to the original Site.  In other words, Site A can have up 


to 10 000 Tags, Tagholders from Site B with access to Site A are therefore included in Site A’s total 


Tag count. 


 


 


In IXP220-3 and IXP220-4 the Input or Output Devices (per Site) figure represents the total number of 


input or output devices for use across Lift (Elevator) Control and Building Management. 


 


 


In IXP220-1 and IXP220-2 the Actions figure represents the input and output available on the IXP220 


Controller Printed Circuit Board (PCB).  


 


 


In IXP220-3 and IXP220-4 of the 300 Actions allowed, you may only allocate 100 of these as Time 


Triggered Actions. 


 


 


A Terminal with two Fixed Addresses, such as the ImproX iTT, is treated as two separate Terminals.  In 


the same way, a Terminal with 3 Fixed Addresses (that is the ImproX MfT), is treated as three 


Terminals by the Software. 


 


 


All figures provided are the maximum.  In some cases interdependence between parameters; that is 


the maximum number of Zones per Controller depends on how many Terminals are used per Location. 


 


 


Unlock System IXP220-3 for up to 1 000 Sites per System and 8 Lifts (Elevators) using the Multi-site 


and Elevator Control Licences.  The Multi-Site License allows for a maximum of 1 seat, and the 


Elevator Control License allows for a maximum of 1 seat. 
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11  
Site Configuration 


To set up a Site, you need to configure the following items: 


 


 Host PC 


 IXP220 Controllers 


 Terminals 


 Zones and Doors (Locations) 


 


Opening the Software 


To open the IXP220 Base Application, proceed as follows: 


 


1. In Windows®, click Start>All Programs>IXP220>IXP220.  


2. Enter your Username (SYSDBA) and Password (masterkey). 


 


 
Figure 2 – Logon Dialog (Enter Username and Password) 


 


3. From the Security Device Search drop-down list, make your selection from the following 


choices: 


 


 


On first time installation of the IXP220 Software, the I do NOT Have One choice is by default selected.  


In this case, if the site has an ImproX RS connected that’s unlocked for a System 3 or System 4 then 


the IXP220 Software starts up as a System 1.  This means no search is performed for the ImproX RS.   


 


 Automatically Search—for IXP220-3 and IXP220-4 installations where an ImproX RS 


is connected but you are unsure of the COM Port number in use by the ImproX RS.  


Automatically searching on a computer that has an enabled Bluetooth or Infrared Port 


may result in the IXP220 application freezing.   


 Enter the COM Port Name—for IXP220-3 and IXP220-4 installations where an ImproX 


RS is connected and you know the COM Port number in use by the ImproX RS.  


Recommended when you have an enabled Bluetooth or Infrared Port.  If you select this 


choice, enter the COM Port number in the supplied textbox.  If your installation does 
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NOT use the default Database Server Port of 3050, enter the server name and port 


number (that is server:port).  An example could include localhost:3051, that is with 3051 


being the port used. 


 I do NOT Have One—for IXP220-1 and IXP220-2 installations with no ImproX RS. 


4. Click the  button. 


 


 


Do NOT disconnect the ImproX RS while still connected to the IXP220 Software.   


Should you unintentionally disconnect the ImproX RS while the Software’s running, close the 


IXP220 Software, reconnect the ImproX RS and then restart the Software. 


 


 


When using separate PC’s for the Base Application (Host PC) and Database (Server PC) 


installation, start the IXP220 Base Application as follows: 


 


1. On the Host PC, start the IXP220 Base Application Software. 


2. At the Login dialog, in the Server Name textbox, enter the actual name (or IP Address) of the 


Server PC. 


3. In the Database textbox, enter the local path to the database file as it resides on the Server 


PC. 


4. Enter the Username (SYSDBA) and Password (masterkey). 


5. Click the  button. 


 


Database Version Check 


After completing the login action, the Automatic Database Upgrade Utility checks the 


database version.  If the Utility confirms the Database is older than that needed by the Software, 


a Warning dialog tells you an upgrade is needed.  Perform the upgrade as follows: 


 


1. At the Warning dialog, click the OK button. 


2. In the Database Updater dialog, click the Upgrade button. 


3. At the Message dialog, click the OK button. 


 


If you do not upgrade the Database immediately, the IXP220 Software closes. 


 


Hardware Auto-ID 


 


 


Hardware detected for the first time receives a Logical Address.  This Logical Address does not 


change, thus ensuring continuity in the Database. 


 


During an Auto-ID, the Base Application searches for and configures ImproX hardware for use 


with the IXP220 System.  Perform an Auto-ID after physically connecting and powering up the 


Hardware.  The Auto-ID process differs across the different communication mediums; therefore 


continue with one of the following: 


 


CCoonnttrroolllleerr  CCoonnnneecctteedd  ttoo  HHoosstt  PPCC  uussiinngg  RRSS448855  ((IImmpprrooXX  RRSS))  


1. At the Auto-ID is Recommended for New Sites dialog, click the Yes button. 


2. At the Confirm Auto-ID dialog, click the OK button. 
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3. From the Auto-ID Communications Configuration dialog, select the appropriate Com Port 


record. 


4. From the list of devices displayed, in the Auto-ID Channel column, make your selection.  


5. Click the  button. 


6. At the Firmware Revision dialog, click the  button. 


 


CCoonnttrroolllleerr  CCoonnnneecctteedd  ttoo  tthhee  HHoosstt  PPCC  uussiinngg  TTCCPP//IIPP    


1. At the Auto-ID is Recommended for New Sites dialog, click the Yes button. 


2. At the Confirm Auto-ID dialog, click the OK button. 


3. If your Controller does NOT appear in the Auto-ID Communications Configuration dialog 


continue as follows: 


 


 


When using IP Terminals, do not use the  button.  Instead, make use of the  button. 


 


a. Click the  button. 


b. In the Channel column, replace the default IP Address details with the IP Address of 


your Controller. 


c. Press Enter. 


 


Or alternatively continue as follows: 


  


a. Click the  button. 


b. In the Input dialog, enter the Subnet Mask details for your Network. 


c. Click the  button. 


 


 


The IP Door Controllers (Advanced) tab provides a list of the IP Terminals in the System as well as 


the IP Address of the Controllers they connect to.  When using IP Terminals over a WAN, change the 


Controller IP Address to the IP Address of the Router to ensure that the IP Terminal communicates 


correctly. To do this, continue as follows: 


 


1. On the Auto-ID Channel tab, click the  button.   


2. In the Input dialog, enter the Subnet Mask details for your network. 


3. Click the  button. 


4. Select the IP Door Controllers (Advanced) tab. 


5. In the Address column, enter the Public Static IP Address of the Router the Controller will use 


to communicate with the Terminal. 


6. In the Respond To Address column, enter the Public Static IP Address of the Router the 


Terminal will use to communicate with the Controller. 


7. If necessary, edit the Additional Timeout (0.1s) value. 


8. Continue with Auto-ID as normal. (See step 4 following). 


 


4. From the list of devices displayed, in the Auto-ID Channel column, make your selection.  


5. Click the  button. 


6. At the Firmware Revision dialog, click the  button. 
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CCoonnttrroolllleerr  CCoonnnneecctteedd  oovveerr  aa  WWiiddee  AArreeaa  NNeettwwoorrkk  ((WWAANN))  


 


 


Controllers connected using a GSM Module do NOT support IP Terminals. 


 


1. At the Auto-ID is Recommended for New Sites dialog, click the Yes button. 


2. At the Confirm Auto-ID dialog, click the OK button. 


3. In the Auto ID Communications Configuration dialog, click the Import Channels button. 


4. Select the Discovery.txt file (originally exported from the Discovery Utility). 


5. Click the Open button. 


 


 


The IP Door Controllers (Advanced) tab provides a list of the IP Terminals in the System as well as 


the IP Address of the Controllers they connect to.  When using IP Terminals over a WAN, change the 


Controller IP Address to the IP Address of the Router to ensure that the IP Terminal communicates 


correctly. To do this, continue as follows: 


 


1. On the Auto-ID Channel tab, click the Import Channels button. 


2. Select the Discovery.txt file (originally exported from the Discovery Utility). 


3. Click the Open button. 


4. Select the IP Door Controllers (Advanced) tab. 


5. In the Address column, enter the Public Static IP Address of the Router the Controller will use 


to communicate with the Terminal. 


6. In the Respond To Address column, enter the Public Static IP Address of the Router the 


Terminal will use to communicate with the Controller. 


7. If necessary, edit the Additional Timeout (0.1s) value. 


8. Continue with Auto-ID as normal. (See step 6 following). 


 


6. From the list of devices displayed, in the Auto-ID Channel column, make your selection.  


7. Click the  button. 


8. At the Firmware Revision dialog, click the  button. 


 


 


You may carry out the Auto-ID process at any stage, by selecting Hardware>Auto ID Units. 


 


Connecting Controller A via the network and Controller B (connected to Controller A) by RS485, lets 


you configure both Controllers at the same time.  This is not supported for Controllers connected using 


a GSM Module. 


 


After performing Auto-ID, review the  log of identified units by selecting Hardware>Latest Auto-ID Log 


from the Menu Bar.  This feature lets you check whether Auto-ID has missed any terminals, possibly 


because of a wrong DIP-switch setting or faulty communications.   


 


Firmware Version Confirmation 


After physically connecting, powering up and identifying the ImproX Hardware, confirm whether 


a Firmware upgrade is required.   


 


The Firmware Revisions dialog indicates the Unit Type along with the Latest Firmware revision 


available and the Current Firmware version in use by the unit.  Access the Firmware Revisions 


dialog by selecting Hardware>Firmware Version Check from the Menu Bar. 
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See Part 7 – Utilities for more information on the Firmware Upgrade Utility. 


 


Configuring the Site 


 
Figure 3 – Site Configuration Pane 


 


SSttaannddaarrdd  SSiittee  CCoonnffiigguurraattiioonn  


1. If not already selected, select the  Page Tab. 


2. In the Configuration Pane, complete the Site Name textbox. 


3. Complete the Site Street/Physical Address text area. 


 


AAddvvaanncceedd  SSiittee  CCoonnffiigguurraattiioonn  


Select the Advanced Configuration radio button.   


 


Communications Group Options 


1. If you wish to communicate only with the selected site, select the Communicate 


Exclusively checkbox. 


2. From the Communication Schedule drop-down list select a Communication Schedule (see 


page 73 for information on setting up a Communication Schedule). 


3. From the Communications Architecture drop-down list, select from the following options: 


 Inter-controller—this allows for communication to take place across Controllers.  Inter-


controller Communications is beneficial when used with Building Management and in 


maintaining Anti-passback (APB) status across Controllers. 


 Fall-back—this allows for configuration where TCP/IP is the default communications 


channel and RS485 being the secondary channel.  Where your TCP/IP connection fails, 


the IXP220 Software falls back on RS485 and operations continue as normal (slightly 


slower than TCP/IP).  When the TCP/IP connection restores, the Software automatically 
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resumes communication on the primary TCP/IP connection.  This configuration does 


NOT support inter-controller or pass-through communications. 


 


 


IXP220-1 and IXP220-2 Systems do NOT support Fall-back Communications. 


 


 


The selection you make under point 3 above, determines the options available to you on the Controller 


Configuration Pane. 


 


 


Click the Synchronize button to write IP Mapping files to the IXP220 directory.  These files are used on 


selection of UDP Multi Controller as the communications type.  See Part 7– Utilities for more 


information. 


 


Region Group Options 


1. From the Time Zone drop-down list, make your selection. 


2. Set the Apply Daylight Saving option as follows: 


a. Alongside Apply Daylight Saving, click the Yes radio button. 


b. Click on the Set Daylight Saving button. 


c. In the Set Daylight Saving dialog, set the Time Offset, Start Date, Start Time, End 


Date and End Time. 


d. Click the  button. 


 


Miscellaneous Group Options 


Door Status Polling 


1. Click the Set Parameters button. 


 Set the Polling Frequency (seconds)—how often Doors (Locations) get polled for their 


status. 


 Set the Door Open Time Limit (seconds)—normal duration Doors (Locations) remain 


open. 


2. Click the  button. 


 


Valid Site Codes 


You may set up to 64 Site Codes per Site.  For your convenience, Site Codes may be copied 


between sites using the Copy Selected Codes (All Sites) and Copy Selected Codes 


(Selected Site) buttons.  Configure a list of accepted Site codes (affects HID
®
 Tags only): 


 


1. Click the Configure button. 


 


 
Figure 4 – Site Code Configuration 
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2. Click the  button. 


3. In the Site Code textbox, enter a suitable code.   


4. Select either the Append to Exiting Codes or Overwrite Existing Codes radio button. 


5. Click the  button. 


 


After updating the Site Configuration Pane, click the  button. 


 


Add a Site 


On sites with an unlocked Multi-site License, add a new Site as follows: 


 


1. Select the  Page Tab. 


2. In the Configuration Pane, select the Advanced Configuration radio button. 


3. Click on the  button. 


4. In the IXP220 Site Creator dialog, complete the Site Name textbox. 


5. Complete the Site Street/Physical Address textbox. 


6. Click the  button. 


 


Refer to the section Running Auto-ID on page 16 for further information.  


 


Delete a Site 


 


 


Deleting a Site deletes all information (including Tagholder details and transactions) relating to 


the Site. 


 


To delete a Site, proceed as follows: 


 


1. Select the  Page Tab. 


2. In the Configuration Pane, select the Advanced Configuration radio button. 


3. From the Select Site group, select the Site for deletion. 


4. Click on the  button. 


5. At the Confirmation of Site Deletion warning dialog, click the OK button. 


6. In the Password textbox, enter your administrator password. 


7. Click the  button. 
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22  
Controller Configuration 


 
Figure 5 – Controller Configuration Pane – With Standard Controller Configuration Tab Selected 


 


 


The information displayed in the Communications Channel column varies according to your 


IXP220 Controllers installation: 


 


 Using TCP/IP, the column displays the IP Address of the Controller. 


 Using USB, RS232 or RS485, the column displays the Communications Port number. 


 Using GPRS, the column displays the public static IP Address or the dynamic Host Name 


of the Controller. 


 


IXP220.properties Configuration 


Where you have ImproX iTT or iTRT Ethernet Terminals connected to your Controller (using 


Firmware V4.00 or above), continue as follows: 


 


1. Close the IXP220 Base Application. 


2. From C:\IXP220, open the IXP220.properties file. 


3. Set the ixp220.controller.diagnostic.interval=0 setting. 
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This is how often the Controller calculates the diagnostic statistics.  The minimum value is 1 minute and 


the maximum 60 minutes (1 hour).  This setting does not indicate how often the communications 


diagnostic transaction goes through.  Rather the Controller recalculates the diagnostic transactions and 


compares the latest value to its last calculation.  If there is a notable difference, the Controller sends a 


new transaction.  Refer to Part 4 – Reports for information on the Communications Diagnostic Report. 


 


4. From the Main Menu, select File>Save. 


5. From the Main Menu, select File>Exit. 


6. Open the IXP220 Base Application.  Refer to page 15 for more information on starting the 


Base Application. 


7. Perform a Full Upload.  Refer to page 70 for more information on performing a Full Upload. 


 


General Configuration 


Configure your Controller as follows: 


 


1. Select the  Page Tab. 


2. In the Controller Name textbox, assign your Controller a suitable name. 


3. From the Mode Configuration drop-down list, make your selection.  See page 56 for more 


information on Modes of Operation. 


 


 


The instructions that follow continue as for an Advanced Configuration.  For a Standard Configuration 


ignore references made to fields that appear greyed out.     


 


4. Select the Advanced Configuration radio button. 


5. Enable or disable Controllers as per your requirements, by selecting or de-selecting the 


Controller Enabled checkbox. 


6. From the APB Configuration group, adjust the following settings: 


 Set the APB Lockout Delay on Entry (minutes)—the same Tagholder may not pass 


the same anti-passback (APB) entry access point within the specified time period.   


 Set the APB Lockout Delay on Exit (minutes)—the same Tagholder may not pass the 


same anti-passback (APB) exit access point within the specified time period.   


 


SSiittee  CCoonnffiigguurraattiioonn  SSeett  ttoo  IInntteerr--ccoonnttrroolllleerr  CCoommmmuunniiccaattiioonnss  


With your site setup to use inter-controller communications, continue with the following 


Controller configuration options: 


 


1. From the Primary Communications drop-down list, make your selection.   


2. From the Communications Mode drop-down list, make your selection from the following 


choices: 


 Standard Controller—this is the default choice.  This configuration associates to 


Controller configurations preceding V1.82, including all configuration choices offered in 


IXP220 Software V1.80.  In addition, support includes inter-controller communications 


(for IP Controllers only). 


 Controller Forwards Communications for RS485 Controllers—this allows for inter-


controller communications for Controllers daisy-chained from an IP Controller.  For 


example, Controller A has a network cable connected to it and has Controller B and 


Controller C connected to its RS485 Controller bus.  A Tagholder enters a Door 
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(Location) on Controller A, Controller A will update the anti-passback status of the 


Tagholder on Controller B and Controller C.  This option DOES NOT affect pass 


through communications.  The Software still communicates with the daisy-chained 


Controllers via Controller A.   


 


 


Activate the Controller Forwards Communications for RS485 Controllers option as follows: 


 


1. In the Controller Configuration Pane, click the Communications button.   


2. In the Communication Configuration dialog, click the  button. 


3. In the Address column of the new record, enter the Communication Port details for your 


ImproX RS. 


4. Click the  button. 


5. From the Communications Mode  drop-down, select the Controller Forwards 


Communications for RS485 Controllers option. 


6. From the Primary Communications drop-down list, select the newly added Communication 


Port number. 


 


SSiittee  CCoonnffiigguurraattiioonn  SSeett  ttoo  FFaallll--bbaacckk  CCoommmmuunniiccaattiioonnss  


Fall-back Communications allows for configuration using TCP/IP as the primary 


communications channel and RS485 as the secondary channel.  Where your TCP/IP 


connection fails, the IXP220 Software falls back on RS485 and operations continue as normal 


(slightly slower than TCP/IP).  When the TCP/IP connection restores, the Software automatically 


resumes communication on the primary TCP/IP connection.  This configuration does NOT 


support inter-controller or pass-through communications.  With your site setup to use fall-back 


communications, continue with the following Controller configuration options: 


 


1. From the Primary Communications drop-down list, make your selection.   


2. From the Secondary Communications drop-down list, make your selection.  


 


After updating the Controller Configuration Pane, click the  button. 


 


Changing the Communications Channel 


 


Change your Controller’s Communications Channel as follows: 


 


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. Click the  button.   


4. In the Communication Configuration dialog, click the  button. 


5. In the Address column of the new record, enter the Communication Port number, IP 


Address or Hostname you wish to change to. 


 


 


When entering a Communications Port, use the prefix COM. 


When entering an IP Address or Host Name, ensure that you enter Port number in the Port column. 


 


6. If the Controller has IP Terminals connected, in the Respond Address column of the 


associated IP Terminal records, enter the IP Address referred to in step 5. 
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7. Click the  button. 


8. From the Primary Communications drop-down list, select the newly added 


Communication Port number, IP Address or Hostname. 


9. If the Controller has IP Terminals connected, perform a Full Upload.  For more information 


on performing a Full Upload refer to page 70. 


 


Controller UDP Broadcast Configuration 


 


 


Controller UDP Broadcast will only work if the Primary Communication of your Controller is set to IP.  


Refer to page 24 for more information on changing the primary communication of your controller. 


 


The IXP220 Controller can broadcast transactions as they happen to a defined IP Address.  The 


Base Application lets you configure the IP Address the Controller broadcasts transactions to.  


Once this information uploads to the Controller, the Controller sends an ASCII string for each 


transaction to the IP Address as defined in the Base Application.  This is a Controller specific 


setting.  The format of the broadcast messages are: 


 


 


Where you see <CR> it stands for a carriage return.  Where you see <LR> it stands for a line feed.  


Where you see SSHHCCTT, the SS stands for Site Address (hard-coded to 01), HH stands for Host 


Address (hard-coded to 01), CC stands for Controller Logical Address and TT stands for Terminal 


Logical Address. 


 


 Heartbeat—<site name>,,,,,,,,,,<CR><LF> 


 Status Transactions—<site name>,<date>,<time>,<sequence number>,<event>,<address 


= SSHHCCTT>,<[door no]door name>,<zone>,,,, <CR><LF> 


 Access Transactions—<site name>,<date>,<time>,<sequence 


number>,<event>,<address = SSHHCCTT>,<[door no]door name>,<zone>,<tagholder last 


name>,<tagcode>,<tag type>,<reason code><CR><LF> 


 


This feature gives users direct access to transactions as they happen on the Controller.  Users 


are therefore not forced to rely on the Base Application being on-line all the time. 


 


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. In the UPD Output group, select the Enable UDP Broadcast checkbox. 


4. In the Address textbox, enter the IP Address for the device receiving the broadcasted data. 


5. In the Port textbox, enter the Port number of the device receiving the broadcasted data. 


6. Set the time (in seconds) between notifications using the Keep Alive Time textbox.  The 


default Keep Alive Time is 60 seconds. 


7. Click the  button. 


 


Disconnecting the GSM Module 


 


 


The Remove GSM Module button only appears when configuring a Controller with a GSM Module 


connected. 
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Clicking the Remove GSM Module button uninstalls the GSM Module from the selected 


Controller.  This lets you disconnect the GSM Module safely.   


 


Disconnect the GSM Module as follows: 


 


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. Click the Remove GSM Module button. 


4. At the Confirmation Required dialog, click the OK button. 


 


Full Upload 


Clicking the Upload button uploads the selected Controllers configuration information to the 


physical unit.  Refer to page 70 for more information on performing a Full Upload. 


 


Upgrade 


The textbox situated alongside the Upgrade button, indicates the status of the Controller (either 


Stand-alone or System).  The Stand-alone Controller has a locked Terminal Bus.  You may 


unlock the Terminal Bus by purchasing an unlock code, thus upgrading your Controller to a 


System Controller. 


 


Upgrade your Stand-alone Controller to a System Controller as follows: 


 


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. Click the Upgrade button. 


4. From the Select Device XML File dialog, select the downloaded XML (Webstore Unlock) 


File. 


 


 


The file name reflects the Fixed Address of the Controller for Upgrade. 


 


5. Click the Open button. 


6. At the Unlock Successful dialog, click the OK button. 


7. Click the Upload button. 


 


When you return to the Controller Configuration Pane, you will notice that the textbox alongside 


the Upgrade button now reflects the Controllers new settings. 
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33  
Door Configuration 


The Door Configuration Pane lets you configure a Site’s Doors (Locations) including Terminals, 


Readers, Zones and Door Mode Patterns.   


 


 


See Part 5 – Advanced Configuration for details on Lift (Elevator) control.  


 


 


Editing Door settings or making changes to the Door Mode Patterns resets all Tags in the System to 


Anti-passback (APB) neutral.  This ensures that Tagholders are not denied access because of Tags 


being in the wrong state.  The Anti-passback (APB) state of all Tags again synchronizes correctly on 


first access. 


 


Add a Door 


Doors are set up using the largely intuitive Door Configuration Wizard.  This allows you to 


configure Doors quickly and easily.  Once configured, use the Door Tab ( ) to edit your 


settings. 


 


1. From the Main Menu, select Wizard > Doors. 


2. From the Assign Readers From drop-down list, make your selection from: 


 All Controllers—assigns available Readers from all Controllers. 


 Your Specific Controller—assigns available Readers from a specific Controller. 


3. From the Reader Allocation drop-down list, make your selection: 


 Only Entry Reader—only configures the Entry Reader for each Door. 


 Entry + Exit Reader—configures both the Entry and the Exit Reader for each Door. 


4. From the Door Naming Convention drop-down list, make your selection: 


 Use Template Name—names all Doors according to the name entered in the Door 


Name textbox. 


 Use Controller Name—uses the Controller name for each Door. 


5. If necessary, deselect the Append Incremental Number to Door Name checkbox.  


 


AAdddd  DDoooorr  MMooddee  PPaatttteerrnnss  


 


 


Making changes to the Door Mode Patterns resets all Tags in the System to Anti-passback (APB) 


neutral.  This ensures that Tagholders are not denied access because of Tags being in the wrong 


state.  The Anti-passback (APB) state of all Tags again synchronizes correctly on first access. 


 


The IXP220 Software supports a maximum of 8 Door Mode Patterns at each door.  This setting 


regulates the Door’s (location’s) operating mode including the start and end time.  Continue as 


follows to add a new Door Mode Pattern: 
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1. In the New Door Configuration Wizard, click the Door Mode Pattern button. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the 


newly created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time and End Time—breaks the day into time slots.  By selecting and changing 


the End Time figure, you effectively create extra records, breaking the day into parts.  


You may create a maximum of 8 time slots per Door Mode Pattern. 


 Mode—indicates the mode in which the Door (Location) operates.   


 


 


Door (Location) operating mode examples include:   


 


 Tag—requires presentation of a Tag to gain access. 


 Supervisor Unlock—requires that a Supervisor unlock the Door prior to normal employees 


gaining entrance. 


 Locked—the Door is locked and cannot be overridden with any Tag. 


 Open on First Tag—the door is opened when the first valid Tagholder presents their Tag. 


 No Entry—only Administrators are granted access. 


 Door Entry Code—requires entry of a Door Entry Code to gain access. 


 Open Now—Door opens at specified time.  A Tag is not required to open the Door. 


 Personal Access Code—requires entry of a Personal Access Code to gain access.  Your 


Personal Access Code may range from between 1 to 999999999 followed by a # symbol.   


 


 Finger (B-SHO)—make a selection from the choices presented:  No, ―+Entry‖, ―+Exit‖, 


―+Both‖, ―or Entry‖, ―or Exit‖, ―or Both‖, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger 


only Both‖.  Selecting ―+Entry‖, ―+Exit‖ or ―+Both‖, calls for Tagholders to present their 


Tag (MIFARE® or DESFIRE®) and their fingerprint at the ImproX B-SHO Fingerprint 


Terminal.  Selecting ―or Entry‖, ―or Exit‖ or ―or Both‖, calls for Tagholders to present 


either their Tag or fingerprint at the ImproX B-SHO Fingerprint Terminal.  For the 


following options, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger only Both‖, only 


fingerprint presentation is allowed (the tag reader is disabled). 


   +PIN—make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


PIN-code at the respective Keypad Reader. 


 +Reason—make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


Reason Code (see page 54 for information on Adding a Reason Code) at the respective 


Keypad Reader. 


 +Dual Tag—requires presentation of 2 individual Tags for access. 


 Record—log Transaction.  If you select NO, the ―Allowed In‖ and ―Allowed Out‖ 


transactions do not appear in the Transaction Viewer and do not save to the Database.  


This affects any report using transactions. 


 Denied Alarm—by selecting Yes, you instruct the System to treat denied events as 


alarms.  Set the Controller Mode Configuration to Intrusion or Alarm Arming for 


functionality of this feature. 


 LED—sets the LED’s behaviour during the stipulated time slot. 
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7. Click the  button. 


8. Click the  button. 


 


AAdddd  aa  ZZoonnee  


To create and configure Zones, continue as follows: 


 


1. In the New Door Configuration Wizard, click the Zone button. 


2. Click the  button. 


 


 
Figure 6 – Create Zone Dialog 


 


3. In the Zone Name textbox, assign the Zone a suitable name. 


4. Select one of the Anti-passback (APB) Mode radio buttons: 


 Off—Anti-passback (APB) not enforced.   


 Relaxed—after entering a Zone, the Tagholder must exit the Zone using their Tag 


before they can re-enter.  However, Tagholders can use their Tags for multiple, 


consecutive exits in this Mode. 


 Strict—enforced Anti-passback (APB) Zone rules for in and out directions.  A 


Tagholder cannot enter or exit a Zone consecutively. 


 


 


You may elect from time to time to reset Anti-passback (APB), essentially giving ALL Tagholders a 


―free pass‖ on their next transaction.  Carry out this task as follows: 


 


1. From the Main Menu, select Hardware>Reset Anti-passback. 


2. At the Reset Anti-passback dialog, click the OK button. 


 


Should you wish to reset Anti-passback (APB) on an individual Tagholder, refer to page 48, 


Miscellaneous Configuration for more information. 


 


5. Click the  button. 


 


 


Once the Zone record appears on the Zone tab, edit the Zone Name and APB Mode settings using the 


Configuration Pane.    
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Configure multiple Zone records at the same time, by holding down the Ctrl key and selecting multiple 


records.  Alternately hold down the left mouse button and drag your mouse over the records, making 


your selection. 


 


6. Click the  button. 


 


DDoooorr  TTeemmppllaattee  SSeettuupp  


1. Select the Door Tab. 


2. In the Door Name textbox, assign the Door a suitable name up to 20 characters.  If under 


Door naming Convention you selected Use Template Name, the name you assign becomes 


the door name template.  Refer to page 27 for more information on the Door Naming 


Convention setting. 


3. Under Zone, select a Zone from the drop-down list. 


4. In the Door Entry Code textbox, enter a 5-digit number for use in gaining access.  Refer to 


Door Mode Patterns page 27 for more information on setting Modes. 


 


 


Using a Door Entry Code allows Tagholders to enter or exit a Door using a numeric code.  Note, 


however, Tags with access permissions for the Door (Location) are still acknowledged by the Reader.       


Activate the Door Entry Code feature, as follows: 


 


1. On the Door Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the newly 


created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time, End Time, +PIN, +Reason, +Dual Tag, Record, Denied Alarm and LED. 


 Mode—select Door Entry Code from the drop-down list.  (Door Entry Codes range from  


1 to 65535.  After entering the Door Entry Code at the Reader or Terminal, complete the 


entry by pressing the # key). 


7. Click the  button. 


8. On the Door Configuration Pane, select the Door Tab. 


9. In the Door Entry Code textbox, enter a 5-digit numeric code. 


 


5. In the Daily Door Mode Patterns group, make your selections from the Day’s Door Mode 


Pattern drop-down lists. 


 


Entry or Exit Reader Configuration 


1. Select the Entry or Exit Tab. 


2. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic features. 


 Advanced Configuration—activates extra advanced features. 


3. From the RTE Mode drop-down list, make your selection from the following: 


 Normally Open—use this option when connecting Normally Open switches. 


 Normally Closed—use this option when connecting Normally Closed switches.  


4. From the Reader Function drop-down list, make your selection from the following: 


 Access Control—sets a flag in the Database alerting third-party time and attendance 


applications that the door is used for Access Control purposes only. 
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 Access Control + Time & Attendance—sets a flag in the database alerting third-party 


time and attendance applications that the Door is used for Time and Attendance and 


Access Control functions. 


5. From the DOS Mode group, from the DOS Mode drop-down list, make your selection: 


 Normally Closed—use this option when connecting Normally Closed Door Sensors. 


 Normally Open—use this option when connecting Normally Open Door Sensors. 


6. From the DOS Usage drop-down list, make your selection from the following: 


 Normal—alarm sounds if the Door remains open too long or if the Door is forced.  Use 


this feature for monitoring real Door open states. 


 Terminate Strike—deactivates the relay if Door is opened and closed or forced.  Use 


this feature where the lock must re-engage once the Door is closed. 


 Inhibit—deactivates the Reader as long as the Door is open; also there is no alarm for 


Doors forced open.  Used when the Door is opened, the Reader disables while the Door 


remains open. 


7. Edit the Strike Duration (0.1s) textbox, the default value is 40 (0.1s).  Setting the Strike 


Duration to 55555 toggles the Relay. 


8. Edit the Open Duration(s) textbox.  By default, the Open Duration is set to 0, disabling the 


Door Open Sensor (DOS).  


9. Enable End-of-line Sensing by selecting the Enable End-of-line Sensing checkbox. 


 


 


End-of-line Sensing lets the System raise an alarm when somebody bypasses the Door Open Sensor.  


That is, the System distinguishes between tampering on the circuit and closure of the Door Open 


Sensor.  End-of-line sensing on the IXP220 Controller, ImproX iTT (input 1 and 3 only) and iTRT (input 


1 and 3 only) is only possible if Door Open Sensing is configured.  Set End-of-line Sensing per Door. 


 


10. From the ON VALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


11. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


12. From the On INVALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


13. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


14. Click the  button. 


15. Review the Door configuration settings selected.  If you accept the settings, click the  


button. 


 


Edit a Door 


Configuration of multiple Doors (Locations) is allowed.  Configure multiple Doors (Locations), by 


holding down the Ctrl key and selecting multiple records.  Alternatively, hold down the left 


mouse button and drag your mouse over the records.  Multi-selecting Doors (Locations) loads 


the default values for all Doors and Readers, only the changed settings save to the individual 


Doors. 


 


1. Select the  Page Tab. Within the previously selected Door Tab, you will notice a new set 


of Tabs activate.  These include a new Door Tab, an Entry Tab and an Exit Tab. 


2. Select the Door you wish to edit. 
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Figure 7 – Left-hand Side of the Door Configuration Pane 


 


3. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic Access Control features. 


 Advanced Configuration—activates extra advanced features, for sites that need Daily 


Door Mode Patterns, Zones, Door Entry Codes and Alarm Arming. 


 


 


The Enable Bell checkbox only activates on Doors using ImproX (KMA) Keypad Mullion Antenna 


Readers.  Selecting this checkbox activates the Bell button (situated at the bottom of the Antenna 


Reader’s Keypad).  


 


EEddiitt  RReeaaddeerrss  


To edit and configure Readers, continue as follows: 


 


Reader Selection 


1. In the Reader Configuration group (see Figure 7), alongside the Entry Reader textbox, 


click the Select button. 


2. In the Unassigned Readers dialog, from the list of displayed records, select a Reader. 


 


 


In the Unassigned Readers dialog, reduce the number of Readers displayed by selecting a specific 


Controller from the Controller Filter drop-down list. 


 


3. Click the  button. 


4. Alongside the Exit Reader textbox, click the Select button. 


5. In the Unassigned Readers dialog, from the list of displayed records, select a Reader. 


6. Click the  button. 
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Select a single Reader by double-clicking the Reader's record.  Alternatively multi-select Readers as 


follows: 


 


1. Click the Entry Reader’s Select button. 


2. In the Unassigned Readers Dialog, select both your Entry and Exit Readers.  


3. Click the  button. 


 


The IXP220 Software automatically assigns the top selected Reader as the Entry Reader and the 


bottom selected Reader as the Exit Reader.    


 


7. Click the  button. 


 


Entry or Exit Reader Configuration 


1. Select the Entry or Exit Tab. 


 


 


The settings displayed on the Entry or Exit Tabs depend on the type of Terminal connected.  Ignore 


references made below to fields that do not display. 


 


2. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic features. 


 Advanced Configuration—activates extra advanced features. 


3. From the Miscellaneous group, from the RTE Mode drop-down list, make your selection 


from the following: 


 Normally Open—use this option when connecting Normally Open switches. 


 Normally Closed—use this option when connecting Normally Closed switches.  


4. From the Reader Function drop-down list, make your selection from the following: 


 Access Control—sets a flag in the Database alerting third-party time and attendance 


applications that the door is used for Access Control purposes only. 


 Access Control + Time & Attendance—sets a flag in the database alerting third-party 


time and attendance applications that the Door is used for Time and Attendance and 


Access Control functions. 


5. From the Message Display Supervisor drop-down list, make your selection. 


6. From the Enable Off-line Validation drop-down list, make your selection from the following: 


 Disabled—disables off-line validation. 


 Enabled—enables off-line validation. 


 


 


ImproX iTT and ImproX iTRT units connected by IP will always run in Full Off-line Validation Mode. 


ImproX iTT and ImproX iTRT units connected by RS485 will run in Full Off-line Validation Mode when 


there are 1 000 Tags or less in the System.  Once this threshold is exceeded, it will switch over to 


Cached Off-line Validation Mode.  Cached Off-line Validation Mode relies on transactions in the ImproX 


iTT and ImproX iTRT Transaction Buffer to make access control decisions. 


 


7. From the DOS Mode group, from the DOS Mode drop-down list, make your selection from 


the following: 


 Normally Closed—use this option when connecting Normally Closed Door Sensors. 


 Normally Open—use this option when connecting Normally Open Door Sensors. 


8. From the DOS Usage drop-down list, make your selection from the following: 


 Normal—alarm sounds if the Door remains open too long or if the Door is forced.  Use 


this feature for monitoring real Door open states. 
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 Terminate Strike—deactivates the relay if Door is opened and closed or forced.  Use 


this feature where the lock must re-engage once the Door is closed. 


 Inhibit—deactivates the Reader as long as the Door is open; also there is no alarm for 


Doors forced open.  Used when the Door is opened, the Reader disables while the Door 


remains open. 


9. Edit the Strike Duration (0.1s) textbox, the default value is 40 (0.1s).  Setting the Strike 


Duration to 55555 toggles the Relay. 


10. Edit the Open Duration(s) textbox.  By default, the Open Duration is set to 0, disabling the 


Door Open Sensor (DOS).  


11. Enable End-of-line Sensing by selecting the Enable End-of-line Sensing checkbox. 


 


 


End-of-line Sensing lets the System raise an alarm when somebody bypasses the Door Open Sensor 


(DOS).  That is, the System distinguishes between tampering on the circuit and closure of the Door 


Open Sensor (DOS).  End-of-line sensing on the IXP220 Controller, ImproX iTT (input 1 and 3 only) 


and iTRT (input 1 and 3 only) is only possible if Door Open Sensing is configured.  Set End-of-line 


Sensing per Door. 


 


12. From the ON VALID Tag group, from the LED Action drop-down list, select the required 


LED Colour State and Duration. 


13. From the Buzzer Volume drop-down list, select the Buzzer Volume and Duration. 


14. From the ON INVALID Tag group, from the LED Action drop-down list, select the required 


LED Colour State and Duration. 


15. From the Buzzer Volume drop-down list, select the Buzzer Volume and Duration. 


16. Click the  button. 


 


Edit a Zone 


To edit and configure Zones, continue as follows: 


 


1. On the Configuration Pane, select the Zone Tab. 


2. Select the Zone you wish to edit. 


3. On the right-hand side of the Configuration Pane, in the Zone Name textbox, edit the name 


of your Zone. 


4. Select one of the Anti-passback (APB) Mode radio buttons: 


 Off  


 Relaxed 


 Strict 


 


 


You may elect from time to time to reset Anti-passback (APB), essentially giving ALL Tagholders a 


―free pass‖ on their next transaction.  Carry out this task as follows: 


 


1. From the Main Menu, select Hardware>Reset Anti-passback. 


2. At the Reset Anti-passback dialog, click the OK button. 


 


Should you wish to reset Anti-passback (APB) on an individual Tagholder, refer to page 48, 


Miscellaneous Configuration for more information. 


 


5. Click the  button. 
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Configure multiple Zone records at the same time, by holding down the Ctrl key and selecting multiple 


records.  Alternately hold down the left mouse button and drag your mouse over the records, making 


your selection. 


 


Edit Door Mode Patterns 


 


 


Making changes to the Door Mode Patterns resets all Tags in the System to Anti-passback (APB) 


neutral.  This ensures that Tagholders are not denied access because of Tags being in the wrong 


state.  The Anti-passback (APB) state of all Tags again synchronizes correctly on first access. 


 


The IXP220 Software supports a maximum of 8 Door Mode Patterns at each Door.  This setting 


regulates the Door’s (Location’s) operating mode including the start and end time. 


Continue as follows to edit a Door Mode Pattern: 


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. From the records displayed on the left-hand side of the Configuration Pane, select the Door 


Mode Pattern record you wish to edit. 


3. In the Pattern Name textbox, edit the name of your Door Mode Pattern. 


4. Edit the following settings for the selected record: 


 Start Time and End Time 


 Mode  


 


 


Door (Location) operating mode examples include:   


 


 Tag—requires presentation of a Tag to gain access. 


 Supervisor Unlock—requires that a Supervisor unlock the Door prior to normal employees 


gaining entrance.  


 Locked—the Door is locked and cannot be overridden with any Tag. 


 Open on First Tag—the Door is opened when the first valid Tagholder presents their Tag. 


 No Entry—only Administrators are granted access. 


 Door Entry Code—requires entry of a Door Entry Code to gain access. 


 Open Now—Door opens at specified time.  A Tag is not required to open the Door. 


 Personal Access Code—requires entry of a Personal Access Code to gain access.  Your 


Personal Access Code may range from between 1 to 999999999 followed by a # symbol.   


 


 Finger (B-SHO) 


 +PIN 


 +Reason 


 +Dual Tag 


 Record 


 Denied Alarm 


 LED 


5. Click the  button. 


 


Edit Advanced Door Configuration 


On selecting the Advanced Configuration radio button, additional advanced settings activate. 
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Continue as follows to edit these settings: 


 


 
Figure 8 – Right-hand Side of the Door Configuration Pane 


 


1. On the Door Configuration Pane, select the Door Tab. 


2. In the Daily Door Mode Patterns group (see Figure 8), make your selections from the 


Day’s Door Mode Pattern drop-down lists. 


3. In the Zone group, select a Zone from the drop-down list. 


 


 
 


Using a Door Entry Code allows Tagholders to enter or exit a Door using a numeric code.  Note, 


however, Tags with access permissions for the Door (Location) are still acknowledged by the Reader.       


Activate the Door Entry Code feature, as follows: 


 


1. On the Door Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the newly 


created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time, End Time, +PIN, +Reason, +Dual Tag, Record, Denied Alarm and LED. 


 Mode—select Door Entry Code from the drop-down list.  (Door Entry Codes range from  


1 to 65535.  After entering the Door Entry Code at the Reader or Terminal, complete the 


entry by pressing the # key). 


7. Click the  button. 


8. On the Door Configuration Pane, select the Door Tab. 


9. In the Door Entry Code textbox, enter a 5-digit numeric code. 
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Refer page 57 for details on Alarm Arming. 


 


 


CCTV integration allows for better end user site management, that is in areas with rising crime, your 


receptionist can from a safe location monitor and control up to 4 Doors (Locations) (4 Cameras) at a 


time per site.  Configure your IP Camera (Axis 210 or 213D range only) as follows: 


 


1. On the Door Configuration Pane, select the Door Tab. 


2. Click the Advanced Configuration radio button. 


3. Within the IP Camera group, click the Configure button. 


4. In the IP Camera Configuration dialog, click the  button. 


5. In the Name textbox, assign your camera a meaningful name. 


6. In the Lookup textbox, enter the IP Address for your camera. 


7. Click the  button 


8. Exit the dialog by clicking the  button. 


9. Select the Door from the list of available Door records. 


10. From the IP Camera drop-down list, select a Camera record, thus associating the Door and IP 


Camera. 


11. Click the  button 


 


4. Click the  button. 


 


Delete a Door 


Deleting a Door automatically deletes reference to assigned Readers.  Thus, these Readers 


return to the Unassigned Readers list ready for you to reallocate to a new Door.  Continue as 


follows to delete a Door (Location): 


 


1. Select the  Page Tab. 


2. On the Configuration Pane, select the Door Tab. 


3. From the Doors Table on the left-hand side of the Configuration Pane, select the Door 


record for deletion. 


4. Click the  button. 


5. At the Warning dialog, click Yes. 


 


Delete a Zone 


1. Select the  Page Tab. 


2. On the Configuration Pane, select the Zone Tab. 


3. From the Zone records displayed, select the Zone for deletion. 


4. Click the  button. 


5. Click the  button. 


 


 


You may delete multiple Zones at the same time, by holding down the Ctrl key and selecting multiple 


records.  Alternately hold down the left mouse button and drag your mouse over the records, making 


your selection. 
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Delete a Door Mode Pattern 


1. Select the   Page Tab. 


2. On the Configuration Pane, select the Door Mode Pattern Tab. 


3. From the Door Mode Pattern Table on the left-hand side of the Configuration Pane, select the 


Door Mode Pattern record for deletion. 


4. Click the  button. 


5. At the Confirmation Warning dialog, click Yes. 


 


 


 


  







Part 3 – General Configuration 


February 2012  39 


44  
Access Group Configuration 


Each Tagholder in a Site is assigned to at least one Tagholder Access Group.  The purpose of 


Access Groups is to grant Tagholder access permissions in bulk.  This saves you the trouble of 


configuring Tagholders one-at-a-time. 


 


Configure Tagholder Access Groups 


CCrreeaattee  aa  TTaagghhoollddeerr  AAcccceessss  GGrroouupp  


 


 


For information on setting a Lift (Elevator) Access Group, see Part 5 – Advanced Configuration. 


 


 
Figure 9 – Left-hand Side of the Access Group Pane (General Access Tab Selected) 


 


To create a Tagholder Access Group, proceed as follows: 


 


1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. As highlighted in Figure 9, click the  button. 


4. In the Access Group textbox, assign your Access Group a suitable name. 
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5. From the Allow For radio buttons, select either of the following choices: 


 Administrator/Supervisor Tags 


 All Tags—Visitor and Employee Tagholders. 


6. Click the  button. 


 


 


Only the SYSDBA user can give a Tagholder access to a Tagholder Access Group categorized as 


Administrator or Supervisor. 


 


CCrreeaattee  aann  AAcccceessss  TTiimmee  PPaatttteerrnn  


 


 


You may add a maximum of 8 Access Time Patterns to each Access Group.    


 


 
Figure 10 – Right-hand Side of the Access Group Pane (General Access Tab Selected) 


 


To create an Access Time Pattern, proceed as follows: 


 


1. As highlighted in Figure 10, click the  button. 


2. In the Access Pattern Configuration group, select the Door Tab. 


3. In the No Access Doors text area, select the Door you want the Access Pattern applied to. 


 


 


From the No Access Doors text area, select multiple Doors (Locations), by holding down the Ctrl key 


and selecting multiple records.   


 


4. Click the  button. 
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5. In the Access Pattern Configuration group, select the Day & Time Tab. 


6. From the Select Day Pattern group, deselect checkboxes where NOT applying the Pattern. 


7. In the Start Time textbox, enter a suitable start time. 


8. In the End Time textbox, enter a suitable end time. 


 


 


The Duration automatically calculates based on the information you capture into the Start and End 


Time textboxes.    


  


9. Click the  button. 


 


SSeelleecctt  aann  AAcccceessss  GGrroouupp  


To select an existing Tagholder Access Group, proceed as follows: 


 


1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. From the list of Access Group records (see the highlighted area in Figure 9 for more 


information) select a record. 


 


The selected Access Group’s details display on the right-hand side of the Access Groups 


Configuration Pane.  See Figure 10 for more information.   


 


DDeelleettee  AAcccceessss  GGrroouupp  aanndd  AAcccceessss  TTiimmee  PPaatttteerrnn  DDeettaaiillss  


To delete a Tagholder Access Group, proceed as follows: 


 


1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. From the list of Access Group records (see the highlighted area in Figure 9 for more 


information) select a record. 


4. Click the  button. 


5. Click Yes.  


 


EEddiitt  AAcccceessss  GGrroouupp  aanndd  AAcccceessss  TTiimmee  PPaatttteerrnn  DDeettaaiillss  


To edit a Tagholder Access Group, proceed as follows: 


 


1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. From the list of Access Group records (see the highlighted area in Figure 9 for more 


information) select a record. 


4. Edit the Access Time Pattern details as required. 


5. Click the  button. 


6. When using distributed templates along with biometrics, after editing the Lift (Elevator) 


Group, ensure you perform a full upload.  Refer to page 70 for more information on 


performing a full upload.     
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55  
Tagholder Configuration 


A Tagholder is any person who uses a Tag in accessing a Site.  Visitors are Tagholders with 


restricted access rights.  Before assigning access to a Tag, first assign the Tag to a Tagholder.   


 


Add a Tagholder 


To add a Tagholder, proceed as follows: 


 


1. Select the  Page Tab. 


2. Click the  button. 


 


 
Figure 11 – Tagholder Dialog (Showing the General Tab) 


 


 


To add a Tagholder through the Transaction Viewer: 


 


1. Present an un-enrolled tag to a Reader. 


2. In the Transaction Viewer, right click on the unidentified Tag. 
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3. Select Enroll Tag. 


4. Continue with either of the following processes: 


 


Tagholders without Tags 


a. At the Tagholders without Tags dialog, select a Tagholder. 


b. Click the  button. 


c. Within the Tagholder dialog, on the General tab, complete the fields as required. 


d. Continue with step 5. 


 


New Tagholders 


a. At the Tagholder dialog, enter the Tagholder’s First Name. 


b. Enter the Tagholder’s Last Name. 


c. Complete the remaining fields as required. 


d. Continue with step 5. 


 


5. Select the Tag tab. 


6. Within the Access Rights group, from the Access Group drop-down list, make your 


selection. 


7. Complete the remaining fields as required. 


8. Click the  button. 


 


The Tagholder dialog consists of two tabs namely General and Tag.  The General Tab allows 


addition of a Tagholder’s information, while the Tag Tab allows Tag assignment.  On the General 


Tab, only the First Name and Last Name fields are required.  However, we recommend 


entering as much information as possible. 


3. In the Tagholder dialog, select the General Tab. 


4. Enter the Tagholder’s First Name. 


5. Enter the Tagholder’s Last Name. 


6. From the Configuration Level group, select from the following radio buttons: 


 Standard Configuration—displays standard Tagholder details. 


 Advanced Configuration—displays extra advanced Tagholder details. 


 


 


The instructions below continue as for an Advanced Configuration.  For a Standard Configuration 


ignore references made to fields that appear greyed out.     


 


7. In the PIN Used with Tag textbox, enter a PIN-code of up to 5 digits.  (PIN-codes range 


from 2 to 65534.  After entering the PIN-code at the Reader or Terminal, complete the entry 


by pressing the # key). 


8. Enter the Tagholders Company name details. 


9. From the Department drop-down list, select a department name.  


 


 


Add extra Departments as follows: 


 


1. Click the Department button.   


2. Click the  button. 


3. In the Department textbox, enter a suitable name for the Department. 


4. Click the  button. 


5. Click the  button. 


 


Click the  button to edit a Department or the  button to delete a Department. 
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The Send E-Mail button lets you send Tagholder details to interested parties.  The To textbox is 


mandatory, thus requiring data entry for successful e-mail transmission.  For e-mail setup information 


please refer to the section Preference Configuration (System Notification Tab) on page 63. 


 


10. From the Type drop-down list make your selection.  The value selected, once captured in 


the master table, lets the third-party Time and Attendance Software determine who to 


calculate and who not to calculate.  For Sites using third-party Time and Attendance 


Software we therefore recommend selecting the Access and Time option, for all other 


installations select the Access Only option.    


11. Complete other personal information as necessary. 


  


 


Add a Tagholder Image as follows: 


 


1. Click the button.   


2. At the Open dialog, select the image file.  Image formats supported include:  jpg, jpeg, gif, tif 


and tiff.  The recommended resolution is 640 x 480 pixels. 


3. Click the Open button. 


 


For more information on the Live Video Image Capture feature ( ) please see Part 5 – Advanced 


Configuration. 


 


Clicking the  button opens the Edit dialog, allowing image cropping, rotation, resizing and use of an 


image mirror effect. 


 


 


To change the Tagholder Image back to the default image: 


 


1. Right click on the Tagholder Image. 


2. Select Default Image. 


 


12. Use the Note text area when entering further information about the Tagholder. 


13. Click the  button. 


 


 


To view a Transaction Image: 


 


1. From the Main Menu, Select View. 


2. Select Enable Transaction Image. 


 


Once Enable Transaction Image is selected, a dialog window will open.  This dialog window will 


display the image for the last Tagholder to have a transaction. 


 


Add a Tagholder by E-mail 


RReeqquueessttiinngg  tthhee  AAvvaaiillaabbllee  SSuubbjjeecctt  LLiinnee  LLiisstt  


 


 


You do not need to perform step 1 every time you want to add a Tagholder by e-mail. 


 


1. Using your preferred e-mail client, create an e-mail message. 
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2. In the To textbox, enter the E-mail Address you configured in E-mail Account Configuration 
(see page 63 for more information). 


3. In the Subject textbox, enter the phrase HELP. 
4. In the body of the E-mail Message, enter the Password you configured in Incoming 


Configuration (see page 64 for more information). 
5. Click the Send button. 


 


RReeqquueessttiinngg  tthhee  EEnnrroollllmmeenntt  FFoorrmm  


1. Using your preferred e-mail client, create an e-mail message. 
2. In the To textbox, enter the E-mail Address you configured in E-mail Account Configuration 


(see page 63 for more information). 
3. In the Subject textbox, enter the phrase ENROLLMENT. 
4. In the body of the E-mail message, enter the password you configured in Incoming 


Configuration (see page 64 for more information). 
5. Click the Send button. 


 


CCoommpplleettiinngg  tthhee  EEnnrroollllmmeenntt  RReeqquueesstt  FFoorrmm  


 


 


The Enrollment Request Form expires after 1 hour, or if the base Application closes.  Each template 


can only be used once. 


 


1. In your e-mail client, select the e-mail with ENROLLMENT TEMPLATE REQUEST in the 
subject. 


2. Open the message attachment. 
 


 


If the ENROLLMENT TEMPLATE REQUEST form does not display correctly, save the attachment to 


your PC and then open it. 


 
3. From the Tagholder Details group, fill in the following required textboxes: 


 First Name—fill in the Tagholder’s first name. 


 Last Name—fill in the Tagholder’s last name. 


 Complete other personal information as necessary. 


4. From the Tag group, select from the following drop-down lists: 


 Tag—Select either Issue on Arrival or Generate Personal Access Code. 


  Tag Level—option activates when you select the Generate Personal Access Code option 


on the Tag drop-down list. Your Tag Level options include Visitor or Normal. 


 Site—select the site the Tagholder belongs to. 


5. Click the Generate Request button. 
6. Click the OK button at the Windows Internet Explorer dialog. 
7. Click the Allow button at the Microsoft Office dialog. 


 


Assign Tags to Tagholders 


A Tagholder can have up to 4 Tags assigned to them.  To assign Tags to a Tagholder, proceed 


as follows: 


 


1. In the Tagholder dialog, select the Tag Tab. 


2. Click any of the Create New Tag buttons.   
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Figure 12 – Tagholder Dialog (Showing the Tag Tab) 


 


3. From the Configuration Level group, select from the following radio buttons: 


 Standard Configuration—disables advanced configuration options. 


 Advanced Configuration—enables advanced configuration options. 


 


 


The instructions below continue as for an Advanced Configuration.  For a Standard Configuration 


ignore references made to fields that appear greyed out.     


 


SSeelleeccttiinngg  aa  RReeggiissttrraattiioonn  RReeaaddeerr  


1. From the Miscellaneous group, select the Configure Reader button. 


2. In the Configure Tag Reader dialog, from the Use Registration Reader radio buttons, 


select one of the following: 


 Yes—when selected, the Registration Reader Port drop-down list activates.  Select 


the Port Number to which you connected your Registration Reader. 


 No—selected by default, activates the Select Reader drop-down list.  Select the 


Reader you intend using as the Registration Reader from the list of available Readers. 


3. Click the  button. 
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TTaagg  EEnnrroollllmmeenntt  


1. Present a Tag to an Enrollment Reader.  


2. On the Tag tab, click the Read Tag button.   


 


 


When the IXP220 Software detects the Tag, the Tag number displays in the Number textbox. 


 


 


When the Software is set to ignore the Tag type, the Tag type updates automatically.  When the Tag 


type is taken into consideration, select the Tag type from the Type drop-down list.  Your Tag Type 


options include: 


 


 Standard (125 kHz)—previously described as Slim Tag 5 Bytes. 


 Read/Write (125 kHz, 2048 bits)—previously described as WriTag 2048. 


 Read/Write (125 kHz, 128 bits)—previously described as WriTag 128. 


 3rd Party (Other)—previously described as ASCII/Barcode/Magstripe. 


 Personal Access Code—create a Personal Access Code (PAC) by selecting the Personal 


Access Code choice from the Type drop-down list and entering the Personal Access Code 


(PAC) in the Tag Code textbox.  Your Personal Access Code may range from between 1 to 


999999999.  After entering the Personal Access Code at the Reader or Terminal, complete the 


entry by pressing the # key). 


 RF/Infrared—previously described as RF/Infrared Tag. 


 Mifare—previously described as Mifare Tag. 


 HID (125 kHz)—previously described as HID Tag. 


 13.56 MHz (General)—previously described as General 13.56 MHz. 


 FeliCa—previously described as FeliCa Tag. 


 


AAcccceessss  RRiigghhttss  CCoonnffiigguurraattiioonn  


1. From the Site drop-down list, select the Site name. 


 


 


Alternatively, click the  button to select the Access Group for the Tagholder across all Sites. 


 


2. From the Level drop-down list make your selection from the following choices: 


 Visitor—restricted access, valid for day of issue only. 


 Normal—employee Tagholder.  Access restricted by Door Mode. 


 Supervisor—opens Doors (Locations) in Supervisor Mode, overrides Anti-passback 


(APB) and may cancel alarms. 


 Administrator—opens Doors (Locations) in Supervisor Mode and ignores No Entry 


Mode. 


3. From the Access Group drop-down list, make a selection. 


 


 


Alternatively, click the  button to create a new Access Group. 


 


 


You must assign a Tagholder Access Group for the Tag to have any access rights. 
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TTaagg  EExxppiirryy  CCoonnffiigguurraattiioonn  


For temporary Tagholders, proceed as follows: 


1. From the Start Date drop-down list, select a suitable start date. 


2. In the Start Time textboxes, enter a suitable start time. 


3. From the Expiry Date drop-down list, select a suitable expiry date. 


4. In the Expiry Time textboxes, enter a suitable expiry time. 


 


MMeessssaaggee  CCoonnffiigguurraattiioonn  


 


 


For information on adding Messages, refer to the Messages section on page 53. 


 


From the Message drop-down list, select a Message for display. 


 


 


Alternatively, click the  button to create a new Message. 


 


MMiisscceellllaanneeoouuss  CCoonnffiigguurraattiioonn  


 Reset APB—resets the Anti-passback (APB) status for an individual Tagholder. 


 Suspend—suspends the Tag in the event the Tag is lost or no longer required. 


 Copy Tag—copies the Tag code for use in sites with Tags and biometric facilities, thus 


upholding Anti-passback (APB) rules. 


 Usage—stores a description of the Tag’s usage. 


 Configure Reader—select the Reader for use as the Registration Reader for the site. 


 Configure Biometric Reader—opens the Tagholder biometric configuration and enrollment 


settings.  See Part 8 – Integration Modules for more information. 


 


GGeenneerraall  DDeettaaiillss  


1. Click the  button. 


2. Click the  button. 


 


If necessary, repeat the Assign Tags to Tagholders procedure for any extra Tags. 


 


Delete an Assigned Tag 


To delete an assigned Tag, proceed as follows: 


 


1. Select the  Page Tab. 


2. From the list of Tagholder records displayed, double-click the Tagholder record for editing. 


3. In the Tagholder dialog, select the Tag Tab. 


4. Click the assigned Tag button (that is Tag 1, Tag 2, Tag 3 or Tag 4) for deletion. 


5. Click the  button. 


6. Click the  button. 


7. Click the  button. 
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Delete a Tagholder 


 


Before deleting a Tagholder, first delete all Tags assigned to the Tagholder. 


 


To delete a Tagholder from the IXP220 System, proceed as follows: 


 


1. Select the  Page Tab. 


2. From the list of Tagholder records displayed, select the Tagholder record for deletion. 


3. Click the  button. 


4. At the Warning dialog, click the OK button. 


 


Set the Default Card Template 


When configuring a Tagholder, this facility allows you to select, from a library of Card Templates, 


the template to be used as the default when printing Credit Card Tags for that Tagholder. 


 


 


For information on setting the Default Card Template, see the Card Designer chapter of Part 6 – 


IXP220 Software Modules. 


 


Batch Enrollment of Tags 


The Batch Enrollment feature lets you rapidly assign multiple Tags to a Site, without entering 


Tagholder details. 


 


SSttaarrtt  BBaattcchh  EEnnrroollllmmeenntt  


1. From the Main Menu, select Tagholder>Batch Tagholders.   


 


 
Figure 13 – Batch Tag Registration Configuration Pane 
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2. From the Select Tag Level drop-down list, select from the following choices: 


 Visitor—restricted access, valid for day of issue only. 


 Normal—employee Tagholder.  Access restricted by Door Mode. 


 Supervisor—opens Doors in Supervisor Mode, overrides Anti-passback (APB) and 


may cancel alarms. 


 Administrator—opens Doors in Supervisor Mode and ignores No Entry Mode. 


3. From the Select Access Group drop-down list, select an Access Group. 


4. Enter a Starting Tag Reference Number.  The Starting Tag Reference Number is any 


number that you can use temporarily in identifying the Tags. 


5. From the Select Department drop-down list, select a Department. 


 


 


Add extra Departments as follows: 


 


1. Click the Department button.   


2. Click the  button. 


3. In the Department textbox, enter a suitable name for the Department. 


4. Click the  button. 


5. Click the  button. 


 


Click the  button to edit a Department or the  button to delete a Department. 


 


6. Select one of the following to start the Batch Enrollment process:  


 Batch Mode Auto Read 


 Manual Read 


 


BBaattcchh  MMooddee  AAuuttoo  RReeaadd  


This Mode lets you scan a batch of Tags in quick succession: 


 


1. Select the Batch Mode Auto Read radio button. 


2. Click the Start button. 


3. Present Tags to the Enrollment Reader one at a time. 


4. Click the Stop button. 


5. On enabling, click the  button. 


 


MMaannuuaall  RReeaadd  MMooddee  


Manual Mode lets you scan a batch of Tags one at a time.  It is useful if the Enrollment Reader 


is away from the Host PC. 


 


1. Select the Manual Mode radio button. 


2. Present a Tag to the Enrollment Reader. 


3. Click the Read button.  On reading the Tag, its numbers display in the Tag Code and 


Second Tag Code (if applicable) textboxes along with their Tag Types. 


4. Click the Add button. 


5. Repeat steps 1 to 4 for further Tags. 


6. After you’ve scanned all the Tags, click the  button. 
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NNoonn--rreeaadd  MMooddee  


This Mode lets you load a range of Tags without physically scanning the Tags.  You may load up 


to 1 000 Tags at a time. 


 


1. Select the Non-read Mode radio button. 


2. In the First Tag Code textbox, enter the first tag code in the range. 


3. In the Last Tag Code textbox, enter the last tag code in the range. 


4. On enabling, click the  button. 


 


Advanced Search 


To search for a Tagholder, continue as follows: 


 


1. Select the  Page Tab. 


2. Enter a suitable keyword in the Search By textbox. 


 


As you type, the Software automatically matches the keyword, highlighting the Tagholder record 


with the closest match. 
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66  
Holidays 


This feature lets you assign different access rights on holidays than on normal working days.  If 


the Holiday checkbox in an Access Pattern is selected, then Tagholders assigned to that 


Access Pattern have access to a Site on or during Holidays.  The IXP220 Software supports a 


maximum of 40 holidays per Site. 


 


AAdddd,,  EEddiitt,,  oorr  DDeelleettee  aa  HHoolliiddaayy  


To add, edit, or delete a Holiday, continue as follows: 


 


1. From the Main Menu, select Configuration>Holidays. 


2. In the Configuration Pane, do one of the following: 


 Click the  button to Add a Holiday. 


 Click the  button to Delete a Holiday. 


 Double-click the appropriate record to Edit a Holiday’s details. 


3. In the Holiday Configuration Pane, click the  button. 


 


CCoonnffiigguurree  HHoolliiddaayyss  


 
Figure 14 – New Holiday Dialog 


 


The New Holiday dialog lets you specify selected dates as Holidays.  To do this, continue as 


follows: 


 


1. In the Name textbox, enter a Holiday name. 


2. From the Start Date drop-down list, select a start date. 


3. From the End Date drop-down list, select an end date. 


4. Click the  button. 
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Messages 


Messages are brief strings of text that display on the ImproX (MDTA) Multi-discipline Time 


Attendance Terminal and the ImproX (TA) Time Attendance Terminal or Remote.  The ImproX 


MDTA supports messages of up to 100 characters.  The ImproX TA supports messages of up to 


16 characters.  The IXP220 System supports up to 100 Messages. 


 


 


The IXP220 Message feature currently only supports ASCII character sets. 


 


AAdddd,,  EEddiitt,,  oorr  DDeelleettee  aa  MMeessssaaggee  


To add, edit, or delete a Message, continue as follows: 


 


1. From the Main Menu, select Configuration>Messages.   


2. In the Configuration Pane, do one of the following: 


 Click the  button to Add a Message. 


 Click the  button to Delete a Message. 


 Double-click the appropriate record to Edit a Messages details. 


3. In the Messages Configuration Pane, click the  button. 


 


CCoonnffiigguurree  MMeessssaaggeess  


 
Figure 15 – New Message Dialog 


 


The New Message dialog lets you specify Message details.  To do this, continue as follows: 


 


1. In the Duration textbox, enter the display duration, in seconds, for the Message.  The 


default duration is 10.  The maximum duration is 3 000. 


2. In the Message textbox, enter the Message text. 


3. Click the  button. 


 


Message Display 


1. Select the  Page Tab. 


2. From the Doors table, select the Door record (with the Display Device). 
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3. Depending on whether the Display Device is installed on the Entry or Exit point, select 


either the Entry or Exit Tab. 


4. From the Configuration Level group, select the Advanced Configuration radio button. 


5. From the Miscellaneous group, from the Message Display Supervisor drop-down list, 


select the record that best represents your setup requirements.   


6. Click the  button. 


 


DDiissppllaayyiinngg  PPeerrssoonnaalliizzeedd  MMeessssaaggeess  ppeerr  TTaagghhoollddeerr  


1. Select the  Page Tab. 


2. From the list of Tagholder records displayed, double-click the Tagholder record for editing. 


3. In the Tagholder dialog, select the Tag Tab. 


4. Click the assigned Tag button (that is Tag 1, Tag 2, Tag 3 or Tag 4) for which you want the 


message displayed. 


5. From the Configuration Level group, select the Advanced Configuration radio button. 


6. From the Message drop-down list, select a Message for display. 


7. Click the  button. 
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Reason Codes 


A code normally used by Tagholders on exit that describes the reason for requesting access at 


a given Terminal.  Reason codes are specific and should be used for access control out of 


ordinary limits.  In other words, allowing access in restricted areas and during uncommon times.  


The IXP220 System allows up to 99 Reason Codes. 


 


AAdddd,,  EEddiitt,,  oorr  DDeelleettee  aa  RReeaassoonn  CCooddee  


To add, edit, or delete a Reason Code, continue as follows: 


 


1. From the Main Menu, select Configuration>Reason Codes.   


2. In the Configuration Pane, do one of the following: 


 Click the  button to Add a Reason Code. 


 Click the  button to Delete a Reason Code. 


 Double-click the appropriate record to Edit a Reason Code’s details. 


3. In the Reason Codes Configuration Pane, click the  button. 


 


CCoonnffiigguurree  RReeaassoonn  CCooddeess  


 
Figure 16 – New Reason Code Dialog 


 


The New Reason Code dialog lets you specify Reason Code details.  To do this, continue as 


follows: 


 


1. In the Reason Code textbox, enter the Reason Code’s number.   


 


 


Reason Codes range from 1 to 99.  When using the Reason Code at a Terminal or Reader, complete 


the entry by pressing the # symbol. 


 


2. In the Reason Text textbox, enter the Reason Code’s text.  This message must not exceed 


15 alpha numeric characters. 


3. Click the  button. 
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Modes of Operation  


 


Refer to the IXP220 Controller’s Hardware Installation Manual for connection details relating to these 


Modes. 


 


The IXP220 System provides the following Software selectable ―Modes of Operation‖: 


 


Power Control (Emergency) Mode 


This Mode, on Sites configured for Inter-controller Communications, Power Control 


(Emergency) Mode allows you to unlock all Doors (Locations).  Essentially, the Alarm Signal 


input on the Controller unlocks all Doors (Locations) on the Site.  That is, where you have 2 


Controllers with Inter-controller Communications, and both Controllers set to Power Control 


(Emergency) Mode, the unlock instruction passes from Controller 1 to Controller 2.  All Doors 


(Locations) connected to these Controllers unlock. 


 


Alternatively, on Sites without Inter-controller Communications, Power Control (Emergency) 


Mode only affects the single Controller’s Doors (Locations). 


 


AAccttiivvaattiinngg  PPoowweerr  CCoonnttrrooll  ((EEmmeerrggeennccyy))  MMooddee  


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. From the Mode Configuration (Optional) drop-down list, select the Power 


Control/Emergency Mode option (default). 


4. Click the  button. 


 


Power Control (Lockdown) Mode 


This Mode, on Sites configured for Inter-controller Communications, Power Control (Lockdown) 


Mode allows you to lockdown all Doors (Locations) denying Tagholders entry.  Essentially, the 


Alarm Signal input on the Controller locks down all Doors (Locations) on the Site.  That is, 


where you have 2 Controllers with Inter-controller Communications, and both Controllers set to 


Power Control (Lockdown) Mode, the lockdown instruction passes from Controller 1 to 


Controller 2.  All Doors (Locations) connected to these Controllers enter lockdown. 


 


Alternatively, on Sites without Inter-controller Communications, Power Control (Lockdown) 


Mode only affects the single Controller’s Doors (Locations). 


 


AAccttiivvaattiinngg  PPoowweerr  CCoonnttrrooll  ((LLoocckkddoowwnn))  MMooddee  


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 
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3. From the Mode Configuration (Optional) drop-down list, select the Power 


Control/Lockdown option. 


4. Click the  button. 


 


Alarm Arming Mode 


In this Mode, the Controller interfaces with an Alarm Panel to either, arm or disarm, or trigger 


the Alarm Panel. 


 


 


The IXP220 Software does not currently support alarm arming on an ImproX MfT and Wiegand Keypad 


Reader combination. 


 


AAccttiivvaattiinngg  AAllaarrmm  AArrmm  MMooddee  


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. From the Mode Configuration (Optional) drop-down list, select the Alarm Arming option. 


4. Click the  button. 


5. Select the  Page Tab. 


6. From the Doors column, select a Door, designating a Reader as an ―Alarm Arming Reader‖. 


7. If not already selected, select the Advanced Configuration radio button. 


8. From the Alarm Arm group, select Enable. 


9. Click the  button. 


 


AArrmmiinngg  tthhee  AAllaarrmm  


1. Present an Administrator or Supervisor Tag to the ―Alarm Arming Reader‖. 


2. Within 10 seconds of presenting the Tag, on the Keypad Reader, press the # key. 


 


The Reader beeps for 30 seconds, before activating the Alarm Relay, giving you sufficient time 


to vacate the Alarm Zone.  The ―Armed‖ Input detects that the Alarm Panel is armed in turn 


setting the ―Alarm Arming Readers‖ Status LED to blink, indicating that the Alarm is armed.  


When the System is armed, the ―Alarm Arming Reader‖ denies Normal or Visitor Tags access. 


 


 


A ―door forced‖ alarm triggers the alarm panel. 


 


DDiissaarrmmiinngg  tthhee  AAllaarrmm  


Present an Administrator or Supervisor Tag to the ―Alarm Arming Reader‖. 


 


The Alarm Relay deactivates, signalling the Alarm Panel to disarm. 


 


Intrusion Mode 


In this Mode, there is no installed Alarm Panel and merely a simple alarm sensor is required. 
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AAccttiivvaattiinngg  IInnttrruussiioonn  MMooddee  


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. From the Mode Configuration (Optional) drop-down list, select the Intrusion option. 


4. Click the  button. 


 


Bell Button Mode 


In this Mode, the Bell Button on the ImproX (KMA) Mullion Keypad Antenna Reader, when 


pushed, drives Relay 3 on the IXP220 Controller. 


 


AAccttiivvaattiinngg  BBeellll  BBuuttttoonn  MMooddee  


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. From the Mode Configuration (Optional) drop-down list, select the Bell Button option. 


4. Click the  button. 


5. Select the  Page Tab. 


6. From the Doors column, select the Door using the ImproX (KMA) Mullion Keypad Antenna 


Reader. 


7. If not already selected, select the Advanced Configuration radio button. 


8. Select the Enable Bell checkbox. 


9. Click the  button. 


 


Action Mode 


Use this Mode when you setup actions making use of your Controller’s Inputs and Relays.  Use, 


for example could include switching on or off various building devices, such as lights or air 


conditioners.    


 


 


See Part 5 – Advanced Configuration for more information on implementing Building Management. 


 


AAccttiivvaattiinngg  AAccttiioonn  MMooddee  


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. From the Mode Configuration (Optional) drop-down list, select the Action option. 


4. Click the  button. 
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Preference Configuration 


The Preferences Dialog features various page tabs that let you set the following: 


 


 General Tab—lets you select the IXP220 Software’s default Configuration Level, Transaction 


Priority and System Seed (used to encrypt communications.  The value is generated randomly 


on first startup of a new IXP220 V1.80 or later System). 


 Enrollment Tab—select from either Tag Type is Ignored when Validating a Tag or Tag 


Type is Taken into Consideration when Validating a Tag.  By selecting Tag Type is 


Ignored when Validating a Tag, you activate the AnyTag Mode.  In this Mode, the IXP220 


Software stores the Tag Code and not the Tag Type.  Pre IXP220 V1.80 you enrolled each 


ImproX (QT) Quad Transmitter Tag twice (once for RF and once for the Passive Tag), using 


AnyTag Mode, you only enroll the Tag once.   


 Web Tab—select either Anyone can View Web Reports or Username and Password is 


Required to View Web Reports.  Also allows you to select the Port used by the Web Server. 


The default is Port 80.   


 System Notifications Tab—lets you configure your E-mail and Twitter account settings, set 


up Incoming Requests and customise the Tagholder V-Card. 


 Maintenance Tab—lets you perform System maintenance including the deletion of expired 


Tagholders, Notifications or Tagholders without Tags. 


 


Setting Your Preferences 


From the Main Menu, select File>Preference. 


 


GGeenneerraall  TTaabb  


1. Select the General Tab. 


 


 
Figure 17 – Preference Configuration Dialog – General Tab Selected 
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2. From the Configuration Level group, select either the Standard Configuration or 


Advanced Configuration radio button.  By selecting the Advanced Configuration radio 


button, you elect that the IXP220 Software automatically display all advanced settings.  


3. From the Transaction Priority group, select either the Alarms have Priority or 


Transactions have Priority radio button.  By selecting the Alarms have Priority radio 


button, you elect that the IXP220 Software give Alarms the highest priority.  Likewise, by 


selecting the Transactions have Priority radio button, you elect that Transactions have the 


highest priority.    


 


EEnnrroollllmmeenntt  TTaabb  


Select the Enrollment Tab. 


 


 
Figure 18 – Preference Configuration Dialog – Enrollment Tab Selected 


 


Tag Truncation and Type Tab 


 


Tag Type Group 


Selecting the Tag Type is Ignored when Validating a Tag radio button, activates the AnyTag 


Mode.  In this Mode, the IXP220 Software stores the Tag Code and not the Tag Type.  Pre 
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IXP220 V1.80 you enrolled each ImproX (QT) Quad Transmitter Tag twice (once for RF and 


once for the Passive Tag), using AnyTag Mode, you only enroll the Tag once. 


 


1. By default, Tag Type is Ignored when Validating a Tag is selected.  To change this 


setting, select the Tag Type is Taken into Consideration when Validating a Tag radio 


button.   


2. From the Select Tag Type to Convert Existing Tags to drop-down list, make your 


selection. 


 


Tag Code Truncation Options Group 


Set the Tag Code Truncation, in effect, allowing enrollment of the Tag using the same 


truncation rules as applied by the Reader (using DIP-switch settings) out in the field, as follows: 


 


1. Select a Tag for editing and click the Tag’s Truncation button. 


2. From the Tag Format drop-down list, make your selection  from the following:   


 Full Tag Code. 


 Standard 16-bit. 


 Standard 24-bit. 


 Standard 32-bit. 


 26-bit Normal. 


 26-bit Raw. 


 37-bit Normal (UK). 


 37-bit Raw (UK). 


 H10302 37-bit Raw 35-bit Tagcode (US). 


 H10304 37-bit Raw 19-bit Tagcode (US). 


 Custom—in most cases on selection of the Custom option, the Tag Code Masking 


and Drop Zero Bits options activate.  However, for 3
rd


 Party (Other) or HID Tag, 


selecting the Custom option lets you set Site Code Masking allowing you to set a 


custom mask.   


3. Click the  button. 


 


Field Customisation  


 


1. Select the Field Customisation Tab. 


2. The information displayed in the Additional Fields group refers to the extra fields displayed 


on the Tagholder dialog.  Customise these fields by selecting from the following: 


 Display Details—by selecting this checkbox, you add fields for ID Number, PIN Used 


with Tag, Address, Company, Employee Number, Telephone Number, Cell Number, E-


mail Address, Department and Date of Birth to the Tagholder dialog.  Where information 


MUST be provided, select the Mandatory checkbox alongside the field name. 


 Display Additional Info—by selecting this checkbox, you add fields for Reports To, 


Destination and Reason for Visiting to the Tagholder dialog.  Where information MUST 


be provided, select the Mandatory checkbox alongside the field name. 


 Display Contractor Info—by selecting this checkbox, you add fields for Occupation, 


Emergency Contact Person, Emergency Contact Details, Working For, Expected 


Departure Date and Date Employed to the Tagholder dialog.  Where information MUST 


be provided, select the Mandatory checkbox alongside the field name. 
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 Display Vehicle Info—by selecting this checkbox, you add fields for Number Plate, 


Make, Number of Occupants, Weight and Additional Details to the Tagholder dialog.  


Where information MUST be provided, select the Mandatory checkbox alongside the 


field name. 


 Display Custom Info—by selecting this checkbox, you can add up to 5 Custom Fields 


to the Tagholder dialog as well as customise the name of the tab.  Where information 


MUST be provided, select the Mandatory checkbox alongside the field name. 


 


 


Re-order the Tagholder Details, Additional Tagholder Details, Contractor Details, Vehicle Details and 


Custom Fields tabs using the  and   buttons. 


 


Enrollment Reader 


 


 


Automatic Enrollment is not supported on Systems using an ImproX RS for fall-back communications or 


where the Controller connects using an ImproX RS. 


 


1. Select the Enrollment Reader Tab. 


2. From the Automatic Tag Reader drop-down list, make your selection: 


 From Anywhere—this option opens the Tagholder dialog automatically on presentation 


of a Tag to the Registration Reader.  Enrollment therefore takes place without opening 


the  Page Tab. 


 From Tagholder Configuration—enrollment takes place from the  Page Tab only. 


 Disable Automatic Reading—by selecting this option, enrollment takes place in the 


Tagholder dialog, from the Tag tab only.  


3. From the Multi-discipline Enrollment Reader drop-down list, make your selection: 


 Enroll 125 kHz and 13.56 MHz—when enrolling dual tags, this option automatically 


saves both the 125 kHz and 13.56 MHz Tag codes to the Tag 1 and Tag 2 positions.  


This is the default setting. 


 Enroll 125 kHz Only—when enrolling dual tags, this option automatically saves only 


the 125 kHz Tag code. 


 Enroll 13.56 MHZ Only—when enrolling dual tags, this option automatically saves only 


the 13.56 MHz Tag code. 


 


WWeebb  TTaabb  


1. Select the Web Tab. 


2. From the Web Report Security group: 


 Select either the Anyone can View Web Reports radio button. 


 Or User Name and Password is Required to View Web Reports radio button. 


 


 


By selecting the User Name and Password is Required to View Web Reports users must enter the 


Username (SYSDBA) and Password (masterkey) before viewing Web Reports. 


 


3. In the Webserver Port textbox, enter a new port number.  By default the Web Server uses 


Port 80.  In the event that Port 80 is already in use, change the port number. 
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SSyysstteemm  NNoottiiffiiccaattiioonn  TTaabb  


Select the System Notification Tab. 


 


 
Figure 19 – Preference Configuration Dialog – System Notification Tab Selected 


 


Configuration Tab  


 


E-mail Account Configuration Group 


 


 


This works on the following e-mail clients: 


 


 Thunderbird 


 Outlook 


 Outlook Express 


 Gmail 


 


1. In the E-mail Address textbox, enter your e-mail account details.   


2. Complete the SMTP Server Name field by entering your mail server’s name or IP Address 


details. 


3. In the Port textbox enter a Port number.  The default Port number is 25. 







Part 3 – General Configuration 


64  February 2012 


4. Complete the POP Server Name field by entering your mail server’s name or IP Address 


details. 


5. In the Port textbox enter a Port number.  The default Port number is 110. 


6. Enter your E-mail Username and Password details. 


7. From the Check for Mail drop-down list make your selection: 


 Once a Minute—checks for e-mail once a minute.  This is the default setting. 


 Once Every 5 Minutes—checks for e-mail every 5 minutes. 


 Once Every 10 Minutes—checks for e-mail every 10 minutes. 


 Once Every 30 Minutes—checks for e-mail every 30 minutes. 


 Once an Hour—checks for e-mail once an hour. 


8. Indicate whether to Use a Secure Connection for the SMTP and POP servers by selecting 


either of the following radio buttons: 


 None—unsecured message transmission on the Internet. 


 SSL—managed security of message transmission on the Internet. 


 


 


Continue as follows where specifying a pre-configured Gmail™ account: 


 


1. In the Account Name textbox, enter your Gmail™ account name (for example 


username@gmail.com). 


2. In the SMTP Server Name textbox, use smtp.gmail.com.  


3. In the Port textbox, use either 465 or 587. 


4. In the POP Server Name textbox, use pop.gmail.com. 


5. In the Port textbox, use 995. 


6. In the Username and Password textboxes enter your pre-configured Gmail™ Username and 


Password details. 


7. Indicate whether to Use a Secure Connection by selecting either the None or SSL radio 


button. 


 


 


Once you have configured this section, a Notification Viewer Tab appears in the Monitoring View 


section of the Software.  This displays all the incoming and outgoing e-mails. 


An E-mail Enrollment drop-down list also appears on the Site Configuration Tab under the 


Miscellaneous group.  This allows you to set the access group you want to use for E-mail Enrollment. 


The E-mail Enrollment drop-down list only works if Generate Personal Access Code is selected under 


Tag, see Add a Tagholder by E-mail on page 44. 


 


Twitter Account Configuration Group 


1. Click the Configure Twitter Access button. 


2. Enter your Twitter Username or Email. 


3. Enter your Twitter Password.  


4. Click the Authorize App button. 


5. Enter the Twitter generated PIN-Code in the PIN textbox. 


6. Click the OK button. 


 


Incoming Tab 


 


1. Select the Incoming Tab. 


2. From the Enrollment drop-down list make your selection: 


 Disabled—disables the E-mail Enrollment feature.  This is the default setting. 


 Password Authentication—requires a password to make use of the E-Mail Enrollment 


feature. 



mailto:username@gmail.com
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3. From the Report Request drop-down list, make your selection: 


 Disabled—disables the Report Request feature.  This is the default setting. 


 Password Authentication—requires a password to make use of the Report Request 


feature. 


4. In the Enrollment Password textbox, enter a suitable alpha-numeric password. 


5. In the Report Password textbox, enter a suitable alpha-numeric password. 


6. Check the SMS Personal Access Code checkbox if you want to enable this feature.  This 


feature only works if a GSM unit is connected. 


 


 


For more information on enrolling Tagholders by E-mail, see Add a Tagholder by E-mail on page 44. 


For more information on requesting Reports by E-mail, see Part 4 – Reports. 


 


V-Card Tab 


 


This tab allows you to customise the Tagholder V-Card sent out when using the E-mail Feature 


(For Tagholder setup information please refer to the section Tagholder Configuration (General 


Tab) on page 42).  The tab is split into two parts, a Preview Area and a Configuration Table. 


 


1. Select the V-Card tab. 


2. If required, remove the Tagholder image by deselecting the Insert Image checkbox. 


3. In the Configuration Table, select or deselect the Enabled checkboxes alongside each field 


as required. 


4. For each enabled field, assign a layout position in the Layout column using the supplied 


drop-down lists. 


 


MMaaiinntteennaannccee  TTaabb  


1. Select the Maintenance Tab. 


2. From the Delete Expired Tags drop-down list, make your selection: 


 Disabled—enabled by default, this option disables automatic deletion of expired 


Tagholders. 


 Enabled—automatically deletes expired Notifications. 


 


 


A Tag will only be deleted once it expires in all the time zones the Tag has access to. 


 


3. From the Delete Expired Notifications drop-down list, make your selection: 


 Disabled— enabled by default, this option disables automatic deletion of expired 


Tagholders. 


 Enabled—automatically deletes expired Notifications. 


 


 


A Notification will only be deleted once it expires in the time zone of the Site it was created for. 


 


4. Delete Tagholders without Tags by clicking the Delete Now button. 


 


After setting your preferences, close the Preference Configuration dialog by clicking the  


button. 
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Broadcast Transactions by UDP 


This feature allows broadcast of real-time transaction data as a UDP comma separated packet 


to an IP Address and Port Number named by you, the user.  The purpose of this is to allow third 


parties to pick up transactions and use the transactions as they wish (for example for Time 


Attendance or Alarms).  During broadcast (to either the Host PC or another named PC), the 


transactions still go into the Database as usual. 


 


Enable this feature as follows:  


 


1. From C:\IXP220, open the IXP220.properties file. 


2. Set the ixp220.broadcast.udp.ip=<IP Address>:<Port> setting. 


 


 


In place of the <IP Address> placeholder fill in the IP Address of the Host PC or other named PC 


picking up the transactions. 


 


 


In place of the <Port> placeholder fill in the Port number of the Host PC or other named PC picking up 


the transactions.  Switch the UDP Broadcast feature off by setting the Port number to 0. 


 


3. From the Main Menu, select File>Save. 


4. From the Main Menu, select File>Exit. 


 


The Base Application collects and sends the broadcasted transactions as a list of comma 


separated values, in this order:    


 


Site Number,yyyy-mm-dd,hh:mm:ss,Transaction Sequence Number,Transaction Event 


Number,Terminal Super Logical Address,Terminal Name,Tag Code,Tag Type,Tagholder 


Name,Employee Number  followed by a carriage return and new line.  


 


 


Where no value exists, integer values appear as 0 and string values appear as a space. 


 







Part 3 – General Configuration 


February 2012  67 


77  
Notification Configuration 


 


Ensure that you unlock your Registration Interface before using the Notification Module.  This unlock 


allows a maximum of 1 seat. 


 


 


Ensure that you have a GPRS Module fitted to your IXP220 Controller before using SMS Notifications.  


E-mail and Twitter Notifications require an internet connection.  


 


The Notification feature is a combination of Hardware and Software providing a huge leap in the 


management of Tagholders.  Notifications are setup using the largely intuitive Notification 


Creation Wizard.  Thereafter, notifications take place at the time of a specified event, offering a 


retrospective view.  Notifications take place by SMS, E-mail or Tweets via the Twitter micro-


blogging network.   


 


AAddddiinngg,,  EEddiittiinngg  oorr  DDeelleettiinngg  NNoottiiffiiccaattiioonnss  


 


1. Select the  Page Tab. 


2. In the Configuration Pane, do one of the following: 


 Click the  button to Add Notifications. 


 Click the  button to Edit Notifications. 


 Click the  button to Delete Notifications. 


3. In the Notification Configuration Pane, click the  button. 


 


NNoottiiffiiccaattiioonn  CCoonnffiigguurraattiioonn  


 
Figure 20 – Notification Creation Wizard 
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1. In the Notification Name textbox, enter a name for your Notification. 


2. In the Transaction Time group, from the Day of Week checkboxes make your selection. 


3. From the From Date drop-down list, make your selection. 


4. From the To Date drop-down list, make your selection. 


5. In the Select Filters to Use group, make your selection from the filter options supplied 


 Department—by selecting this option the following Wizard page asks for a Department 


selection.  This selection triggers the Department filter part of the notification trigger.   


 Tagholder—by selecting this option the following Wizard page asks for a Tagholder 


selection.  This selection triggers the Tagholder filter part of the notification trigger.   


 Location—by selecting this option the following Wizard page asks for a Location (Door) 


selection.  This selection triggers the Location (Door) filter part of the notification trigger.   


 Access Group—by selecting this option the following Wizard page asks for an Access 


Group selection.  This selection triggers the Access Group filter part of the notification 


trigger.   


 Event—by selecting this option the following Wizard page asks for an Event selection.  


This selection triggers the Event filter part of the notification trigger.   


6. After completing the opening Wizard page, click the  button. 


7. Navigate through the Filter Wizard pages by clicking the  button. 


8. From the Actions group, make your selection from the following options: 


 Send an E-mail for this Notification—after selecting this option the following Wizard 


page confirms the E-mail details.  This includes selection of the E-mail Recipients ( ) 


and details of the actual E-mail for sending.  Currently you may only send E-mail 


Notifications from the Host PC.  The GSM Module DOES NOT support sending of E-


mail Notifications.  Refer to the section Preference Configuration (E-mail Account 


Configuration Group) on page 63 for more information.     


 


 


Add a Report Attachment to your E-mail Notification, as follows: 


 


1. Click the  button.   


2. From the Select Report drop-down list, make your selection from the following options: 


 Absenteeism—details a list of Employees absent on a specified date.  


 Person—displays a detailed record for a selected individual Tagholder.  


 Hours Worked—calculates hours worked from the IN and OUT Transactions of all 


Zones.  


 Timesheet—calculates hours worked from the IN and OUT Transactions of all Zones.  


 Access Pattern—displays a summary of an individual employee’s time in, average time 


in, time out, average time out and average hours worked (grouped by Department). 


 Zone Occupancy—displays a summary of Tagholders within a specific Zone. 


 Tagholder Transaction—displays all transactions for a Tagholder. 


 Transactions—displays all transactions for a Tagholder. 


3. From the Filters group, make your selection from the following available filters:  From and To 


Date,  From and To Time, Site, Zone, Door (Location), Department and Tagholder. 


4. Click the  button. 


 


 Send an SMS for this Notification—after selecting this option the following Wizard 


page confirms the SMS details.  This includes selection of the SMS Recipient ( ) and 


details of the actual SMS for sending.  The Enter SMS text area supports entry of up to 


160 characters (including spaces).  Refer to Part 7 – Utilities for more information on 


configuring the Controller’s mobile settings (GPRS).     
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 Send a Tweet for this Notification—after selecting this option the following Wizard 


page asks you to enter a Tweet.  The Enter Tweet text area supports text-based posts 


of up to 140 characters.  These Tweets display on the author's profile page while also 


being delivered to the author's followers.  Refer to the section Preference Configuration 


(Twitter Account Configuration Group) on page 64 for more information.   


9. After making your selection above, click the  button. 


 


 


Clicking the  button lets you quickly select fields, from a shortcut menu, for use in your SMS or        


E-mail notification. 


 


10. After capturing your E-mail, SMS or Tweet information, continue by clicking the  button. 


11. Review the summary information. 


12. Click the  button. 
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88  
Full Upload 


A Full Upload writes data from the Site Database to the IXP220 Controller.   


 


Full Upload Procedure 


After configuring your IXP220 Software, ensure that you perform a full upload as follows: 


 


1. Select the  Page Tab. 


2. Select the Controller for upload. 


 


 


You may perform a full upload per Controller, or elect to multi-select the desired Controllers for upload 


as a group.   


 


3. Click the Upload button. 


 


 


Alternately, from the Main Menu, select Configuration>Start Full Upload.   
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Operator Management 


The Manage Operator feature allows you to create extra Users and customise their System 


Rights.  This allows you to restrict access to Site definition and configuration tools without 


limiting access to day-to-day operations. 


 


 


Operators do NOT have permission to edit a Supervisor or Administrator’s Tagholder settings.   


 


AAdddd  aann  OOppeerraattoorr  


To add an Operator, continue as follows: 


 


1. From the Main Menu, select File>Manage Operators.   


2. In the Tagholders with Login Privileges dialog, click the  button. 


3. In the Tagholders without Login Privileges dialog, select a Tagholder. 


4. Click the  button. 


 


 
Figure 21 – User Configuration Dialog 


 


5. In the User Configuration dialog, enter a suitable User Name and Password (not 


exceeding 20 characters).   


6. Confirm your chosen Password in the Confirm Password textbox. 


7. From the Type drop-down list, make your selection: 


 System Operator—only has access to the day to day operations of the IXP220 


System.  By default, a System Operator has access to the following System Rights: 
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Rich Client, Web Enrollment Employee, Web Enrollment Visitor, Reports and Visual 


Door Control.  However, you may remove privileges by deselecting the associated 


checkbox. 


 User—cannot log into the IXP220 Base Application.  By default, a User only has access 


to Reports. 


 Administrator—has access to Site definition and configuration tools (the same rights 


as the SYSDBA user).  An Administrator has access to the following System Rights: 


Rich Client, Web Enrollment Employee, Web Enrollment Visitor, Reports and Visual 


Door Control.  This User Type is not customisable. 


8. Select the checkbox next to Restrict to Home Site if you want the person to only be able to 


configure changes for or view the site they belong to. 


 


 


Restrict to Home Site does not apply to anyone logged in through the Base Application. 


 


9. Remove System Rights from an Operator by deselecting the associated checkboxes in the 


System Rights group. 


10. Click the  button. 


11. Click the  button. 


 


EEddiitt  aann  OOppeerraattoorr  


To edit an Operator, continue as follows: 


 


1. From the Main Menu, select File>Manage Operators.   


2. Click the  button. 


3. In the User Configuration dialog, enter a new suitable User Name and Password. 


4. Click the  button. 


5. Click the  button. 


 


DDeelleettee  aann  OOppeerraattoorr  


To delete an Operator, continue as follows: 


 


1. From the Main Menu, select File>Manage Operators.   


2. Select the Operator for deletion. 


3. Click the  button. 


4. Click the  button. 
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Communication Schedule Creator 


This feature lets you set up a Site communication Schedule, essentially dictating when Site 


communication takes place.  Schedules may run at a specified time on any day of the week, or 


on any combination of days in a month. 


 


 


Ensure the IXP220 Software is running for the scheduled Site communication to take place. 


 


Communication Schedule Setup 


AAddddiinngg  aa  CCoommmmuunniiccaattiioonn  SScchheedduullee  


To add a communication Schedule, continue as follows: 


 


1. From the Main Menu, select Configuration>Schedule Creator.   


 


 
Figure 22 – Configure Communication Schedules Dialog 


 


2. Click the  button (as highlighted in Figure 22). 


3. In the Schedule Name textbox, assign your new Schedule a name. 


4. Click the  button (as highlighted in Figure 23). 
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Figure 23 – Configure Communication Schedules Dialog 


 


5. Make your selection by selecting values from each of the following drop-down menus: 


 Month—select from the range January to December for Site communication to take 


place on a given month.  Else select the Monthly alternative for Site communication to 


take place monthly. 


 Date—select from the range 1
st


 to 31
st


 for Site communication to take place on a given 


date.  Else select (Every) for Site communication to take place daily. 


 Day—select from the range Sunday to Saturday for Site communication to take place 


on a given day.  Else select the Daily alternative. 


 Hour—select from the range 00:00 to 23:00 for Site communication to take place at a 


given hour.  Else select (Every) for Site communication to take place hourly. 


 Minute—select from the range 00:00 to 00:59 for Site communication to take place. 


 Connection Limit—select from 00:00 to 00:59, limiting the connection duration. 


6. Click the  button. 


7. Click the  button. 


 


IImmpplleemmeenntt  aa  CCoommmmuunniiccaattiioonn  SScchheedduullee  


 


1. Select the  Page Tab. 


2. Select the Advanced Configuration radio button. 


3. From the Communication Schedule drop-down list, select the Schedule created earlier. 


4. Click the  button. 


 


 


Ensure the IXP220 Software is running for the scheduled Site communication to take place. 
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Edit a Communication Schedule 


 
Figure 24 – Left-hand Side of the Configure Communication Schedules Dialog 


 


To edit a communication Schedule, continue as follows: 


 


1. From the Main Menu, select Configuration>Schedule Creator.   


2. From the list of displayed Schedules, select a Schedule record (see Figure 24 for 


clarification). 


3. Edit the Schedule’s details as per your requirements. 


4. Click the  button. 


5. Click the  button. 


 


Delete a Communication Schedule 


To delete a Communication Schedule, continue as follows: 


 


1. From the Main Menu, select Configuration>Schedule Creator.   


2. From the list of displayed Schedules, select a Schedule record (see Figure 24 for 


clarification). 


3. Click the  button. 


4. Click the  button. 
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Scheduled Reports Creator 


This feature lets you set up schedules that automatically run the Reports you request.  These 


scheduled Reports may run at a specified time on any day of the week, or on any combination 


of days in a month.   


 


 


Ensure the IXP220 Software is running for the scheduled Report to run. 


 


Scheduled Reports Setup 


AAddddiinngg  aa  SScchheedduulleedd  RReeppoorrtt  


To add details of a Scheduled Report, continue as follows: 


 


1. From the Main Menu, select Configuration>Scheduled Reports.   


2. Click the  button. 


 


 
Figure 25 – Scheduled Reports Dialog 


 


3. In the Name textbox, assign your new Schedule a name. 


4. From the Select Report drop-down list, make your selection: 


 Absenteeism Report— this Report details a list of Employees absent on a specified 


date.  The Report includes information such as:  Employee Name and Number.   
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 Person Report—this Report displays a detailed record for a selected individual 


Tagholder.  The Report includes information such as:  First Name and Last Name, ID 


Number, Company, Department, Employee Number, transaction Date and Time, Door 


Accessed, Event and Tag code.  The Report also displays a photo of the employee.    


 Hours Worked Timesheet Report—this Report calculates hours worked of all 


employees from the IN and OUT Transactions of all Zones.  The Report includes 


information such as:  Name, Employee Number, Date, Time, Event, Terminal, Zone and 


Reason. 


 Access Pattern Report—this Report displays a summary of an individual employee’s 


time in, average time in, time out, average time out and average hours worked.  The 


Report includes information such as:  Date, First Transaction, Last Transaction, Time 


(Last Transaction – First Transaction), Average Time In and Out, Average Hours at 


Work and Total Time at Work. 


 Zone Occupancy Report—this Report displays a summary of Tagholders within a 


specific Zone.  The Report includes information such as:  First Name, Last Name, 


Employee Number, Department, Zone, Site, Time In, Date and Hours in Zone. 


 Tagholder Transaction Report—this Report displays all transactions for a Tagholder.  


The Report includes information such as:  Time, Name, Door, Event and Tag. 


 Transactions Report—this Report displays all Tagholders transactions on a specific 


date.  The Report includes information such as:  Time, First Name, Last Name, 


Employee Number, Door, Event, Tag and Zone.   


 Tag Expiry Report—this Report displays details of Tags either expired or due for 


expiry.  The Report includes information such as:  Site, Tag Code, Tag Type, First 


Name, Last Name, ID, Expiry Date and Expiry Time.  


5. From the checkbox, indicate whether to Keep a Local Copy of the Report. 


6. From the Schedule group, make your selection: 


 Month—select from the range January to December for the Report to run on a given 


month.  Else select the Monthly alternative for the Report to run monthly. 


 Date—select from the range 1
st


 to 31
st


 for the Report to run on a given date.  Else 


select (Every) for the Report to run daily. 


 Day of Week—select from the range Sunday to Saturday for the Report to run on a 


given day.  Else select the Daily alternative. 


 Hour—select from the range 00:00 to 23:00 for the Report to run at a given hour.  Else 


select (Every) for the Report to run hourly. 


 Minute—select from the range 00:00 to 00:59 for the Report to run at the specified 


interval.  Else select (Every) for the Report to run on a per minute basis.   


7. From the Filters group, make your selection from the available filters:  From Date, To Date, 


From Time, To Time, Site, Zone, Door, Department and Tagholder.  Filter availability is 


determined by the Report selected.   


8. Click the  button to configure e-mail recipients for the Report. 


9. In the Recipient Selection dialog, make your selection from the listed Tagholders. 


10. Click the  button. 


11. At the Scheduled Reports dialog, click the  button. 


12. Click the  button. 
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Edit a Report Schedule 


 
Figure 26 – Left-hand Side of the Scheduled Reports Dialog 


 


To edit Scheduled Reports, continue as follows: 


 


1. From the Main Menu, select Configuration>Scheduled Reports.   


2. From the list of displayed Schedules, select a Schedule record (see Figure 24 for 


clarification). 


3. Edit the Schedule’s details as per your requirements. 


4. Click the  button. 


5. Click the  button. 


 


Delete a Scheduled Report 


To delete Scheduled Reports, continue as follows: 


 


1. From the Main Menu, select Configuration> Scheduled Reports.   


2. From the list of displayed Schedules, select a Schedule record (see Figure 24 for 


clarification). 


3. Click the  button. 


4. Click the  button. 
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Hardware Replacement 


 


When you replace an old unit with a new one, ensure both units are of the same type. 


 


 


If Controllers are running on Fallback Communications, replacing hardware will fail.  Therefore, only 


replace hardware running over primary communications.   


 


Using the IXP220 Software, continue as follows: 


 


UUnniinnssttaallll  OOLLDD  HHaarrddwwaarree  


1. From the Main Menu, select Hardware>Device Management Wizard. 


2. In the Device Maintenance Wizard, select the I Would Like to Uninstall a Device From 


This Site radio button. 


3. Click the  button.  


4. From the list of displayed hardware, make your selection using the checkbox alongside. 


5. Click the  button.  


6. At the Uninstall Confirmation dialog, click the Yes button. 


 


 


Uninstalling a device that has multiple Fixed Addresses, warns that uninstalling the selected device 


uninstalls other devices as well.  For example, uninstalling a Controller that has its own Fixed Address 


and those of its Readers.   


 


7. Click the  button. 


 


IInnssttaallll  RReeppllaacceemmeenntt  ((NNEEWW))  HHaarrddwwaarree  


1. From the Main Menu, select Hardware>Device Management Wizard. 


2. In the Device Maintenance Wizard, select the I Would Like to Replace a Device On This 


Site radio button. 


3. Click the  button.  


4. From the list of displayed hardware, make your selection using the checkbox alongside. 


5. Click the  button.  


6. At the Replace Confirmation dialog, click the Yes button. 


 


Controllers or Terminals connected by RS485 


 


1. In the activated Replacement Device group(s), enter the Fixed Address(s) of the 


replacement Controller or Terminal.  When replacing Terminals, continue to step 4. 


2. For Controllers connected by RS485, click the  button. 


3. From the Select Device dialog, double-click your chosen COM Port number.  


4. Click the  button.  


5. At the Replace Unit dialog, connect the NEW hardware. 
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Figure 27 – Replace Unit Dialog 


 


6. Click the Yes button. 


7. Click the  button. 


 


Controllers or Terminals connected by Ethernet 


 


 
Figure 28 – Device Maintenance Wizard – Ethernet Settings 


 


1. Under Load IP Device Configuration From, make your selection from the following: 


 Import Device—allows you to select the Discovery.txt file (originally exported from the 


Discovery Utility). 


 Search Subnet—selected by default, allows you to enter the Subnet Mask details for 


your Network. 


2. Click the  button. 
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Import Device  


a. Select the Discovery.txt file (originally exported from the Discovery Utility). 


b. Click the Open button. 


 


Search Subnet  


a. In the Input dialog, enter the Subnet Mask details for your Network. 


b. Click the  button. 


 


3. From the Select Device dialog, double-click the replacement Controller or Terminal. 


4. Click the  button. 


5. At the Replace Unit dialog, connect the NEW hardware. 


 


 
Figure 29 – Replace Unit Dialog 


 


6. Click the Yes button. 


7. Click the  button. 


 


 


After replacing an IP Terminal, ensure you group the new Terminal to the relevant Controller.  See Part 


7 – Discovery Utility for more information on Grouping Controllers and Terminals. 
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Localisation and Translation 


 


Do not edit the same translation twice in the same session otherwise, your translation is overwritten. 


 


 


Translation changes are permanent. 


 


Localisation and Translation lets Users from different locales (countries and geographical 


locations), use the IXP220 Software in their own language.  The IXP220 Software starts up in 


English unless a Locale is already set by the Operating System. 


 


Choose Locale 


1. From the Main Menu, select File>Choose Locale. 


 


 
Figure 30 – Locale Chooser Dialog 


 


2. In the Locale Chooser dialog, from the Language drop-down list, make your selection. 


3. From the Country drop-down list, make your selection. 


4. From the Variant drop-down list, select a language variant based on your previous 


selections. 


5. Click the OK button. 


 


Translating the Software Interface 


1. From the Main Menu, select File>Translate. 


2. In the Translation Selection dialog, from the Text Group drop-down list, select a group for 


editing. 


3. Click the OK button. 
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Figure 31 – Translate Text :  Dialog 


 


4. In the Translate Text : dialog, from the New Text column, select a phrase to translate.   


 


 


The Original column displays words in English.  The New Text column displays a copy of the English 


words, but it is editable.  This means you can substitute the default words in the New Text column for 


words in your own language. 


 


5. Press the F2 key, thus opening the phrase for editing.   


6. Enter a substitute phrase suitable for your Locale. 


7. Press the Tab key to move to the next phrase. 


8. Repeat steps 5 to 7 for each phrase you wish to edit. 


9. Click the OK button. 
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Clearing the Transaction Buffer 


The IXP220 Controller temporarily stores transactions in a buffer.  Clearing the buffer on the 


Controller permanently erases this buffered transaction data.  Transactions that have not been 


downloaded to the Host PC are lost, therefore only clear the buffer if you suspect that it has 


become corrupted. 


  


In the event of corruption only, proceed as follows to clear the buffer: 


 


1. From the Main Menu, select Hardware>Clear Transaction Buffer. 


2. In the Clear Transaction Buffer dialog, click the OK button. 
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Database Maintenance 


Firebird General 


GGeenneerraall  


Firebird is a powerful, compact client or server SQL relational database management system 


offering many ANSI SQL standard features and can run on various server and client operating 


systems.  Firebird’s officially supported platforms are Windows and Linux.  Firebird will, 


however, also run on operating systems, such as FreeBSD and Apple Macintosh OS/X.  


Firebird offers excellent concurrency, high performance, and powerful language support for 


stored procedures and triggers. 


 


Firebird features a higher level of SQL standards compliance than most other industrial-strength 


client or server database management systems on the market today.  Firebird also carries out 


some powerful language features in the vendor-specific sphere of procedure programming. 


 


Firebird 2.1 is a full-featured SQL database engine.  Firebird is powerful, yet lightweight, with 


the smallest possible configuration and administration needs.  It's easily scalable from single-


user, single-database use up to company-wide enterprise purposes.  A single Firebird server 


can handle multiple independent databases, each with multiple client connections.  And best of 


all: it’s true Open Source, thus free of any license fees even for commercial use. 


 


We publish all our Software with the Firebird Database as our standard offering.  The purpose 


of this document is to aid you in running Systems on the Firebird Database. 


 


This section will address the following topics: 


 


 Firebird Utilities 


 Database Backups 


 Database Restore 


 Database Corruption 


 


SSuuggggeesstteedd  MMaaiinntteennaannccee  SScchheedduullee  


We recommend regular database maintenance.  The schedule of maintenance depends on how 


critical transactions are to the organisation, the size of the database, as well as the number of 


transactions written to the database daily.  An organisation that uses the transactions for export 


to payroll may choose to make daily backups of the database.  Whereas the small office with 20 


employees may choose perform a backup once a month or even every 2 to 3 months. 


Irrespective of the above factors, carry out the following for database maintenance: 


 


1. Perform regular backups using the tools and techniques described under the section 


Database Backups. 


2. Perform regular test restores on the backup files, using the tools and techniques described 


under the section Database Restore. 
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3. At regular intervals, take the working database off-line and carry out a Backup and restore.  


This ensures the working database does not contain any corrupt data or tables.  Refer to 


the section Recovering a Corrupt Database for more information. 


 


Following these steps will not guarantee the Database will not corrupt in time, but they will 


lessen the odds of corruption occurring and ensure the least possible resulting data loss. 


 


Figure 32 below shows an example of a monthly maintenance schedule:  This organisation 


needs daily backups as data is critical. 


 


 
Figure 32 – Example of a Monthly Maintenance Schedule 


 


If the Database does not restore on the 25
th
, you have 2 choices: 


 


1. Try to recover the Database using the steps described in the section Recovering a Corrupt 


Database, or 


2. Resort to the previous day’s backup and restore that file. 


 


Firebird Utilities 


There are many Database Management Utilities available for maintaining Firebird Databases.  


Many of these are open source utilities and are available at www.firebirdsql.org.  These utilities 


include IBEasy
 
(Freeware), IBExpert (commercial and open source personal editions), 


IBFirstAid (commercial) and IBConsole (open source).  We ship IBConsole as the Database 


Management Utility. 


 


 


 



http://www.firebirdsql.org/
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AAnn  IInnttrroodduuccttiioonn  ttoo  IIBBCCoonnssoollee  


IBConsole is a relational database management utility allowing connection to and administration 


of multiple Firebird Servers and Databases.  The entire functionality of IBConsole is beyond the 


scope of this document; however administrators of Impro Access Control Databases may find 


the following roles within IBConsole useful: 


 


 Database maintenance in the form of database sweeps and checking for errors 


 Backup and Restores of the database 


 Review of the database structure, allows addition of extra tables for third-party integration 


 


The first step in connecting to an Impro Database is registering the Database Server.  The 


following examples refer to the default Database DB220.FDB used by the IXP220 Software.  


The default locations for the Databases and the IBConsole Utility varies dependent on the 


Access Control System used. 


 


Start the IBConsole Software 


In Windows®, go to Start>All Programs>IXP220>Utils>IBConsole. 


 


Register the Server 


 


 


You need only perform these steps once.  After registration, the settings remain and you need only 


login to the Server. 


 


 
Figure 33 – Register Server and Connect Dialog 


 


1. From the Server drop-down menu, select the Register choice. 


2. In the Register Server and Connect dialog, click the Remote Server radio button. 


3. In the Server Name textbox, assign the Server a name.  In this example, we used 


LOCALHOST. 


 


 


Rather than assigning the Server a name in the Server Name textbox, you may use the PC’s IP 


Address. 
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4. In the Network Protocol textbox, select TCP/IP from the drop-down list. 


5. In the Alias Name textbox, assign a suitable name. 


6. Leave the remaining fields unchanged. 


7. Click the OK button. 


 


Login to the InterBase Server 


1. From the Hierarchical Tree, select your InterBase Server (based on the example in Figure 


33 select Local Server). 


2. From the Server drop-down menu, select the Login choice. 


3. In the Server Login dialog, enter the Username and Password. 


 


 


The default username is SYSDBA.  The default password is masterkey. 


 


4. Click the Login button. 


 


Register the Database 


 


 
Figure 34 – Register Database and Connect Dialog 


 


1. From the Database drop-down menu, select Register. 


2. In the Register Database and Connect dialog, In the Database textbox, enter the full file 


path to your Database (see Figure 34). 


3. Click your mouse pointer in the File textbox, the Database’s file name automatically 


appears. 


4. Leave the remaining fields unchanged. 


5. Click the OK button. 
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The default Database path for the IXP220 Software is:  C:\IXP220\Database\DB220.FDB 


 


6. In the Hierarchical Tree, double-click on the DB220.FDB file, starting the Database. 


 


Database Backups 


Administrators of Impro Access Control Systems have various choices for making a backup of 


their Access Control Database.  The simplest alternative employed, is copying the Database.  


 


 


Copying the Database simply copies the Database irrespective of whether there is corruption of the 


Database or not. 


 


 


Before making a copy of the Database ensure that you shut down the IXP220 Software.   


 


The preferred method of making a backup, however, is to use the built in backup feature 


included in the IXP220 Software.  


 


During the backup procedure, the Base Application takes a snapshot of the working Database, 


the snapshots compacted and a new file created.  The resulting backup file has an fbk file 


extension.   


 


 


Note, a backup does not guarantee that your IXP220 Database is free from corruption.  Ensure that you 


carry out regular database maintenance, thus ensuring that your IXP220 Database is not corrupt. 


  


BBaacckkuupp  ooff  tthhee  IIXXPP222200  DDaattaabbaassee  UUssiinngg  tthhee  IIXXPP222200  SSooffttwwaarree  


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. From the Main Menu, select File>Manage Backups. 


 


 
Figure 35 – Backup Configuration Dialog 


 


3. In the Backup Path textbox, provide the directory path for the backup Database. 


 


 


If you change the backup directory path, ensure that you enter text only, NO spaces. 
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The default to backup the Database is ON. The default settings are: 


 


 Retain 7 backups. 


 Perform a backup every day at 01:00am. 


 


4. From the Number of Backups to Retain at Backup Location drop-down list, select a 


suitable number. 


5. In the Groups labelled Monday through Sunday, carry out the following: 


 Select the relevant day by selecting the checkbox. 


 From the Time (hh:mm) drop-down lists, select a suitable time. 


 


 


Perform an immediate backup, by clicking the Backup Now button. 


 


6. Click the  button. 


7. Click the  button. 


 


BBaacckkuupp  tthhee  IIXXPP222200  DDaattaabbaassee  uussiinngg  IIBBCCoonnssoollee  


1. In Windows®, go to Start>All Programs>IXP220>Utils>IBConsole. 


2. From the Database drop-down menu, select Maintenance>Backup / Restore>Backup. 


 


 
Figure 36 – Database Backup Dialog 


 


3. In the Database group, from the Alias drop-down list, select the Database for backup. 


4. In the Backup File(s) group, in the Alias textbox, provide a name for the backed up 


Database. 


 


 


Ensure that your backed up file has an FBK file extension. 
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5. In the Backup File(s) group, in the Filename(s) textbox, provide the directory path and file 


name for the backup Database.  We suggest C:\IXP220\Database\DB220.FBK. 


6. Leave the remaining values as they are. 


7. Click on the OK button. 


8. In the Information dialog, click on the OK button. 


9. Close the Database Backup dialog. 


  


BBaacckkuupp  tthhee  IIXXPP222200  DDaattaabbaassee  UUssiinngg  aa  BBaattcchh  FFiillee  


Create the “.bat” File 


1. Capture the following text into a text file (for example Notepad). 


 


 
Figure 37 – Backup Using a Batch File 


 


 


Settings explained: 


 


 @SET USER=SYSDBA—this sets the user name as SYSDBA, thus ensuring the backup 


utility connects to the Database. 


 @SET PASSWORD=MASTERKEY—this sets the password.  If you changed the default 


password, ensure that you use the new password. 


 @SET PATH=C:\Program Files\Firebird\Firebird_2_1\bin—indicates the path to the GBAK 


backup utility.  If the GBAK backup utility does not appear in this directory, set the path 


accordingly. 


 gfix -m -f DB220.FDB—repairs minor database corruption. 


 gbak -b -g -v -z DB220.FDB DB220.FBK—creates the backup file DB220.FBK.  To change 


the name of the target database, simply change the DB220.FBK file to another name, keeping 


the FBK file extension. 


 


2. Save the text file as a “.bat” file. 


 


Run the “.bat” Batch File 


1. In Windows®, click Start>All Programs>Accessories>Run. 


2. In the Run dialog, click on the Browse button. 


3. In the Browse dialog, select the “.bat” file you created. 


4. Click on the Open button. 


5. In the Run dialog, click on the OK button. 


6. Follow the on-screen prompts. 
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This backup process may take some time on large Databases.  Once the backups complete, ensure 


that you copy the resulting backup file to a different PC or on to removable media for storage. 


 


Database Restore 


Perform a Database restoration for the following reasons: 


 


 Your original IXP220 Database becomes corrupt. 


 Your PC’s hard drive is damaged for any reason. 


 To ensure that Database backups are not corrupt, a successful restoration suggests a 


sound Database. 


 


RReessttoorriinngg  tthhee  IIXXPP222200  DDaattaabbaassee  UUssiinngg  IIBBCCoonnssoollee  


Disconnect from the Database 


1. In Windows®, go to Start>All Programs>IXP220>Utils>IBConsole. 


2. From the Hierarchical Tree, click on the DB220.FDB file. 


3. From the Database drop-down menu, select Maintenance>Shutdown. 


4. Click the OK button. 


5. At the Information dialog, click the OK button. 


 


Restore the Backup 


1. In IBConsole, from the Database drop-down menu, select Maintenance>Backup / 


Restore>Restore. 


 


 
Figure 38 – Database Restore Dialog 


 


2. In the Backup File(s) group, in the Alias textbox, select the name of the backed up 


Database.   


 


If IBConsole does not auto complete the remaining fields continue as follows, otherwise 


continue with point 4: 
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 In the Backup File(s) group, in the Filename(s) textbox, provide the directory path and 


file name for the backup database.  We suggest C:\IXP220\Database\DB220.FBK. 


 In the Database group, from the Server drop-down list, select the server in which the 


Database will remain. 


 In the Database group, from the Alias drop-down list, select the Database to restore to. 


 In the Database group, in the Filename(s) textbox, provide the directory path and file 


name for the restored Database.  We suggest C:\IXP220\Database\DB220.FDB. 


 


3. From the Options group, select the Overwrite record. 


4. From the Overwrite drop-down list, select True. 


5. Click on the OK button. 


6. Close the Database Restore dialog when you see the comment “Service Ended”. 


 


Reconnect to the Database 


1. In IBConsole, from the Hierarchical Tree, click on the DB220.FDB file. 


2. From the Database drop-down menu, select Maintenance>Database Restart. 


 


RReessttoorriinngg  tthhee  IIXXPP222200  DDaattaabbaassee  UUssiinngg  aa  BBaattcchh  FFiillee  


Create the “.bat” File 


1. Capture the following text into a text file (for example Notepad). 


 


 
Figure 39 – Restore Using a Batch File 


 


 


Settings explained: 


 


 @SET USER=SYSDBA—this sets the username as SYSDBA, thus ensuring the backup utility 


connects to the Database. 


 @SET PASSWORD=MASTERKEY—this sets the password, if you changed the default 


password, ensure that you use the new password. 


 @SET PATH=C:\Program Files\Firebird\Firebird_2_1\bin—points out the path to the GBAK 


backup utility.  If the GBAK backup utility does not appear in this directory, set the path 


accordingly. 


 gbak -p 8192 –c -v DB220.FBK DB220.FDB—restores the DB220.FBK file to the name of 


DB220NEW.FDB. 


 


2. Save the text file as “restore.bat”. 
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Run the “restore.bat” File 


1. In Windows®, click Start>All Programs>Accessories>Run. 


2. In the Run dialog, click on the Browse button. 


3. In the Browse dialog, select the “.bat” file you created. 


4. Click on the Open button. 


5. In the Run dialog, click on the OK button. 


6. Follow the on-screen prompts. 


 


 


This restore process may take some time on large Databases.  This process restores the new 


Database to the same directory as where the batch file ran from.  Once the restore process is 


complete, close all applications connected to the original Database.  Rename the existing Database as 


DB220OLD.FDB and rename the DB220NEW.FDB Database to DB220.FDB. 


 


Database Corruption 


 


 


Lessen data loss if Database corruption occurs, by making regular Database back-ups.  It is essential 


that these regular backups are made and kept on removable media, or on a networked drive. Storing 


backups on the local disk will not prevent data loss if the hard drive fails. 


 


A Corrupt Database does not always mean a loss of data.  Usually, you can recover the 


Database using a combination of the tools described earlier.  There are various indicators of a 


corrupt Database: 


 


 The Software may not start up 


 The Software may hang or not upload transactions 


 


CCaauusseess  ooff  DDaattaabbaassee  CCoorrrruuppttiioonn  


Database corruption can result from various causes beyond the scope of this document, the list 


below outlines the common causes of database corruption: 


 


1. Abnormal or incorrect shutdown of the server, especially during power failures.  Ensure 


the server has a working uninterrupted power supply. 


2. Server defects and hardware faults, especially with hard disk drives, disk controllers, 


main memory of the PC and cache memory of raid controllers. 


3. Copying the Database while the servers running.  


4. Hard disk drive or Operating System corruption. 


5. Poor Database design by third-party integrators. 


6. Sharing the Database folder (allowing access over the network) is a security risk, and 


increases the chance of database corruption.  Firebird cannot tolerate other applications 


locking sectors of the Database file.   


 DO NOT use Windows Explorer (or command line 'Copy' or 'Xcopy') when copying the 


Database file on a live Database.  In practice, these utilities may lock the sector they’re 


copying.  So merely copying the DB220.FDB file with Windows Explorer is enough to 


corrupt the Database. 


 DO NOT use any arbitrary backup tool or archiving tool to make a backup copy of the 


Database.  The only safe way to make a backup copy of the Database is to use the 


backup facility we provide as part of the IXP220 Software, or use Firebird's GBAK tool.  
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This creates a '.gbk' or '.fbk' backup file, suitable for safe copying after finishing the 


backup process.  Alternatively, stop Firebird Server on the server to copy the '.fdb' file, 


restart the Server again afterwards. 


7. Check for other processes trying to read the Database file. These are typically Virus 


and Spy-ware scanners, common on corporate PC's.  


8. The bigger the size of the Database file, the more likely is it to become corrupt because 


of one of the above mentioned reasons. 


 


If you suspect your IXP220 Database is corrupt, carry out an immediate backup and restore on 


the Database. 


 


CChheecckkiinngg,,  RReeppaaiirriinngg  aanndd  RReeccoovveerriinngg  ffrroomm  MMiinnoorr  DDaattaabbaassee  CCoorrrruuppttiioonn    


 


 


Carry out these steps regularly for checking, repairing and recovering from Minor Database 


Corruption, for example every 2 or 3 months. 


 


1. Close all applications connected to the Database. 


2. Copy the Database to a separate directory. 


3. In the same directory, capture the following text into a text file (for example Notepad). 


 


 
Figure 40 – “repair.bat” Batch File 


 


4. Save the file as “repair.bat”. 


 


Run the “repair.bat” Batch File 


1. In Windows®, click Start>All Programs>Accessories>Run. 


2. In the Run dialog, click on the Browse button. 


3. In the Browse dialog, select the “.bat” file you created. 


4. Click on the Open button. 


5. In the Run dialog, click on the OK button. 


6. Follow the on-screen prompts. 


 


 


This process mends and backs-up the Database to the same directory as where the batch file ran from.  


Once complete, the restore process runs resulting in the DB220NEW.FDB Database file.  If successful, 


you may use the restored Database as a direct replacement for the existing Database.   
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AAnn  IInnttrroodduuccttiioonn  ttoo  IIBBFFiirrssttAAIIDD  


For Firebird Database corruption that you cannot correct with GFIX, you may buy advanced 


Firebird database recovery tools from the IB Surgeon web site.   


 


Accessing the IB Surgeon Web Site 


1. In Windows®, click Start>Internet Explorer. 


2. In the Address bar, type in the URL:  http://www.ib-aid.com/.  From here you may read up 


on the Software, or buy a copy for use. 


 


USER NOTES 
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Web Reports  


Overview 


The IXP220 Software lets you compile Reports on functions and transactions within the IXP220 


System.  As these Reports are essentially Web Reports, you can compile Reports for one or 


more Sites over LAN or WAN networks.  The Reports Module allows selection of single or 


multiple Sites, allowing management of both.   


 


You may use the Web Reports Module, and e-mail reports, with Windows® Internet Explorer 8 


(and above) or alternatively Firefox 3 (and above).  


 


 


Using IXP220 V1.82 (onwards) lets you connect to Web Modules through a Secure Socket Layer 


(SSL) connection.  See Part 5 – Advanced Configuration for information on this feature. 


 


Starting up the Web Reports Module 


 


 


If the Web Server resides on a Port other than Port 80, the URL becomes: 


http://localhost:XX/220Web/homepage.html.  The XX highlighted in the URL refers to the new Port 


number, for example 82, 83 or 84 and so on. 


 


Open the IXP220 Base Application as follows: 


 


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. Click the  button. 


4. From the Menu Bar, select the Web>Web Home Page. 


 


 


Alternately using a separate PC workstation, you may startup the Web Reports Module in your selected 


browser using the following URL:  http://localhost/220Web/homepage.html.  Replace the term 


localhost with the IP Address for the System’s Host PC. 


 


5. At the IXP220 Home Page, select the  (Web Reports) Icon. 


6. At the Login dialog, enter your Username (SYSDBA) and Password (masterkey). 


 


 


From the IXP220 Base Application, disable the Report’s Login option as follows: 


 


1. From the Main Menu, select File>Preference. 


2. Select the Web Tab. 


3. Select the Anyone can View Web Reports radio button.  


4. Click the  button. 


 


7. Click the Submit button. 
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User Interface 


 


Display Web Reports correctly by setting your monitor screen resolution to a minimum of 1 024 x 768 


pixels. 


 


 


Set the following when printing Reports displaying graphics: 


 


Internet Explorer 


1. From the Explorer toolbar, select Tools>Internet Options. 


2. Select the Advanced Tab. 


3. Scroll down to the Printing settings. 


4. Select the Print Background Colours and Images checkbox. 


5. Click the OK button. 


 


Firefox 


1. From the Firefox toolbar, select File>Print Preview. 


2. Click the Page Setup button. 


3. Select the Format and Options Tab. 


4. Under Options, select the Print Background (Colours and Images) checkbox. 


5. Click the OK button.  


 


 
Figure 1 – Web Reports Configuration Tab Selection 


 


On opening of the Web Reports Module, Tabs appear (Access, Person, Transaction, 


Configuration, Tagholders and Charts).  Essentially these Tabs break the Reports into 


categories for easier selection.   


From each of these Tabs, open a chosen Report by selecting the Report’s title.  Thereafter, 


select a new Report by selecting the appropriate Tab and selecting another Report’s title. 
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Figure 2 – Typical Report Screen 


 


From within a Report, select parameters using the set of filters displayed on the screen.  These 


filters may consist of information fields (occasionally), drop-down menus, checkboxes or 


calendars.   


 


Report screens include an All Sites filter, that when selected displays information for all Shared 


Sites (Shared Sites are described later in this section).   


 


Click on the Submit button to view a Report after capturing the filter data. 


 


Report Categories 


The categories of Reports available are: 


 


Report Category Description 


Access Reports Provides access data for all Tagholders at all selected Sites. 


Person Reports Provides transaction data relating to a specific person or persons 


having access to the Site(s) concerned. 


Transaction Reports Provides data about system occurrences, such as Alarms, Terminal 


time-outs, frequency of Door access, and so on. 


Configuration Reports Provides data such as Terminals that a given Tagholder has access 


to, Terminals in each Area and Actions available at each Terminal. 


Tagholder Reports Provides data about Employee and Visitors’ Tags, Tags not used, 


Tag Expiry, and so on. 


Charts Provides a graphic representation of Door Usage. 


Table 1 – Report Categories 
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AAcccceessss  RReeppoorrttss  


Under ACCESS REPORTS, the following Reports are available: 


 


Message Board Report 


 The Message Board Report shows the latest IN and OUT Transaction Information for 


each Tagholder on the selected Site(s).  The webserver.properties file includes properties 


for the Message Board Report.  These properties help filter the Report and control the 


Report’s refresh rate.  


 The Report includes information such as:  Site Name, Department, First Name, Last Name, 


IN Time/Date and OUT Time/Date. 


 Filter the Report by:  Date, Site, and Department. 


 


First Access Report 


 The First Access Report displays all Tagholders’ First Access transaction for a specific 


day.   


 The Report includes information such as:  Site, First Name, Last Name, Employee Number, 


Department, Door, Time and Date. 


 Filter the Report by:  Date, Site, Door, Department and Person. 


 


Last Access Report 


 The Last Access Report provides information on the Last Access (in-clockings and/or 


out-clockings) by a selected person at a selected door during a period from a 


selected date to the current time.  The webserver.properties file includes properties for 


this Report that control the Report’s refresh rate.      


 The Report includes information such as:  Site, First Name, Last Name, Employee Number, 


Department, Door, Time, Date and Reason Code. 


 Filter the Report by:  Date, Site, Door, Department and Person. 


 


Last Access for Day Report 


 The Last Access for Day Report displays all Tagholders’ Last Access Transactions for a 


specific day.   


 The Report includes information such as:  Site, First Name, Last Name, Employee Number, 


Department, Door, Time, Date and Reason Code. 


 Filter the Report by:  Date, Site, Door, Department and Person. 


 


PPeerrssoonn  RReeppoorrttss  


 


 


Anti-passback (APB) Zones are required for accuracy in the Zone Occupancy Report.  The 


following Reports will run without Anti-passback (APB) Zones (Relaxed or Strict), however, report 


accuracy is NOT guaranteed. 


 


 Hours Worked (Person) Report  


 Hours Worked Timesheet Report 


 Access Pattern (Person) Report 


 Access Pattern (Department) Report 


 


 


The Hours Worked Report, Hours Worked Timesheet Report, Access Pattern Report and Access 


Pattern (Department) Report support night-shift in the IXP220 V1.82 (onwards) Software release. 
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Under PERSON REPORTS, the following Reports are available: 


 


Absenteeism Report    


 The Absenteeism Report details a list of Employees absent on a specified date.   


 The Report includes information such as:  Employee Name and Employee Number.   


 Filter the Report by:  Date, Site, Department and by 7 Day Period. 


 


 


The Department Filter only affects the Chart for this Report, NOT the Report itself. 


 


Person Details Report    


 The Person Details Report displays a detailed record for a selected individual 


Tagholder.   


 The Report includes information such as:  First Name and Last Name, ID Number, 


Company, Department, Employee Number, transaction Date and Time, Door Accessed, 


Event and Tag code.  The Report also displays a photo of the employee.    


 Filter the Report by:  From Date, To Date, Site and Person. 


 


Hours Worked (Person) Report    


 Report calculates hours worked from the IN and OUT Transactions of all Zones.   


 The Report includes information such as:  Name, Employee Number, Date, Time, Event, 


Terminal, Zone and Reason. 


 Filter the Report by:  From Date, To Date, Site and Person. 


 


Hours Worked Timesheet Report    


 This Report calculates hours worked of all employees from the IN and OUT Transactions 


of all Zones.   


 The Report includes information such as:  Name, Company, Date, Time In, Time Out, Time 


Out – Time In, Hours in Zone, Hours to Now and Information. 


 Filter the Report by:  From Date, To Date, Site, Person, Company, Department and Zone. 


 


Access Pattern Report    


 This Report displays a summary of an individual employee’s time in, average time in, time 


out, average time out and average hours worked. 


 The Report includes information such as:  Date, Time In, Time Out, Time Out – Time In, 


Average Time In and Out, Average Hours and Total Hours. 


 Filter the Report by:  From Date, To Date, Site and Person. 


 


Access Pattern (Department) Report    


 This Report displays a summary of an individual employee’s time in, average time in, time 


out, average time out and average hours worked (grouped by Department). 


 The Report includes information such as:  Name, Company, Date, Time In, Time Out and 


Time Out – Time In. 


 Filter the Report by:  From Date, To Date, Site, Person, Company, Department and Zone. 


 


Zone Occupancy Report    


 This Report displays a summary of Tagholders within a specific Zone. 


 The Report includes information such as:  First Name, Last Name, Employee Number, 


Department, Zone, Site, Time In, Date and Hours in Zone. 


 Filter the Report by:  Site and Zone. 
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TTrraannssaaccttiioonn  RReeppoorrttss  


Under TRANSACTION REPORTS, the following reports are available: 


 


Tagholder Transaction Report 


 This Report displays all transactions for a Tagholder.   


 The Report includes information such as:  Date, Time, Name, Door, Event, Tag and Reason 


Code. 


 Filter the Report by:  Date From, Date To, Daily Time From, Daily Time To, Site, Tagholder, 


Department, Company and Door.   


 


Alarm Transaction Report    


 The Alarm Report displays all Alarms generated by the System.   


 The Report includes information such as:  Date, Time, Source, Event, Tagholder, 


Acknowledgement, Acknowledgement Date, Acknowledgement Time and Operator. 


 Filter the Report by:  From Date, To Date, Daily Time From, Daily Time To and Site. 


 


Status Transaction Report    


 This Report displays all the status transactions from Controllers and Terminals on a 


selected date.  That is Terminal timeouts; tables corrupt and Request to Enter/Exit 


information.   


 The Report includes information such as:  Date, Time, Source, Source Address, Event and 


Operator. 


 Filter the Report by:  From Date, To Date, Daily Time From, Daily Time To and Site. 


 


Transactions Report    


 The Transactions Report displays all Tagholders transactions on a specific date.   


 The Report includes information such as:  Time, First Name, Last Name, Employee 


Number, Door, Event, Tag, Zone and Reason Code. 


 Filter the Report by:  Date, Door, Person and Site. 


 


Comms Diagnostic Report    


 The Comms Diagnostic Report displays all diagnostic transactions from IP Terminals for 


a specific date. 


 The Report includes information such as:  Site Name, Time, Event, Round Trip 


(milliseconds), Failures and Door Name (Reader Fixed Address). 


 Filter the Report by:  Date, Site, Controller and Door. 


 


Conflicting Controller Comms Report    


 The Conflicting Controller Comms Report displays all conflicting Controller 


communication transactions reported by IP Terminals. 


 The Report includes information such as:  Date, Time, Door Name, Terminal Logical 


Address and IP Address (of the Controller who is trying to talk to this IP Door Controller). 


 Filter the Report by:  Date and Site. 
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CCoonnffiigguurraattiioonn  RReeppoorrttss  


Under CONFIGURATION REPORTS, the following reports are available: 


 


Tag Configuration Report 


 This Report displays configuration details for each Tag in the System.   


 The Report includes information such as:  Site, Tag Code, First Name, Last Name, 


Department, Level, Type, Start Date, Expiry Date, Suspended, Group Site and Access 


Group. 


 Filter the Report by:  Site and View Same Tag Code.   


 


Tagholder Configuration Report 


 This Report displays configuration details for each Tagholder in the System.   


 The Report includes information such as:  Employee Number, First Name, Last Name, 


Department, Company, Address, Tag Code, Start Date, Expiry Date, and Site. 


 Filter the Report by:  Site.  


 


Holiday Report 


 This Report displays details of public and other company holidays.   


 The Report includes information such as:  Holidays (defined during the configuration 


process). 


 Filter the Report by:  Site and View (Table or Calendar).   


 


Terminal Configuration Report 


 This Report displays a detailed report on Terminals.   


 The Report includes information such as:  Logical Address, Fixed Address, Enabled, Type, 


Type Description and Site. 


 Filter the Report by:  Site.   


 


Door Mode Configuration Report 


 This Report displays a detailed report on Door (Location) Modes.   


 The Report includes information such as:  Number, Start Time, End Time, Mode, PIN-code, 


Reason Code, Dual Tag, Record, Alarm Denied, LED Mode, Finger Mode and Site. 


 Filter the Report by:  Site.   


 


Access Group Configuration Report 


 This Report displays Access Group configuration details.   


 The Report includes information such as:  Site, Access Group, Pattern Number, Day, Start 


Time, Duration, Access Door and Access Floor. 


 Filter the Report by:  Site.   


 


 


Where the Access Group’s Pattern Number shows a (+) alongside the Pattern Number, clicking the (+) 


displays linked Lift (Elevator) Groups.  A (-) alongside the Pattern Number shows the Access Group 


has no connected Lift (Elevator) Groups. 


  


Reader Configuration Report 


 This Report displays Reader configuration details, including the indicators given on 


presentation of an Allowed or Denied Tag.   


 The Report includes information such as:  Door Names, Logical Address, Strike Duration, 


Open Duration, DOS Usage, Message Mode, Message Device Address, Time and 
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Attendance, DOS Mode, RTE Mode, Offline Validation, FAR, Buzzer Volume, Buzzer 


Duration, LED Action and LED Duration. 


 Filter the Report by:  Site.   


 


Door/Lift Configuration Report 


 This Report displays details of each Door or Lift (Elevator) configuration, including the 


daily operating modes.   


 The Report includes information such as:  Site, Door Number, Door Name, APB, Zone, 


Armed, Door PIN, In Reader, Out Reader, Bottom Lift, Top Lift, Day and Mode. 


 Filter the Report by:  Site.   


 


Door Access Configuration Report 


 This Report displays Door configuration and access details.  Doors (or Lifts (Elevators)) 


appear on the left of the screen.  Clicking a Door (or Lift (Elevator)) displays a list of 


Tagholders with access to the Door (or Lift (elevator)) and details of the relevant access 


group. 


 The Report includes information such as:  Site, Controller, Door Names, First Name, Last 


Name, Access Group, Pat Number, Day, Start Time and Duration. 


 Filter the Report by:  Site.   


  


Triggered Action Configuration Report 


 This Report displays Triggered Action Configuration details.   


 The Report includes information such as:  Site, Number, Name, Day, Start Time, Duration, 


Trigger Inputs and Action Type. 


 Filter the Report by:  Site and Trigger Type.   


 


IO Device Configuration Report 


 This Report displays configuration information for each Input and Output Device in the 


System.   


 The Report includes information such as:  Site, Device Name, Fixed Address, Logical 


Address, Unit Name, Unit Description and Information. 


 Filter the Report by:  Site.   


 


GSM Configuration Report 


 This Report, only available to Administrators, displays GSM configuration information.   


 The Report includes information such as:  Controller Logical Address, Controller Hostname, 


SIM Pin, SIM Puk, APN, APN Username, APN Password, DDSN Provider, DDNS 


Username, DDNS Password and PC Hostname. 


 


TTaagghhoollddeerrss  RReeppoorrttss  


Under TAGHOLDERS REPORTS, the following reports are available: 


 


Biometric Report 


 This Report displays whether Tagholders have Biometric Templates or not.   


 The Report includes information such as:  First Name, Last Name, Employee Number, Tag 


Code, Tag Type, Database Number, Template 1 Quality, Template 2 Quality and Exists. 


 Filter the Report by:  Person, Tag, Site, Tag has Biometric Template and Tag does not have 


a Biometric Template.   
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Tag Expiry Report 


 This Report displays details of Tags either expired or due for expiry.   


 The Report includes information such as:  Site, Tag Code, Tag Type, First Name, Last 


Name, ID, Expiry Date and Expiry Time. 


 Filter the Report by:  Date From, Date To and Site. 


 


CChhaarrttss  


Under CHARTS, the following reports are available: 


 


Door Usage Chart 


 This Report displays a Bar Chart representing the percentage of allowed transactions 


per Door (Location).  


 The Report graphically includes information such as:  the Percentage of Allowed 


Transactions, Doors, In Transactions and Out Transactions. 


 Filter the Report by:  Site, Door, Date, Time from and Time To. 


 


Typical Sample Reports 


This section outlines one Report from each category, thus providing insight into the use of the 


Reports. 


 


AAcccceessss  RReeppoorrttss  


Message Board Report 


The Message Board Report displays the latest IN and OUT transactions for each Tagholder. 


 


 
Figure 3 – Message Board Report (Initial Set-up Screen) 
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1. Select the Date from the Date Filter calendar selection tool. 


 


 


As you select the Date, a calendar selection tool opens.  Continue as follows to make your selection: 


 


1. Click on the << or >> buttons to move between Years.  


2. Click on the < or > buttons to move between Months. 


3. Finally, select the required date. 


 


2. Select the Site from the Site Filter drop-down list. 


3. Select the required Department from the Department Filter drop-down list. 


4. Click the Submit button. 


 


 
Figure 4 – Message Board Report (Sample) 


 


Export CSV (Comma Separated Value) 


 


 


The Export CSV button displays after you submit the filter data. 


 


 


When exporting a Report to a CSV file, if the results of the Report are greater than 200 000 records, an 


error occurs.  To avoid this, draw smaller Reports when exporting. 


 


Export a Report as follows: 


 


1. Click on the Export CSV button. 


2. In the File Download dialog, select one of the following button options: 


 Open—clicking the Open button, opens a screen similar to Figure 5.  In this case the 


file opened using MS Excel. 


 Save—clicking the Save button, gives you the option to save the exported data to a 


location of your choice. 
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 Cancel—clicking the Cancel button, cancels the export process. 


 


 
Figure 5 – Message Board Report Exported in CSV Format 


 


PPeerrssoonn  RReeppoorrttss  


Absenteeism Report 


The Absenteeism Report displays a list of Employees absent on a specified date.   


 


 
Figure 6 – Typical Absenteeism Report  


 


TTrraannssaaccttiioonn  RReeppoorrttss  


Tagholder Transaction Report 


This Report displays the frequency of access at each Door. 
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Figure 7 – Typical Tagholder Transaction Report 


 


CCoonnffiigguurraattiioonn  RReeppoorrttss  


Tagholder Configuration Report 


This Report displays configuration details for each Tagholder in the System.   


 


 
Figure 8 – Typical Tagholder Configuration Report 
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TTaagghhoollddeerrss  RReeppoorrttss  


Tag Expiry Report 


This Report gives details of expired Tags as well as Tags that will expire in the future. 


 


 
Figure 9 – Typical Tag Expiry Report 


 


CChhaarrttss  


Door Usage Chart 


This Report displays the percentage of allowed transactions per Door (Location). 







Part 4 – Reports 


18  February 2012 


 
Figure 10 – Typical Door Usage Chart 


 


OOtthheerr  RReeppoorrttss  


The other Reports available are all conceptually similar to one or other of the Reports described 


previously. 
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E-mail Reports 


Overview 


The IXP220 Software lets you compile Reports on functions and transactions within the IXP220 


System.  As these Reports are essentially Web Reports, you can compile Reports for one or 


more Sites over LAN or WAN networks.  The E-mail Reports allows selection of single or 


multiple Sites, allowing management of both.   


 


You may use the E-mail Reports with Windows® Internet Explorer 8 (and above) or alternatively 


Firefox 3 (and above).  


 


Starting up E-mail Reports 


The following sections show you how to request reports by e-mail. 


 


RReeqquueessttiinngg  tthhee  AAvvaaiillaabbllee  RReeppoorrttss  LLiisstt  


 


 


You do not need to perform Requesting the Available Reports List every time you want to request 


the available Reports list by E-mail. 


 


1. Using your preferred e-mail client, create an e-mail message. 


2. In the To textbox, enter the E-mail Address you configured in E-mail Account 


Configuration (see Part 3 – General Configuration for more information). 


3. In the Subject textbox, enter the phrase HELP. 


4. In the body of the E-mail Message, enter the Password you configured in Incoming 


Configuration (See Part 3 – General Configuration for more information). 


5. Click the Send button. 


 


RReeqquueessttiinngg  tthhee  RReeppoorrtt  RReeqquueesstt  FFoorrmm  


1. Using your preferred e-mail client, create an e-mail message. 


2. In the To textbox, enter the E-mail Address you configured in E-mail Account 


Configuration (see Part 3 – General Configuration for more information). 


3. In the Subject textbox, enter either one of the following phrases, ensuring NO space 


between Menu and number command: 


 Report Menu1—has one set of filters for all Reports. 


 Report Menu2—has a different set of filters for each Report. 


4. In the body of the E-mail Message, enter the Password you configured in Incoming 


Configuration (See Part 3 – General Configuration for more information). 


5. Click the Send button. 
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CCoommpplleettiinngg  tthhee  RReeppoorrtt  RReeqquueesstt  FFoorrmm  


 


 


The Report Request Form expires after 1 hour, or if the base Application closes.  Each template can 


only be used once. 


 


1. In your e-mail client, select the e-mail with RE: REPORT REQUEST - Menu in the subject. 


2. Open the message attachment.  


3. From the Report group, using the checkboxes alongside, select your required report(s): 


 Absenteeism Report—filtered by From Date, To Date, Site and Tagholder. 


 Person Details Report—filtered by From Date, To Date, Site and Tagholder. 


 Hours Worked Timesheet Report—filtered by From Date, To Date, Site, Department 


and Tagholder. 


 Access Pattern (Department) Report—filtered by From Date, To Date, Site, 


Department and Tagholder. 


 Zone Occupancy Report—filtered by Site. 


 Tagholder Transaction Report—filtered by From Date, To date, Site, Department and 


Tagholder. 


 Transactions Report Report—filtered by From Date, Site and Tagholder. 


 Tag Expiry Report—filtered by From Date, To Date and Site. 


4. Continue with either of the following options: 


 


Steps Specific to Report Menu1 


In the Filters group select from the following: 


 


a. From the From Date drop-down list, make your selection. 


b. From the To Date drop-down list, make your selection.   


c. From the Site drop-down list, make your selection. 


d. From the Department drop-down list, make your selection. 


e. From the Tagholder drop-down list, make your selection. 


 


Steps Specific to Report Menu2 


 


 


Refer to Completing the Report Request Form, point 3 on page 20 for details of filters by Report. 


 


a. From the Absenteeism Report group, make your selection from the available filters.   


b. From the Person Details group, make your selection from the available filters.   


c. From the Hours Worked Timesheet group, make your selection from the available 


filters.   


d. From the Access Pattern (Department) group, make your selection from the available 


filters.   


e. From the Zone Occupancy Report group, make your selection from the available 


filters.   


f. From the Tagholder Transaction group, make your selection from the available filters.   


g. From the Transactions Report group, make your selection from the available filters.   


h. From the Tag Expiry group, make your selection from the available filters.   


 


5. Within the Authentication group, complete the Password textbox with the Password 


configured in Incoming Configuration. (See Part 3 – General Configuration for more 
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information. 


6. Click the Generate Request button. 


7. Click the OK button at the Windows Internet Explorer dialog.  


8. Click the Allow button at the Microsoft Office Outlook dialog. 


 


User Interface 


 


 
Figure 11 – Report Request Form for Report Menu1 


 


The Report Request Form for Report Menu1 (see Figure 11) has the following groups: 


 


 Reports Group—this is where you select the Report(s) you want to run by selecting the 


suitable checkbox. 


 Filters Group—this is where you choose which filters to apply by using the drop-down lists. 


 Authentication Group—this is where you enter your password in the textbox. 
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Figure 12 – Report Request Form for Report Menu2 


 


The Report Request Form for Report Menu2 (see Figure 12) has the following groups: 


 


 Reports Group—this is where you select the report(s) you want to run by selecting the 


suitable checkbox. 


 Absenteeism Report Group—this is where you select the filters for the Absenteeism 


Report. 


 Person Details Group—this is where you select the filters for the Person Details Report. 


 Hours Worked Timesheet Group—this is where you select the filters for the Hours 


Worked Timesheet Report. 


 Access Pattern (Department) Group—this is where you select the filters for the Access 


Pattern (Department) Report. 
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 Zone Occupancy Group—this is where you select the filter for the Zone Occupancy 


Report. 


 Tagholder Transaction Group —this is where you select the filters for the Tagholder 


Transaction Report. 


 Transactions Report Group—this is where you select the filters for the Transactions 


Report. 


 Tag Expiry Group—this is where you select the filters for the Tag Expiry Report. 


 Authentication Group—this is where you enter your password in the textbox. 


 


Report Categories 


Here follows a list of available reports. 


 


PPeerrssoonn  RReeppoorrttss  


 


 


Anti-passback (APB) Zones are required for accuracy in the Zone Occupancy Report.  The 


following Reports will run without Anti-passback (APB) Zones (Relaxed or Strict), however, Report 


accuracy is NOT guaranteed. 


 


 Hours Worked Timesheet Report 


 Access Pattern (Department) Report 


 


 


The Hours Worked Timesheet Report and the Access Pattern (Department) Report support night-


shift in the IXP220 V1.82 (onwards) Software release. 


 


Under PERSON REPORTS, the following Reports are available: 


 


Absenteeism Report 


 The Absenteeism Report details a list of Employees absent on a specified date. 


 The Report includes information such as: Employee Name and Employee Number. 


 For Report Menu1 filter the Report by: From Date, To Date, Site, Department and 


Tagholder. 


 For Report Menu2 filter the Report by: From Date, To Date, and Tagholder. 


 


Person Details Report 


 The Person Details Report displays a detailed record for a selected individual 


Tagholder. 


 The Report includes information such as: First Name and Last Name, ID Number, 


Company, Department, Employee Number, Transaction Date and Time, Door Accessed, 


Event and Tag Code. The Report also displays a photo of the employee. 


 For Report Menu1 filter the Report by: From Date, To Date, Site, Department and 


Tagholder. 


 For Report Menu2 filter the Report by: From Date, To Date, Site and Tagholder. 


 


Hours Worked Timesheet Report 


 This Report calculates hours worked of all employees from the IN and OUT Transactions 


of all Zones. 
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 The Report includes information such as: Name, Company, Date, Time In, Time Out, Time 


Out – Time In, Hours in Zone, Hours to Now and Information. 


 For Report Menu1 and Report Menu2 filter the Report by: From Date, To Date, Site, 


Department and Tagholder. 


 


Access Pattern (Department) Report 


 This Report displays a summary of an individual employee’s time in, average time in, time 


out, average time out and average hours worked (grouped by Department). 


 The Report includes information such as: Name, Company, Date, Time In, Time Out, and 


Time Out – Time In. 


 For Report Menu1 and Report Menu2 filter the Report by: From Date, To Date, Site, 


Department and Tagholder. 


 


Zone Occupancy Report 


 This Report displays a summary of Tagholders within a specific Zone. 


 The Report includes information such as: First Name, Last Name, Employee Number, 


Department, Zone, Site, Time In, Date and Hours in Zone. 


 For Report Menu1 filter the Report by: From Date, To Date, Site, Department and 


Tagholder. 


 For Report Menu2 filter the Report by: Site. 


 


TTrraannssaaccttiioonn  RReeppoorrttss  


Under TRANSACTION REPORTS, the following Reports are available: 


 


Tagholder Transactions Report 


 This Report displays all transactions for a Tagholder. 


 The Report includes information such as: Date, Time, Name, Door, Event, Tag and Reason 


Code. 


 For Report Menu1 and Report Menu2 filter the Report by: From Date, To Date, Site, 


Department and Tagholder. 


 


Transactions Report 


 The Transactions Report displays all Tagholders transactions on a specific date. 


 The Report includes information such as: Time, First Name, Last Name, Employee Number, 


Door, Event, Tag, Zone and Reason Code.  


 For Report Menu1 filter the Report by: From Date, To Date, Site, Department and 


Tagholder. 


 For Report Menu2 filter the Report by: From Date, Site, and Tagholder. 


 


TTaagghhoollddeerrss  RReeppoorrttss  


Under TAGHOLDERS REPORTS, the following Report is available: 


 


Tag Expiry Report 


 This Report displays details of Tags either expired or due for expiry. 


 The Report includes information such as: Site, Tag Code, Tag Type, First Name, Last 


Name, ID, Expiry Date and Expiry Time.  


 For Report Menu1 filter the Report by: From Date, To Date, Site, Department and 


Tagholder. 







Part 4 – Reports 


February 2012  25 


 For Report Menu2 filter the Report by: From Date, To Date and Site. 


 


Typical Sample Reports 


This section outlines one Report from each category, thus providing insight into the use of the Reports. 
 


PPeerrssoonn  RReeppoorrttss  


Absenteeism Report 


The Absenteeism Report displays a list of Employees absent on a specified date. 


 


 
Figure 13 – Typical Absenteeism Report 


 


TTrraannssaaccttiioonn  RReeppoorrttss  


Tagholder Transaction Report 


This Report displays the frequency of access at each Door. 


 


 
Figure 14 – Typical Tagholder Transaction Report 
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TTaagghhoollddeerrss  RReeppoorrttss  


Tag Expiry Report 


This Report gives details of expired Tags as well as Tags that will expire in the future. 


 


 
Figure 15 – Typical Tag Expiry Report 


 


OOtthheerr  RReeppoorrttss  


The other Reports available are all conceptually similar to one or other of the Reports described 


previously. 


 


 


USER NOTES 
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Registration Interface Licensing 


Purpose of this Feature 


 


The Registration Interface Licensing feature enables the purchase of feature licenses (for 


use with System 3 and System 4 only). 


 


Example 


The following example procedure shows the use of this feature.  


 


Procedure 


 


 


Connect your ImproX RS Registration Interface before using the Registration Interface Licensing 


feature. 


 


 
Figure 1 – Licensing Dialog 
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FFeeaattuurree  LLiicceennccee  UUnnlloocckk  PPrroocceedduurree  


1. In the IXP220 Base Application, from the Menu Bar select Help Topics>Licensing. 


2. Click the Import File button. 


3. From the Select Device XML File dialog, select the downloaded XML (Web Store Unlock) 


File. 


 


 


The file name reflects the Fixed Address of the Registration Interface for Upgrade. 


 


4. Click the Open button. 


5. At the Unlock Successful dialog, click the OK button. 


6. Click the Close button. 
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Communication Configuration 


Purpose of this Feature 


 


The Communication Configuration feature lets you change the Communication Port being 


used by your IXP220 Controller.  That is, for example, moving your Controller from COM8 to 


COM17.   


 


Make use of this feature when damage occurs to your IXP220 Controller along with its 


associated Communications Port (for example in the event of a lightning strike). 


 


 


We advise that only Network Administrators with knowledge of Device Management use this feature. 


 


Example 


The following example procedure shows the use of this feature.  


 


Procedure 


 
Figure 2 – Communications Configuration Dialog 


 


1. In the IXP220 Base Application, from the Menu Bar select Hardware>Communications. 


2. Double-click your mouse in the Address column, over the record for editing. 


3. Edit the Communication Port number as per your requirements. 
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The Communications Configuration Dialog, also lets you change the following settings: 


 


 Timeout (Controller)—is the duration for which the Base Application waits for a reply from a 


Controller.  Increase this if using a WAN, a slow connection, Radio Modems, and so on.  (For 


example, use a setting of 5 000 for EtherPADs).  Also increase this setting if you receive many 


‘Controller Timeout’ messages. 


 Drop Time (Controller)—the duration for which the Controller will be dropped if it times out.  


This setting rarely requires change. 


 Additional Timeout (Controller)—an extra timeout value for increasing timeouts on the 


Controller bus.  Increase this when fast polling Controllers across a WAN, a slow connection, 


Radio Modems, and so on.  (For example, use a setting of 500).  Ideally, disable fast polling 


for a WAN, a slow connection, Radio Modems and so on. 


 Additional Timeout (Terminal)—an extra timeout value for increasing timeouts on the 


Communications bus.  Set this when Terminals are on a different network to the Controller.  


For example, when a Controller connects to a Terminal across a WAN. 


 Inter Poll Delay—the delay between successive polls.  Use this to poll less often thus 


reducing network traffic over EtherPADs on a WAN (for example, use a setting of 2 000). 


 IC Port—displays the inter-controller communications port number, that is the port used when 


controllers communicate with one another. 


 Respond Address—displays the IP Address the IP Terminals use to communicate with the 


Controller. 


 


4. Click the  button. 
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Lift (Elevator) Control (Base Application) 


Purpose of this Feature 


The Lift (Elevator) Control feature lets you setup Lift (Elevator) Control in your IXP220 


System.   


 


Using Lift (Elevator) Control, control access by a Lift (Elevator) to various floors in a building so 


a Tagholder can only select the floor or floors that they have access rights to.   


 


The IXP220 Software supports configuration of up to 8 Lifts (Elevators) per Site with a 


maximum of 32 floors per Lift (Elevator). 


 


Example 


1. Install a Reader inside the Lift (Elevator). 


2. Wire the ImproX O16 Terminals so that each Lift (Elevator) button is in series with the 


respective Relay on the ImproX O16 Terminal. 


3. Create the required Access Groups allowing access to the necessary floors. 


4. Give the respective access rights to the Tagholders that need access to these floors. 


 


When the Tagholder presents their Tag to the Entry Reader in the Lift (Elevator), the buttons for 


the assigned floors light up allowing selection of the floor.   


 


Procedure 


DDoooorr  CCoonnffiigguurraattiioonn  


 


 


Ensure that you unlock your Registration Interface for Elevator Control before using this feature.  This 


unlock allows for a maximum of 1 seat.  See page 5 of this section for more information. 


 


1. In the IXP220 Base Application, select the  Page Tab. 


2. Select the Lift (Elevator) Tab. 


3. Click the  button. 
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Figure 3 – Left-hand Side of the Door Configuration Pane 


 


4. In the Lift (Elevator) Name textbox, assign a suitable name. This textbox has a 16 


character limit. 


5. Click the Select button alongside the Reader textbox.   


6. In the Unassigned Readers dialog, from the list of displayed records, select the Lift 


(Elevator) Reader. 


7. Click the  button. 


8. Click the Select button alongside the Floor 1-16 textbox. 


9. In the Unassigned Readers dialog, from the list of displayed records, select the O16 


Terminal that corresponds to the Lift (Elevator). 


10. Click the  button. 


11. Click the Floor 1-16 button.   


12. In the Floor Name Configuration dialog, in the Name textbox, assign a suitable name. 


13. Assign Floor Names to the Relays. 


 


 
Figure 4 – Floor Name Configuration Dialog Showing Relay Assigned to Floor 
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Rather than entering the floor number, you may assign your floors names.    


 


14. Click the  button. 


15. Click the  button. 


16. Click the Floors 17-32 button and repeat steps 11 to 13 for these floors if required.   


 


 


When using Lift (Elevator) Control across multiple Lifts (Elevators), Lift (Elevator) buttons must connect 


to the ImproX 016 Terminal’s output Relays in the same order for each Lift (Elevator).   


 


17. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic Access Control features. 


 Advanced Configuration—activates extra advanced features. 


18. Click the  button. 


 


Entry Reader Configuration 


 


 


The settings displayed on the Entry or Exit Tabs depend on the type of Terminal connected.  Ignore 


references made below to fields that do not display. 


 


1. Select the Entry Tab. 


2. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic Access Control features. 


 Advanced Configuration—activates extra advanced features. 


3. From the DOS Mode group, from the DOS Mode drop-down list, make your selection from 


the following: 


 Normally Closed—use this option when connecting Normally Closed Door Sensors. 


 Normally Open—use this option when connecting Normally Open Door Sensors. 


4. From the DOS Usage drop-down list, make your selection from the following: 


 Normal—alarm sounds if the Door remains open too long or if the Door is forced.  Use 


this feature for monitoring real Door open states. 


 Terminate Strike—deactivates the relay if Door is opened and closed or forced.  Use 


this feature where the lock must re-engage once the Door is closed. 


 Inhibit—deactivates the Reader as long as the Door is open; also there is no alarm for 


Doors forced open.  Used when the Door is opened, the Reader disables while the Door 


remains open. 


5. Edit the Strike Duration (0.1s) textbox, the default value is 40 (0.1s).  Setting the Strike 


Duration to 55555 toggles the Relay. 


6. Edit the Open Duration(s) textbox.  By default, the Open Duration is set to 0, disabling the 


Door Open Sensor (DOS).    


7. Enable End-of-line Sensing by selecting the Enable End-of-line Sensing checkbox. 


 


 


End-of-line Sensing lets the System raise an alarm when somebody bypasses the Door Open Sensor.  


That is, the System distinguishes between tampering on the circuit and closure of the Door Open 


Sensor.  End-of-line sensing on the IXP220 Controller, ImproX iTT (input 1 and 3 only) and iTRT (input 


1 and 3 only) is only possible if Door Open Sensing is configured.  Set End-of-line Sensing per Door. 


 


8. From the ON VALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


9. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 
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10. From the ON INVALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


11. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


12. Click the  button. 


 


Configure Lift (Elevator) Mode Pattern 


 


 


The IXP220 Software supports a maximum of 8 Door Mode Patterns at each Door.    


 


This setting regulates the Lift’s (Elevator’s) operating mode including the start and end time.  


Continue as follows to add a new Lift (Elevator) Pattern: 


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the 


newly created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time and End Time—breaks the day into time slots.  By selecting and changing 


the End Time figure, you effectively create extra records, breaking the day into parts.  


You may create a maximum of 8 time slots per Door Mode Pattern. 


 Mode—indicates the mode in which the Door (Location) operates.   


 


 


Door (Location) operating mode examples include:   


 


 Tag Mode—requires presentation of a Tag to gain access. 


 Supervisor Unlock—requires that a Supervisor unlock the Door prior to normal employees 


gaining entrance. 


 Locked—the Door is locked and cannot be overridden with any Tag. 


 Open—the door is opened when the first valid Tagholder presents their Tag. 


 No Entry—only Administrators are granted access. 


 Door Entry Code—requires entry of a Door Entry Code to gain access.  Your Door Entry 


Code may range from between 1 to 65535.  After entering the Door Entry Code at the Reader 


or Terminal, complete the entry by pressing the # key.    


 Open Now—Door opens at specified time.  A Tag is not required to open the Door. 


 Personal Access Code—requires entry of a Personal Access Code to gain access.  Your 


Personal Access Code may range from between 1 to 999999999.  After entering your 


Personal Access Code at the Reader or Terminal, complete the entry by pressing the # key. 


 


 Finger (B-SHO)—make a selection from the choices presented:  No, ―+Entry‖, ―+Exit‖, 


―+Both‖, ―or Entry‖, ―or Exit‖, ―or Both‖, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger 


only Both‖.  Selecting ―+Entry‖, ―+Exit‖ or ―+Both‖, calls for Tagholders to present their 


Tag (MIFARE® or DESFIRE®) and their fingerprint at the ImproX B-SHO Fingerprint 


Terminal.  Selecting ―or Entry‖, ―or Exit‖ or ―or Both‖, calls for Tagholders to present 


either their Tag or fingerprint at the ImproX B-SHO Fingerprint Terminal.  For the 


following options, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger only Both‖, only 


fingerprint presentation is allowed (the tag reader is disabled). 
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 +PIN—make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


PIN-code at the respective Keypad Reader. 


 +Reason—make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


Reason at the respective Keypad Reader. 


 +Dual Tag—requires presentation of 2 individual Tags for access. 


 Record—log Transaction.  If you select NO, the ―Allowed In‖ and ―Allowed Out‖ 


transactions do not appear in the Transaction Viewer and do not save to the Database.  


This affects any report using transactions. 


 Denied Alarm—by selecting Yes, you instruct the System to treat denied events as 


alarms. 


 LED—sets the LED’s behaviour during the stipulated time slot. 


7. Click the  button. 


 


Advanced Configuration 


On selecting the Advanced Configuration radio button, the Lift (Elevator) Patterns and Zone 


settings activate.  Configure the following settings:   


 


 
Figure 5 – Right-hand Side of the Door Configuration Pane 


 


1. On the Configuration Pane, select the Lift (Elevator) Tab. 


2. In the Lift (Elevator) Pattern group (see Figure 5), make your selections from the Day’s Lift 


(Elevator) Mode Pattern drop-down lists.  


3. In the Zone group, select a Zone from the drop-down list. 
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Using a Lift (Elevator) Activation Code allows Tagholders to enter or exit a Lift (Elevator) using a 


numeric code.  Note, however, Tags with access permissions for the Lift (Elevator) are still 


acknowledged by the Reader. Activate the Lift (Elevator) Activation Code feature, as follows:  


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the newly 


created Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time, End Time, +PIN, +Reason, +Dual Tag, Record, Denied Alarm and LED. 


 Mode—select Door Entry Code from the drop-down list.  (Door Entry Codes range from  


1 to 65535.  After entering the Door Entry Code at the Reader or Terminal, complete the 


entry by pressing the # key). 


7. Click the  button. 


8. On the Configuration Pane, select the Lift (Elevator) Tab. 


9. In the Lift (Elevator) Activation Code textbox, enter a 5 digit numeric code. 


 


 


CCTV integration allows for better end user site management, that is in areas with rising crime, your 


operator can from a safe location monitor and control up to 4 Doors (Locations) (4 Cameras) at a time 


per Site.  Configure your IP Camera (Axis 210 or 213D range only) as follows: 


 


1. On the Door Configuration Pane, select the Lift (Elevator) Tab. 


2. Click the Advanced Configuration radio button. 


3. Within the IP Camera group, click the Configure button. 


4. In the IP Camera Configuration dialog, click the  button. 


5. In the Name textbox, assign your camera a meaningful name. 


6. In the Lookup textbox, enter the IP Address for your camera. 


7. Click the  button. 


8. Exit the dialog by clicking the  button. 


9. Select the Lift (Elevator) from the list of available Lift (Elevator) records. 


10. From the IP Camera drop-down list, select a Camera record, thus associating the Lift 


(Elevator) and IP Camera. 


11. Click the  button. 


 


4. Click the  button. 


 


AAcccceessss  GGrroouupp  CCoonnffiigguurraattiioonn  


Lift (Elevator) Access Tab 


 


 


Ensure that all Lifts (Elevators) in a Lift (Elevator) Access Group go to the same floors.  Note, you need 


not use all Lifts (Elevators).  Selecting floors from a single Lift (Elevator), the selection works as normal. 


 


 


When using distributed templates along with biometrics, after editing the Lift (Elevator) Access Group, 


ensure you perform a full upload.  Refer to Part 3 – General Configuration for more information on 


performing a full upload.     


 


1. Select the  Page Tab. 
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2. Select the Lift (Elevator) Access Tab. 


 


 
Figure 6 – Access Group Configuration Pane 


 


3. Click the  button. 


4. In the Lift (Elevator) group textbox, assign a suitable name. 


5. From the Denied Floors group, multi-select the Lifts (Elevators) and Floors to which you 


want to assign access. 


6. Click the  button. 


 


 


Return wrongly selected Lifts (Elevators) and Floors to the Denied Floors group by clicking the  


button.  


 


7. Click the  button. 


 


General Access Tab 


1. Select an Access Group as created in Part 3 – General Configuration. 


2. From the Lift (Elevator) group drop-down list, make your selection. 


3. Click the  button. 
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Lift (Elevator) Control (IXP220 Rich Client 
Module) 


Purpose of this Feature 


This procedure lists the steps involved in setting up Lift (Elevator) Control through the IXP220 


Rich Client Module. 


 


Using Lift (Elevator) Control, control access by a Lift (Elevator) to various floors in a building so 


a Tagholder can only select the floor or floors that they have access rights to.   


 


The IXP220 Software supports configuration of up to 8 Lifts (Elevators) per Site with a 


maximum of 32 floors per Lift (Elevator). 


 


Example 


1. Install a Reader inside the Lift (Elevator). 


2. Wire the ImproX O16 Terminals so that each Lift (Elevator) button is in series with the 


respective Relay on the ImproX O16 Terminal. 


3. Create the required Access Groups allowing access to the necessary floors.  This step is 


only available through the IXP220 Base Application. 


4. Give the respective access rights to the Tagholders that need access to these floors. 


 


When the Tagholder presents their Tag to the Entry Reader in the Lift (Elevator), the buttons for 


the assigned floors light up allowing selection of the floor.   


 


Procedure 


DDoooorr  CCoonnffiigguurraattiioonn  


 


 


Ensure that you unlock your Registration Interface for Elevator Control and Web Enrollment before 


using this feature.  This unlock allows for a maximum of 1 seat. See page 5 of this section for more 


information. 


 


1. In the IXP220 Rich Client Module, select the  Page Tab. 


2. Select the Lift (Elevator) Tab. 


3. Click the  button. 
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Figure 7 – Left-hand Side of the Door Configuration Pane 


 


4. In the Lift (Elevator) Name textbox, assign a suitable name.  This textbox has a 16 


character limit. 


5. Click the Select button alongside the Reader textbox.   


6. In the Unassigned Readers dialog, from the list of displayed records, select the Lift 


(Elevator) Reader. 


7. Click the  button. 


8. Click the Select button alongside the Floor 1-16 textbox. 


9. In the Unassigned Readers dialog, from the list of displayed records, select the O16 


Terminal that corresponds to the Lift (Elevator). 


10. Click the  button. 


11. Click the Floor 1-16 button.   


12. In the Floor Name Configuration dialog, in the Name textbox, assign a suitable name. 


13. Assign Floor Names to the Relays. 
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Figure 8 – Floor Name Configuration Dialog Showing Relay Assigned to Floor 


 


 


Rather than entering the floor number, you may assign your floors names.    


 


14. Click the  button. 


15. Click the  button. 


16. Click the Floors 17-32 button and repeat steps 11 to 13 for these floors if required.   


 


 


When using Lift (Elevator) Control across multiple Lifts (Elevators), Lift (Elevator) buttons must connect 


to the ImproX 016 Terminal’s output Relays in the same order for each Lift (Elevator).   


 


17. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic Access Control features. 


 Advanced Configuration—activates extra advanced features. 


18. Click the  button. 


 


Entry Reader Configuration 


 


 


The settings displayed on the Entry or Exit Tabs depend on the type of Terminal connected.  Ignore 


references made below to fields that do not display. 


 


1. Select the Entry Tab. 


2. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic Access Control features. 


 Advanced Configuration—activates extra advanced features. 


3. From the DOS Mode group, from the DOS Mode drop-down list, make your selection from 


the following: 


 Normally Closed—use this option when connecting Normally Closed Door Sensors. 


 Normally Open—use this option when connecting Normally Open Door Sensors. 


4. From the DOS Usage drop-down list, make your selection from the following: 


 Normal—alarm sounds if the Door remains open too long or if the Door is forced.  Use 


this feature for monitoring real Door open states. 


 Terminate Strike—deactivates the relay if Door is opened and closed or forced.  Use 


this feature where the lock must re-engage once the Door is closed. 


 Inhibit—deactivates the Reader as long as the Door is open; also there is no alarm for 


Doors forced open.  Used when the Door is opened, the Reader disables while the Door 


remains open. 
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5. Edit the Strike Duration (0.1s) textbox, the default value is 40 (0.1s).  Setting the Strike 


Duration to 55555 toggles the Relay. 


6. Edit the Open Duration(s) textbox.  By default, the Open Duration is set to 0, disabling the 


Door Open Sensor (DOS).      


7. Enable End-of-line Sensing by selecting the Enable End-of-line Sensing checkbox. 


 


 


End-of-line Sensing lets the System raise an alarm when somebody bypasses the Door Open Sensor.  


That is, the System distinguishes between tampering on the circuit and closure of the Door Open 


Sensor.  End-of-line sensing on the IXP220 Controller, ImproX iTT (input 1 and 3 only) and iTRT (input 


1 and 3 only) is only possible if Door Open Sensing is configured.  Set End-of-line Sensing per Door. 


 


8. From the ON VALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


9. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


10. From the ON INVALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


11. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


12. Click the  button. 


 


Configure Lift (Elevator) Mode Pattern 


 


 


The IXP220 System supports a maximum of 8 Door Mode Patterns at each Door.    


 


This setting regulates the Lift’s (Elevator’s) operating mode including the start and end time.  


Continue as follows to add a new Lift (Elevator) Pattern: 


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the 


newly created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time and End Time—breaks the day into time slots.  By selecting and changing 


the End Time figure, you effectively create extra records, breaking the day into parts.  


You may create a maximum of 8 time slots per Door Mode Pattern. 


 Mode—indicates the mode in which the Door (Location) operates.   


 


 


Door (Location) operating mode examples include:   


 


 Tag Mode—requires presentation of a Tag to gain access. 


 Supervisor Unlock—requires that a Supervisor unlock the Door prior to normal employees 


gaining entrance. 


 Locked—the Door is locked and cannot be overridden with any Tag. 


 Open—the door is opened when the first valid Tagholder presents their Tag. 


 No Entry—only Administrators are granted access. 


 Door Entry Code—requires entry of a Door Entry Code to gain access.  Your Door Entry 


Code may range from between 1 to 65535.  After entering the Door Entry Code at the Reader 


or Terminal, complete the entry by pressing the # key.    
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 Open Now—Door opens at specified time.  A Tag is not required to open the Door. 


 Personal Access Code—requires entry of a Personal Access Code to gain access.  Your 


Personal Access Code may range from between 1 to 999999999.  After entering your 


Personal Access Code at the Reader or Terminal, complete the entry by pressing the # key. 


 


 Finger (B-SHO)—make a selection from the choices presented:  No, ―+Entry‖, ―+Exit‖, 


―+Both‖, ―or Entry‖, ―or Exit‖, ―or Both‖, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger 


only Both‖.  Selecting ―+Entry‖, ―+Exit‖ or ―+Both‖, calls for Tagholders to present their 


Tag (MIFARE® or DESFIRE®) and their fingerprint at the ImproX B-SHO Fingerprint 


Terminal.  Selecting ―or Entry‖, ―or Exit‖ or ―or Both‖, calls for Tagholders to present 


either their Tag or fingerprint at the ImproX B-SHO Fingerprint Terminal.  For the 


following options, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger only Both‖, only 


fingerprint presentation is allowed (the tag reader is disabled). 


 +PIN—make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


PIN-code at the respective Keypad Reader. 


 +Reason—make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


Reason at the respective Keypad Reader. 


 +Dual Tag—requires presentation of 2 individual Tags for access. 


 Record—log Transaction.  If you select NO, the ―Allowed In‖ and ―Allowed Out‖ 


transactions do not appear in the Transaction Viewer and do not save to the Database.  


This affects any report using transactions. 


 Denied Alarm—by selecting Yes, you instruct the System to treat denied events as 


alarms. 


 LED—sets the LED’s behaviour during the stipulated time slot. 


7. Click the  button. 


 


Advanced Configuration 


On selecting the Advanced Configuration radio button, the Lift (Elevator) Patterns and Zone 


settings activate.  Configure the following settings:   


 







Part 5 – Advanced Configuration 


22  February 2012 


 
Figure 9 – Right-hand Side of the Door Configuration Pane 


 


1. On the Configuration Pane, select the Lift (Elevator) Tab. 


2. In the Lift (Elevator) Pattern group (see Figure 5), make your selections from the Day’s Lift 


(Elevator) Mode Pattern drop-down lists.  


3. In the Zone group, select a Zone from the drop-down list. 


 


 


Using a Lift (Elevator) Activation Code allows Tagholders to enter or exit a Lift (Elevator) using a 


numeric code.  Note, however, Tags with access permissions for the Lift (Elevator) are still 


acknowledged by the Reader.  Activate the Lift (Elevator) Activation Code feature, as follows:  


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the newly 


created Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time, End Time, +PIN, +Reason, +Dual Tag, Record, Denied Alarm and LED. 


 Mode—select Door Entry Code from the drop-down list.  (Door Entry Codes range from  


1 to 65535.  After entering the Door Entry Code at the Reader or Terminal, complete the 


entry by pressing the # key). 


7. Click the  button. 


8. On the Configuration Pane, select the Lift (Elevator) Tab. 


9. In the Lift (Elevator) Activation Code textbox, enter a 5 digit numeric code. 
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CCTV integration allows for better end user site management, that is in areas with rising crime, your 


operator can from a safe location monitor and control up to 4 Doors (Locations) (4 Cameras) per Site.  


Configure your IP Camera (Axis 210 or 213D range only) as follows: 


 


1. On the Door Configuration Pane, select the Lift (Elevator) Tab. 


2. Click the Advanced Configuration radio button. 


3. Within the IP Camera group, click the Configure button. 


4. In the IP Camera Configuration dialog, click the  button. 


5. In the Name textbox, assign your camera a meaningful name. 


6. In the Lookup textbox, enter the IP Address for your camera. 


7. Click the  button. 


8. Exit the dialog by clicking the  button. 


9. Select the Lift (Elevator) from the list of available Lift (Elevator) records. 


10. From the IP Camera drop-down list, select a Camera record, thus associating the Lift 


(Elevator) and IP Camera. 


11. Click the  button. 


 


4. Click the  button. 


 


AAcccceessss  GGrroouupp  CCoonnffiigguurraattiioonn  


 


 


Ensure that all Lifts (Elevators) in a Lift (Elevator) Access Group go to the same floors.  Note, you need 


not use all Lifts (Elevators).  Selecting floors from a single Lift (Elevator), the selection works as normal. 


 


 


When using distributed templates along with biometrics, after editing the Lift (Elevator) Access Group, 


ensure you perform a full upload.  Refer to Part 3 – General Configuration for more information on 


performing a full upload.     


 


Configuration of Access Groups may only be carried out by operators with the correct operator 
permissions.  Setup is carried out through the Base Application, therefore go to Page 14 for details of 
the setup required.  
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Building Management 


Purpose of this Feature 


The Building Management feature lets you manage various hardware devices in and around 


the office, such as irrigation, lighting or airconditioning with the use of event driven or time 


triggered actions.  The IXP220 System supports up to 18 input or output devices (that is up to 


16 ImproX O16 Terminals and 2 ImproX I16 Terminals) per Site, configured as required.   


 


 As the name suggests, set up a time triggered action by selecting a time and day and 


assigning a relay drive time to the Action. 


 Event driven actions use the Inputs from the ImproX I16 to trigger a relay to drive and stop.  


 


Example 


The following example procedure shows the use of this feature.  


 


Procedure 


 


 


Ensure that you unlock your Registration Interface for Input/Output Control before using this feature.  


This unlock allows for a maximum of 1 seat.  See page 5 of this section for more information. 


 


CCoonnttrroolllleerr  CCoonnffiigguurraattiioonn  


1. In the IXP220 Base Application, select the  Page Tab. 


2. From the Mode Configuration drop-down list, select Action. 


3. Click the  button. 


 


TTeerrmmiinnaall  CCoonnffiigguurraattiioonn  


From the Menu Bar select Configuration>Building Management>Input/Output Devices. 


 


ImproX I16 Terminal – Input Setup 


1. From the left-hand side table, select your ImproX I16 Input Terminal. 


2. In the Name textbox, assign your Terminal a meaningful name. 


3. Disable or Enable End-of-Line Sensing by selecting the appropriate radio button. 


4. In the right-hand side Terminal Setting table, assign each Input in use an Input Name.   


5. Check the corresponding Alarm checkbox if required. 


6. Click the  button. 


 


ImproX O16 Terminal – Output Setup 


1. From the left-hand side table, select your ImproX O16 Output Terminal. 


2. In the Name textbox, assign your Terminal a meaningful name. 


3. In the right-hand side Terminal Setting table, assign each Relay in use an Output Name.  
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4. Click the  button. 


 


AAccttiioonn  CCoonnffiigguurraattiioonn  


1. Select the  Page Tab.  


2. Click the  button. 


3. Give your Action a Name. 


4. From the Trigger Type drop-down, make your selection: 


 


Input Triggered Action Setup 


1. From the Trigger Type drop-down, select Input. 


 


 
Figure 10 – Action Configuration Pane 


 


2. From the Action Type drop-down list, make your selection: 


 Relay—configure the Relay Action Configuration group by making your selections 


from the available fields. 


 LED and Buzzer—configure the LED and Buzzer Action Configuration group by 


making your selections from the available fields. 


 SMS Message—configure the SMS Action Configuration group by completing the 


available fields. See page 29 for building management message configuration details. 


 SMS Service Message—configure the SMS Network Service group by completing 


the available fields. 







Part 5 – Advanced Configuration 


February 2012  27 


3. From the Controller (Trigger) drop-down list, select the Controller that will trigger the 


Action. 


4. From the Select Input drop-down list, select one of the Input names. 


5. From the Select State drop-down list, select from the following choices: 


 Closed—input state closed. 


 Open—input state open. 


 Toggled—input state alternates between open and closed. 


6. From within the Input Trigger Configuration group, click the  button. 


7. From the Active Days group, make your selection from the Sun to Hol checkboxes. 


8. Select the Start Time. 


9. Select the Duration (65535 or 1 000 000 holds the Relay indefinitely). 


10. From the Controller (Action) drop-down list, make your selection. 


11. Depending on your selection in point 2, complete the activated fields as required. 


12. Click the  button. 


 


Time Triggered Action Setup 


1. From the Trigger Type drop-down, select Time. 


 


 
Figure 11 – Action Configuration Pane 


 


2. From the Action Type drop-down list, make your selection: 


 Relay—configure the Relay Action Configuration group by making your selections 


from the available fields. 
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 LED and Buzzer—configure the LED and Buzzer Action Configuration group by 


making your selections from the available fields. 


 SMS Message—configure the SMS Action Configuration group by completing the 


available fields.  See page 29 for building management message configuration details. 


 SMS Service Message—configure the SMS Network Service group by completing 


the available fields. 


3. From the Controller (Trigger) drop-down list, select the Controller that will trigger the 


Action. 


4. From the Active Days group, make your selection from the Sun to Hol checkboxes. 


5. Select the Trigger Time. 


6. From the Controller (Action) drop-down list, make your selection. 


7. Depending on your selection in point 2, complete the activated fields as required. 


8. Click the  button. 


 


Event Triggered Action Setup 


1. From the Trigger Type drop-down, select Event. 


 


 
Figure 12 – Action Configuration Pane 


 


2. From the Action Type drop-down list, make your selection: 


 Relay—configure the Relay Action Configuration group by making your selections 


from the available fields. 


 LED and Buzzer—configure the LED and Buzzer Action Configuration group by 


making your selections from the available fields. 
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 SMS Message—configure the SMS Action Configuration group by completing the 


available fields.  See page 29 for building management message configuration details. 


 SMS Service Message—configure the SMS Network Service group by completing 


the available fields. 


3. From the Controller (Trigger) drop-down list, select the Controller that will trigger the 


Action. 


4. From the Select Event Source drop-down list, make a selection. 


5. From the Select Event drop-down list, make a selection from the list of Events supplied. 


6. From the Active Days group, make your selection from the Sun to Hol checkboxes. 


7. Select the Start Time. 


8. Select the Duration (65535 holds the Relay indefinitely). 


9. From the Controller (Action) drop-down list, make your selection. 


10. Depending on your selection in point 2, complete the activated fields as required. 


11. Click the  button. 


 


BBuuiillddiinngg  MMaannaaggeemmeenntt  MMeessssaaggee  CCoonnffiigguurraattiioonn  


 


 


For Building Management Messages to work successfully, you need to have an IXP220 Controller and 


a GSM module. 


 


Configure Building Management Messages as follows: 


 


Adding Building Management Messages 


1. From the Menu Bar select Configuration>Building Management>Building Management 


Messages. 


2. Click the  button. 


3. In the Message textbox, enter your message (not exceeding 70 characters including 


spaces). 


4. Click the  button. 


5. Click the  button. 


 


Deleting Building Management Messages 


1. From the Menu Bar select Configuration>Building Management>Building Management 


Messages. 


2. Select the Message record for deletion. 


3. Click the  button. 


4. Click the  button. 
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Secure Socket Layer (SSL) Connection 


Purpose of this Feature 


Using the IXP220 Software V1.82 onwards, you may connect to the various Web Modules using 


a secure (1 024 Bit encrypted) connection.     


 


Example 


The following example procedures show the use of this feature.  


 


Procedure 


CCoonnffiigguurraattiioonn  ffoorr  WWiinnddoowwss®®  IInntteerrnneett  EExxpplloorreerr  88  


 


 


Carry out the following procedure at the Host PC with the IXP220 Base Application running.    


 


1. In the Address textbox enter the https://localhost/220Web/homepage.html URL.  The ―s‖ 


ensures communication to the server takes place on a secure, encrypted connection. 


2. Select the Continue to this Website (Not Recommended) option.      


 


 


We supply a generic Security Certificate with the distributed IXP220 Software.  Purchase Security 


Certificates from signing authorities such as VeriSign, Thawte or any other major signing authority.     


 


 
Figure 13 – Windows® Internet Explorer 8 with Secure Socket Layer (SSL) Used 
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CCoonnffiigguurraattiioonn  ffoorr  MMoozziillllaa  FFiirreeffooxx  33..55  


 


 


Carry out the following procedure at the Host PC with the IXP220 Base Application running.    


 


1. In the Address textbox enter the https://localhost/220Web/homepage.html URL.  The ―s‖ 


ensures communication to the server takes place on a secure, encrypted connection. 


2. Select the I Understand the Risks option.      


 


 


We supply a generic Security Certificate with the distributed IXP220 Software.  Purchase Security 


Certificates from signing authorities such as VeriSign, Thawte or any other major signing authority.     


 


3. Click the Add Exception button.   


4. Click the Confirm Security Exception button.    


 


 
Figure 14 – Mozilla Firefox 3.5 with Secure Socket Layer (SSL) Used 
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Live Video Image Capture 


Purpose of this Feature 


The Live Video Image Capture feature allows you to use a web camera to capture and save 


Tagholder images.  By connecting a web camera to a PC running either the Base Application or 


the Web Enrollment Module, users can capture an image from live video and save it directly to 


the Tagholder data.  You can use this feature when loading new Tagholders or when editing 


existing Tagholders.    


 


Procedure 


 


This feature supports the following cameras: 


 


 Logitech®  Webcam Pro 9000 


 Logitech® 1.3 MP Webcam C500 


 Logitech® Webcam C120 


 


Ensure that you load your chosen camera’s drivers before using the Live Video Image Capture feature. 


 


 


To use this feature in the Web Enrollment Module, install Java Runtime Environment V1.60 Update 20 


or above. 


 


 


Windows® Vista users must disable the User Account Control before using the Live Image Capture 


feature in the Web Enrollment Module.  Disable the control as follows: 


 


1. Select Start>Control Panel. 


2. Select the User Accounts icon. 


3. Select the Turn User Account Control On or Off option. 


4. Deselect the Use User Account Control (UAC) to Help Protect Your Computer option. 


5. Click the OK button. 


6. Click the   button. 


 


To capture an image from video: 


 


1. Open either the Add Tagholder or Edit Tagholder in the Base Application or Web 


Enrollment Module. 


2. Click the  button.   
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Figure 15 – Select Capture Device Dialog 


 


3. From the next Select Capture Device dialog, from the Available Devices drop-down list, 


select the required camera device. 


4. Click the  button. 


5. From the Select Format drop-down list, select the snapshot format and resolution.  The 


recommended resolution is 640 x 480 pixels.   


 


 
Figure 16 – Select Format Dialog 


 


6. Click the  button. 


 


 
Figure 17 – Capture Dialog 
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If you click the  button, the Select Format dialog appears.  This allows you to edit the snapshot 


format and resolution.  


 


7. In the Capture dialog, click the  button to capture the image. 


 


 
Figure 18 – Capture Dialog 


 


 


If you click the  button after capturing the image, the Edit dialog appears.  This dialog allows you to 


rotate, resize, mirror or crop your image.  Once you crop an image this measurement becomes the 


default setting.   


 


To reset the automatic image cropping default, in the Add or Edit Tagholder dialog, right-click over the 


Image Frame.  From the shortcut menu select the Reset option. 


 


You may also disable the automatic image cropping feature as follows: 


 


1. From the C:\:IXP220: 


 Open the IXP220.properties file when using the Base Application.  


 Open the Quicktag>Quicktag.properties file when using the Web Enrollment Module. 


2. Set the access.image.autocrop=true to access.image.autocrop=false. 


3. From the Main Menu, select File>Save. 


4. From the Main Menu, select File>Exit. 


 


After editing the image in the Edit dialog, click the OK button to save changes and return to the 


Tagholder dialog.   


 


8. Click the  button. 


9. Click the  button to save the Tagholder’s information. 


 


USER NOTES 
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USER NOTES 
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Chapter 1:  Web Enrollment Module 


Introduction 


GGeenneerraall  


The Web Enrollment Module is intended for use by an operator using a PC at a location remote 


from the System’s Base Application (Host PC).  This Module requires no extra IXP220 Software 


installation, simply installing Java Runtime Environment V1.60 Update 20 or above allows any 


member of your staff access to the Module.  The Module’s basic function is enrolling Tags so 


general Tagholders and visitor Tagholders may access selected areas at named times.  As 


this is an enrollment Module, each PC running the Web Enrollment Module must connect to a 


Registration Reader.  In software preceding the Web Enrollment Module, clients uploaded a 


large portion of the Database to the client PC.  The Web Enrollment Module creates minimal 


network traffic, thereby offering improved network speed. 


 


You may use the Web Enrollment Module with Windows® Internet Explorer 8 (and above) or 


alternatively Firefox 3 (and above).   


 


 


Windows® Vista users must disable the User Account Control before running the Web Enrollment 


Module.  Disable the control as follows: 


 


1. Select Start>Control Panel. 


2. Select the User Accounts icon. 


3. Select the Turn User Account Control On or Off option. 


4. Deselect the Use User Account Control (UAC) to Help Protect Your Computer option. 


5. Click the OK button. 


6. Click the  button. 


 


 


Using IXP220 V1.82 (onwards) lets you connect to Web Modules through a Secure Socket Layer 


(SSL) connection.  See Part 5 – Advanced Configuration for information on this feature. 


 


IInnssttaalllliinngg  JJaavvaa  RRuunnttiimmee  EEnnvviirroonnmmeenntt  ((JJRREE))  


1. Using Windows® Internet Explorer go to www.java.com. 


2. On the Home Page, click on the Free Java Download button. 


3. At the Internet Explorer – Security Warning dialog, click the Install button. 


4. At the Java Setup – Welcome dialog, click the Accept > button. 


5. At the Java Setup – Complete dialog, click the Finish button. 


6. Close Internet Explorer. 


7. Restart your PC. 


 



http://www.java.com/
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Starting up the Web Enrollment Module 


SSttaarrttiinngg  tthhee  IIXXPP222200  BBaassee  AApppplliiccaattiioonn  oonn  tthhee  HHOOSSTT  PPCC  


 


 


On upgrade of your IXP220 Software, ensure that you clear the cache on the client PC. 


 


 


Ensure that you unlock your Registration Interface for Web Tagholder Enrollment or Web Visitor 


Enrollment (or both) before using the Web Enrollment Module.  Both the Web Tagholder Enrollment 


and the Web Visitor Enrollment allow for a maximum of 50 seats each.  See Part 5 – Advanced 


Configuration for further information.   


 


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. Click the  button. 


 


SSttaarrttiinngg  tthhee  WWeebb  EEnnrroollllmmeenntt  MMoodduullee  oonn  aa  CCLLIIEENNTT  PPCC  ((SSeeppaarraattee  PPCC  WWoorrkkssttaattiioonn))  


 


 


Ensure that you do NOT open more than 1 instance of the Web Enrollment Module per PC workstation. 


 


 


If the Web Server resides on a Port other than Port 80, the URL becomes: 


http://localhost:XX/220Web/homepage.html.  The XX highlighted in the URL refers to the new Port 


number, for example 82, 83 or 84 and so on. 


 


1. Startup the Web Enrollment Module from your Internet Browser using the following URL:  


http://localhost/220Web/homepage.html.  Replace the term Localhost with the IP 


Address (or server name) for the System’s Host PC. 


2. At the IXP220 Home Page, select the  (Web Enrollment) Icon. 


 


 


The same Tagholder configuration settings apply whether you select Tagholder or Visitor Enrollment.  


If you select Visitor Enrollment at the Enrollment Selection dialog, you can only edit and add visitor 


Tagholders to the System.  In Visitor Enrollment view, you will however see details of Tagholders 


where Tags have not yet been assigned. 


 


3. At the Enroll Selection dialog, make your selection. 


4. At the Login dialog, enter your Username (SYSDBA) and Password (masterkey). 


5. Click the Submit button. 


  



http://localhost:XX/220Web/homepage.html
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UUsseerr  IInntteerrffaaccee  


 
Figure 1 – Web Enrollment Module User Interface 


 


The standard Add and Delete buttons are available at the bottom of the screen.  Move 


between Tagholder records by using the back and forward buttons displayed at the base of the 


Tagholder Table (see Figure 1 for details).   


 


 


You may set the sort order of the records by clicking your mouse over any column header.  The Arrow 


indicates the direction (ascending or descending) of the sort order applied.  Alternatively right-click your 


mouse over any column header and select either the Sort Ascending or Sort Descending option.  


 


You may show or hide columns, by right-clicking your mouse over any column header and select the 


Column option.  Select or deselect the checkboxes to show or hide the columns as you require. 


 


Tagholder Configuration 


AAdddd  aa  TTaagghhoollddeerr  


1. Click the  button. 


2. Select a Configuration Level: 


 Standard Configuration  


 Advanced Configuration 


 


 


For the sake of this example we selected the Advanced Configuration radio button.   
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3. When asked Would you like to Keep Advanced Settings for this Session? click Yes. 


 


 
Figure 2 – Tagholder: Dialog Showing General Tab Selected 


 


4. In the Tagholder:  dialog, on the General tab, enter the following information: 


 


 


The minimum information needed for the System to accept the data is the First Name and Last Name 


fields. 


 


5. Enter the Tagholder’s First Name and Last Name. 


6. If required, in the PIN Used with Tag textbox, enter a PIN-code of up to 5 digits.  (PIN-


codes range from 2 to 65534). 


7. Enter the Company Name. 


8. In the ID No. textbox, enter the Tagholders ID Number. 


9. In the Department field select the required Department from the drop-down list.   


 


 


Add extra Departments as follows: 


 


1. Click the Department button.   


2. Click the  button. 


3. In the Departments textbox, enter a suitable name for the Department. 


4. Click the  button. 


5. Click the  button. 


 


Click the  button to edit a Department or the  button to delete a Department. 
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The Send E-Mail button lets you send Tagholder details to interested parties.  The To textbox is 


mandatory, thus requiring data entry for successful e-mail transmission.  For e-mail setup information 


please refer to the section Preference Configuration (System Notification Tab) in Part 3 – General 


Configuration. 


 


10. From the Type drop-down list make your selection.  The value selected, once captured in 


the master table, lets the third-party Time and Attendance Software determine who to 


calculate and who not to calculate.  For Sites using third-party Time and Attendance 


Software we therefore recommend that you select the Access and Time option, for all 


other installations select the Access Only option.    


11. Complete other personal information as necessary. 


 


 


Add a Tagholder Image as follows: 


 


1. Click the  button.   


2. At the Open dialog, select the image file.  Image formats supported include:  jpg, jpeg, gif, tif 


and tiff.  The recommended resolution is 640 x 480 pixels. 


3. Click the Open button. 


 


For more information on the Live Video Image Capture feature ( ) please see Part 5 – Advanced 


Configuration. 


 


Clicking the button opens the Edit dialog, allowing image cropping, rotation, resizing and use of an 


image mirror effect. 


 


 


To change the Tagholder Image back to the default image: 


 


1. Right-click on the Tagholder Image. 


2. Select Default Image. 


 


12. Use the Note text area when entering further information about the Tagholder. 


13. Click the  button. 


 


AAssssiiggnn  TTaaggss  ttoo  TTaagghhoollddeerrss  


1. Select the Tag tab. 


2. Click the  button. 
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Figure 3 – Tagholder: Dialog Showing Tag Tab Selected 


 


3. Select a Configuration Level: 


 Standard Configuration  


 Advanced Configuration 


 


 


For the sake of this example we selected the Advanced Configuration radio button.   


 


4. Present your Tag to the Enrollment Reader. 


5. Click the Read Tag button. 


 


 


When the IXP220 Software detects the Tag, the Tag number displays in the Number textbox. 


 


 


When the Software is set to ignore the Tag type, the Tag type updates automatically.  When the Tag 


type is taken into consideration, select the Tag type from the Type drop-down list.  Your Tag Type 


options include: 


 


 Standard (125 kHz)—previously described as Slim Tag 5 Bytes. 


 Read/Write (125 kHz, 2048 bits)—previously described as WriTag 2048. 


 Read/Write (125 kHz, 128 bits)—previously described as WriTag 128. 


 3rd Party (Other)—previously described as ASCII/Barcode/Magstripe. 
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 Personal Access Code—create a Personal Access Code (PAC) by selecting the Personal 


Access Code choice from the Type drop-down list and entering the Personal Access Code 


(PAC) in the Number textbox. Ensure that you use the numeric keys that form part of the 


typewriter part of your PC's keyboard when entering the Personal Access Code (PAC).  Your 


Personal Access Code may range from between 1 to 999999999.  After entering the Personal 


Access Code at the Reader or Terminal, complete the entry by pressing the # key. 


 RF/Infrared—previously described as RF/Infrared Tag. 


 Mifare—previously described as Mifare Tag. 


 HID (125 kHz)—previously described as HID Tag. 


 13.56 MHz (General)—previously described as General 13.56 MHz. 


 Felica—previously described as Felica Tag. 


 


6. From the Site drop-down list, select the Site name. 


7. From the Level drop-down list make your selection from the following choices: 


 Visitor—restricted access, valid for day of issue only. 


 Normal—employee Tagholder.  Access restricted by Door Mode. 


 Supervisor—opens Doors in Supervisor Mode, overrides Anti-passback (APB) and 


may cancel alarms. 


 Administrator—opens Doors in Supervisor Mode and ignores No Entry Mode. 


8. From the Access Group drop-down list, make a selection. 


 


 


You must assign a Tagholder Access Group for the Tag to have any access rights. 


 


Tag Expiry Configuration 


For temporary Tagholders, proceed as follows: 


 


1. From the Start Date drop-down list, select a suitable start date. 


2. In the Start Time textboxes, enter a suitable start time. 


3. From the Expiry Date drop-down list, select a suitable expiry date. 


4. In the Expiry Time textboxes, enter a suitable expiry time. 


 


Message Configuration 


 


 


For information on adding Messages, refer to the Messages section in Part 3 – General Configuration. 


 


From the Message drop-down list, select a Message for display. 


 


Miscellaneous Configuration 


 Reset APB—resets the Anti-passback (APB) status for the Tagholder. 


 Suspend—suspends the Tag in the event the Tag is lost or no longer required. 


 Usage—stores a description of the usage of the Tag. 


 


1. Click the  button. 


2. Click the  button. 


 


If necessary, repeat the Assign Tags to Tagholders procedure for any extra Tags. 
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DDeelleettee  aann  AAssssiiggnneedd  TTaagg  


1. From the list of Tagholder records displayed, double-click the Tagholder record for editing. 


2. In the Tagholder dialog, select the Tag Tab. 


3. Click the assigned Tag button (that is Tag 1, Tag 2, Tag 3 or Tag 4) for deletion. 


4. Click the  button. 


5. Click the  button. 


6. Click the  button. 


 


DDeelleettee  aa  TTaagghhoollddeerr  


 


 


Before deleting a Tagholder, first delete all Tags assigned to the Tagholder. 


 


1. From the list of Tagholder records displayed, select the Tagholder record for deletion. 


2. Click the  button. 


3. At the Warning dialog, click the OK button. 


 


SSeeaarrcchhiinngg  ffoorr  TTaagghhoollddeerrss  


1. From the Search By drop-down list, select a search field, for example: 


 First Name—searches the First Name column for a matching record. 


 Last Name—searches the Last Name column for a matching record. 


 Address—searches the Address column for a matching record. 


 Company—searches the Company column for matching records. 


 Department—searches the Department column for matching records. 


 Employee No—searches the Employee No column for a matching record. 


 ID No—searches the ID No column for a matching record. 


 Tag—searches the Tag column for the matching Tag code. 


2. Enter a suitable keyword in the Value textbox. 


 


Only the row(s) matching the Search By criteria display on the Tagholder page. 
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Chapter 2:  IXP220 Rich Client Module 


Introduction 


The IXP220 Rich Client Module lets you configure Doors (Locations) and Tagholders from a 


separate PC (not running the IXP220 Base Application).  In theory, you would use this Module 


where you need feature flexibility not offered by the Web Enrollment Module.  These instances 


could include but are not limited to: 


 


 During Biometric enrollment. 


 Where you need to change Door (Location) configuration patterns (on a PC away from the 


Base Application) without stopping the IXP220 Base Application. 


 


Starting the IXP220 Rich Client Module 


 


 


Ensure that you unlock your Registration Interface for Web Tagholder Enrollment or Web Visitor 


Enrollment (or both) before using the Rich Client Enrollment Module.  Both the Web Tagholder 


Enrollment the Web Visitor Enrollment Modules allow for a maximum of 50 seats each.  See Part 5 – 


Advanced Configuration for further information. 


 


1. In Windows®, click Start>All Programs>IXP220>IXP220 Client. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. Click the  button. 


 


 
Figure 4 – IXP220 Rich Client Module 
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Door Configuration 


The Door Configuration Pane lets you configure the Site’s Doors (Locations) including 


Terminals, Readers, Zones and Door Mode Patterns.   


 


 


Editing Door settings or making changes to the Door Mode Patterns resets all Tags in the System to 


anti-passback neutral.  This ensures that Tagholders are not denied access because of Tags being in 


the wrong state.  The anti-passback state of all Tags again synchronizes correctly on first access. 


 


 


Refer to Part 5 – Advanced Configuration for details on Lift (Elevator) Control through the IXP220 Rich 


Client. 


 


AAdddd  aa  DDoooorr  


To create a Door (Location) continue as follows: 


 


1. Select the  Page Tab.  Within the previously selected Door Tab, you will notice a new set 


of Tabs activate.  These newly activated Tabs include a new Door Tab, an Entry Tab and an 


Exit Tab. 


2. Click the  button. 


 


 
Figure 5 – Left-hand Side of the Door Configuration Pane 
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3. In the Door Name textbox, assign the Door a suitable name.  This Door Name textbox has 


a 16 character limit. 


4. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic Access Control features. 


 Advanced Configuration—activates extra advanced features, for sites that need Daily 


Door Mode Patterns, Zones, Door Entry Codes and Alarm Arming. 


 


 


The Enable Bell checkbox only activates on Doors using ImproX (KMA) Keypad Mullion Antenna 


Readers.  Selecting this checkbox activates the Bell button (situated at the bottom of the Antenna 


Reader’s Keypad).  


 


Add Readers 


To add and configure Readers, continue as follows: 


 


1. In the Reader Configuration group (see Figure 5), alongside the Entry Reader textbox, 


click the Select button. 


2. In the Unassigned Readers dialog, from the list of displayed records, select a Reader. 


 


 


In the Unassigned Readers dialog, reduce the number of Readers displayed by selecting a specific 


Controller from the Controller Filter drop-down list. 


 


3. Click the  button. 


4. Alongside the Exit Reader textbox, click the Select button.  


5. In the Unassigned Readers dialog, from the list of displayed records, select a Reader. 


6. Click the  button. 


 


 


Select a single Reader by double-clicking the Reader's record.  Alternatively multi-select Readers as 


follows: 


 


1. Click the Entry Reader’s Select button. 


2. In the Unassigned Readers Dialog, select both your Entry and Exit Readers.  


3. Click the  button. 


 


The IXP220 Software automatically assigns the top selected Reader as the Entry Reader and the 


bottom selected Reader as the Exit Reader.    


 


7. Click the  button. 


 


Entry or Exit Reader Configuration 


1. Select the Entry or Exit Tab. 


 


 


The settings displayed on the Entry or Exit Tabs depend on the type of Terminal connected.  Ignore 


references made to fields that do not display. 


 


2. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic features. 


 Advanced Configuration—activates extra advanced features. 


3. From the Miscellaneous group, from the RTE Mode drop-down list, make your selection 


from the following: 
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 Normally Open—use this option when connecting Normally Open switches. 


 Normally Closed—use this option when connecting Normally Closed switches.  


4. From the Reader Function drop-down list, make your selection from the following: 


 Access Control—sets a flag in the Database alerting third-party time and attendance 


applications that the door is used for Access Control purposes only. 


 Access Control + Time & Attendance—sets a flag in the database alerting third-party 


time and attendance applications that the Door is used for Time and Attendance and 


Access Control functions. 


5. From the Message Display Supervisor drop-down list, make your selection. 


6. From the Enable Off-line Validation drop-down list, make your selection from the following: 


 Disabled—disables off-line validation. 


 Enabled—enables off-line validation. 


 


 


ImproX iTT and ImproX iTRT units connected by IP will always run in Full Off-line Validation Mode. 


ImproX iTT and ImproX iTRT units connected by RS485 will run in Full Off-line Validation Mode when 


there are 1 000 Tags or less in the System. Once this threshold is exceeded, it will switch over to 


Cached Off-line Validation Mode. Cached Off-line Validation Mode relies on transactions in the ImproX 


iTT and ImproX iTRT Transaction Buffer to make access control decisions. 


 


7. From the DOS Mode group, from the DOS Mode drop-down list, make your selection from 


the following: 


 Normally Closed—use this option when connecting Normally Closed Door Sensors. 


 Normally Open—use this option when connecting Normally Open Door Sensors. 


8. From the DOS Usage drop-down list, make your selection from the following: 


 Normal—alarm sounds if the Door remains open too long or if the Door is forced.  Use 


this feature for monitoring real Door open states. 


 Terminate Strike—deactivates the relay if Door is opened and closed or forced.  Use 


this feature where the lock must re-engage once the Door is closed. 


 Inhibit—deactivates the Reader as long as the Door is open; also there is no alarm for 


Doors forced open.  Used when the Door is opened, the Reader disables while the Door 


remains open. 


9. Edit the Strike Duration (0.1s) textbox, the default value is 40 (0.1s).  Setting the Strike 


Duration to 55555 toggles the Relay. 


10. Edit the Open Duration(s) textbox.  By default the Open Duration is set to 0, disabling the 


Door Open Sensor (DOS). 


 


 


It is possible to drive a single Relay or use a single Door Open Sensor (DOS) for both entry and exit 


Readers, removing the need to wire up both Relays or both Door Open Sensors (DOS) for a single 


door.  To do this, set the Strike Duration or Open Duration to 0 on one Reader.  The associated Reader 


is then able to use the Relay or Door Open Sensor (DOS) from the opposite Door.  When using an 


ImproX MDTA, the Open Duration and Strike Duration default to 0.  Therefore, setting the Strike 


Duration and Open Duration on the associated Reader allows the MDTA to use the opposite Reader’s 


Relay or DOS. 


 


A practical example would be: 


A Terminal, used for a reception entry and exit, only requires one Relay to open.  The entry Reader 


(Reader 1) has the Strike Duration set accordingly.  Instead of bridging the Relay for the exit Reader 


(Reader 2), set the Strike Duration to 0.  This allows both the entry and exit Readers to drive Relay 1 


when someone presents an allowed Tag to either of the Readers. The same theory applies to the Door 


Open Sensor (DOS). 
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11. Enable End-of-line Sensing by selecting the Enable End-of-line Sensing checkbox. 


 


 


End-of-line Sensing lets the System raise an alarm when somebody bypasses the Door Open Sensor.  


That is, the System distinguishes between tampering on the circuit and closure of the Door Open 


Sensor.  End-of-line sensing on the IXP220 Controller, ImproX iTT (input 1 and 3 only) and iTRT (input 


1 and 3 only) is only possible if Door Open Sensing is configured.  Set End-of-line Sensing per Door. 


 


12. From the ON VALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


13. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


14. From the ON INVALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


15. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


16. Click the  button. 


  


AAdddd  aa  ZZoonnee  


To create and configure Zones, continue as follows: 


 


1. On the Configuration Pane, select the Zone Tab. 


2. Click the  button. 


 


 
Figure 6 – Create Zone Dialog 


 


3. In the Zone Name textbox, assign the Zone a suitable name. 


4. Select one of the Anti-passback (APB) Mode radio buttons: 


 Off—Anti-passback not enforced.   


 Relaxed—after entering a Zone, the Tagholder must exit the Zone using their Tag 


before they can re-enter.  However, Tagholders can use their Tags for multiple, 


consecutive exits in this Mode. 


 Strict—enforced Anti-passback Zone rules for in and out directions.  A Tagholder 
cannot enter or exit a Zone consecutively. 


 


 


You may elect from time to time to reset Anti-passback, essentially giving ALL Tagholders a ―free 


pass‖ on their next transaction.  Carry out this task as follows: 
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1. From the Main Menu, select Hardware>Reset Anti-passback. 


2. At the Reset Anti-passback dialog, click the OK button. 


 


Should you wish to reset Anti-passback on an individual Tagholder, refer to page 30, Miscellaneous 


Configuration for more information. 


 


5. Click the  button. 


 


 


Once the Zone record appears on the Zone tab, edit the Zone Name and APB Mode settings using the 


Configuration Pane.    


 


 


Configure multiple Zone records at the same time, by holding down the Ctrl key and selecting multiple 


records.  Alternately hold down the left mouse button and drag your mouse over the records, making 


your selection. 


 


AAdddd  DDoooorr  MMooddee  PPaatttteerrnnss  


 


 


Making changes to the Door Mode Patterns resets all Tags in the System to anti-passback neutral.  


This ensures that Tagholders are not denied access because of Tags being in the wrong state.  The 


anti-passback state of all Tags again synchronizes correctly on first access. 


 


The IXP220 Software supports a maximum of 8 Door Mode Patterns at each Door.  This setting 


regulates the Door’s (location’s) operating mode including the start and end time.  Continue as 


follows to add a new Door Mode Pattern: 


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the 


newly created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time and End Time—breaks the day into time slots.  By selecting and changing 


the End Time figure, you effectively create extra records, breaking the day into parts.  


You may create a maximum of 8 time slots per Door Mode Pattern. 


 Mode—indicates the mode in which the Door (Location) operates.   


 


 


Door (Location) operating mode examples include:   


 


 Tag—requires presentation of a Tag to gain access. 


 Supervisor Unlock—requires that a Supervisor unlock the Door prior to normal employees 


gaining entrance. 


 Locked—the Door is locked and cannot be overridden with any Tag. 


 Open on First Tag—the door is opened when the first valid Tagholder presents their Tag. 


 No Entry—only Administrators are granted access. 


 Door Entry Code—requires entry of a Door Entry Code to gain access. 


 Open Now—Door opens at specified time.  A Tag is not required to open the Door. 


 Personal Access Code—requires entry of a Personal Access Code to gain access.  Your 


Personal Access Code may range from between 1 to 999999999 followed by a # symbol. 







  Part 6 – IXP220 Software Modules 


February 2012  19 


 Finger (B-SHO)—make a selection from the choices presented:  No, ―+Entry‖, ―+Exit‖, 


―+Both‖, ―or Entry‖, ―or Exit‖, ―or Both‖, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger 


only Both‖.  Selecting ―+Entry‖, ―+Exit‖ or ―+Both‖, calls for Tagholders to present their 


Tag (MIFARE® or DESFIRE®) and their fingerprint at the ImproX B-SHO Fingerprint 


Terminal.  Selecting ―or Entry‖, ―or Exit‖ or ―or Both‖, calls for Tagholders to present 


either their Tag or fingerprint at the ImproX B-SHO Fingerprint Terminal.  For the 


following options, ―Finger only Entry‖, ―Finger only Exit‖ or ―Finger only Both‖, only 


fingerprint presentation is allowed (the tag reader is disabled). 


  +PIN—make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


PIN-code at the respective Keypad Reader. 


 +Reason— make a selection from the choices presented:  No, Entry, Exit or Both.  By 


selecting Entry, Exit or Both, you call for Tagholders to present their Tag and enter a 


Reason Code (see Part 3 – General Configuration for information on Adding a Reason 


Code) at the respective Keypad Reader. 


 +Dual Tag—requires presentation of 2 individual Tags for access. 


 Record—log Transaction.  If you select NO, the ―Allowed In‖ and ―Allowed Out‖ 


transactions do not appear in the Transaction Viewer and do not save to the Database.  


This affects any report using transactions. 


 Denied Alarm—by selecting Yes, you instruct the System to treat denied events as 


alarms.  In the IXP220 Base Application, set the Controller Mode Configuration to 


Intrusion or Alarm Arming for functionality of this feature. 


 LED—sets the LED’s behaviour during the stipulated time slot. 


7. Click the  button. 


 


AAddvvaanncceedd  DDoooorr  CCoonnffiigguurraattiioonn  


On selecting the Advanced Configuration radio button, the Daily Door Mode Patterns, Zone, 


Door Entry Code and Alarm Arm settings activate.  Continue as follows to configure these: 
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Figure 7 – Right-hand Side of the Door Configuration Pane 


 


1. On the Configuration Pane, select the Door Tab. 


2. In the Daily Door Mode Patterns group (see Figure 7), make your selections from the 


Day’s Door Mode Pattern drop-down lists.  


3. In the Zone group, select a Zone from the drop-down list. 


 


 


Using a Door Entry Code allows Tagholders to enter or exit a Door using a 4 digit numeric code 


instead of a Tag.  Note, however, Tags with access permissions for the Door (Location) are still 


acknowledged by the Reader.      


 


Activate the Door Entry Code feature, as follows: 


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the newly 


created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time, End Time, +PIN, +Reason, +Dual Tag, Record, Denied Alarm and LED. 


 Mode—select Door Entry Code from the drop-down list.  (Door Entry Codes range from  


1 to 9999). 


7. Click the  button. 


8. On the Configuration Pane, select the Door Tab. 


9. In the Door Entry Code textbox, enter a 4 digit numerical PIN-code. 
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CCTV integration allows for better end user site management, that is in areas with rising crime, your 


receptionist can from a safe location monitor and control up to 4 Doors (Locations) (4 Cameras) at a 


time per Site.  Configure your IP Camera (Axis 210 or 213D range only) as follows: 


 


1. On the Door Configuration Pane, select the Door Tab. 


2. Click the Advanced Configuration radio button. 


3. Within the IP Camera group, click the Configure button. 


4. In the IP Camera Configuration dialog, click the  button. 


5. In the Name textbox, assign your camera a meaningful name. 


6. In the Lookup textbox, enter the IP Address for your camera. 


7. Click the  button. 


8. Exit the dialog by clicking the  button. 


9. Select the Door from the list of available Door records. 


10. From the IP Camera drop-down list, select a Camera record, thus associating the Door and IP 


Camera. 


11. Click the  button. 


 


 


Refer to Part 3 – General Configuration for details on Alarm Arming. 


 


 


Configuration of multiple Doors (Locations) is allowed.  Configure multiple Doors (Locations), by holding 


down the Ctrl key and selecting multiple records.  Alternately hold down the left mouse button and drag 


your mouse over the records.  Multi-selecting Doors (Locations) loads the default values for all Doors 


and Readers, only the changed settings save to the individual Doors. 


 


4. Click the  button. 


 


DDeelleettee  aa  DDoooorr  


 


 


Deleting a Door automatically deletes reference to assigned Readers.  Thus, these Readers return to 


the Unassigned Readers list ready for you to reallocate to a new Door.    


 


1. Select the  Page Tab. 


2. On the Configuration Pane, select the Door Tab. 


3. From the Doors Table on the left-hand side of the Configuration Pane, select the Door 


record for deletion. 


4. Click the  button. 


5. At the Warning dialog, click Yes. 


 


DDeelleettee  aa  ZZoonnee  


1. Select the  Page Tab. 


2. On the Configuration Pane, select the Zone Tab. 


3. From the Zone records displayed, select the Zone for deletion. 


4. Click the  button. 


5. Click the  button. 
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You may delete multiple Zones at the same time, by holding down the Ctrl key and selecting multiple 


records.  Alternately hold down the left mouse button and drag your mouse over the records, making 


your selection. 


 


DDeelleettee  aa  DDoooorr  MMooddee  PPaatttteerrnn  


1. Select the  Page Tab. 


2. On the Configuration Pane, select the Door Mode Pattern Tab. 


3. From the Door Mode Pattern Table on the left-hand side of the Configuration Pane, select 


the Door Mode Pattern record for deletion. 


4. Click the  button. 


5. At the Confirmation Warning dialog, click Yes. 


 


Access Group Configuration 


Each Tagholder in a Site is assigned to at least one Tagholder Access Group.  The purpose of 


Access Groups is to grant Tagholder access permissions in bulk.  This saves you the trouble of 


configuring Tagholders one-at-a-time. 


 


CCoonnffiigguurree  TTaagghhoollddeerr  AAcccceessss  GGrroouuppss  


Create a Tagholder Access Group 


 


 


For information on setting a Lift (Elevator) Access Group, see Part 5 – Advanced Configuration. 
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Figure 8 – Left-hand Side of the Access Group Pane (General Access Tab Selected) 


 


To create a Tagholder Access Group, proceed as follows: 


 


1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. As highlighted in Figure 8, click the  button. 


4. In the Access Group textbox, assign your Access Group a suitable name. 


5. From the Allow For radio buttons, select either of the following choices: 


 Administrator/Supervisor Tags 


 All Tags—Visitor and Employee Tagholders. 


6. Click the  button. 


 


 


Only the SYSDBA user can give a Tagholder access to a Tagholder Access Group categorized as 


Administrator or Supervisor. 


 


Create an Access Time Pattern 


 


 


You may add a maximum of 8 Access Time Patterns to each Access Group.    
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Figure 9 – Right-hand Side of the Access Group Pane (General Access Tab Selected) 


 


To create an Access Time Pattern, proceed as follows: 


 


1. As highlighted in Figure 9, click the  button. 


2. In the Access Pattern Configuration group, select the Door Tab. 


3. In the No Access Doors text area, select the Door you want the Access Pattern applied to. 


 


 


From the No Access Doors text area, select multiple Doors (Locations), by holding down the Ctrl key 


and selecting multiple records.   


 


4. Click the  button. 


5. In the Access Pattern Configuration group, select the Day & Time Tab. 


6. From the Select Day Pattern group, deselect checkboxes where NOT applying the Pattern. 


7. In the Start Time textbox, enter a suitable start time. 


8. In the End Time textbox, enter a suitable end time. 


 


 


The Duration automatically calculates based on the information you capture into the Start and End 


Time textboxes.    


  


9. Click the  button. 


 


Select an Access Group 


To select an existing Tagholder Access Group, proceed as follows: 
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1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. From the list of Access Group records (see the highlighted area in Figure 8 for more 


information) select a record. 


 


The selected Access Group’s details display on the right-hand side of the Access Groups 


Configuration Pane.  See Figure 9 for more information.   


 


Delete Access Group and Access Time Pattern Details 


To delete a Tagholder Access Group, proceed as follows: 


 


1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. From the list of Access Group records (see the highlighted area in Figure 8 for more 


information) select a record. 


4. Click the  button. 


5. Click Yes.  


 


Edit Access Group and Access Time Pattern Details 


To edit a Tagholder Access Group, proceed as follows: 


 


1. Select the  Page Tab. 


2. Select the General Access Tab. 


3. From the list of Access Group records (see the highlighted area in Figure 8 for more 


information) select a record. 


4. Edit the Access Time Pattern details as required. 


5. Click the  button. 


6. When using distributed templates along with biometrics, after editing the Lift (Elevator) 


Group, ensure you perform a full upload.   


 


Tagholder Configuration 


AAdddd  aa  TTaagghhoollddeerr  


To add a Tagholder, proceed as follows: 


 


1. Select the  Page Tab. 


2. Click the  button. 


 


The Tagholder dialog consists of two tabs namely General and Tag.  The General Tab allows 


addition of a Tagholder’s information, while the Tag Tab allows Tag assignment.  On the General 


Tab, only the First Name and Last Name fields are required.  However, we recommend 


entering as much information as possible. 
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Figure 10 – Tagholder Dialog (Showing the General Tab) 


 


3. In the Tagholder dialog, select the General Tab. 


4. Enter the Tagholder’s First Name. 


5. Enter the Tagholder’s Last Name. 


6. From the Configuration Level group, select from the following radio buttons: 


 Standard Configuration—displays standard Tagholder details. 


 Advanced Configuration—displays extra advanced Tagholder details. 


 


 


The instructions below continue as for an Advanced Configuration.  For a Standard Configuration 


ignore references made to fields that appear greyed out.     


 


7. In the PIN Used with Tag textbox, enter a PIN-code of up to 4 digits.  (PIN-codes range 


from 2 to 65534). 


8. Enter the Tagholders Company name details. 


9. From the Department drop-down list, select a department name.  


 


 


Add extra Departments as follows: 


 


1. Click the Department button.   


2. Click the  button. 


3. In the Department textbox, enter a suitable name for the Department. 


4. Click the  button. 


5. Click the  button. 


 


Click the  button to edit a Department or the  button to delete a Department. 
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The Send E-Mail button lets you send Tagholder details (by customizable V-Card) to interested parties.   


Data entry in the e-mail's To textbox is mandatory for e-mail transmission.  For information on V-Card 


customization and e-mail setup please refer to the section Preference Configuration (System 


Notification Tab) in Part 3 – General Configuration. 


 


10. From the Type drop-down list make your selection.  The value selected, once captured in 


the master table, lets the third-party Time and Attendance Software determine who to 


calculate and who not to calculate.  For Sites using third-party Time and Attendance 


Software we therefore recommend that you select the Access and Time option, for all 


other installations select the Access Only option.    


11. Complete other personal information as necessary. 


 


 


Add a Tagholder Image as follows: 


 


1. Click the button.   


2. At the Open dialog, select the image file.  Image formats supported include:  jpg, jpeg, gif, tif 


and tiff.  The recommended resolution is 640 x 480 pixels. 


3. Click the Open button. 


 


For more information on the Live Video Image Capture feature ( ) please see Part 5 – Advanced 


Configuration. 


 


Clicking the  button opens the Edit dialog, allowing image cropping, rotation, resizing and use of an 


image mirror effect. 


 


 


To change the Tagholder Image back to the default image: 


 


1. Right click on the Tagholder Image. 


2. Select Default Image. 


 


12. Use the Note text area when entering further information about the Tagholder. 


13. Click the  button. 


 


AAssssiiggnn  TTaaggss  ttoo  TTaagghhoollddeerrss  


A Tagholder can have up to 4 Tags assigned to them.  To assign Tags to a Tagholder, proceed 


as follows: 


 


1. In the Tagholder dialog, select the Tag Tab. 


2. Click any of the Create New Tag buttons.   
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Figure 11 – Tagholder Dialog (Showing the Tag Tab) 


 


3. From the Configuration Level group, select from the following radio buttons: 


 Standard Configuration—disables advanced configuration options. 


 Advanced Configuration—enables advanced configuration options. 


 


 


The instructions below continue as for an Advanced Configuration.  For a Standard Configuration 


ignore references made to fields that appear greyed out.     


  


Selecting a Registration Reader 


1. From the Miscellaneous group, select the Configure Reader button. 


2. In the Configure Tag Reader dialog, from the Use Registration Reader radio buttons, 


select one of the following: 


 Yes—when selected, the Registration Reader Port drop-down list activates.  Select 


the Port Number to which you connected your Registration Reader. 


 No—selected by default, activates the Select Reader drop-down list.  Select the 


Reader you intend using as the Registration Reader from the list of available Readers. 


3. Click the  button. 


 


Tag Enrollment 


1. Present a Tag to an Enrollment Reader.  


2. On the Tag tab, click the Read Tag button.   


 


 


When the IXP220 Software detects the Tag, the Tag number displays in the Number textbox. 
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When the Software is set to ignore the Tag type, the Tag type updates automatically.  When the Tag 


type is taken into consideration, select the Tag type from the Type drop-down list.  Your Tag Type 


options include: 


 


 Standard (125 kHz)—previously described as Slim Tag 5 Bytes. 


 Read/Write (125 kHz, 2048 bits)—previously described as WriTag 2048. 


 Read/Write (125 kHz, 128 bits)—previously described as WriTag 128. 


 3rd Party (Other)—previously described as ASCII/Barcode/Magstripe. 


 Personal Access Code—create a Personal Access Code (PAC) by selecting the Personal 


Access Code choice from the Type drop-down list and entering the Personal Access Code 


(PAC) in the Tag Code textbox.  Your Personal Access Code may range from between 1 to 


999999999.  After entering the Personal Access Code at the Reader or Terminal, complete the 


entry by pressing the # key).  


 RF/Infrared—previously described as RF/Infrared Tag. 


 Mifare—previously described as Mifare Tag. 


 HID (125 kHz)—previously described as HID Tag. 


 13.56 MHz (General)—previously described as General 13.56 MHz. 


 Felica—previously described as Felica Tag. 


 


Access Rights Configuration 


1. From the Site drop-down list, select the Site name. 


 


 


Alternatively, click the  button t to select the Access Group for the Tagholder across all Sites. 


 


2. From the Level drop-down list make your selection from the following choices: 


 Visitor—restricted access, valid for day of issue only. 


 Normal—employee Tagholder.  Access restricted by Door Mode. 


 Supervisor—opens Doors (Locations) in Supervisor Mode, overrides Anti-passback 


(APB) and may cancel alarms. 


 Administrator—opens Doors (Locations) in Supervisor Mode and ignores No Entry 


Mode. 


3. From the Access Group drop-down list, make a selection. 


 


 


Alternatively, click the  button to create a new Access Group. 


 


 


You must assign a Tagholder Access Group for the Tag to have any access rights. 


  


Tag Expiry Configuration 


For temporary Tagholders, proceed as follows: 


 


1. From the Start Date drop-down list, select a suitable start date. 


2. In the Start Time textboxes, enter a suitable start time. 


3. From the Expiry Date drop-down list, select a suitable expiry date. 


4. In the Expiry Time textboxes, enter a suitable expiry time. 
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Message Configuration 


 


 


For information on adding Messages, refer to the Messages section in Part 3 – General Configuration. 


 


From the Message drop-down list, select a Message for display. 


 


 


Alternatively, click the  button to create a new Message. 


 


Miscellaneous Configuration 


 Reset APB—resets the Anti-passback (APB) status for an individual Tagholder. 


 Suspend—suspends the Tag in the event the Tag is lost or no longer required. 


 Copy Tag—copies the Tag code for use in sites with Tags and biometric facilities, thus 


upholding Anti-passback (APB) rules. 


 Usage—stores a description of the Tag’s usage. 


 Configure Reader—select the Reader for use as the Registration Reader for the site. 


 Configure Biometric Reader—opens the Tagholder biometric configuration and enrollment 


settings.  See Part 8 – Integration Modules for more information. 


 


General Details 


1. Click the  button. 


2. Click the  button. 


 


If necessary, repeat the Assign Tags to Tagholders procedure for any extra Tags. 


 


DDeelleettee  aann  AAssssiiggnneedd  TTaagg  


To delete an assigned Tag, proceed as follows: 


 


1. Select the  Page Tab. 


2. From the list of Tagholder records displayed, double-click the Tagholder record for editing. 


3. In the Tagholder dialog, select the Tag Tab. 


4. Click the assigned Tag button (that is Tag 1, Tag 2, Tag 3 or Tag 4) for deletion. 


5. Click the  button. 


6. Click the  button. 


7. Click the  button. 


 


DDeelleettee  aa  TTaagghhoollddeerr  


 


 


Before deleting a Tagholder, first delete all Tags assigned to the Tagholder. 


 


To delete a Tagholder from the IXP220 System, proceed as follows: 


 


1. Select the  Page Tab. 


2. From the list of Tagholder records displayed, select the Tagholder record for deletion. 


3. Click the  button. 


4. At the Warning dialog, click the OK button. 
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SSeett  tthhee  DDeeffaauulltt  CCaarrdd  TTeemmppllaattee  


When configuring a Tagholder, this facility allows you to select, from a library of Card Templates, 


the template to be used as the default when printing Credit Card Tags for that Tagholder. 


 


 


For information on setting the Default Card Template, see the Card Designer chapter of Part 6 – 


IXP220 Software Modules. 


 


BBaattcchh  EEnnrroollllmmeenntt  ooff  TTaaggss  


The Batch Enrollment feature lets you rapidly assign multiple Tags to a Site, without entering 


Tagholder details. 


 


Start Batch Enrollment 


1. From the Main Menu, select Tagholder>Batch Tagholders.   


 


 
Figure 12 – Batch Tag Registration Configuration Pane 


 


2. From the Select Tag Level drop-down list, select from the following choices: 


 Visitor—restricted access, valid for day of issue only. 


 Normal—employee Tagholder.  Access restricted by Door Mode. 


 Supervisor—opens Doors in Supervisor Mode, overrides Anti-passback (APB) and 


may cancel alarms. 


 Administrator—opens Doors in Supervisor Mode and ignores No Entry Mode. 


3. From the Select Access Group drop-down list, select an Access Group. 


4. Enter a Starting Tag Reference Number.  The Starting Tag Reference Number is any 


number that you can use temporarily in identifying the Tags. 
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5. From the Select Department drop-down list, select a Department. 


 


 


Add extra Departments as follows: 


 


1. Click the Department button.   


2. Click the  button. 


3. In the Department textbox, enter a suitable name for the Department. 


4. Click the  button. 


5. Click the  button. 


 


Click the  button to edit a Department or the  button to delete a Department. 


 


6. Select one of the following to start the Batch Enrollment process:  


 Batch Mode Auto Read 


 Manual Read 


Batch Mode Auto Read 


This Mode lets you scan a batch of Tags in quick succession: 


 


1. Select the Batch Mode Auto Read radio button. 


2. Click the Start button. 


3. Present Tags to the Enrollment Reader one at a time. 


4. Click the Stop button. 


5. On enabling, click the  button. 


 


Manual Read Mode 


Manual Mode lets you scan a batch of Tags one at a time.  It is useful if the Enrollment Reader 


is away from the Host PC. 


 


1. Select the Manual Mode radio button. 


2. Present a Tag to the Enrollment Reader. 


3. Click the Read button.  On reading the Tag, its numbers display in the Tag Code and 


Second Tag Code (if applicable) textboxes along with their Tag Types. 


4. Click the Add button. 


5. Repeat steps 1 to 3 for further Tags. 


6. After you’ve scanned all the Tags, click the  button. 


  


Non-read Mode 


This Mode lets you load a range of Tags without physically scanning the Tags.  You may load up 


to 1 000 Tags at a time. 


 


1. Select the Non-read Mode radio button. 


2. In the First Tag Code textbox, enter the first tag code in the range. 


3. In the Last Tag Code textbox, enter the last tag code in the range. 


4. On enabling, click the  button. 


 


AAddvvaanncceedd  SSeeaarrcchh  


To search for a Tagholder, continue as follows: 
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1. Select the  Page Tab. 


2. Enter a suitable keyword in the Search By textbox. 


 


As you type, the Software automatically matches the keyword, highlighting the Tagholder record 


with the closest match. 
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Chapter 3:  Tracker Module 


Introduction 


The Tracker Module keeps you advised as to the whereabouts of selected Tagholders 


(maximum 10 Tagholders per site) as they move about the Site.  Alternatively, you may use the 


Tracker Module to monitor events at a selected Reader (maximum 10 Readers per Site).  Both 


these facilities allow for better end user site management, by displaying the latest 20 


transactions for today only, in time order per your group (Tagholders or Readers) selected.    


 


  


In instances where a single Tagholder (Reader) returns more transactions than others it may happen 


that some Tagholders (Readers) do not appear in the list of transactions.  It must be emphasized that it 


is the most recent 20 transactions for the group, not the most recent for each individual Tagholder.  


Achieve best results with this Module by narrowing your range for monitoring to your exact 


requirements.    


 


On opening, the Tracker Module remains discreetly minimized as an icon in the System Tray 


(Notifications Area).  As Tracker receives Tagholder transactions or events from Monitored 


Readers, notification pop-up windows display in the Notification area. 


 


By default the Tracker Module refreshes every 10 seconds, this is the recommended setting.  


The refresh rate is, however, user configurable where you need a faster or slower refresh rate. 


 


 


Each Tracker Client makes a single connection to the Database.  The Base Application and other 


Clients also make many connections to the Database, thus DO NOT exceed 30 connections in total. 


 


Starting the Tracker Module 


SSttaarrttiinngg  tthhee  IIXXPP222200  BBaassee  AApppplliiccaattiioonn  oonn  tthhee  HHOOSSTT  PPCC  


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. Click the  button. 


 


SSttaarrttiinngg  tthhee  TTrraacckkeerr  MMoodduullee  oonn  aa  CCLLIIEENNTT  PPCC  ((SSeeppaarraattee  PPCC  WWoorrkkssttaattiioonn))  


 


 


Ensure that you do NOT open more than 1 instance of the Tracker Module per PC workstation. 


 


1. In Windows®, click Start>All Programs>IXP220>Tracker. 


2. In the Logon dialog, complete the Server Name textbox.  The default (Localhost) only 


applies where you run Tracker from the Host PC. 


3. In the Database textbox, enter the Database’s path and filename.  (Only use the Browse 


button where the Server is Localhost). 
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4. Enter your Username (SYSDBA) and Password (masterkey). 


5. Click the  button. 


 


UUsseerr  IInntteerrffaaccee  


By default the Tracker Module remains discreetly minimized as an icon in the System Tray 


(Notifications Area).  Configure Tracking settings by right-clicking your mouse over the  Icon 


and selecting Show Tracker.   


 


When open the Tracker Module lists the last 20 transactions generated by the tracked 


Tagholders or Readers.  You may track a maximum of 10 Tagholders or Readers.      


 


 


By double-clicking on any record displayed in the Tracker Module (Tagholders or Readers tab) a dialog 


opens displaying the last 10 transactions for the selected Tagholder or Reader. 


 


 
Figure 13 – Tracker Module User Interface 


 


Tagholder Tracking   


AAdddd  TTrraacckkeedd  TTaagghhoollddeerrss  


1. With the Tracker Module open (see User Interface on page 36), select the Tagholders tab. 


2. Click the Select Tagholders button. 


3. Make your selection from the displayed Tagholder records. 


4. Click the  button. 
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RReemmoovvee  TTrraacckkeedd  TTaagghhoollddeerrss  


1. With the Tracker Module open, select the Tagholders tab. 


2. Click the Select Tagholders button. 


3. Deselect, previously selected Tagholders. 


 


 


Click the selected column header thus sorting by the selected Tagholders. 


 


4. Click the  button. 


 


FFiinndd  TTaagghhoollddeerrss  


1. With the Tracker Module open, select the Tagholders tab. 


2. Click the Select Tagholders button. 


3. From the In Column drop-down list, select a search field, for example: 


 Last Name—searches the Last Name column for a matching record. 


 First Name—searches the First Name column for a matching record. 


 Department—searches the Department column for matching records. 


4. Enter a suitable keyword in the Find textbox. 


 


 


When entering search criteria, keep in mind that the Find textbox is case sensitive. 


 


As you type, the Software automatically moves to the Tagholder record with the closest match. 


 


Reader Event Tracking 


AAdddd  TTrraacckkeedd  RReeaaddeerrss  


1. With the Tracker Module open (see User Interface on page 36), select the Readers tab. 


2. Click the Select Readers button. 


3. Make your selection from the displayed records. 


4. Click the  button. 


 


RReemmoovvee  TTrraacckkeedd  RReeaaddeerrss  


1. With the Tracker Module open, select the Readers tab. 


2. Click the Select Readers button. 


3. Deselect, previously selected Readers. 


 


 


Click the selected column header thus sorting by the selected Readers. 


 


4. Click the  button. 


 


FFiinndd  RReeaaddeerrss  


1. With the Tracker Module open, select the Readers tab. 


2. Click the Select Readers button. 
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3. From the In Column drop-down list, select a search field, for example: 


 Site Name—searches the Site Name column for a matching record. 


 Reader Address—searches the Reader Address column for a matching record. 


 Reader Name—searches the Reader Name column for matching records. 


4. Enter a suitable keyword in the Find textbox. 


 


 


When entering search criteria, keep in mind that the Find textbox is case sensitive. 


 


As you type, the Software automatically moves to the record with the closest match. 


 


Preference Setup 


On opening, the Tracker Module remains discreetly minimized as an icon in the System Tray 


(Notifications Area).  Set your custom preferences as follows: 


 


1. Right-click your mouse over the  Icon (minimized as an icon in the System Tray 


(Notifications Area)).   


2. From the displayed menu, select the Preferences option. 


 


 
Figure 14 – Preferences Dialog 


 


3. From the Preferences dialog, select a Scan Frequency (in seconds). 


4. To have Tracker open without displaying the Logon dialog, select the Remember 


Username and Password checkbox.   


5. Select the Play Sound File on Alert checkbox if required.   


 


 


Browse for an alternate sound file by clicking the  button.  After selection, the file name displays in 


the textbox alongside the  button.   


 


6. During Tracker’s configuration, if you log on as the SYSDBA Administrator you may restrict 


monitored sites for a ―Normal User‖.  ―Normal Users‖ will NOT see this option.  Make your 


selection from the Restrict Site for Tagholder Selection drop-down list. 
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7. Make your selection from the Restrict Site for Transaction Monitoring drop-down list. 


8. Click the  button. 


 


Localisation and Translation 


Localisation and Translation lets Users from different locales (countries and geographical 


locations), use the Tracker Module in their own language. 


 


CChhoooossee  LLooccaallee  


1. Right-click your mouse over the  Icon (minimized as an icon in the System Tray 


(Notifications Area)).   


2. From the displayed menu, select the Choose Locale option. 


 


 
Figure 15 – Locale Chooser Dialog 


 


3. In the Locale Chooser dialog, from the Language drop-down list, make your selection. 


4. From the Country drop-down list, make your selection. 


5. From the Variant drop-down list, select a language variant based on your previous 


selections (optional). 


6. Click the OK button. 


 


TTrraannssllaattiinngg  tthhee  SSooffttwwaarree  IInntteerrffaaccee  


1. Right-click your mouse over the  Icon.   


2. From the displayed menu, select the Translate option. 
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Figure 16 – Translate Dialog 


 


3. In the Translate Text : TrackerManager dialog, from the New Text column, select a phrase 


to translate.   


 


 


The Original column displays words in English.  The New Text column displays a copy of the English 


words, but it is editable.  This means you can substitute the default words in the New Text column for 


words in your own language. 


 


4. Press the F2 key, thus opening the phrase for editing.   


5. Enter a substitute phrase suitable for your Locale. 


6. Press the Tab key to move to the next phrase. 


7. Repeat steps 4 to 7 for each phrase you wish to edit. 


8. Click the OK button. 


9. Click the Close button. 


 


  


  







  Part 6 – IXP220 Software Modules 


February 2012  41 


Chapter 4:  Visual Door Control Module 


Introduction 


The Visual Door Control Module CCTV integration solution allows for better end user site 


management.  In areas with rising crime, the operator can from a safe location monitor and 


control up to 4 Doors (Locations) (4 Cameras) at a time per Site. 


 


The Module also allows tracking of up to 30 Tagholders at a time on a per site basis.  The 


Tagholder monitor refreshes every 5 seconds giving you a near real time Tagholder tracking 


solution. 


 


You may use the Visual Door Control Module with Windows® Internet Explorer 8 (and above) or 


alternatively Firefox 3 (and above).  The Module is designed for use with the Axis 210 and 213D 


range of cameras.  


 


 


Using IXP220 V1.82 (onwards) lets you connect to Web Modules through a Secure Socket Layer 


(SSL) connection.  See Part 5 – Advanced Configuration for information on this feature. 


  


 


Refer to Part 3 – General Configuration for details on IP Camera Configuration.   


 


Where you have multiple clients connected to this Module, each monitoring up to 30 Tagholders, 


Database speed reduction may take place. 


 


Starting up the Visual Door Control Module 


SSttaarrttiinngg  tthhee  IIXXPP222200  BBaassee  AApppplliiccaattiioonn  oonn  tthhee  HHOOSSTT  PPCC  


 


 


Ensure that you unlock your Registration Interface (Visual Door Control Licence) before using the 


Visual Door Control Module.  This unlock allows a maximum of 1 seat. 


 


 


On upgrade of your IXP220 Software, ensure that you clear the cache on the client PC. 


 


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. Click the  button. 


  


SSttaarrttiinngg  tthhee  VViissuuaall  DDoooorr  CCoonnttrrooll  MMoodduullee  oonn  aa  CCLLIIEENNTT  PPCC  ((SSeeppaarraattee  PPCC  


WWoorrkkssttaattiioonn))  


 


 


Ensure that you do NOT open more than 1 instance of the Visual Door Control Module per PC 


workstation. 
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If the Web Server resides on a Port other than Port 80, the URL becomes: 


http://localhost:XX/220Web/homepage.html.  The XX highlighted in the URL refers to the new Port 


number, for example 82, 83 or 84 and so on. 


 


1. Startup the Visual Door Control Module from your Internet Browser using the following URL:  


http://localhost/220Web/homepage.html.  Replace the term Localhost with the IP 


Address (or server name) for the System’s Host PC. 


2. At the IXP220 Home Page, select the  (Visual Door Control) Icon. 


3. At the Visual Door Control dialog, click the Visual Door Control button. 


4. At the Login dialog, enter your Username (SYSDBA) and Password (masterkey). 


5. Click the Submit button. 


 


 


On first-time use of the Module with Internet Explorer, Explorer prompts you for installation of the Axis 


Media Control Software.  At the Security Warning dialog, click the Install button. 


 


UUsseerr  IInntteerrffaaccee  


 
Figure 17 – Visual Door Control Module User Interface 


 


The left-hand side of the workspace has placeholders for up to 4 Cameras per site.  Figure 17 


shows 2 functional Camera feeds and 2 placeholders.     


 


 


If Firefox returns the message ―Camera Image Loading‖ for an extended period of time, ensure the 


camera’s IP Address is correct.  Refer to Part 3, Edit Advanced Door Configuration for more 


information. 



http://localhost:XX/220Web/homepage.html
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The Tagholders to Monitor Panel on the right-hand side of the workspace lists the up to 30 


Tagholders you select for monitoring.  These Tagholder records appear in green initially and 


remain green on Door (Location) entry.  On exit from the Door (Location) the records appear in 


red.  Moving your mouse pointer over a monitored Tagholder displays the latest Tagholder 


monitoring information, which includes the Door Name, Event, Date and Time. 


 


Door Control 


 Open the Door (Location) by clicking the  button. 


 Take a Snapshot by clicking the  button. 


 Edit the Camera’s settings online by clicking the  button. 


 Switch between Cameras (Doors) by clicking the  button. 


 


Tagholder Tracking   


 


 


If you monitor a Tagholder with access rights across sites and you switch between these sites, the 


Tagholder still appears on the Tagholders to Monitor Panel.   


 


AAdddd  aa  TTaagghhoollddeerr    


1. In the Tagholders to Monitor Panel, click the  button. 


2. Make your selection from the displayed Tagholder records. 


3. Click the  button. 


 


RReemmoovvee  aa  MMoonniittoorreedd  TTaagghhoollddeerr  


1. In the Tagholders to Monitor Panel, select a Tagholder record for removal. 


2. Click the  button. 
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Chapter 5:  Card Designer Module 


Introduction 


The Impro Card Designer Software Module lets you design and store templates for printing 


information on adhesive labels or directly onto Credit Card Tags.   


 


When used with the System Database, a design could typically provide information such as the 


Tagholders Name, Department, Tag Code, and so on. 


 


Starting the Card Designer Module 


 


 


Ensure that you unlock your Registration Interface (Card Designer Licence) before using the Card 


Designer Module.  This unlock allows a maximum of 1 seat. 


 


Open the IXP220 Base Application as follows: 


 


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. Click the  button. 


4. From the Menu Bar, select the Tagholder>Card Designer. 


 


 


The New Template dialog displays the first time you use the Software.  Thereafter, once you have 


existing templates, the Select Template dialog displays when the Software’s used.  For a new 


installation, continue from point 5.  For an existing installation select one of the templates shown in the 


Select Template dialog and click the   button. 


 


 
Figure 18 – New Template Dialog 


 


5. In the Enter Template Name dialog, enter a name for your template. 


6. Using the Portrait or Landscape radio buttons, select the orientation of your template. 


7. Click the  button. 
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UUsseerr  IInntteerrffaaccee  


The Card Designer principles of operation are similar to other drawing application packages, 


and are largely intuitive.  If you have experience of these and wish to start designing 


immediately, skip to the section titled Designing a Typical Template on page 49. 


 


Menu Bar 


File 


Option Description 


New Creates a new blank template. 


Open Opens an existing template from a list provided. 


Rename Renames the open template. 


Delete Lets you permanently delete a single template. 


Import Lets you import templates into Card Designer. 


Export Lets you export your templates created in Card Designer. 


Choose Locale Allows the choice of the area and language for translation purposes. 


Translate Displays a list of all terms used in the Card Designer Module for translation. 


Print Preview Lets you preview your print job prior to printing. 


Properties Allows setting of the printer settings (including printer options (card or label 


layout), print margins, and units of measurement). 


Exit Exits the Card Designer Module. 


Table 1 – File Menu Options 


 


Edit 


Option Description 


Undo Undoes the previous action. 


Redo Restores the previously cancelled action. 


Table 2 – Edit Menu Options 


 


Database 


Option Description 


Base Query Allows users with experience in SQL Syntax to custom configure fields.  You 


may then drop these custom fields onto the card template. 


Table 3 – Database Menu Options 


 


View 


Option Description 


Grid Allows you to display or hide the background grid.  Note, however, that 


elements still align to the gridlines even when the grid’s hidden. 


Zoom Allows the selection of three magnification settings: Small, Medium and 


Large.  (Large is the default setting on start-up). 


Table 4 – View Menu Options 
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Options 


Option Description 


Snap to Grid With the menu item checked, drawing elements line up to the nearest grid 


lines.  With the menu item unchecked, you may place drawing elements 


freely. 


Grid Interval Allows the selection of grid intervals (in pixels) of 5, 10 or 15.  (10 is the 


default setting on start-up). 


Default Text 


Font 


Sets the default font style, colour or size for future placement of text fields. 


Card Colour Allows a choice, from 255 colours, as to the background colour of the printed 


card. 


Table 5 – Options Menu Options 


 


Format 


The Format drop-down list activates when you select more than one object. 


 


Option Description 


Align  (Top, Middle, Bottom, Left, Centre, Right) enables alignment of objects. 


Same Size  (Vertical, Horizontal) enables matching of object sizes. 


Table 6 – Format Menu Options 


 


Help 


Option Description 


Help Activates Card Designers on-line Help. 


About Tells you about the Card Designer version running. 


Table 7 – Help Menu Options 


 


Top Tool Panel 


At the top of the Card Designer Screen the following icons appear (from left to right): 


 


Symbol Icon Name Description 


 
Reverse Card  Allows the selection of the front or back of a card. 


 
Undo Undoes previous action (except delete). 


 
Redo Restores previous action (except delete). 


 
Zoom Increases or decreases magnification. 


 
Refresh Refreshes screen contents. 


Table 8 – Top Tool Panel 


 


Side Tool Panel 


The Side Panel Icons control the generation of Fields.  To place a field: 


 


1. Select one of the field types from the Side Tool Panel.  


2. Then drag an area on the card representing the area for the field.  
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Symbol Icon Name Description 


 
Pointer Allows the selection of any object in the template. 


 
Line Draw Allows drawing of horizontal or vertical lines. 


 
Rectangle Allows drawing of rectangles. 


 
Ellipse Allows drawing of ellipses. 


 
Text Allows entry of text. 


 
Image Allows import of an image (such as a logo) in JPEG or GIF 


format. 


 
Database Allows the insertion of database fields. 


 
Barcode Allows the display of a barcode in one of several formats. 


 
Date Provides the date (YYYY-MM-DD) of issue.  This field’s format is 


configurable. 


Table 9 – Side Tool Panel 


 


Each of the above icons allows the creation of a ―field‖.  Each such field is a defined area on the 


card that contains the data specified by the icon when the card prints from the System Software.  


 


For example, a Text field contains text included by you, the designer; a Database field contains 


specified information from the System Database, such as the Tagholder’s name. 


 


Database Fields 


The standard Database Fields available in the IXP220 System include:  


 


Item Description 


MST_SQ Seldom used – for database maintenance only. 


MST_TITLE The Tagholder’s title (Mr, Mrs, etc). 


MST_FIRST NAME The Tagholder’s first name. 


MST_MIDDLE NAME The Tagholder’s middle name. 


MST_LAST NAME The Tagholder’s last name. 


MST_SUFFIX The Tagholder’s suffix. 


MST_ID The Tagholder’s access ID number. 


MST_GENDER The Tagholder’s gender. 


MST_PIN The Tagholder’s access PIN number. 


MST_TYPE System data determining whether a Tagholder is an employee or a 


visitor. 


MST_CURRENT System data which determines whether a Tagholder is still valid. 


EMP_EMPLOYEENO The Tagholder’s employee number. 


EMP_EMPLOYER The Tagholder’s employer’s name. 


EMP_POSITION The Tagholder’s position in the employer’s organisation. 


DEPT_NAME The name of the Tagholder’s Department. 


SITE_SLA Site address. 


IMG_IMAGE The Tagholder’s photograph. 


MSTNT_MEMO General information specific to the Tagholder. 


Table 10 – Database Fields 
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Barcode Fields 


The Barcode icon gives you access to the same database fields as the Database icon. 


Database items chosen for barcoding depend on your requirements.  A typical example could 


be an ID number, if this is available in the Database for the System concerned.  You could use 


the ID barcode for example, if a barcode reader controls access to a company car park. 


 


Modifying Field Properties 


To change the properties of a field: 


 


1. Using the Pointer icon, select the field for editing. 


2. Right-click the mouse over the field.  


3. Select Properties from the menu.  


4. Edit the settings as necessary. 


 


 


Designing a Typical Template 


GGeenneerraall  


Card Designer lets you to define where on the card data prints.  A template typically contains: 


 


 one Image field 


 one or more Text fields 


 one database Image field (for example the Tagholder’s photo) 


 several other Database fields (for example the Tagholder’s name, and so on) 


 


 


Text fields and Image fields contain information common to all cards for printing using a given 


template, while Database fields contain information specific to a Tagholder. 


 


The typical steps in designing a template are: 


 


1. Show or hide the Grid. 


2. Select Snap to Grid ON or OFF. 


3. Select the Grid spacing. 


4. Insert and format Text Fields. 


5. Set the card colour. 


6. Insert, define and format Database Fields. 


7. Insert Image Fields. 


8. Insert a Barcode Field. 


9. Draw the outlines required (such as the card outline, and frames for images, etc). 


10. Print Preview the card. 


11. Alter the template elements as required. 


12. Test Print the card. 


13. Batch Print the cards. 


 


TTyyppiiccaall  EExxaammppllee  TTeemmppllaattee  


The typical example template, used below, is that for the Manufacturing Department for a 


company called Excel Technologies.  The dimensions of the outer edges of the Grid are the 


same as those of an ISO Credit Card Tag. 
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Card Designer saves templates automatically; therefore Card Designer has no Save button. 


 


 
Figure 19 – Typical Example Template 


 


Show or Hide the Grid 


1. From the Menu Bar, select the View drop-down menu. 


2. From the View drop-down menu, select the Grid option. 


 


 


A tick mark alongside the Grid option shows the Grid options active.  No tick mark alongside the Grid 


option shows the Grid options NOT active. 


 


Snap to Grid ON or OFF 


1. From the Menu Bar, select the Options drop-down menu. 


2. From the Options drop-down menu, select the Snap to Grid option. 


 


 


A tick mark alongside the Snap to Grid option shows the options active.  No tick mark alongside the 


Snap to Grid option shows the options NOT active. 


 


Set the Grid Spacing 


1. From the Menu Bar, select the Options drop-down menu. 


2. From the Options drop-down menu, select the Grid Interval option. 


3. From the Grid Interval menu, select one of the following options: 


 5 


 10 (default) 


 15 


 


Add Text and Set Font Properties 


1. From the Side Tool Panel, click the  icon. 


2. Using the Left mouse button, drag the mouse over the grid to place the text. 


3. In the Default Text Font dialog, select a font from the list: 


 Dialog (default) 
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 SansSerif 


 Serif 


 MonoSpaced 


 DialogInput 


4. For Bold or Italic text, check the appropriate checkbox. 


5. From the Size drop-down list select an appropriate size for the font. 


6. Click on the Colour button. 


7. In the Text Colour dialog, select the new colour for the font. 


8. Click the OK button. 


9. In the Write Text Here text area, type in the text you want to appear on the template. 


10. Click the  button. 


 


Set the Card Colour 


1. From the Menu Bar, select the Options drop-down menu. 


2. From the Options drop-down menu, select the Card Colour option. 


3. Select the new colour for the card. 


4. Click the OK button. 


 


 


In this example we left the card with the default setting of White. 


 


Add Database Fields 


1. From the Side Tool Panel, click the  icon. 


2. Using the Left mouse button, drag the mouse over the grid to place the Database Field. 


3. In the Select Database Field dialog, select a Field from the list. 


4. Click the  button. 


5. Using the Pointer icon, select the field for editing. 


6. Right-click the mouse over the Database Field. 


7. Select Properties from the menu. 


8. In the Query Properties dialog, click on each of the following tabs for editing options: 


 Border—allows update of the border position, colour and line width. 


 Font—allows selection of a new font, selection of the bold and italic format, selection of 


the font size and colour. 


 Query—allows selection of a new Database Field. 


 Alignment—allows selection of the horizontal and vertical alignment and rotation of the 


text within the Database Field. 


9. Click the  button. 


 


Insert Image Fields 


1. From the Side Tool Panel, click the  icon. 


2. Using the Left mouse button, drag the mouse over the grid to place the Image Field. 


3. In the Open dialog, select the required image file. 


4. Click the Open button. 


5. Right-click the mouse over the Database Field. 


6. Using the Pointer icon, select the field for editing. 


7. Select Properties from the menu. 


8. In the Image Properties dialog, click on each of the following tabs for editing options: 


 Border—allows update of the border position, colour and line width. 


 Alignment—allows selection of the horizontal and vertical alignment and an image only 


property. 
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9. Click the  button. 


 


 


If the Card Printing Module uses third-party tables, then any image fields must contain the word 


―IMAGE‖. 


 


Insert a Barcode Field 


1. From the Side Tool Panel, click the  icon. 


2. Using the Left mouse button, drag the mouse over the grid to place the Barcode Field. 


3. In the Select Database Field dialog, select a Field from the list. 


4. Click the  button. 


5. Using the Pointer icon, select the field for editing. 


6. Right-click the mouse over the Barcode Field. 


7. Select Properties from the menu. 


8. In the Barcode Properties dialog, click on each of the following tabs for editing options: 


 Border—allows update of the border position, colour and line width. 


 Query—allows selection of a new Database Field. 


 Barcode—allows selection of general and text settings. 


9. Click the  button. 


 


Drawing Tools 


Borders (Rectangle) 


1. From the Side Tool Panel, click the  icon. 


2. Using the Left mouse button, drag the mouse over the grid in the position that you want the 


Border. 


3. Using the Pointer icon, select the Border for editing. 


4. Right-click the mouse over the Border. 


5. Select Properties from the menu. 


6. In the Rectangle Properties dialog, update of the border position, colour and line width as 


necessary. 


7. Click the  button. 


 


Lines 


1. From the Side Tool Panel, click the  icon. 


2. Using the Left mouse button, drag the mouse over the grid in the position that you want the 


Line. 


3. Using the Pointer icon, select the Line for editing. 


4. Right-click the mouse over the Line. 


5. Select Properties from the menu. 


6. In the Line Properties dialog, update of the border position, colour and line width as 


necessary. 


7. Click the  button. 


 


Print Preview the Card 


1. On the Menu Bar, select File. 


2. From the File drop-down menu, select Print Preview. 
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Figure 20 – Typical Example – Print Preview Mode 


 


Test Print 


 


 


You may have to adjust printer driver settings to ensure that printings performed as needed.  These 


settings differ from printer to printer. 


 


 


Single or double-sided card printing is possible.  For details of double-sided printing, please refer to the 


on-line Help facility. 


 


1. On the Menu Bar, select File. 


2. From the File drop-down menu, select Print Preview. 


3. In the Print Preview dialog, click the Print Test Card button. 


4. In the Print dialog, select your printer’s settings. 


5. Click the OK button. 


 


Set the Card Properties 


1. On the Menu Bar, select File. 


2. From the File drop-down menu, select Properties. 


3. In the Printer Settings dialog, select from the following options: 


 Print Options—allows selection of Card Layout or Label Layout and offers a preview 


of the Label Layout facility.  In Preview you may adjust the Page Width and Height, the 


X and Y Origin and the X and Y Space. 


 Printing Margin—allows selection of the printing margins width and height, the Default 


button lets you return the settings to the default (0). 


 Units of Measurement—allows selection of imperial or metric units of measurement. 


4. Click the  button. 
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Close Card Designer 


1. On the Menu Bar, select File. 


2. From the File drop-down menu, select Exit. 


 


Localisation and Translation 


Localisation and Translation lets Users from different locales (countries and geographical 


locations), use the Card Designer Module in their own language. 


 


Choose Locale 


1. From the Menu Bar, select File>Choose Locale. 


 


 
Figure 21 – Locale Chooser Dialog 


 


2. In the Locale Chooser dialog, from the Language drop-down list, make your selection. 


3. From the Country drop-down list, make your selection. 


4. From the Variant drop-down list, select a language variant based on your previous 


selections (optional). 


5. Click the OK button. 


 


Translating the Software Interface 


1. From the Menu Bar, select File>Translate. 


 


 
Figure 22 – Translate Text :  Dialog 


 


2. In the Translate Card Designer : Card dialog, from the New Text column, select a phrase 


to translate.   
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The Original column displays words in English.  The New Text column displays a copy of the English 


words, but it is editable.  This means you can substitute the default words in the New Text column for 


words in your own language. 


 


3. Press the F2 key, thus opening the phrase for editing.   


4. Enter a substitute phrase suitable for your Locale. 


5. Press the Tab key to move to the next phrase. 


6. Repeat steps 3 to 5 for each phrase you wish to edit. 


7. Click the OK button. 


8. At the Information dialog, click the OK button. 


 


Hints and Tips 


SSeett  tthhee  DDeeffaauulltt  CCaarrdd  TTeemmppllaattee  


Purpose 


This is a facility provided by Card Designer, but used in Tagholders configuration.  The facility 


allows you to select from a library of Card Templates (when configuring a Tagholder in the 


IXP220 Base Application), the template to be used as the default when printing Credit Card 


Tags for a specific Tagholder. 


 


Procedure 


1. In the IXP220 Base Application, select the  Page Tab. 


2. In the Configuration Pane, select the required Tagholder record. 


3. Double-click the record, opening it for editing. 


4. In the Tagholder dialog, select the Tag Tab. 


5. Click the assigned Tag button (that is Tag 1, Tag 2, Tag 3 or Tag 4) for editing. 


 


 
Figure 23 – Default Card Template Selection 
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6. Hold down the Ctrl key, and click the  button.  The Select Template dialog appears (see 


Figure 23). 


7. From the Select Template dialog select the required template. 


8. Click the  button. 


 


 


All Credit Card Tags printed for this Tagholder will now use the selected Template. 


 


IImmaaggee  QQuuaalliittyy  


 


 


Specifying large images can adversely affect Database performance and size. 


 


 


As Tagholder images are not automatically resized, the optimum resolution for Tagholder images is 


640 x 480 dpi. 


 


When using a Logo Image 


 Set the X and Y margins to 0. 


 If the image requires a border, use a rectangle. 


 Do not use auto-stretch (right-click the image>properties). 


 Make sure the field dimensions are in proportion, so the image proportions are not changed 


when imported, this would produce a distorted image. 


 


When using a Database Image 


 Set the X and Y margins to 0. 


 If the image requires a border, use a rectangle. 


 


USER NOTES 


 


 


 


 


 


 


 


 


 


 


 


 


 


 


 


 


 


 


 


ISW300-0-0-GB-09 Issue 10 February 2012 
IXP220\Software\English Manuals Branded\LATEST 


ISSUE\P6 220-swmb-en-10.docx 
 





		PART 6 – IXP220 SOFTWARE MODULES

		Contents

		Chapter 1:  Web Enrollment Module

		Introduction

		General

		Installing Java Runtime Environment (JRE)



		Starting up the Web Enrollment Module

		Starting the IXP220 Base Application on the HOST PC

		Starting the Web Enrollment Module on a CLIENT PC (Separate PC Workstation)

		User Interface



		Tagholder Configuration

		Add a Tagholder

		Assign Tags to Tagholders

		Tag Expiry Configuration

		Message Configuration

		Miscellaneous Configuration



		Delete an Assigned Tag

		Delete a Tagholder

		Searching for Tagholders





		Chapter 2:  IXP220 Rich Client Module

		Introduction

		Starting the IXP220 Rich Client Module

		Door Configuration

		Add a Door

		Add Readers

		Entry or Exit Reader Configuration



		Add a Zone

		Add Door Mode Patterns

		Advanced Door Configuration

		Delete a Door

		Delete a Zone

		Delete a Door Mode Pattern



		Access Group Configuration

		Configure Tagholder Access Groups

		Create a Tagholder Access Group

		Create an Access Time Pattern

		Select an Access Group

		Delete Access Group and Access Time Pattern Details

		Edit Access Group and Access Time Pattern Details





		Tagholder Configuration

		Add a Tagholder

		Assign Tags to Tagholders

		Selecting a Registration Reader

		Tag Enrollment

		Access Rights Configuration

		Tag Expiry Configuration

		Message Configuration

		Miscellaneous Configuration

		General Details



		Delete an Assigned Tag

		Delete a Tagholder

		Set the Default Card Template

		Batch Enrollment of Tags

		Start Batch Enrollment

		Batch Mode Auto Read

		Manual Read Mode

		Non-read Mode



		Advanced Search





		Chapter 3:  Tracker Module

		Introduction

		Starting the Tracker Module

		Starting the IXP220 Base Application on the HOST PC

		Starting the Tracker Module on a CLIENT PC (Separate PC Workstation)

		User Interface



		Tagholder Tracking

		Add Tracked Tagholders

		Remove Tracked Tagholders

		Find Tagholders



		Reader Event Tracking

		Add Tracked Readers

		Remove Tracked Readers

		Find Readers



		Preference Setup

		Localisation and Translation

		Choose Locale

		Translating the Software Interface





		Chapter 4:  Visual Door Control Module

		Introduction

		Starting up the Visual Door Control Module

		Starting the IXP220 Base Application on the HOST PC

		Starting the Visual Door Control Module on a CLIENT PC (Separate PC Workstation)

		User Interface



		Door Control

		Tagholder Tracking

		Add a Tagholder

		Remove a Monitored Tagholder





		Chapter 5:  Card Designer Module

		Introduction

		Starting the Card Designer Module

		User Interface

		Menu Bar

		Top Tool Panel

		Side Tool Panel

		Database Fields

		Barcode Fields

		Modifying Field Properties





		Designing a Typical Template

		General

		Typical Example Template

		Show or Hide the Grid

		Snap to Grid ON or OFF

		Set the Grid Spacing

		Add Text and Set Font Properties

		Set the Card Colour

		Add Database Fields

		Insert Image Fields

		Insert a Barcode Field

		Drawing Tools

		Print Preview the Card

		Test Print

		Set the Card Properties

		Close Card Designer





		Localisation and Translation

		Choose Locale

		Translating the Software Interface



		Hints and Tips

		Set the Default Card Template

		Purpose

		Procedure



		Image Quality

		When using a Logo Image

		When using a Database Image














Part 7 – Utilities 


PART 7 – UTILITIES 







Part 7 – Utilities 


2  February 2012 







Part 7 – Utilities 


February 2012  3 


Contents 


PART 7 – UTILITIES 1 


CONTENTS ............................................................................................................ 3 


FIRMWARE UPGRADE UTILITY ................................................................................. 5 


Introduction ............................................................................................................... 5 


Opening the Utility ..................................................................................................... 5 


Select and Configure the Communications Port ....................................................... 5 


Ping Function ............................................................................................................ 6 


Firmware Upgrade Procedure ................................................................................... 6 


Display Firmware Versions (Available on the Software CD) ..................................... 7 


Additional Features ................................................................................................... 8 


DISCOVERY UTILITY ............................................................................................. 11 


Introduction ..............................................................................................................11 


Viewing Available Controllers and Terminals ...........................................................11 


Secure Logon .......................................................................................................... 12 


Grouping Controllers and Terminals ....................................................................... 13 


Communication Configuration – Case Local .......................................................... 14 


Communication Configuration – Case Remote ...................................................... 16 


Configure the Port Number ..................................................................................... 23 


Advanced Features ................................................................................................. 23 


UNIVERSAL DATA EXPORTER UTILITY .................................................................... 27 


Introduction ............................................................................................................. 27 


Opening the Utility ................................................................................................... 27 


Template Creation (Design Mode) .......................................................................... 27 


Export Data (Run Mode) ......................................................................................... 32 


Advanced Features ................................................................................................. 33 


DATABASE CONVERSION UTILITY .......................................................................... 37 


Introduction ............................................................................................................. 37 


Opening the Utility ................................................................................................... 37 







Part 7 – Utilities 


4  February 2012 


Convert a Database ................................................................................................ 37 


IB CONSOLE UTILITY ........................................................................................... 39 


Introduction ............................................................................................................. 39 


Opening the Utility ................................................................................................... 39 


Manual Upgrade Function ....................................................................................... 39 


Database Maintenance ........................................................................................... 41 


DATABASE ARCHIVE UTILITY ................................................................................ 45 


Introduction ............................................................................................................. 45 


Opening and Using the Database Archive Utility .................................................... 45 


DATABASE PUMP UTILITY ..................................................................................... 47 


Introduction ............................................................................................................. 47 


Opening and Using the Database Pump Utility ...................................................... 47 


TRANSLATE UTILITY ............................................................................................. 49 


Introduction ............................................................................................................. 49 


Opening the Utility ................................................................................................... 49 


Choose the Locale .................................................................................................. 49 


Translate a File ....................................................................................................... 49 


 


 


  







Part 7 – Utilities 


February 2012  5 


Firmware Upgrade Utility 


Introduction 


The Firmware Upgrade Utility lets you perform the following actions: 


 


 Identify Firmware versions of connected Hardware. 


 Selection and configuration of the Communications Port. 


 You may Ping the connected Hardware (feedback informs you of whether Hardware is 


connected and working as specified). 


 Perform in-field Firmware Upgrades to connected Hardware. 


 


Opening the Utility 


In Windows®, go to Start>All Programs>IXP220>Utils>Firmware Upgrade Utility. 


 


Select and Configure the Communications Port 


To specify a communication protocol, continue as follows:   


 


 
Figure 1 – Protocol Group 


 


1. In the Protocol group, select one of the following radio buttons: 


 RS232—used where your IXP220 Controller connects by RS232 or USB or where or 


you are using a communications interface device, select the RS232 option and enter 


the relevant COM Port number. 


 TCP/IP—used where your IXP220 Controller connects by Ethernet. 


 UDP—used when connecting UDP to a single Controller. 


 UDP Multi Controller—used when connecting many UDP devices.  On selection of the 


UDP Multi Controller radio button, a drop-down list displays, listing IP Mapping files 


created by the IXP220 Base Application.  Creation of these files takes place on closure 


of the Base Application Module, on hardware Auto-ID or on replacement of a Controller.  


From the drop-down list you can select a site matching to your IXP220 setup.  Once 


selected, the Firmware Upgrade Utility communicates with all the Site’s Controllers. 
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2. Based on your selection made in step 1, complete the following activated fields: 


 Host IP—your IXP220 Controller’s IP Address. 


 Host Port—enter the default Host Port number of 10005. 


 Local Port—enter the default Local Port number of 10005. 


 Baud Rate—use the default 38 400. 


 


Ping Function 


Ensure that all hardware is connected and working as specified by using the Ping tool. 


 


1. Click the Ping button.  


2. At the IP Door Controllers dialog, click the OK button. 


 


 
Figure 2 – Results of a Ping Check 


 


Firmware Upgrade Procedure 


 


 


On Sites with installed iTT or iTRT Ethernet Terminals,  upgrade the Controller’s Firmware and perform 


a Full Upload before upgrading the Terminal’s Firmware. 
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CCoonnttrroolllleerrss  


To upgrade the Firmware on a Controller, proceed as follows: 


 


1. Configure the Protocol settings specific to your Controller and installation requirements.  


Refer to the section Selecting and Configuring the Communications Port on page 5. 


2. Ensure all hardware is connected and working as specified using the Ping tool.  Refer to 


the section Ping Function on page 6. 


3. Click the Controller’s Select checkbox. 


4. Click the Upgrade button. 


5. Once the Upgrade is complete, perform a Full Upload.  For information on performing a 


Full Upload, please refer to the section Full Upload in Part 3 – General Configuration.  


 


 


The Force Upgrade checkbox forces an upgrade on a unit that has a newer firmware version than is 


available with your current IXP220 Software Suite.  We recommend that you do not use this feature. 


 


TTeerrmmiinnaallss  aanndd  RReeaaddeerrss  


To upgrade the Firmware on a Terminal or Reader proceed as follows: 


 


1. Configure the Protocol settings specific to your Controller and installation requirements.  


Refer to the section Selecting and Configuring the Communications Port on page 5. 


2. Ensure all hardware is connected and working as specified using the Ping tool.  Refer to 


the section Ping Function on page 6. 


3. Click the Terminal or Reader’s Select checkbox. 


 


 


Readers connected to a Terminal have the same fixed address as the Terminal itself.  When upgrading 


a Terminal and its Readers, ensure that you select the checkboxes of both the Readers and the 


Terminal. 


 


4. Click the Upgrade button. 


 


 


The Force Upgrade checkbox forces an upgrade on a unit that has a newer firmware version than is 


available with your current IXP220 Software Suite.  We recommend that you do not use this feature. 


 


 


The ImproX iTT, iTRT, MDR and MDK allow for Zero Downtime Upgrade Support.  During a firmware 


upgrade the affected Hardware continues to operate as expected, however for the ImproX MDR and 


MDK the LED flickers intermittently while the new file uploads.  Once the upgrade is complete, a reset 


(about 30 seconds) takes place for the new firmware to load.  During this reset, the related Hardware 


will not read Tags. 


 


Display Firmware Versions (Available on the Software CD) 


 


From the Config drop-down menu, select File Versions to view firmware file versions available 


on the local IXP220 Installation. 


 







Part 7 – Utilities 


8  February 2012 


Additional Features 


SSeett  tthhee  LLooggiiccaall  AAddddrreessss  


Change the Logical Address of your Controller or Terminal as follows: 


 


1. Click the Advanced radio button. 


2. In the Controller group, select the Set Logical Address button. 


3. Select the Controller or Terminal radio button. 


4. In the Fixed Address textbox, enter the Fixed Address. 


5. In the active Logical Address textbox, enter the new Logical Address for the Controller or 


Terminal. 


6. Click the OK button. 


 


CClleeaarr  tthhee  CCoonnttrroolllleerr’’ss  MMeemmoorryy  


This option clears the Controller’s memory, including details of all transactions.  Because of the 


complexities of this feature, we advise that only approved Distributors or Impro Technical 


Support Staff use it.  Therefore, please contact your Impro Distributor for support. 


 


LLooccaalliissaattiioonn  aanndd  TTrraannssllaattiioonn  


Localisation and Translation lets Users from different locales (countries and geographical 


locations), use the Firmware Upgrade Utility in their own language. 


 


Choose Locale 


1. From the Menu Bar, select File>Choose Locale. 


 


 
Figure 3 – Locale Chooser Dialog 


 


2. In the Locale Chooser dialog, from the Language drop-down list, make your selection. 


3. From the Country drop-down list, make your selection. 


4. From the Variant drop-down list, select a language variant based on your previous 


selections (optional). 


5. Click the OK button. 


 


Translating the Software Interface 


1. From the Menu Bar, select File>Translate. 
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Figure 4 – Translate Text :  Dialog 


 


2. In the Translate Text : dialog, from the New Text column, select a phrase to translate.   


 


 


The Original column displays words in English.  The New Text column displays a copy of the English 


words, but it is editable.  This means you can substitute the default words in the New Text column for 


words in your own language. 


 


3. Press the F2 key, thus opening the phrase for editing.   


4. Enter a substitute phrase suitable for your Locale. 


5. Press the Tab key to move to the next phrase. 


6. Repeat steps 3 to 5 for each phrase you wish to edit. 


 


 


Do NOT edit a translation twice in the same session.  Close the application and re-start thus preventing 


loss of the translated data. 


 


7. Click the OK button. 


8. At the Information dialog, click the OK button. 
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Discovery Utility 


Introduction 


 


 


For IXP220 Controllers and Terminals installed on the LAN (that is the local Subnet of the Host 


PC), make use of the Discovery Utility integrated with the IXP220 Base Application.  For IXP220 


Controllers and Terminals installed on a WAN (that is the non-local Subnet of the Host PC), make 


use of the stand-alone Discovery Utility (local to the Controller or Terminal) and export the 


configuration settings to the Host PC.  The Host PC runs the IXP220 Base Application. 


 


The Discovery Utility is used for detection and configuration of IXP220 Controllers and 


Terminals on a LAN or remote WAN.  The Utility lets you carry out the following actions: 


 


 Detection of Controllers (System Controllers) on the network. 


 Detection of Terminals (Door Controllers) on the network. 


 Configuration of the network address settings. 


 Configuration of the Controller’s settings. 


 Configuration of the Terminal’s settings. 


 


We recommend you carry out configuration using the following sequence: 


  


1. View the Controllers and Terminals on the Network. 


2. Confirm or change the IP Address and set the Address to static. 


3. Change the default password to a suitable password for your site.  


 


 


Ensure that you keep the same password across all Controllers. 


 


4. Group each Controller with the Terminal it should control. 


5. Configure each Controller and its grouped Terminals.  (This step is optional - default 


settings should do for most sites).  


6. Select all the Controllers and Terminals for your site and export their settings to a file. 


7. Check the file exists and contains the data for auto-id. 


 


Viewing Available Controllers and Terminals 


 


 


Ensure the PC running Discovery is on the SAME subnet as the IXP220 Controllers or Terminals for 


viewing. 


 


VViieeww  AALLLL  AAvvaaiillaabbllee  IIXXPP222200  CCoonnttrroolllleerrss  aanndd  TTeerrmmiinnaallss  oonn  tthhee  LLooccaall  SSuubbnneett  


1. Using your chosen method, open the Discovery Utility: 


a. From the Base Application, from the Menu Bar, select Hardware>Unit Discovery.   
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b. Alternatively, start the stand-alone Discovery Utility from Windows® by going to 


Start>All Programs>IXP220>Utils>Discovery Utility. 


2. On the Menu Bar, go to Network>Search Local Subnet. 


3. If the Utility fails to find any Devices, at the Device Not Found dialog, click the OK button. 


4. On the Menu Bar, go to Network>Advanced Local Search. 


 


By selecting Advanced Local Search, you may select the correct Network Interface (only 


displayed where more than one exists) and enter the correct Subnet Mask.  If the search 


returns Controller or Terminal details, the Utility (while running) retains the Network Interface 


and Subnet Mask information for further searches.  You may however, use Advanced Local 


Search again during the session for further searches using different search criteria. 


 


5. Select the relevant Network Interface, if more than one displays. 


6. Click the OK button. 


7. In the Input dialog, in the textbox, enter the Subnet Mask for your network. 


8. Click on the  button.  Wait for the Controllers and Terminals to display. 


 


 


Sort the information displayed in either ascending or descending order by selecting the column header.   


 


VViieeww  aa  SSPPEECCIIFFIICC  CCoonnttrroolllleerr  oorr  TTeerrmmiinnaall  


1. On the Menu Bar, go to Network>Search IP. 


2. In the Enter IP Address dialog, enter the IP Address of the Controller or Terminal you’re 


searching for. 


3. Click on the  button.  Wait for the Controller or Terminal to display. 


 


On display of Controllers and Terminals, the following icons appear: the  icon represents 


unlinked Controllers.  The  icon represents Terminals and the  icon represents 


Controllers with linked Terminals.  On expanding the Controller tree, the  icon displays, with 


the linked Terminals displaying below.   


 


Secure Logon 


Accessing certain menu choices needs a secure logon (activating after about 12 seconds).  You 


remain logged on to the selected Controller or Terminal until you select another Controller or 


Terminal and choose a menu alternative needing a logon.  You will also have to logon to the 


Controller or Terminal again after changing the IP Address, clearing the memory or changing the 


configuration. 


 


1. In the Device Password dialog, enter your password.  The default password is 


masterkey, for improved security we recommend that you change this password. 


2. Click on the  button. 


 


CChhaannggee  tthhee  SSeeccuurree  LLooggoonn  


1. From the Menu Bar, select Configuration>Change Password. 


2. Logon if requested. 
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3. In the Enter New Password textbox enter a new password (not exceeding 16 characters) 


for the selected Controller or Terminal.   


4. In the Confirm New Password textbox re-enter your chosen password. 


5. Click on the  button. 


 


Grouping Controllers and Terminals 


On display of Controllers and Terminals, the following icons appear: the  icon represents 


unlinked System Controllers.  The  icon represents Terminals and the  icon represents 


System Controllers with linked Terminals.  On expanding the System Controller tree, the  


icon displays, with linked Terminals displaying below. 


 


Creating the Group and Adding Controllers 


 


 


It is unnecessary to give a group name to a Controller if it has no IP Terminals. 


 


1. Select the Controller and the Terminal’s it should control. 


2. On the Menu Bar, go to Configuration>Add to Group. 


 


 


Alternatively, right-click and select Add to Group from the pop-up menu. 


 


3. In the Enter Group Name dialog, enter a suitable group name for the selected Controllers.  


4. Logon if requested (see page 12).  A password is required for each Controller and Terminal 


being added to the Group. 


5. Click the  button. 


 


Adding Terminals to Existing Controller Groups 


1. Select the Terminal(s) to be added to the Group. 


2. On the menu bar, go to Configuration>Add to Group. 


 


 


Alternatively, right-click and select Add to Group from the pop-up menu. 


  


3. In the Select the Group Name dialog, double-click on your chosen group name row. 


4. Logon if requested (see page 12). 


5. Click the  button. 
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Communication Configuration – Case Local 


CCoonnffiigguurree  tthhee  CCoonnttrroolllleerr  oorr  TTeerrmmiinnaall’’ss  SSttaattiicc  IIPP  AAddddrreessss  ((EEtthheerrnneett))    


 


 
Figure 5 – Case Local—Configure the Controller or Terminal’s Static IP Address (Ethernet)  


 


 


If a DHCP server is present, IP Addresses are dynamically assigned initially.  Obtain a suitable IP 


Address from your Network Administrator.  A private static IP Address is essential for the Controller or 


Terminal because a DHCP Server may assign a new IP Address resulting in the Software losing 


communications.   


 


If the Controller or Terminal is NOT on the DHCP Server, ensure the PC is on the same IP Range as 


that of the Controller or Terminal.  If the PC’s IP Range differs, you cannot change the Controller or 


Terminal’s settings. 


 


1. From the IXP220 Base Application, from the Menu Bar, select Hardware>Unit Discovery. 


2. In the Discovery Utility window, select the Controller or Terminal for configuration. 


3. From the Menu Bar, select Network>Configure IP. 


4. Logon if requested (see page 12).                 
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Figure 6 – Configuration Settings Dialog 


 


 


By assigning an invalid IP Address, the Controller or Terminal may no longer communicate.  


Refer to the Hardware Installation Manual for information on restoring factory defaults. 


 


5. In the Device IP Address textbox, enter a Device IP Address. 


6. Tick the checkbox to set the IP Address to Static. 


7. In the Gateway IP Address textbox, enter a Gateway IP Address.   


8. Tick the checkbox to set the Gateway IP Address to Static. 


9. Continue with ONE of the procedures (Subnet Mask or Subnet Host Bits) that follow: 


 


Subnet Mask 


a. Select the Subnet Mask radio button. 


b. In the textbox, alongside, enter the Subnet’s Address.   


c. Tick the checkbox to set the Subnet Mask to Static. 


 


Subnet Host Bits 


a. Select the Subnet Host Bits radio button. 


b. Enter the number of bits in the textbox. 


 


10. If necessary, amend the supplied Device Name.  Use the same site prefix to name devices 


belonging to the same site.  For example: ―Site_1–Factory‖, ―Site_1–Testing‖ and so on. 


Changes to the IP Configuration result in the Controller or Terminal rebooting on acceptance 


of the change.  The Configuration Settings dialog remains open while allowing the Controller 


or Terminal to reboot.  On closure of the dialog, the Utility again searches for the Controller 


or Terminal and if successful, displays the updated details. 


11. Ensure the Force Update checkbox is UNCHECKED.  If the Force Update checkbox 


remains unchecked, the Controller or Terminal changes the IP Address testing 


communication on the new Address.  If successful, the update becomes final; if not, the 


Controller or Terminal reverts to its old settings. 


12. Click the Update button. 


 


After detection and configuration it’s not necessary to assign a Logical Address, as the IXP220 


Auto-ID process does this.  It is not necessary to export the settings to a file. 
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Communication Configuration – Case Remote 


OOppttiioonn  11::    CCoonnffiigguurree  tthhee  CCoonnttrroolllleerr  oorr  TTeerrmmiinnaall’’ss  SSttaattiicc  IIPP  AAddddrreessss  ((EEtthheerrnneett))    


 


 
Figure 7 – Case Remote—Configure the Controller or Terminal’s Static IP Address (Ethernet)  


 


Use the stand-alone Discovery Utility on the same local Subnet as the IXP220 Controllers or 


Terminals for configuration.  You may temporarily install and pre-configure the Controllers or 


Terminals on any convenient Subnet, local to the PC running the Discovery Utility.  After 


configuration, move the Controllers or Terminals to the remote location.  Alternatively, install the 


Discovery Utility on a PC on the remote Subnet.  Export the settings to a file for manual entry 


into the IXP220 Base Application.     


 


 


If a DHCP Server is present, IP Addresses are dynamically assigned initially.   


 


If the Controller or Terminal is NOT on the DHCP Server, ensure the PC is on the same IP Range as 


that of the Controller or Terminal.  If the PC's IP Range differs, you cannot change the Controller or 


Terminal’s settings.  A public static IP Address is essential for the Controller or Terminal because the 


Controller or Terminal is destined for a WAN.   


 


1. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


2. In the Discovery Utility window, select the Controller or Terminal for configuration. 


3. From the Menu Bar, select Network>Configure IP. 


4. Logon if requested (see page 12).               
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Figure 8 – Configuration Settings Dialog 


 


 


By assigning an invalid IP Address, the Controller or Terminal may no longer communicate.  


Refer to the Hardware Installation Manual for information on restoring factory defaults. 


 


5. In the Device IP Address textbox, enter a Device IP Address. 


6. Tick the checkbox to set the IP Address to Static. 


7. In the Gateway IP Address textbox, enter a Gateway IP Address.   


8. Tick the checkbox to set the Gateway IP Address to Static. 


9. Continue with ONE of the procedures (Subnet Mask or Subnet Host Bits) that follow: 


 


Subnet Mask 


a. Select the Subnet Mask radio button. 


b. In the textbox, alongside, enter the Subnet’s Address.   


c. Tick the checkbox to set the Subnet Mask to Static. 


 


Subnet Host Bits 


a. Select the Subnet Host Bits radio button. 


b. Enter the number of bits in the textbox. 


 


10. If necessary, amend the supplied Device Name.  Use the same site prefix to name devices 


belonging to the same site.  For example: ―Site_1–Factory‖, ―Site_1–Testing‖ and so on. 


 


 


If the Force Update checkbox remains UNCHECKED, the Controller or Terminal changes the IP 


Address testing communication on the new Address.  If successful, the update becomes final; if 


not, the Controller or Terminal reverts to its old settings. 


 


Changes to the IP Configuration result in the Controller or Terminal rebooting on acceptance 


of the change.  The Configuration Settings dialog remains open while allowing the Controller 


or Terminal to reboot.  On closure of the dialog, the Utility again searches for the Controller 


or Terminal and if successful, displays the updated details. 


11. Ensure the Force Update checkbox is CHECKED when assigning an Address on an 


external subnet.  The Controller or Terminal changes the IP Address and reboots.  If the 


Address points outside the Local Subnet, the Controller or Terminal is not found until it’s 


physically moved to the new location. 
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12. Click the Update button. 


13. From the Menu Bar, select File>Export IP Config. 


14. In the Save dialog, click the Save button (by default this file is named discovery.txt, you 


may however change this file name). 


15. Exit the Discovery Utility. 


16. Send a copy of the exported Discovery file (discovery.txt) to the Host Location. 


17. If locally pre-configured, move the Controller or Terminal to its remote location. 


 


 


After installing the Controller or Terminal in its new location, you can find it by going to 


Network>Search IP. 


 


OOppttiioonn  22::    CCoonnffiigguurree  tthhee  CCoonnttrroolllleerr  oorr  TTeerrmmiinnaall’’ss  PPuubblliicc  HHoosstt  NNaammee  ((EEtthheerrnneett))    


Use this option where you install your IXP220 Controller or Terminal behind a Router with a 


public hostname resolved to an IP Address.  In this scenario, the Router is setup (by your 


Network Administrator) to route data to the separate Controllers or Terminals via the port 


numbers uniquely associated with them.  Detection of Controllers or Terminals using the 


Discovery Utility is only done locally, that is on the Local Subnet, behind the Router.  To address 


the Controller or Terminal from the world beyond the Router, the local IP Address of the 


Controller or Terminal must change to the Router’s public hostname.  


 


 


Figure 9 – Case Remote—Configure the Controller or Terminal’s Public Host Name 


(Ethernet)  


 


1. Select a UNIQUE Communication Port Number for the IXP220 Controller or Terminal.  


2. Program the Router to direct all data destined for that port to the Controller or Terminal.  


3. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


4. In the Discovery Utility window, select the Controller or Terminal for configuration.   


5. From the Menu Bar, select Network>Configure IP. 


6. Logon if requested (see page 12).                 


7. Allow the DHCP assigned addresses to remain and set as static or obtain a static address 


from your network administrator. 


8. If necessary, amend the supplied Device Name.   
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Change the Secure Logon and Clear the Controller or Terminal’s memory as required. 


 


9. Change the Communication Port Number to the unique port number set up on the Router 


(see page 23). 


10. From the Menu Bar, select File>Export IP Config. 


11. In the Save dialog, click the Save button (by default this file is named discovery.txt, you 


may however change this file name according to your needs). 


12. Exit the Discovery Utility. 


13. Send a copy of the exported Discovery file (discovery.txt) to the Host Location. 


 


In the IXP220 Software now add a new communication channel to your selected Site, either 


manually or by importing the file you exported earlier (discovery.txt).  If the file is imported, the 


Port Number is correct and you need only change the IP Address to the Router’s public 


Hostname.  Auto-ID continues as normal.  See Part 3 – General Configuration for full details on 


this procedure. 


 


OOppttiioonn  33::    CCoonnffiigguurree  tthhee  CCoonnttrroolllleerr’’ss  MMoobbiillee  SSeettttiinnggss  ((GGPPRRSS))  


 


 


This connection option is not supported where you have Controllers connected (by RS485) to the 


GPRS enabled Controller. 


 


 


When configuring the GSM Module for GPRS and SMS ensure that you obtain a PUBLIC Access Point 


Name (APN) from your Mobile Service Provider. 


 


 


When using a Hostname instead of an IP Address, ensure that you have access to a PC with an active 


Internet connection. 


 


 


This option only applies to the IXP220 Controller fitted with a GSM Module. 


 


Configuration for GPRS and SMS 


 


 


Pre-configure the Controller with the Controller connected to the local LAN.  After pre-configuration, 


remove the network connection from the Controller. 


 


Pre-configuration, get the following from your Mobile Service Provider: 


 


 Buy a SIM Card (you will need the PIN and PUK numbers for this SIM Card). 


 Get a public Access Point Name (APN). 


 Confirm details for the SMS Service Centre. 


 Have the Username and Password for the Access Point Name (APN) available (only 


needed in some instances). 


 


And from a Dynamic Domain Name Service Provider, get the following: 


 


 Select one of the supported Providers, namely changeip.org, dyndns.com or no-ip.com. 


 Register a Hostname for your IXP220 Controller with your chosen Provider. 


 Register a Username and Password for your IXP220 Controller. 
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 Register a Hostname for the PC hosting the IXP220 Software, or use a public static IP 


Address. 


 


 


Both Hostnames must resolve to a public IP Address, they cannot remain blank. 


 


1. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


2. In the Discovery Utility window, select the Controller for configuration.   


3. From the Menu Bar, select Network>Configure Mobile Settings. 


4. Logon if requested (see page 12).  


 


 
Figure 10 – Configure Mobile Settings Dialog 


 


 


The Signal Strength icon on the Status bar indicates the signal strength being experienced by the 


Controller’s GSM Module.  5 Bars indicates maximum signal strength. 


 


5. Complete the fields under the header Mobile Service Provider: 


 SIM PIN—this is the Personal Identification Number (PIN), a numerical combination of 


up to 5 digits, supplied with your SIM Card.  Wrong entry of the PIN (more than 3 times) 


locks the SIM Card.    


 SIM PUK—this is the PIN Unlock Key.  This number offers protection of the device and 


SIM Card with the PIN.  Entry of the wrong PUK (more than 10 times) permanently 


blocks the device, a new SIM Card is then required.     


 SMS Service Centre—the contact number for the repository that stores messages for 


delivery to the destination user when they are available.  Stored on the SIM Card, this 
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number may not come into sight until you activate your mobile settings.  If you wish to 


use the service and the number does not finally appear, contact your service provider 


for assistance. 


 Access Point Name (APN)—this is the name used to identify a public (free) GPRS 


bearer service in the GSM mobile network.  The Access Point Name (APN) defines the 


type of service provided in the packet data connection.  


 APN Username—possibly needed for the Access Point Name (APN). 


 APN Password—possibly needed for the Access Point Name (APN).        


6. Ensure the Configure for GPRS and SMS radio button is selected (default).    


7. Under the header Dynamic Domain Name Service, From the Dynamic DNS Provider 


drop-down list, select one of the supported Providers. 


8. In the Dynamic DNS Hostname textbox, enter the registered IXP220 Controller’s 


Hostname. 


9. In the Dynamic DNS Username textbox and Dynamic DNS Password textbox, enter the 


registered Username and Password respectively for your IXP220 Controller. 


10. In the Host PC IP Address textbox, enter the public static IP Address. 


 


 


When using a SIM Card with a single static IP Address, enter the public static IP Address of the Host 


PC, not the Hostname.  Contact your Mobile Service Provider for more information on your SIM Card. 


 


11. Click the Apply button.   


 


The Discovery Utility captures the configuration information and forwards the information on to 


the Controller for activation.  The Controller starts the process of establishing a GPRS 


connection.  The Discovery Utility queries the Controller for status until the Utility gets a result. 


During the verification process there is an approximately 60-second time-out.   


 


The Discovery Utility decides on the success of the configuration.  At the end of the verification 


process, the Status bar at the bottom of the Configure Mobile Settings dialog, displays the 


status of the configuration.  Possible status messages include:   


 


 Listening—this is the desired status message. 


 GSM Module Not Present—indicates the GSM Module is removed or uninstalled. 


 GSM Module Present—Controller is aware the GSM Module is connected; however 


the Controller is busy going through the connection process. 


 SIM PIN or PUK Error—indicates you have captured the wrong PIN or PUK number. 


 GPRS Network Error—indicates the GSM Module cannot connect to the Network. 


 APN Error—indicates the wrong APN Name was captured.  This message also appears 


however, where you have exceeded your data cap or you have no available airtime on 


your SIM Card.    


 DDNS Error—indicates there is an error with the captured DDNS parameters. 


 Connected—connected status only occurs if a Controller was already configured and 


currently connected by GPRS to the IXP220 Software while still connected by Ethernet. 


 


 


If the connection is not established, the Controller may begin the verification process again.  In an 


instance where the verification process times out, click the Query Status button manually requesting 


the status.   


 


 


If you do NOT get the status Listening, correct any errors and then press the Apply button again. 
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On acceptance of the settings, the GPRS parameters are written to the DiscoveryGSM.txt file. 


The IXP220 Software automatically imports this file for permanent storage in the Database (in 


case of Hardware replacement). 


 


12. On achieving the Listening status, close the Configure Mobile Settings dialog. 


13. Export the configuration file, from the Menu Bar, select File>Export IP Config. 


14. Click the Save button. 


15. Exit the Discovery Utility. 


16. Send both the DiscoveryGSM.txt and Discovery.txt files to the Host PC (ensuring you 


place both files in the same destination folder) before beginning the Auto-ID process. 


17. Disconnect the IXP220 Controller from the LAN. 


18. Reboot the Controller.   


19. Continue with the Auto-ID process (see Part 3 – General Configuration for more information 


on this process). 


 


Configuration for SMS Only 


 


 


A public Access Point Name (APN) is NOT required for SMS only. 


 


In instances where your Controller connects by Ethernet, but you still require SMS capability, 


continue as follows: 


 


 
Figure 11 – Configure Mobile Settings Dialog 


 


 


The Signal Strength icon on the Status bar indicates the signal strength being experienced by the 


Controller’s GSM Module.  5 Bars indicates maximum signal strength. 


 


1. In Windows®, go to Start>All Programs>IXP220>Utils>Discovery Utility. 


2. In the Discovery Utility window, select the Controller for configuration.   


3. From the Menu Bar, select Network>Configure Mobile Settings. 


4. Logon if requested (see page 12).  


5. Ensure the Configure for SMS Only radio button is selected.  


6. Complete the fields under the header Mobile Service Provider: 


 SIM PIN  


 SIM PUK  


 SMS Service Centre  


7. Click the Apply button. 
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Your setup is complete and working correctly when you receive the Status message SMS 


Configuration Completed.  We recommend that you test the connection by clicking the Test SMS 


button.  Where called for by your country and or your service provider, precede the recipient’s mobile 


number with the country code.         


 


Configure the Port Number  


 


 


This is an advanced feature; use the feature only if required.   


 


 


After making changes to one or more Controller or Terminal’s Configuration Settings, ensure 


that you export the configuration file for entry into the IXP220 Base Application. 


 


Using the Discovery Utility, view or configure the Port Number of the Controller or Terminal as 


follows: 


1. Select the Controller or Terminal for configuration. 


2. From the Menu Bar, select Configuration>Set Configuration. 


3. Logon if requested (see page 12). 


4. In the Communication Port Number textbox, change the Port Number.  The default Port 


Number is 10005 for Controllers and 10008 for Terminals.  Only change the default Port 


Number if it clashes with other devices or services on your network. 


5. In the Terminal Listener Port textbox, change the Port Number (Controller listens to 


Terminals on this Port).  The default Port Number is 10008.  Only change the default Port 


Number if it clashes with other devices or services on your network or if you communicate 


with the Terminal over a WAN using Port Fowarding. 


6. Tick the Safe IP checkbox, thus ensuring that the Controller or Terminal only responds to 


the Host PC. 


7. Click the  button to confirm. 


8. Wait while the Controller or Terminal re-boots (about 15 seconds). 


 


Advanced Features 


CClleeaarr  tthhee  CCoonnttrroolllleerr  oorr  TTeerrmmiinnaall’’ss  MMeemmoorryy  


This feature lets you clear the Controller or Terminal’s memory (used for storing the Database - 


that is the Tags, Transactions, Terminal Tables, Actions, Time Patterns and so on).   


 


1. Select the Controller or Terminal for configuration. 


2. From the Menu Bar, select Configuration>Clear Memory. 


3. Logon if requested (see page 12). 


  


LLooccaalliissaattiioonn  aanndd  TTrraannssllaattiioonn  


Localisation and Translation lets Users from different locales (countries and geographical 


locations), use the Discovery Utility in their own language. 
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Choose Locale 


1. From the Menu Bar, select File>Choose Locale. 


 


 
Figure 12 – Locale Chooser Dialog 


 


2. In the Locale Chooser dialog, from the Language drop-down list, make your selection. 


3. From the Country drop-down list, make your selection. 


4. From the Variant drop-down list, select a language variant based on your previous 


selections (optional). 


5. Click the OK button. 


 


Translating the Software Interface 


1. From the Menu Bar, select File>Translate. 


 


 
Figure 13 – Translation Selection Dialog 


 


2. Select the Unit for translation, for example:  Main Frame. 


3. Click the corresponding Translate button. 
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Figure 14 – Translate Text :  Dialog 


 


4. In the Translate Text : dialog, from the New Text column, select a phrase to translate.   


 


 


The Original column displays words in English.  The New Text column displays a copy of the English 


words, but it is editable.  This means you can substitute the default words in the New Text column for 


words in your own language. 


 


5. Press the F2 key, thus opening the phrase for editing.   


6. Enter a substitute phrase suitable for your Locale. 


7. Press the Tab key to move to the next phrase. 


8. Repeat steps 5 to 7 for each phrase you wish to edit. 


9. Click the OK button. 


10. Repeat steps 1 to 9 for the remaining Units for translation. 


11. Click the Close button. 


 


 


Do NOT edit a Module’s translation (for example Main Frame), twice in the same session.  Close the 


application and re-start thus preventing loss of the translated data. 
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Universal Data Exporter Utility  


Introduction 


The Universal Data Exporter Utility lets you extract transaction (including time and attendance) 


records from the IXP220 Database for use by third-party applications.  The Exporter Utility 


makes use of user defined templates (created in Design Mode) that specify the data for 


extraction and the export format.   


 


Using the Run Mode, you have the choice of exporting the records interactively or as scheduled 


(using Windows® Scheduler).  Command line arguments specify the Mode and other 


parameters. 


 


On installation of the IXP220 Software V1.80 (and upwards), two additional Utility shortcuts 


appear on the Programs Menu.  These are Universal Data Exporter (Designer) (used for 


Design Mode) and Universal Data Exporter (used for Run Mode).    


 


 


This Utility requires advanced knowledge of SQL.   


 


Opening the Utility 


In Windows®, go to Start>All Programs>IXP220>Utils>Universal Data Exporter (Designer). 


 


Template Creation (Design Mode) 


1. From the toolbar, click the  button.  


2. If no template exists, at the Message dialog, click the OK button. 


3. Enter your Username and Password. 


 


 


The default administrator username is SYSDBA, and the default password is masterkey. 
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Figure 15 – Template File Tab 


 


TTeemmppllaattee  FFiillee  TTaabb  


1. In the Template Name textbox, enter a name for the template (template files must have the 


file extension tpl).  Find this file in the subfolder Templates in the installation folder.   


 


 


Alternatively, load an existing template by clicking the Browse button (alongside the Template Name 


textbox) and selecting the template file.   


 


2. In the Export Filename textbox, specify a name for the exported file.  


3. In the Export Directory Path textbox, specify the export directory details. 


4. From the Export Filename group, select one of the following radio buttons: 


 Leave Unchanged—lets you export the filename unchanged. 


 Append ISO Date—lets you attach an ISO formatted date to the filename. 


 Append ISO Date/Time to Filename—lets you attach an ISO formatted date and time 


to the filename. 
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5. Select either the Append to File or Overwrite File radio button. 


6. Select the End of Line Character required: 


 CR & LF—the Carriage Return (CR) & Line Feed (LF) option is selected by default for 


Windows®.   


 CR Only—Carriage Return (CR) Only. 


 LF Only—Line Feed (LF) Only. 


 


EExxppoorrtt  FFoorrmmaatt  TTaabb  


Build Export Format 


1. Select the Export Format Tab. 


 


 
Figure 16 – Export Format Tab 


 


A suggested SQL Query (specific to the product database) displays.  You may edit this Query 


including other fields or restricting the record set selection. 
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Edit this SQL Query at your own risk.  Knowledge of the System Database Tables and of SQL is 


essential during editing.  If you mistakenly edit the SQL Query click the Reset Query button to return to 


the default SQL Query. 


 


 


The query includes placeholders for a Start and End Date for the selected transaction records.  You 


may specify these at runtime using command line arguments (for example: START_DATE=20090101).  


Note that the End Date is NOT inclusive, so the Utility exports from the Start Date up to and including 


the day before the End Date.  If you do not want the Start and End Date for the selection, or you intend 


using Windows® Scheduler, then delete the date parameters.     


 


Similarly you may include a site placeholder as AND field_name=%SITE% where for example 


field_name is S_ID.  An example of the query with the placeholders specified could look as follows:  


and TR_DATE>=2009 0101 and TR_DATE<20090131 and t.s_ID=1. 


 


 


Expand your transaction results beyond time and attendance by changing the TA value in the query to 


TA=0. 


 


2. Click the Execute SQL Query button. 


3. In the Input dialog, enter a Start Date, using the yyyymmdd format. 


4. Click the OK button. 


5. Enter the End Date, again using the supplied format. 


6. Click the OK button. 


7. If prompted, enter the Site Number (that is 1 for IXP220 Systems with 1 Site).   


8. Click the OK button.  Once successfully executed, the Select Field drop-down list 


populates. 


9. Start building the export format, column by column using one or both of the following 


methods: 


 


Select Field Method 


For using fields stored in your Database, continue as follows: 


 


1. From the now-populated Select Field drop-down list, select a field. 


2. Alongside the Select Field drop-down list, click the Format button.  The Format Field 


dialog opens giving you various choices specific to the field selected, edit these fields 


as needed: 


 Selected Field—displays the actual data found in this field. 


 Format Pattern—based on the field selected, you may choose from the following 


choices:   


 None—adds the field value exactly as stored in the database. 


 Fixed Length—field value truncated (only if selected) or padded to the required 


length with the fill character in the direction named. 


 dd/MM/yyyy—this applies only to a date field stored as an integer yyyymmdd. 


The d represents day, dd represents the double-digit day preceded by a 0 as 


necessary and MM represents double-digit month.  Alternatively use MMM 


representing the 3-letter abbreviation of the month name.  The yyyy represents 


a 4-digit century and yy represents the last 2 digits of the century.  The / 


represents the date separator, you may, however, use any preferred separator. 


 HH:mm—this applies to a time field stored as an integer hhmmss.  The HH 


represents the double-digit hour of day, mm represents the double-digit minute 
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of the hour and ss represents the double-digit second of the minute.  The : 


represents the time separator, you may, however, use any preferred separator. 


 I/O—this applies only to the integer Direction field stored as 1 (In) (formatted as 


I) and 0 (Out) (formatted as O).  You may specify alternative characters 


separated by a ―/‖, for example In/Out. 


 Clock# d—this applies only to the Name field of a Door (Location).  If a number 


follows the last space in the name, it’s interpreted as a number.  This would be 


a way for the user to give a specific number to the time attendance point, for 


example TA Reader 1.   


 


 


If the name does not follow this convention then the formula fails for this field and the record will not 


export. 


 


 Use Field Delimeter—select this checkbox, if a field delimiter must follow the field. 


 Delimiter Character—allows selection of the character used to separate fields in 


the output record.   


 Fill Char—the character used when padding a field value to the chosen length in 


the direction named. 


 Length—extends the field output to the number of characters named. 


 Truncate—select whether output must be shortened. 


 Fill Left—select this alternative if you want the fill characters to fill from Left. 


 Fill Right—select this alternative if you want the fill characters to fill from Right. 


3. Click the Test button and make sure that the Output meets your expectations. 


4. Click the OK button. 


 


Enter Fixed Data Method 


For entering constant information not physically stored in your Database, this could include 


for example a Company Registration Number. 


 


1. Select the Fixed Data radio button. 


2. Enter the required data. 


3. Click the Add button. 


 


The fixed data appears in the Build Export Format text area, enclosed in square brackets.  


You may also add a delimiter in this way if needed. 


 


10. After editing the choices mentioned in point 9, click the Test button.  The Output and Format 


textboxes complete as follows: 


 Output—shows a sample of the output record. 


 Format—formula used to construct the output from the data. 


11. Click the OK button. 


 


 


As you edit Fields from the Select Fields drop-down list, they appear in the Build Export Format text 


area, midway on the Universal Data Exporter Utility dialog.  Clicking the Test button displays a sample 


record (in the Export Output Record text area) based on the choices you made in the Format Field 


dialog.  The Clear button lets you delete first the delimiter and then the field from the Build Export 


Format text area.   
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Should you incorrectly add field information in the Build Export Format text area, position your cursor at 


a suitable point and delete the necessary field information.  After you have added new field information 


your cursor automatically reverts to the end of the field list.  Alternatively, reposition the cursor at the 


end of the field list yourself and continue adding fields in the usual manner. 


 


12. Select the Mark Records Successfully Exported checkbox (if required). 


 


 


The Transact table in the Database has an integer field called TR_PROCESSED.  Its value is set to 


zero when the transaction is added to the Database.  You may, however, set this value to 1 after export 


of the record, to distinguish it from other records.  To use this successfully, add the clause AND 


TR_PROCESSED=0 to the Selection SQL Query thus excluding records already exported. 


 


13. Click the Save button. 


 


Export Data (Run Mode) 


1. From the toolbar, click the  button. 


 


 
Figure 17 – Export Transactions From Database Dialog 


 


If you did not supply a template file name as a command line argument, the file name default.tpl 


is assumed.  The template loads with any other arguments, for example:  Site, Start Date or End 


Date. 
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Click the Browse button alongside the Template textbox to select a different template. 


 


2. Click the Export button.   


 


The formatted export records display in the Data text area.  Depending on the number of 


records in the set, the export process may take some time.  Only every 100
th
 record exported 


displays thus preventing the user interface from becoming overloaded.  Wait until the message 


***** Export ended ***** displays in the Status textbox. 


 


Advanced Features 


CCoommmmaanndd  LLiinnee  AArrgguummeennttss  


The Universal Data Exporter Utility also lets you assign arguments using the command line.  


This advanced alternative automates tasks, simplifying the process.   


 


A typical command line argument appears as follows:  "C:\IXP220\bin\Universal Data 


Exporter.exe" mode=run template=default.tpl site=1 startdate=20090101 


enddate=20090131 run= auto.  The text above (in bold) represents a few typical (optional) 


arguments. 


 


 


Ensure that you precede listed arguments with a space as shown earlier.  Note however that spaces 


are NOT allowed within the individual arguments, that is startdate= 20080901 is not allowed, 


startdate=20080901 is correct.  


 


Access the command line as follows: 


   


1. In Windows®, navigate to Start>All Programs>IXP220>Utils. 


2. Right-click the Universal Data Exporter program name. 


3. From the Menu, select the Properties choice. 


4. Select the Shortcut tab if not already selected. 


5. In the Target textbox, at the end of the "C:\IXP220\bin\Universal Data Exporter.exe" 


phrase, add any of the following arguments: 


 mode=design—drives the Utility to open in Design Mode.  This Mode provides the 


tools necessary for template creation. 


 mode=run—drives the Utility to open in Run Mode (default).  This Mode provides the 


tools necessary for export of transactions.  When used without any further supporting 


arguments, the Utility runs interactively, this requires that you manually supply the Start 


Date and End Date before export takes place.   


 template=filename.tpl—specifies the template file for use by the Utility.  If no template 


file exists, the Utility exits in Run Mode.  The default value is default.tpl. 


 run=auto—ignored when you specify Design Mode.  When named alongside the Run 


Mode argument, the Utility runs without user intervention and exits when complete.  


Export of transactions, not marked as exported, takes place according to the Start Date, 


End Date and Schedule details.   


 site=ddddd—specifies the site for which transactions are to be exported.  If not named, 


the Utility exports transactions for all sites. 


 schedule=sd—when used with the Auto argument the Utility automatically extracts 


transactions for yesterday’s date only. 
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 schedule=sw—when used with the Auto argument the Utility automatically extracts 


transactions for the last seven days ending yesterday. 


 schedule=sm— when used with the Auto argument the Utility automatically extracts 


transactions for the month ending yesterday.   


 


 


The Schedule argument runs best when used with the run=auto argument and with Windows® 


Scheduler.  


 


 startdate=yyyymmdd—the Start Date in ISO format, specifies the earliest date that 


transactions are required.  The Utility ignores this argument when you specify a 


Schedule. 


 enddate=yyyymmdd—the End Date in ISO format, specifies the last date that 


transactions are required.  The Utility ignores this argument when you specify a 


Schedule. 


 


 


Transactions for the startdate and enddate will be included depending on how the query is stated, for 


example TR_DATE  <= %END_DATE%.  


 


6. Click the Apply button. 


7. Click the OK button. 


 


LLooccaalliissaattiioonn  aanndd  TTrraannssllaattiioonn  


Localisation and Translation lets Users from different locales (countries and geographical 


locations), use the Utility in their own language. 


 


Choose Locale 


1. From the Menu Bar, select File>Choose Locale. 


 


 
Figure 18 – Locale Chooser Dialog 


 


2. In the Locale Chooser dialog, from the Language drop-down list, make your selection. 


3. From the Country drop-down list, make your selection. 


4. From the Variant drop-down list, select a language variant based on your previous 


selections (optional). 


5. Click the OK button. 
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Translating the Software Interface 


1. From the Menu Bar, select File>Translate. 


 


 
Figure 19 – Translate Text :  Dialog 


 


2. In the Translate Text : dialog, from the New Text column, select a phrase to translate.   


 


 


The Original column displays words in English.  The New Text column displays a copy of the English 


words, but it is editable.  This means you can substitute the default words in the New Text column for 


words in your own language. 


 


3. Press the F2 key, thus opening the phrase for editing.   


4. Enter a substitute phrase suitable for your Locale. 


5. Press the Tab key to move to the next phrase. 


6. Repeat steps 3 to 5 for each phrase you wish to edit. 


 


 


Do NOT edit a translation twice in the same session.  Close the application and re-start thus preventing 


loss of the translated data. 


 


7. Click the OK button. 


8. At the Information dialog, click the OK button. 
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Database Conversion Utility 


Introduction 


The Database Conversion Utility converts existing IXP120 or IXP200 Databases for use in 


IXP220.  The Conversion Utility uses the same ImproX RS Registration Interface constraints as 


the IXP220 Software itself.  This means the Utility checks for an ImproX RS Registration 


Interface and then checks the IXP220 System itself, confirming the number of allowed 


Tagholders and so on.   


 


Note, the Utility does NOT move information such as Doors (Locations), Terminals, Controllers 


and so on.  The Utility does move information such as Tagholder details, Tag information, 


Holidays, Messages, Reason Codes, Door Mode Patterns, Access Groups and Access 


Patterns.  Therefore, at start-up, perform an Auto-ID of your Hardware and configure and link 


Doors (Locations) to Access Patterns. 


 


Opening the Utility 


In Windows®, go to Start>All Programs>IXP220>Utils>Database Conversion. 


 


Convert a Database 


 


 


Configure a Site for the Destination Database BEFORE converting the Database.  See Part 3 – 


General Configuration for information on Site Configuration. 


 


 


Backup the Destination Database before carrying out the conversion process. 


 


 


Ensure that the Source Database and Source Type match before beginning the conversion process. 


 


 
Figure 20 – Logon to Database Dialog 


 
1. Enter your Password (masterkey). 


2. From the Source Type drop-down list, select the source Database type. 
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3. Click the Browse button. 


4. Navigate to your source Database. 


5. Click the Open button. 


6. Click the OK button. 


 


 
Figure 21 – Database Conversion Dialog 


 


7. From the Select Site drop-down list, select the Site to populate.  


8. Click the OK button. 
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IB Console Utility 


Introduction 


This Utility lets you perform the following functions to your IXP220 Database: 


 


 Manual upgrades from older versions of IXP220. 


 Database maintenance in the form of checking for errors and performing backup and 


restores of the Database. 


 From IB Console you can review the Database structure, allowing addition of extra tables 


for third-party integration. 


 


Opening the Utility 


In Windows®, go to Start>All Programs>IXP220>Utils>IBConsole. 


 


Manual Upgrade Function 


RReeggiisstteerr  tthhee  SSeerrvveerr  


 


 


You need only perform these steps once.  After registration, the settings remain and you need only 


login to the Server. 


 


 
Figure 22 – Register Server and Connect Dialog 
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1. From the Server drop-down menu, select the Register choice. 


2. In the Register Server and Connect dialog, click the Remote Server radio button. 


3. In the Server Name textbox, assign the Server a name.  In this example, we used 


LOCALHOST. 


 


 


Rather than assigning the Server a name in the Server Name textbox, you may use the PC’s IP 


Address. 


 


4. In the Network Protocol textbox, select TCP/IP from the drop-down list. 


5. In the Alias Name textbox, assign a suitable name. 


6. Leave the remaining fields unchanged. 


7. Click the OK button. 


 


Login to the Firebird Server 


1. From the Hierarchical Tree, select your Firebird Server (based on the example in Figure 22 


select Local Server). 


2. From the Server drop-down menu, select the Login choice. 


3. In the Server Login dialog, enter the Username and Password. 


 


 


The default username is SYSDBA.  The default password is masterkey. 


 


4. Click the Login button. 


 


RReeggiisstteerr  tthhee  DDaattaabbaassee  


 


 
Figure 23 – Register Database and Connect Dialog 
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1. From the Database drop-down menu, select Register. 


2. In the Register Database and Connect dialog, in the Database textbox, enter the full file 


path to your Database (see Figure 23). 


3. Click your mouse pointer in the File textbox, the Database’s file name automatically 


appears. 


4. Leave the remaining fields unchanged. 


5. Click the OK button. 


 


 


The default Database path for the IXP220 Software is:  C:\IXP220\Database\DB220.FDB. 


 


6. In the Hierarchical Tree, double-click on the DB220.FDB file, starting the Database. 


 


Database Maintenance 


PPeerrffoorrmmiinngg  aa  BBaacckkuupp  ooff  tthhee  DDaattaabbaassee  


1. In Windows®, go to Start>All Programs>IXP220>Utils>IBConsole. 


2. From the Database drop-down menu, select Maintenance>Backup/Restore>Backup. 


 


 
Figure 24 – Database Backup Dialog 


 


3. In the Database group, from the Alias drop-down list, select the Database for backup. 


4. In the Backup File(s) group, in the Alias textbox, provide a name for the backed up 


Database. 


 


 


Ensure that your backed up file has an FBK file extension. 
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5. In the Backup File(s) group, in the Filename(s) textbox, provide the directory path and file 


name for the backup Database.  We suggest C:\IXP220\Database\DB220.FBK. 


6. Leave the remaining values as they are. 


7. Click on the OK button. 


8. In the Information dialog, click on the OK button. 


9. Close the Database Backup dialog. 


 


RReessttoorriinngg  tthhee  DDaattaabbaassee  


 


 


Ensure that you shut down the IXP220 Base Application (and any other applications using the 


Database) before disconnecting from the Database. 


 


Disconnect from the Database 


1. In IBConsole from the Hierarchical Tree, click on the DB220.FDB file. 


2. From the Database drop-down menu, select Maintenance>Shutdown. 


3. Click the OK button. 


4. At the Information dialog, click the OK button. 


 


Restore the Backup 


1. In IBConsole, from the Database drop-down menu, select Maintenance> 


Backup/Restore>Restore. 


 


 
Figure 25 – Database Restore Dialog 


 


2. In the Backup File(s) group, in the Alias textbox, select the name of the backed up 


Database.   
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3. If IBConsole does not auto complete the remaining fields continue as follows, otherwise 


continue with point 5: 


 In the Backup File(s) group, in the Filename(s) textbox, provide the directory path and 


file name for the backup database.  We suggest C:\IXP220\Database\DB220.FBK. 


 In the Database group, from the Server drop-down list, select the server in which the 


Database will remain. 


 In the Database group, from the Alias drop-down list, select the Database to restore to. 


 In the Database group, in the Filename(s) textbox, provide the directory path and file 


name for the restored Database.  We suggest C:\IXP220\Database\DB220.FDB. 


4. From the Options group, select the Overwrite record. 


5. From the Overwrite drop-down list, select True. 


6. Click on the OK button. 


7. Close the Database Restore dialog when you see the comment ―Service Ended‖. 


 


Reconnect to the Database 


1. In IBConsole, from the Hierarchical Tree, click on the DB220.FDB file. 


2. From the Database drop-down menu, select Maintenance>Database Restart. 
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Database Archive Utility 


Introduction 


This Utility lets you archive transactions (Normal, Status and Alarms), placing the transactions in 


a separate archived Database.  We recommend that you run the Database Archive Utility on a 


regular basis.  Running the Utility regularly keeps your Database below the maximum 


recommended database size of 2 GB.  This action has the following major benefits: 


 


 Manages the size of the Database, freeing up space on the PC. 


 Keeps a cleaner, uncluttered Database. 


 Keeps Database performance at optimum speed. 


 


Opening and Using the Database Archive Utility 


1. In Windows®, go to Start>Programs>IXP220>Utils>Database Archive. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


 


 
Figure 26 – Database Archive Utility Dialog 


 


SSeelleecctt  tthhee  AArrcchhiivvee  DDaattee  


 


 


This is the end date for the archive.  Your newly archived database will therefore contain all 


transactions for this date and earlier. 
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1. In the Database Archive Utility dialog, from the Archive Date group, click the Change 


button. 


2. In the calendar dialog, click on the Month drop-down list and select the desired month from 


the list. 


3. Click the Year drop-down list and select the year from the list. 


4. From the grid, select the day number. 


 


CCoonnffiirrmm  tthhee  AArrcchhiivviinngg  OOppttiioonnss  


 
Figure 27 – Archiving Options Dialog 


 


1. In the Database Archive Utility dialog, click on the Options button. 


2. In the Archiving Options dialog, click either the Archive or Delete radio button for each of 


the named transaction types. 


 


 


If you select the delete option, confirm the deletion in the Delete Transactions dialog, by clicking on 


the OK button.  After confirmation, the Archiving Options dialog closes automatically. 


 


3. Click on the OK button. 


 


AArrcchhiivvee  tthhee  TTrraannssaaccttiioonnss  


1. In the Database Archive Utility dialog, click on the Archive button. 


2. In the Archiving Options dialog, confirm the archiving details by clicking on the OK button. 


3. In the Archive Complete dialog, click the OK button. 
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Database Pump Utility 


Introduction 


The Database Pump Utility lets you flush out and correct a ―muddled‖ or overloaded Database.  


When executed, the Pump takes ALL data and pumps this into a fresh Database. 


 


 


Before implementing the Database Pump Utility, ensure that you close all other applications. 


 


 


For large Databases, carry out this action over a quiet period, as completion could take many hours. 


  


Opening and Using the Database Pump Utility 


1. In Windows®, go to Start>Programs>IXP220>Utils>Database Pump. 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. Click the OK button. 


 


 
Figure 28 – Pump Database Dialog 


  


4. In the Pump Database dialog, click the Start button. 


5. In the Message dialog, click the OK button. 
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Translate Utility 


Introduction 


This Utility facilitates changing field names in the Database to words of another language.  This 


Utility requires that you manually enter replacement text.  


 


Opening the Utility 


In Windows®, go to Start>All Programs>IXP220>Utils>Translate. 


 


Choose the Locale 


 
Figure 29 – Locale Dialog 


 


1. In the External Translation Utility dialog, click on the  button. 


2. From the Language drop-down list, select the language for use in the translation. 


3. From the Country drop-down list, select the corresponding country. 


4. Click the OK button. 


 


Translate a File 


1. In the External Translation Utility dialog, from File drop-down list, select Open. 


2. In the Open dialog, select the LOCALIZATION.XML file. 


3. Click on the Open button. 
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Figure 30 – External Translation Utility Dialog 


 


4. Expand one of the folders (Database, Reports or Web Enrollment). 


 


 


Editing the Database contents files requires entry of a username and password.  The default username 


is SYSDBA.  The default password is masterkey.   


 


5. In the Directory Tree, double-click the file for editing. 


6. From the list of records displayed, select a line for translation. 


7. In the Translation column, double-click on the pre-existing text, activating the text for 


replacement. 


8. Type in the replacement text. 


9. Once you’ve edited the required records, click on the  button. 


10. From the File drop-down list, select Exit. 


 


 


USER NOTES 
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Introduction 


This section describes integration of the following third-party systems with the IXP220 Software: 


 


 Various Morpho Fingerprint and Registration Readers, integrated via the Biometric Server 


Software. 


 ImproX B-SHO Fingerprint Terminals, integrated direct to the IXP220 Base Application. 


 NITGEN Fingerprint Terminals, integrated via the Biometric Server Software. 


 


The introduction of biometric access control greatly increases the access control capabilities of 


IXP220 Systems where you need extra security measures.  Some Biometric Readers are not 


supported by the Biometric Server Software. Table 1 gives Reader support information. 
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MorphoAccess MA100 YES 500 2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MorphoAccess MA120 YES 500  2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MorphoAccess J-Bio YES 500 standard, 


upgradeable to 3 000   


2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MorphoAccess J-Dual YES 500 standard,  


upgradeable to 3 000   


2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MA200 Fingerprint Reader YES 800 5.53 iTRT, MfT, TA and 


IXP220 Controller 


No 


MA220 Fingerprint Reader YES 800  5.53 iTRT, MfT, TA and 


IXP220 Controller 


No 


MA300 Fingerprint Reader YES 48 000  5.53 iTRT, MfT, TA and 


IXP220 Controller 


No 


MA500 Fingerprint Reader YES 3 000 standard, 


upgradeable to 50 000 


2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MA500+ Fingerprint Reader YES 3 000 standard, 


upgradeable to 50 000 


2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MA520 Fingerprint Reader YES 3 000 standard, 


upgradeable to 50 000  


2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MA520+ Fingerprint Reader YES 3 000 standard, 


upgradeable to 50 000 


2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


OMA520 Fingerprint Reader YES 3 000 standard, 


upgradeable to 50 000 


2.13.4 iTRT, MfT, TA and 


IXP220 Controller 


No 


MorphoSmart MSO300 


Registration Reader 


YES NA TBA TBA Yes 
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ImproX B-SHO Fingerprint 


Terminal 


No TBA 1.22 TBA No 


ImproX B-SHO USB 


Fingerprint Enrollment Reader 


No TBA 1.04 TBA Yes 


ImproX B-SHO BioMini USB 


Fingerprint Enrollment Reader 


No TBA TBA TBA Yes 


NITGEN Fingkey Hamster II™ YES TBA TBA TBA Yes 


NITGEN Fingkey Access 


Terminal 


YES TBA TBA TBA No 


NITGEN NAC-2500 Plus 


Terminal 


YES TBA TBA TBA No 


NITGEN NAC-5000 Terminal YES TBA TBA TBA No 


Table 1 – Biometric Reader Support Information 


 


 


Number of users supported by the MA120, MA220 and MA520 limited by the number of Tags 


supported by the Controller. 


 


 


MA200 and MA300 limited to 3 000 users per Database, with a maximum of 16 Databases supported. 


MA5XX series, limited to 5 Databases of 10 000 users each. 


 


 


The ImproX TA, ImproX iTRT and ImproX MfT each offer a Third-party Port approved for use with the 


Biometric Reader. 


 


 


The MorphoAccess™ J-Bio and MorphoAccess™ J-Dual support 500 users (with 2 templates each) or 


3 000 users (with 2 templates each) with a license. 


 


The Biometric Server Module lets the System Administrator configure various third-party 


Biometric Readers for use with the IXP220 Software.  The Module also allows for the direct 


enrollment (registration) of Tagholders and related biometric data at those Biometric Readers 


from within the IXP220 Software. 
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Morpho (Sagem) Reader Use in an IXP220 
System 


General 


This section guides you step by step through the process of setting up Morpho Biometric 


Readers to work with the IXP220 System.  The requirements for the integration are as follows: 


 


 IXP220 Access Control System 


 IXP220 System Software Installed 


 Latest Morpho Integration Patch 


 


There are five steps in configuring the Biometric Readers in the IXP220 System.  These are: 


 


1. Hardware installation of the Biometric Readers. 


2. Setting up the Enrollment Reader. 


3. Detection of the Biometric Readers on the TCP/IP bus. 


4. Software setup of the Biometric Readers using the Biometric Server Software. 


5. Enrolling users on the System. 


 


 


Ensure that you unlock your Registration Interface (Impro-Touch License) and source your Unlock 


Token and Verification Dongle before using Morpho equipment with the IXP220 Software.  The 


Impro-Touch License allows for a maximum of 1 seat. 


 


Principle of Operation 


 
Figure 1 – Using Morpho Fingerprint Readers within an IXP220 System 
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Hardware Installation  


Each Morpho Reader must connect to the LAN to send and receive templates from the IXP220 


Database.  The Morpho Reader must also connect to an associated ImproX Terminal (such as 


the ImproX TA, iTRT or the MfT) thus facilitating communication with the Controller.  Install the 


Morpho Readers as outlined in the associated Morpho Hardware Installation Manual. 


 


CCoonnnneeccttiioonn  ttoo  tthhee  MMAA110000,,  MMAA112200,,  MMAA220000,,  MMAA330000,,  MMAA550000  oorr  MMAA552200  ttoo  tthhee  IIXXPP222200  


CCoonnttrroolllleerr  


 
Figure 2 – Morpho Reader (MA100, MA120, MA200, MA300, MA500 or MA520) Connected to the IXP220 


Controller and LAN 
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CCoonnnneeccttiioonn  ttoo  tthhee  MMAA110000,,  MMAA112200,,  MMAA220000,,  MMAA330000,,  MMAA550000  oorr  MMAA552200  ttoo  tthhee  IImmpprrooXX  


iiTTRRTT  


 
Figure 3 – Morpho Reader (MA100, MA120, MA200, MA300, MA500 or MA520) Connected to the ImproX 


iTRT and LAN 
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CCoonnnneeccttiioonn  ttoo  tthhee  MMAA110000,,  MMAA112200,,  MMAA220000,,  MMAA330000,,  MMAA550000  oorr  MMAA552200  ttoo  tthhee  IImmpprrooXX  


MMffTT  


 
Figure 4 – Morpho Reader (MA100, MA120, MA200, MA300, MA500 or MA520) Connected to the ImproX 


MfT and LAN 
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CCoonnnneeccttiioonn  ttoo  tthhee  MMAA110000,,  MMAA112200,,  MMAA220000,,  MMAA330000,,  MMAA550000  oorr  MMAA552200  ttoo  tthhee  IImmpprrooXX  


TTAA  


 
Figure 5 – Morpho Reader (MA100, MA120, MA200, MA300, MA500 or MA520) Connected to the ImproX TA 


and LAN 
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CCoonnnneeccttiioonn  ttoo  tthhee  MMoorrpphhooAAcccceessss™™  JJ--BBiioo  oorr  JJ--DDuuaall  ttoo  tthhee  IIXXPP222200  CCoonnttrroolllleerr  


 
Figure 6 – MorphoAccess™ J-Bio or J-Dual Connected to the IXP220 Controller and LAN 
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CCoonnnneeccttiioonn  ttoo  tthhee  MMoorrpphhooAAcccceessss™™  JJ--BBiioo  oorr  JJ--DDuuaall  ttoo  tthhee  IImmpprrooXX  iiTTRRTT  


 
Figure 7 – MorphoAccess™ J-Bio or J-Dual Connected to the ImproX iTRT and LAN 
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CCoonnnneeccttiioonn  ttoo  tthhee  MMoorrpphhooAAcccceessss™™  JJ--BBiioo  oorr  JJ--DDuuaall  ttoo  tthhee  IImmpprrooXX  MMffTT  


 
Figure 8 – MorphoAccess™ J-Bio or J-Dual Connected to the ImproX MfT and LAN 
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CCoonnnneeccttiioonn  ttoo  tthhee  MMoorrpphhooAAcccceessss™™  JJ--BBiioo  oorr  JJ--DDuuaall  ttoo  tthhee  IImmpprrooXX  TTAA  


 
Figure 9 – MorphoAccess™ J-Bio or J-Dual Connected to the ImproX TA and LAN 
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Installation and Setup of the MSO300 Enrollment Reader and 
Verification Dongle 


 


 


Ensure that you unlock your Registration Interface (Impro-Touch License) before proceeding further.  


This license allows for a maximum of 1 seat. 


 


..NNEETT  FFrraammeewwoorrkk  IInnssttaallllaattiioonn  


If the .Net Framework is NOT already installed, download the update as follows:  From 


http://www.microsoft.com/downloads, download the .NET Framework Version 2.0 update. 


 


 


Alternatively download the update from http://www.impro.net/site/downloads/listing/10/Other.  From the 


list of displayed files, select Files for Sagem Enrolment.  This package includes the .NET Framework 


installation files. 


 


MMSSOO330000  EEnnrroollllmmeenntt  DDeevviiccee  DDrriivveerr  IInnssttaallllaattiioonn  


 


 


Install the drivers, before you plug in the MSO300. 


If connected, disconnect the MSO300 Enrollment Reader and reboot the PC.  


 


1. If running a 32-bit operating system, continue as follows: 


 Browse to C:\IXP220\driver\Sagem MorphoSmart USB 32 bits Driver. 


 Double-click on the Sagem MorphoSmart USB Drivers.msi file. 


2. Alternatively, if running a 64-bit operating system, continue as follows: 


 Browse to C:\IXP220\driver\Sagem MorphoSmart USB 64 bits Driver. 


 Double-click on the Sagem MorphoSmart USB 64 bits Drivers.msi file. 


3. At the Welcome screen, click the Next button. 


4. Click the Next button to install in the default directory. 


5. Click the Install button. 


6. Click the Finish button. 


 


VVeerriiffiiccaattiioonn  DDoonnggllee  DDeevviiccee  DDrriivveerr  IInnssttaallllaattiioonn  


 


 


Install the drivers, before you plug in the Verification Dongle. 


If connected, disconnect the Verification Dongle and reboot the PC. 


 


SafeNet Dongle 


1. Browse to C:\IXP220\driver\SafeNetDongle. 


2. Double-click the SentinelProtectionInstaller.7.4.0.exe file. 


3. At the Welcome screen, click the Next button. 


4. Select the I Accept the Terms in the License Agreement radio button. 


5. Click the Next button. 


6. Under Setup Type, select either the Complete or Custom radio button. 


7. Click the Next button. 


8. Click the Install button. 


9. At the Windows Firewall Detected screen, click the Yes button. 


10. Click the Finish button. 



http://www.impro.net/site/downloads/listing/10/Other
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Morpho Dongle (MSO-EVerif) 


1. If running a 32-bit operating system, browse to C:\IXP220driver\Morpho Dongle\x86. 


2. Alternatively, if running a 64-bit operating system, browse to C:\IXP220\driver\Morpho 


Dongle\x64. 


3. Double-click on the ACR38U_PCSC_Driver-1.1.6.1.msi file. 


4. At the Welcome screen, click the Next button. 


5. Click the Next button to install in the default directory. 


6. Click the Install button. 


7. Click the Finish button. 


 


MMSSOO330000  IInnssttaallllaattiioonn  


1. Plug the MSO300 Enrollment Reader into an unused USB Port on the PC. 


 


 


Some PC’s proceed with automatic installation of the MSO300, if installation occurs automatically 


move direct to step 4 below.  


 


2. Follow the on-screen prompts, instead of letting the Installer run automatically, select Install 


from a Specific Location. 


3. Browse to C:\Program Files\Sagem Securite\MorphoSmart Drivers, this folder contains 


the drivers for the MSO300.  


4. After installation of the Drivers, the LED on the MSO300 blinks Green once a second.  


 


MMSSOO330000  FFiirrmmwwaarree  UUppggrraaddee  PPrroocceedduurree  


1. Browse to C:\IXP220\driver\Sagem MorphoSmart Firmware Update. 


2. Double-click on the Firmware_MSO.exe file. 


3. At the Welcome screen, click the Next button. 


4. Select the method by which you want to upgrade your MSO300 Enrollment Reader. 


 A Serial Connection 


 A USB Connection 


5. Click the Next button. 


6. Once the result shows Upgrade Successful, click the Finish button. 


 


VVeerriiffiiccaattiioonn  DDoonnggllee  IInnssttaallllaattiioonn  


1. Now plug in the Verification Dongle into an unused USB Port on the PC.  


2. The installer runs discreetly and when fully installed, the Verification Dongles Green LED 


remains permanently on.  


 


MMoorrpphhookkiitt  LLiicceennssiinngg  SSeerrvviiccee  IInnssttaallllaattiioonn  


 


 


The Morphokit Licensing Service runs continuously after installation.  If you do not see evidence of the 


SagemSecurite_Licence_Protection.exe file running in the Windows Task Manager, install the software 


as follows. 


 


1. Browse to C:\IXP220\driver. 


2. Double-click on the SagemSecurite_Licence_Protection_Installer.exe file. 


3. At the Welcome screen, click the Next button. 
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4. Click the Next button to install in the default directory. 


5. Click the Next button. 


6. Click the Close button. 


 


CCrreeaattiinngg  aa  DDaattaa  EExxeeccuuttiioonn  PPrreevveennttiioonn  EExxcceeppttiioonn  ffoorr  SSaaggeemm  SSeeccuurriittee  LLiicceennccee  


MMaannaaggeerr  


1. From the Control Panel, select the System option. 


2. Select the Remote Settings option. 


3. In the System Properties dialog, select the Advanced tab. 


4. In the Performance group, click the Settings... button. 


5. In the Performance options dialog, select the Data Execution Prevention tab. 


6. Select the Turn On DEP for all Programs and Services Except Those I Select radio 


button. 


7. Click the Add... button. 


8. Navigate to the installation directory at C:\Program Files\Sagem Securite\Licence 


Protection. 


9. Double-click on the following executable files: 


 SagemSecurite_Licence_Protection.exe 


 SagemSecurite_Licence_Manager.exe 


10. Click the OK button. 


11. At the System Properties dialog, click the OK button. 


12. Click the  button. 


 


MMoorrpphhoo  MMSSOO330000  BBiioommeettrriicc  CCoonnffiigguurraattiioonn  


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. Select the  Page Tab. 


3. Open an existing Tagholder record for editing. 


4. In the Tagholder dialog, select the Tag Tab. 


5. Click one of the assigned Tag buttons (that is Tag 1, Tag 2, Tag 3 or Tag 4). 


6. From the Configuration Level group, select the Advanced Configuration radio button. 


 


Configure the Biometric Reader 


1. From the Miscellaneous group, select the Configure Biometric Reader button. 


 


 
Figure 10 – Biometric Addresses Configuration Dialog 
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2. In the Biometric Address Configuration dialog, from the Biometric Device drop-down 


list, select Sagem.  In future versions of this Software, this list will detail other biometric 


devices that can be integrated with the IXP220 Software, and will allow you to set up the 


enrollment units for each biometric device. 


3. From the Device drop-down list, select the MSO300 option. 


 


 


The Unit Address field appears greyed out for Sagem, as it refers to addresses of units on the RS485 


bus, Morpho (Sagem) does not currently support RS485.  The Unit IP Address field is reserved for 


future use. 


 


4. From the Connection Type drop-down list, make your selection. 


5. Click on the  button. 


6. Click on the  button. 


7. Click the  button. 


8. Click the  button. 


 


Morpho MA100, MA120, MA500 or J-Series Internal Parameter Setup  


 


 


The Morpho MA1XX, MA5XX and J-Series biometric devices have the following default IP Address: 


134.1.32.214. 


 


UUSSBB  FFllaasshh  DDiisskk  SSeettuupp  


Using a USB Flash Disk, acceptable Flash Disk sizes include 128 MB, 256 MB or 512 MB 


(maximum usable size): 


 


1. Format the Flash Disk in FAT16. 


2. Assign the Flash Disk a name of no more than 12 characters. 


3. Browse to C:\IXP220\Driver\Tools\Sagem\USB Network Tools. 


4. Double-click on the USBNetworkTool.exe file. 
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Figure 11 – USB Network Tool Dialog 


 


5. In the USB Network Tool dialog, under TCP Parameters complete the following details: 


 In the IP field, assign an available IP Address for your network. 


 In the Mask field, give details for the Subnet Mask. 


 In the Gateway field, give details for the Default Gateway. 


 


 


If you are in any doubt as to where to source this information, please contact your network 


administrator for assistance. 


 


 


You cannot at this time edit the Terminal Serial Number field.   


 


6. Click the Write File button. 


7. In the Save As dialog, from the Save In drop-down list, select your pre-formatted USB 


Flash Disk. 


8. In the File Name field, give the file a name (The file saves as a *.reg file). 


9. With the MA100 powered up, plug the USB Flash Disk into the front of your MA100. 


 


 


During the file download process the MA100’s Buzzer beeps and the LED changes colour.   


 


 


Do NOT remove the USB Flash Disk until the download is complete.  On completing the download, 


the MA100’s Buzzer emits a deep tone and the LED slowly flashes Blue.   
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SSeettttiinngg  uupp  tthhee  WWiieeggaanndd  CCoonnffiigguurraattiioonn  oonn  aann  MMAA110000,,  MMAA550000  oorr  JJ--SSeerriieess  


1. Browse to C:\IXP220\Driver\Tools\Sagem\Configuration Tool. 


2. Double-click on the ConfigurationTool.exe file. 


 


 
Figure 12 – Configuration Tool Dialog 


 


3. In the Morpho Access Connection dialog, ensure that the IP Address field reflects the same 


IP Address details as used in point 5 on page 21. 


4. Click the Connect >> button. 
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Figure 13 – Configuration Tool Dialog 


 


5. In the Configuration Tool dialog, click the Get File button. 


 


 


The Log File setting referred to in point 6 (only available on sites using MA100 and MA500 Morpho 


Readers) is required for the functionality of the Sagem Identify Report.  In Installations without 


installed MA100 and MA500 Morpho Readers, skip direct to point 8. 


 


6. From the Directory Tree, double-click the Log File setting. 


7. Double-click on the Enabled setting and adjust the value to 1. 


8. From the Directory Tree, double-click the send ID wiegand setting. 


9. Double-click on the following settings to adjust their values: 


 build frame— 


 valid format—1 


 custom Format—0.0 


 ID format—1.24 


 site Format—0.0 


 stop Format—3.12 


 start Format—2.12 


 frame length—26 


 HID Conversion—0 


 site code—0 


 enabled—1 


10. Apply the settings by rebooting the Terminal. 
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Problems and Solutions 


1. Problem—Software fails to report denied transactions on sites with installed Sagem          


J-Series Readers. 


Solution—Adjust the following settings under Failure ID: 


 not recognized ID—0 


 enabled—1 


2. Problem—Wiegand Code not sent through. 


Solution 1—Swap your Data 1 and Data 0. 


Solution 2—Check the Controller’s DIP-switch settings. 


Solution 3—Check each setting in the App file according to the following list: 


 


 
Figure 14 – Configuration Tool Dialog 


 


 bio ctrl 


 AC_ID—FINGER;CARDDATA;KBD;WGDTCLK; 


 authent remote ID source—0 


 bypass authentication—0 


 authent ID keyboard—0 


 identification timeout—5 


 nb attempts—2 


 identification—1 


 relay 


 external control by LED1—0 


 relay default state—0 


 aperture time in 10 ms—300 


 enabled—1 


 led IN 


 controller ack timeout—300 


 enabled—0 
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 send ID UDP 


 host name—134.1.2.189 


 host port—11020 


 enabled—0 


 log file 


 enabled—1 


 tamper alarm 


 interval—1500 


 level—0 


 info 


 release—15 


 minor—9 


 major—2 


 type—500 


 G.U.I 


 display hour—0 


 LED out signal—0 


 Time and attendance icons—1 


 database conversion—500 


 display user info—2 


 time and attendance icons—1 


 default language—0 


 volume—5 


 send ID ethernet 


 connect timeout—2000 


 profile id—0 


 SSL enabled—0 


 controller on no responce—1 


 timeout back to controller 1—3600 


 controller 2 port—11020 


 controller 2 IP—134.1.2.189 


 controller 1 port—11020 


 controller 1 IP—134.1.2.189 


 mode—0 


 send ID wiegand 


 built frame— 


 valid format—1 


 custom format—0.0 


 ID format—1.24 


 site format—0.0 


 stop format—3.12 


 start format—2.12 


 frame length—26 


 HID conversion—0 


 site code—0 


 enabled—1 


 send ID dataclock 


 card present signal—0 


 data inverted—0 
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 clock inverted—0 


 enabled—0 


 send ID serial 


 display duration—3 


 reply timeout—5 


 wait reply—0 


 terminal identifier—178 


 priority—0 


 stopbits—1 


 databits—8 


 speed—11520 


 mode—485 


 enabled—0 


 failure ID 


 send ID mask—255 


 not on time ID—65535 


 generic error ID—65535 


 timeout ID—65535 


 not in DB ID—65535 


 not recognized ID—65535 


 alarm ID—65535 


 enabled—0 


 wiegand in 


 custom format—0.0 


 ID format—9.16 


 site format—1.8 


 stop format—2.12 


 start format—2.12 


 frame length—26 


 check site code—1 


 site code—7 


 data clock in 


 data inverted—0 


 clock inverted—0 


 modes 


 idle timeout—0 


 idle peripherals—3 


 T&A operation timeout—20 


 time mask—0 


 time and attendance—0 


 


Morpho MA200 or MA300 Internal Parameter Setup  


GGeenneerraall  


Set up the internal parameters for MA200 and MA300 Biometric Readers using the built-in 


Display and Keypad.  In order to carry out this procedure, please refer to:   Morpho MA200/300 


MorphoAccess Installation Guide, SK-0000011145-03 – January 2004. 
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NNootteess  oonn  SSeett--uupp  ffoorr  MMoorrpphhoo  MMAA220000  oorr  MMAA330000  


The information that follows takes you through the Morpho Manual, indicating which information 


applies to the use of the Biometric Reader with the IXP220 Software, and which does not. 


  


IInntteerrnnaall  MMoorrpphhoo  CCoonnffiigguurraattiioonn  SStteeppss  


The internal configuration steps of the MA200 or MA300 into the IXP220 System include: 


 


1. Configure the Switches on the motherboard. 


2. Configure the Software Administration Interface. 


3. Perform Sagem System Set-up Actions (biometric management operations). 


4. Configure the Biometric Reader using the Sagem CONFIG Menu. 


 


Table 2 lists all headings in the Morpho manual, and indicates whether, and how, this 


information relates to the Morpho-IXP220 integration process.  


 


 


The Morpho MA200 or MA300 Manual headings are listed sequentially in Table 2 as a guide to the 


use of the Morpho manual in this application. However, in some cases the most convenient order for 


the integration process is different. In these cases the PROCEDURE or COMMENTS column will refer 


you to the STEP in which this information is used. 


 


STEP DESCRIPTION MORPHO MANUAL HEADING PROCEDURE OR COMMENTS 


1. PHYSICAL INSTALLATION INSTALLATION PROCEDURE Follow the Morpho Manual procedures. 


2. ELECTRICAL CONNECTION ELECTRICAL INTERFACE The Morpho Interfaces used in this 


application are J1, J3 and J4 (Refer to the 


Morpho Manual).   


 


See Figure 3, Figure 4 and Figure 5 in this 


manual. 


Terminal Block Board Background Information. 


Power Supply Cable See Figure 3, Figure 4 and Figure 5 in this 


manual. 


Ethernet Wiring See Figure 3, Figure 4 and Figure 5 in this 


manual. 


Wiegand Output Wiring See Figure 3, Figure 4 and Figure 5 in this 


manual. 


Output Relays and Tamper Switch Optional, depends on user requirements.  


Follow the instructions in the Morpho Manual 


if required. 


CONFIGURING THE MORPHOACCESS  


Motherboard Configuration Refer to the Morpho Manual. 


Configure the Switches as follows: 


Set SW1 and SW2 for Wiegand Mode. 


Set SW3 and SW4 as indicated in the 


Morpho Manual. 


Set SW7 and SW8 for Wiegand Mode. 


MORPHOACCESS SOFTWARE Refer to step 5 of this Table. 
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STEP DESCRIPTION MORPHO MANUAL HEADING PROCEDURE OR COMMENTS 


3. INTERNAL SETUP OF THE 


READER BEFORE 


INTEGRATION AND USE WITH 


IXP220 


BIOMETRIC MANAGEMENT OPERATIONS Refer to the Morpho Manual, “Access the Set 


up Functions of the System”, but ignore the 


following headings: 


 Biometric Management in Stand Alone 


 Insert Template/ID in Database 


 Remove Template/ID from Database 


THE CONFIG MENU Refer to the Morpho Manual. 


 SETTING UP NETWORK PARAMETERS Refer to the Morpho Manual. 


SETTING UP THE SYSTEM 


ADMINISTRATOR PIN 


Refer to the Morpho Manual. 


 


This PIN provides access to the SYSTEM 


Menus in the Morpho Software for 


administration of the Reader. 


 SETTING UP THE MORPHOACCESS 


ADMINISTRATOR PIN 


Refer to the Morpho Manual. 


 


This PIN provides access to the MACCESS 


Menus in the Morpho Software for 


administration of the external management. 


Setting Up Host Communication Refer to the Morpho Manual. 


Set the Host Com value to 3. 


Setting Up User Interface Refer to the Morpho Manual. 


Setting Up Wiegand or Dataclock Output  Refer to the Morpho Manual. 


Setting Up Wiegand Interface Refer to the Morpho Manual. 


The default format is 26-Bit. 


Frame Definition Refer to the Morpho Manual. 


Configuration Keys Refer to the Morpho Manual. 


Set Section is OUT. 


Set Length is 26. 


Setting Up Etherlink Parameters Refer to the Morpho Manual. 


Set Etherlink Send is 1. 


Set IP Address as required. 


Setting Up Time Attendance Refer to the Morpho Manual. 


4. OPTIONAL SETUP AND 


BACKGROUND INFORMATION 


THE VERSION MENU Refer to the Morpho Manual. 


THE SERIAL NUMBER MENU Refer to the Morpho Manual. 


THE SETTING MENU Refer to the Morpho Manual. 


COMMUNICATION PROTOCOL Background Information. 


MORPHOACCESS TECHNICAL 


CHARACTERISTICS 


Background Information. 


Recommendations Background Information. 


Ethernet Colour Standard Background Information. 


Appendix 2 Background Information. 


Appendix 4 Background Information. 


APPENDIX 5 – FINGERPRINT PLACEMENT 


RULES 


Refer to step 6 of this Table. 


5. USER INTERFACE SETUP MORPHOACCESS SOFTWARE USER 


INTERFACE 


Refer to the Morpho Manual. 


Access Control by Identification (MA200) Refer to the Morpho Manual. 


The Mode is 0. 
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STEP DESCRIPTION MORPHO MANUAL HEADING PROCEDURE OR COMMENTS 


 Access Control by Identification (MA300) Refer to the Morpho Manual. 


The Mode is 0. 


Access Control by Identification (MA200 and 


MA300) 


Optional – use if authentication is used by 


presentation of Tag to an external Reader. 


6. OPERATIONAL INFORMATION APPENDIX 5 – FINGERPRINT PLACEMENT 


RULES 


Important operational information.  Follow the 


instructions in the Morpho Manual.  Ensure 


that all users are aware of these rules. 


Table 2 – Internal Configuration of the Morpho Fingerprint Readers 


 


 


For easy reference we listed the Morpho Manual Headings in Table 2 in the order in which they appear 


in the Morpho Manual.  Sections not listed in Table 2 are NOT required for IXP220 Integration. 


 


Configuration of Morpho Readers into the IXP220 System  


Once you’ve connected the Morpho Readers and configured them internally as described in the 


previous paragraphs, configure the Readers into the IXP220 System.   This section applies to 


the supported Morpho Fingerprint Readers, the MA100, MA120, MA200, MA300, MA500, 


MA520 and J-Series. 


 


 


Each Morpho Reader used in the Biometric Server requires its own Unlock Token.  For details of the 


unlocking procedure refer to the section titled Morpho Dongle Protection using the Unlock Token on 


page 31. 


 


The configuration of these Readers within IXP220 is done using the Biometric Server Software, 


as follows:  From the IXP220 Software, select File>Biometric Server. 


 


DDeetteeccttiinngg  MMoorrpphhoo  RReeaaddeerrss  oonn  tthhee  TTCCPP//IIPP  BBuuss  


1. From the Main Menu, select Configuration>Sagem>Sagem Devices.  


 


 
Figure 15 – Sagem Devices Dialog 







Part 8 – Integration Modules 


30  February 2012 


At the top of the Sagem Devices dialog you will see the Connection Type drop-down list with 


TcpipSocket selected.  This is the only option at this stage. 


 


2. In the IP Range field enter the start and end IP Addresses for the range of Addresses that 


the Biometric Server must search for. 


3. Click the Search button.  


 


 


The Search may take some time, depending on how busy the network is.  After the Search finds the 


Morpho units, they appear as records in the table with their Serial Numbers, IP Addresses and their 


current Status.  The displayed units appear as follows: 


 


 All newly discovered units highlight in Green. 


 All units with changed IP Addresses highlight in Orange. 


 All units that are in the Database but have been found to be off-line or missing highlight in 


Red. 


 


 


The Enabled checkbox enables or disables EACH INDIVIDUAL Morpho unit on the network.  This 


means that you can carry out repairs on a unit without affecting the rest.  While the Enable All 


checkbox enables or disables ALL the Morpho units on the network.  The Server will not attempt 


communication with a disabled Morpho unit. 


 


 


You will also notice a  button in the dialog.  This button allows manual deletion of Morpho Readers 


from the Database.  Note however, reintroduction of the Morpho Reader requires use of the Unlock 


Token. 


 


 


On enabled Morpho Readers with their status shown as OK, clicking the Info button displays the 


Device Information dialog.  This dialog shows the number of templates uploaded to the Morpho 


Reader and the unused capacity.   


 


4. When you are finished using the Sagem Devices dialog, click the  button. 


5. After setting up the units, do a Full Upload to create fresh databases on the units. 


6. Now click on the Start button to get the Biometric Server running and ready to upload 


templates as you enroll users. 


 


BBiioommeettrriicc  SSeerrvveerr  QQuueeuuee  


All messages to Morpho devices queue so that each device can be processed independently.  


The Unit Details tab shows the queue status and allows you to upload to each unit individually.  


 


This tab is also useful in identifying units having communication problems. 
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Figure 16 – Unit Details Tab 


 


The queue processes automatically during normal operation (that is after you press the Start 


button).  You may perform a full upload on a specific Morpho Reader as follows: 


 


1. Select the unit record for update. 


2. From the menu popup, select the Full Upload option. 


 


DDuupplliiccaattee  SSeeaarrcchh  ((11::NN  MMaattcchhiinngg))  


Using the IXP220 Software, the Biometric Server communicates with the Sagem Matcher.  This 


communication structure enables duplicate search functionality.  To use this feature, ensure that 


you have a MorphoSmart MSO300 Registration Reader and one of the following licences:  an 


IDENT LITE (5 000 templates), an IDENT (10 000 templates) or an IDENT PLUS (20 000 


templates). 


 


Usually installed on a USB Flash Disk, the IDENT licence connects direct to the Biometric 


Server.  You may, however, purchase an IDENT licence that resides direct on the MSO300, for 


use in a stand-alone PC environment. 


 


Enabling Matcher in the Biometric Server Software 


1. Start the Biometric Server Software (for more information, see page 29). 


2. From the menu bar, select Configuration>Sagem>Matcher. 
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Figure 17 – Matcher Configuration Dialog 


 


3. In the Matcher Configuration dialog, select the Enabled checkbox. 


4. From the Maximum Records drop-down list, select the maximum number of records 


supported by your IDENT LITE, IDENT or IDENT PLUS licence. 


5. Click the  button. 


6. Restart the Biometric Server Software for the changes to take effect. 


 


 


The Biometric Server opens a TCP/IP server on Port 26670 for all Matcher related communications. 


 


 


For an existing site, with templates already loaded, the Matcher decompresses all your existing 


templates into a format easily searched and stored in the Matcher database.  This process can take 


some time to complete but only runs upon starting the Biometric Server.   


 


Enabling Duplicate Search at an Enrollment Station 


 


 


For detailed steps on arriving at the Biometric Enrollment dialog, refer to page 33. 


 


1. In the Biometric Enrollment dialog, click the Advanced button. 


2. Select the Enable Duplicate Check checkbox. 


3. Click the  button.  


4. Restart the IXP220 Base Application for this change to take effect. 


 


 


Ensure the Biometric Server Software is running for checking to take place. 


 


If the Matcher Service does NOT find a matching record, the record is added to the Matcher 


Database.  If the Matcher Service finds a matching record, an Error message gives you the 


matching records Tag code. 


 


MMoorrpphhoo  DDoonnggllee  PPrrootteeccttiioonn  uussiinngg  tthhee  UUnnlloocckk  TTookkeenn  


 


 


On initial use, ANY Unlock Token of the correct type unlocks ANY Morpho Reader of the same type. 


That is, any MA100 Unlock Token unlocks any MA100 Morpho Reader, any MA200/300 Token unlocks 


any MA200, MA300 or MA500 Morpho Reader and any J-Series Token unlocks any J-Bio or J-Dual 


Reader.  However, once an Unlock Token is used with a specific Morpho Reader, the Unlock Token is 


permanently associated to that Reader.  Ensure that you keep your supplied Unlock Tokens labelled 


and in a safe place. 
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The Unlock Token supplied with third-party integrated products, shows the products have our 


full factory level approval.  This means the products work seamlessly with IXP220, with central 


enrollment taking place in the IXP220 Tagholder Enrollment screen. 


 


The Token allows you access to extra integration features related to the Morpho Readers.  


These features include: 


 


 Intelligent distribution of templates (uploading of templates only to Readers where the 


Tagholder has access). 


 Sagem Capture Quality Report. 


 


To unlock Morpho Readers enabled in the Biometric Server, continue as follows: 


 


1. Using the IXP220 Main Menu, select File>Biometric Server. 


2. In the Licence Info dialog, click the Unlock button. 


3. Place your Unlock Token in position in the Tag Registration Reader. 


4. In the Sagem Device Unlock dialog, click on the Read button. 


5. Click on the OK button. 


 


On unlock, the Biometric Server Software opens allowing full use of the Software. 


 


EEnnrroolllliinngg  UUsseerrss  oonn  tthhee  SSyysstteemm  


From Windows® select Start>All Programs>IXP220>IXP220. 


 


Preference Setup 


1. From the Main Menu, select File>Preference. 


2. Select the Enrollment Tab. 


3. From the Tag Code Truncation group, from the 3rd Party Other drop-down list, select 24 


bits.  


4. Click the  button. 


 


Enrollment in the IXP220 Software  


1. Select the  Page Tab. 


2. Open a new or existing Tagholder record for editing. 


3. In the Tagholder dialog, select the Tag Tab. 


4. Click one of the assigned Tag buttons (that is Tag 1, Tag 2, Tag 3 or Tag 4) or select one of 


the Create New Tag buttons. 


5. From the Configuration Level group, select the Advanced Configuration radio button. 


6. Have the Tagholder place his/her Tag on the Enrollment Reader. 


7. Click Read Tag. 


8. Set the Access Rights group options as you require. 


9. Click the  button. 


10. Click on the Biometric Enrollment button. 
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Figure 18 – Biometric Enrollment Dialog 


 


11. In the Biometric Enrollment dialog, from the Device drop-down list, select the type of 


device you wish to enroll the user on, in this case Sagem.  


 


 


The ID field is the ID derived from the Tag Code and is the number under which the user’s data is 


saved when his or her fingerprints are enrolled in the units. 


 


 


The Template field remains empty until the enrollments completed. 


 


12. Click on the Advanced button. 


 


Advanced Settings 


Clicking the Advanced button makes the following settings available for change: 


 


 Timeout—this is the time the enrollment unit will wait before declaring the enrollment a 


failure.  The default 30 seconds should serve for most enrollments. 


 Default DB—the default MA300 or MA500 database to which the Reader assigns 


fingerprint templates.  Changing the default database to a number greater than 0 may result 


in fingerprint templates not uploading to the MA100, MA120, MA200 and J-Series Readers. 


 DB for this User—the default MA300 or MA500 database to which this users templates are 


stored.  Changing the default database to a number greater than 0 may result in fingerprint 


templates not uploading to the MA100, MA120, MA200 and J-Series Readers. 


 Quality Threshold—determines the minimum quality score for each template.  A higher 


threshold, leads to a better quality template.  Make your selection from the range 0 to 255.  


For best results, we recommend a score of above 200. 


 Use Consolidation—allows you to capture the fingerprint 3 times.  The software then 


saves the best capture.  If disabled, the software only captures the fingerprint once. 


 Enable Matching  


 Matching Threshold—determines the minimum accepted matching threshold during the 


verification stage of each template capture.  For full functionality, ensure that you have a 


Morpho Dongle or Verification Dongle installed and plugged in.  Make your selection from 


the range 0 to 255.  For best results, we recommend a score above of 200. 


 Enable Duplicate Check—when enabled, after template capture, the IXP220 Software 


searches for matches in the Matcher Database (located in the Biometric Server Software).  
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Restart the Base Application for this setting to take effect.  For full functionality, ensure that 


you start the Biometric Server Software and that you have a MorphoSmart MSO300 


Registration Reader and either an IDENT LITE (5 000 templates), an IDENT (10 000 


templates) or an IDENT PLUS (20 000 templates) licence.  Refer to the section Duplicate 


Search (1:N Matching) on page 31 for more information. 


 


13. Click on the Enroll button, thereby initiating the enrollment.  


 


Fingerprint Placement Rules 


Figure 19 shows the area of the fingerprint that contains the most information.  Therefore, when 


enrolling Tagholders, ensure they place their fingers as shown in Figure 20.   


 


 
Figure 19 – Area of the Fingerprint Containing the most Information 


 


 
Figure 20 – Fingerprint Placement Rules (Generic Enrollment Reader, Fingerprint Sensor Shown) 
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Enrollment procedure at the Sagem MSO300 


1. Place Finger 1 (fingerprint down) on the MSO300 Enrollment Reader’s fingerprint Sensor. 


2. Remove Finger 1 from the Sensor. 


3. Place Finger 1 on the Sensor a second time.  


4. Again, remove Finger 1 from the Sensor. 


5. Place Finger 2 (fingerprint down) on the MSO300 Enrollment Reader’s fingerprint Sensor. 


6. Remove Finger 2 from the Sensor. 


7. Place the Finger 2 on the Sensor a second time. 


8. Again, remove Finger 2 from the Sensor. 


 


Once the enrollments complete, the Template field displays the Template Number and an 


Enrollment Successful message appears in the Status Bar. 


1. Click the  button. 


2. Click the  button.  


 


The enrollment process is now complete.   Repeat this process for each Tagholder, as required. 


 


 


With the Biometric Server running, the Server automatically uploads templates to the Morpho Readers. 


 


Configuration of MIFARE® Encoders into the IXP220 System 


In instances where you cannot store fingerprint templates in the IXP220 Database, you may 


write templates direct to the MIFARE® Tag.  Reasons for this action could include:  cost, Reader 


limits, laws of the country or just general safety concerns. 


 


By making use of MIFARE® Encoder support, templates do not upload to the Biometric 


Readers.  Instead templates write direct to the MIFARE® Tag.  Thus when you present the 


MIFARE® Tag to the Biometric Reader, the template on the Tag is read.  Presenting your finger 


to the Reader then confirms the template information stored on the MIFARE® Tag. 


 


 


The MIFARE® Encoder is only supported when using the Morpho MA120, MA520 and the J-Dual. 


 


 


You may have as many MIFARE® Tags with templates written to them as you wish, there are no limits 


imposed. 


 


 


IXP220 offers MIFARE® Encoder support on the following 32-bit and 64-bit Operating Systems:  


Windows XP, Windows Vista and Windows 7.   


 


 


IXP220 supports 1 K and 4 K MIFARE® Tags used with the SDI010 Contact or Contactless Reader 


(MIFARE® Encoder). 


  


MMIIFFAARREE®®  EEnnccooddeerr  DDrriivveerr  IInnssttaallllaattiioonn  


 


 


On a 32-bit Operating System, ensure you use Driver version V4.36.   
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On a 64-bit Operating System, use Driver version V5.18.  V5.18 is however a legacy Windows XP 


driver and therefore installation must take place from a PC running Windows XP.   


 


1. Plug the SDI010 Contact or Contactless Reader into an unused USB Port on the PC. 


2. From the Found New Hardware dialog, click the Cancel button. 


3. From the Control Panel, select the Device Manger option. 


 


SDI010 Contact (Smart) Card Reader Driver 


1. From the displayed tree, select the Other Devices node. 


2. From the displayed list, select the SDI010 Smart Card Reader option. 


3. Select the Update Driver Software... option. 


4. Select the Browse My Computer for Driver Software option. 


5. Browse to C:\IXP220\driver\Mifare Encoder. 


6. Click the OK button. 


7. Select the Include Subfolders checkbox. 


8. Click the Next button. 


9. At the Found New Hardware dialog, click the Cancel button. 


10. At the Update Driver Software – SDI010 Smart Card Reader dialog, click the Close button. 


 


SDI010 Contactless Reader Driver 


1. From the displayed tree, select the Other Devices node. 


2. From the displayed list, select the SDI010 Contactless Reader option. 


3. Select the Update Driver Software... option. 


4. Select the Browse My Computer for Driver Software option. 


5. Browse to C:\IXP220\driver\Mifare Encoder. 


6. Click the OK button. 


7. Select the Include Subfolders checkbox. 


8. Click the Next button. 


9. At the Update Driver Software – SDI010 Contactless Reader dialog, click the Close button.  


10. At the Device Manager dialog, click the  button. 


 


MMIIFFAARREE®®  EEnnccooddeerr  FFiirrmmwwaarree  IInnssttaallllaattiioonn  


 


 


V6.32 is the supported Firmware version and is included in the IXP220 installation. 


 


1. Browse to C:\IXP220\driver\Mifare Encoder\SDI010_fw6.32. 


2. Run the file FwUpdate.exe. 


3. Follow the prompts as they appear thus completing the Firmware installation. 


 


MMIIFFAARREE®®  EEnnccooddeerr  CCoonnffiigguurraattiioonn  aanndd  TTeessttiinngg    


 


 


Ensure the SDI010 Contact or Contactless Reader is plugged in and that a MIFARE® Tag is in position 


on the MIFARE® Encoder.   


 


1. Browse to C:\IXP220\test.exe. 


2. In the Card Writer Test dialog, from the Select Writer drop-down list, select the Mifare SCM 


option. 
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3. At the Contactless Card error message, click the OK button. 


4. On the Left-hand-side of the Card Writer Test dialog, click the Configure button. 


5. From the Device Name drop-down list, select the SCM Microsystems Inc. SDI010 


Contactless Reader 0 option. 


6. In the Mifare Contactless Card Writer Configuration dialog, click the Autodetect button. 


7. At the Information dialog, click the OK button. 


8. In the Mifare Contactless Card Writer Configuration dialog, click the OK button. 


9. In the Card Writer Test dialog, from the Basic Operations group, click the Autodetect 


button. 


10. From the Basic Operations group, click the Read File Keys button. 


11. At the Test dialog, click the OK button. 


12. From the Basic Operations group, click the Load Keys button. 


13. At the Test dialog, click the OK button. 


14. From the Basic Operations group, click the Write button. 


15. At the Test dialog, click the Yes button. 


16. Click the Quit button. 


 


Key File Configuration 


 


The steps that follow are optional for Contact (Smart) Card users.  By following this procedure a 


unique to site security code writes to the Contact (Smart) Card.  This unique security code 


prevents users gaining entry to site using unencrypted MIFARE® Tags.   


 


1. Browse to C:\IXP220\test.exe. 


2. In the Card Writer Test dialog, from the Select Writer drop-down list, select the Mifare SCM 


option. 


3. On the Left-hand-side of the Card Writer Test dialog, click the Configure button. 


4. From the Key Files group, alongside the Old Key File textbox, click the  button. 


5. Browse to IXP220\keys\4K.   


6. Select the oldkeys_Philips.ini file. 


7. Click the Open button. 


8. Alongside the New Key File textbox, click the  button. 


9. Browse to IXP220\keys\4K.   


10. Select the newkeys_Philips.ini file. 


11. Click the Open button. 


12. Alongside the Default Key File textbox, click the  button. 


13. Browse to IXP220\keys\4K.   


14. Select the defaultkeys_Philips.ini file. 


15. Click the Open button. 


16. Click the Check Key Files button. 


17. At the Information dialog, click the OK button. 


18. Click the Quit button. 


 


WWrriittiinngg  TTeemmppllaatteess  ttoo  tthhee  MMIIFFAARREE®®  TTaagg  


Editing the Biometric.properties File 


1. Browse to C:\IXP220\Biometric.properties.   


2. Set the server.drivers.Sagem.enroll.writeToTag=false property to True. 


3. From the drop-down menu, select File>Save. 


4. Click the  button. 







 Part 8 – Integration Modules 


 


February 2012  39 


Setting Truncation for Enrollment 


1. From Windows® select Start>All Programs>IXP220>IXP220. 


2. From the Main Menu, select File>Preference. 


3. Select the Enrollment Tab. 


4. From the Tag Code Truncation group, from the 3rd Party Other drop-down list, select 24 


bits.  


5. Click the  button. 


 


Tagholder Setup 


1. Select the  Page Tab. 


2. Open a new or existing Tagholder record for editing. 


3. In the Tagholder dialog, select the Tag Tab. 


4. Click one of the assigned Tag buttons (that is Tag 1, Tag 2, Tag 3 or Tag 4) or select one of 


the Create New Tag buttons. 


5. From the Configuration Level group, select the Advanced Configuration radio button. 


6. Have the Tagholder place his/her Tag on the Enrollment Reader. 


7. Click Read Tag. 


8. Set the Access Rights group options as you require. 


9. Click the  button. 


10. Click on the Biometric Enrollment button. 


 


 
Figure 21 – Biometric Enrollment Dialog 


 


11. In the Biometric Enrollment dialog, from the Device drop-down list, select the type of 


device you wish to enroll the user on, in this case Sagem.  


12. Place your MIFARE® Tag on the SDI010 Contact or Contactless Reader. 


13. Click on the Enroll button, thereby initiating the enrollment.  


14. If you enrolled your template previously, and therefore wish to write an existing template to 


the MIFARE® Tag, click on the Write button.  Otherwise, continue with the enrollment 


procedure as outlined under Enrollment Procedure at the Sagem MSO300 (below).   


 


Enrollment Procedure at the Morpho MSO300 


 


 


The number of times you present your finger depends on whether you have duplicate checking 


enabled.   
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1. Place Finger 1 (fingerprint down) on the MSO300 Enrollment Reader’s fingerprint Sensor. 


2. Remove Finger 1 from the Sensor. 


3. Place Finger 1 on the Sensor a second time.  


4. Again, remove Finger 1 from the Sensor. 


5. Place Finger 2 (fingerprint down) on the MSO300 Enrollment Reader’s fingerprint Sensor. 


6. Remove Finger 2 from the Sensor. 


7. Place the Finger 2 on the Sensor a second time. 


8. Again, remove Finger 2 from the Sensor. 


 


Once the enrollment is complete, the Template field displays the Template Number and an 


Enrollment Successful message appears in the Status Bar. 


 


9. Click the Write button. 


10. Click the  button. 


11. Click the  button.  


 


The enrollment process is now complete.  Repeat this process for each Tagholder, as required. 
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ImproX B-SHO Fingerprint Terminals Use 
in an IXP220 System 


General 


This section guides you step by step through the process of setting up ImproX B-SHO 


Fingerprint Terminals to work with the IXP220 System.  The requirements for the integration are 


as follows: 


 


 IXP220 Access Control System. 


 IXP220 V1.80 (and Service Pack 1) or later Installed. 


 


There are four steps in configuring the Fingerprint Terminals to work with IXP220.  These are: 


 


1. Hardware installation of the Fingerprint Terminals. 


2. Detection of the Fingerprint Terminals on the RS485 bus. 


3. Setting up the Enrollment Reader. 


4. Enrolling users on the System. 


 


Principle of Operation 


 
Figure 22 – Tag and Template data flow when using a B-SHO Fingerprint Terminal with IXP220 
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Hardware Installation of ImproX B-SHO Fingerprint Terminals  


The IXP220 System recognizes these Fingerprint Terminals in the same fashion as our ImproX 


Terminals.  Therefore, connect these Terminals to the IXP220 Controller’s Terminal Bus using 


the RS485 bus protocol.  As when using with associated ImproX Terminals, you may multi-drop 


up to 64 Terminal Fixed Addresses, including up to 16 B-SHO Terminals per IXP220 Controller.  


 


In situations that require heightened security, we recommend that you connect the ImproX       


B-SHO Fingerprint Terminal via an associated ImproX OSCAR Door Control Unit.  In all other 


instances multi-drop the Fingerprint Terminals direct from the Terminal Bus. 


 


 


Fall-back communications is NOT supported on sites using ImproX B-SHO Fingerprint Terminals. 


 


 


Figure 23, Figure 25 and Figure 24 show connections to the ImproX B-SHO Fingerprint Terminal, 


these connections remain the same for the ImproX B-SHO Keypad Fingerprint Terminal. 


 


 
Figure 23 -  Fingerprint Terminals Relationship with the Rest of the ImproX Product Range 
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Figure 24 – ImproX B-SHO Fingerprint Terminal Connected to the Controller via the Terminal Bus 
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Figure 25 – ImproX B-SHO Fingerprint Terminal Connected Via the ImproX OSCAR Door Control Unit 


 


CCoonnnneeccttiinngg  tthhee  IImmpprrooXX  BB--SSHHOO  UUSSBB  FFiinnggeerrpprriinntt  EEnnrroollllmmeenntt  RReeaaddeerr  


1. Plug the ImproX B-SHO USB Fingerprint Enrollment Reader or ImproX B-SHO BioMini 


USB Fingerprint Enrollment Reader into an unused USB Port on the PC. 


2. Follow the on-screen prompts for installation of the Enrollment Reader. 
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Configuring the Biometric Device 


Continue as follows for configuration into an IXP220 System: 


 


RRuunn  AAuuttoo--IIDD  ttoo  DDeetteecctt  yyoouurr  BB--SSHHOO  FFiinnggeerrpprriinntt  TTeerrmmiinnaallss  


Before you can use your Fingerprint Terminals, you must run the Auto-ID function to detect the 


hardware.   


 


To open the IXP220 Base Application, proceed as follows: 


 


1. In Windows®, click Start>All Programs>IXP220>IXP220. 


2. Enter your Username (SYSDBA) and Password (masterkey).  


3. From the Security Device Search drop-down list, select from the following choices: 


 


 


On first time installation of the IXP220 Software, the I do not have one choice is by default selected.  If 


the site has an ImproX RS connected that’s unlocked for a System 3 or System 4 then the IXP220 


Software starts up as a System 1.  This means, no search is performed for the ImproX RS.   


 


 Automatically Search 


 Enter the COM Port Name  


 I do not have one 


4. Click the  button. 


 


After completing the login action, the Automatic Database Upgrade Utility checks the 


database version.  If the Utility confirms the Database is older than that needed by the Software, 


perform the upgrade as follows: 


 


1. At the Warning dialog, click the OK button. 


2. In the Database Updater dialog, click the Upgrade button. 


3. At the Message dialog, click the OK button. 


 


The Auto-ID process differs across the different communication mediums; therefore continue 


with one of the following: 


 


Controller Connected to Host PC using RS485 (ImproX RS) 


1. From the Main Menu, select Hardware>Auto ID Units. 


2. At the Confirm Auto-ID dialog, click the OK button. 


3. From the Auto ID Communications Configuration dialog, select the appropriate Com Port 


record. 


4. From the list of devices displayed, in the Auto-ID Channel column, make your selection.  


5. Click the  button. 


6. At the Firmware Revision dialog, click the  button. 


 


Controller Connected to the Host PC using TCP/IP  


1. From the Main Menu, select Hardware>Auto ID Units. 


2. At the Confirm Auto-ID dialog, click the OK button. 


3. If your Controller does NOT appear in the Auto ID Communications Configuration dialog 


continue as follows: 
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When using IP Terminals, do not use the  button.  Instead, make use of the  button. 


 


a. Click the  button. 


b. In the Channel column, replace the default IP Address details with the IP Address of 


your Controller. 


c. Press Enter. 


 


Or alternatively continue as follows: 


  


a. Click the  button. 


b. In the Input dialog, enter the Subnet Mask details for your Network. 


c. Click the  button. 


 


 


The IP Door Controllers (Advanced) tab provides a list if the IP Terminals in the System as well as 


the IP Address of the Controllers they connect to.  When using IP Terminals over a WAN, change the 


Controller IP Address to the IP Address of the Router to ensure that the IP Terminal communicates 


correctly. To do this, continue as follows: 


 


1. On the Auto-ID Channel tab, click the  button.   


2. In the Input dialog, enter the Subnet Mask details for your network. 


3. Click the  button. 


4. Select the IP Door Controllers (Advanced) tab. 


5. In the Address column, enter the Public Static IP Address of the Router the Controller will use 


to communicate with the Terminal. 


6. In the Respond To Address column, enter the Public Static IP Address of the Router the 


Terminal will use to communicate with the Controller. 


7. If necessary, edit the Additional Timeout (0.1s) value. 


8. Continue with Auto-ID as normal. (See step 4 below). 


 


4. From the list of devices displayed, in the Auto-ID Channel column, make your selection.  


5. Click the  button. 


6. At the Firmware Revision dialog, click the  button. 


 


Controller Connected over a Wide Area Network (WAN) 


 


 


Controllers connected using a GSM Module do NOT support IP Terminals. 


 


1. At the Auto-ID is Recommended for New Sites dialog, click the Yes button. 


2. At the Confirm Auto-ID dialog, click the OK button. 


3. In the Auto ID Communications Configuration dialog, click the Import Channels button. 


4. Select the Discovery.txt file (originally exported from the Discovery Utility). 


5. Click the Open button. 


 


 


The IP Door Controllers (Advanced) tab provides a list of the IP Terminals in the System as well as 


the IP Address of the Controllers they connect to.  When using IP Terminals over a WAN, change the 


Controller IP Address to the IP Address of the Router to ensure that the IP Terminal communicates 


correctly. To do this, continue as follows: 
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1. On the Auto-ID Channel tab, click the Import Channels button.   


2. Select te Discovery.txt file (originally exported from the Discovery Utility). 


3. Click the Open button. 


4. Select the IP Door Controllers (Advanced) tab. 


5. In the Address column, enter the Public Static IP Address of the Router the Controller will use 


to communicate with the Terminal. 


6. In the Respond To Address column, enter the Public Static IP Address of the Router the 


Terminal will use to communicate with the Controller. 


7. If necessary, edit the Additional Timeout (0.1s) value. 


8. Continue with Auto-ID as normal. (See step 6 below). 


 


6. From the list of devices displayed, in the Auto-ID Channel column, make your selection.  


7. Click the  button. 


8. At the Firmware Revision dialog, click the  button. 


 


When hardware units are detected, they are added to the IXP220 Database and become 


available in the IXP220 Software.  Use your Unit Location Chart to re-name the Fingerprint 


Terminals. 


 


AAssssiiggnn  tthhee  FFiinnggeerrpprriinntt  TTeerrmmiinnaallss  


To assign the Fingerprint Terminals to a Controller, proceed as follows: 


 


1. Select the  Page Tab.  Within the previously selected Door Tab, you will notice a new set 


of Tabs activate.  These newly activated Tabs include a new Door Tab, an Entry Tab and an 


Exit Tab. 


2. Click the  button. 


3. In the Door Name textbox, assign the Door a suitable name. This Door Name textbox has a 


16 character limit. 


4. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—activates only the basic Access Control features. 


 Advanced Configuration—activates extra advanced features, for sites that need Daily 


Door Mode Patterns, Zones, Door Entry Codes and Alarm Arming. 


5. In the Reader Configuration group, alongside the Entry Reader textbox, click the Select 


button. 


6. In the Unassigned Readers dialog, from the list of displayed records, select a Reader (for 


example the ImproX B-SHO Fingerprint Terminal).   


 


 


In the Unassigned Readers dialog, reduce the number of Readers displayed by selecting a specific 


Controller from the Controller Filter drop-down list. 


 


7. Click the  button. 


8. Alongside the Exit Reader textbox, click the Select button.  


9. In the Unassigned Readers dialog, from the list of displayed records, select a Reader (for 


example the ImproX B-SHO Fingerprint Terminal).   


10. Click the  button. 


 


Entry or Exit Reader Configuration 


1. Select the Entry or Exit Tab. 
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The settings displayed on the Entry or Exit Tabs depend on the type of Terminal connected.   


Ignore references made to fields that do not display. 


 


2. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration 


 Advanced Configuration 


3. From the Miscellaneous group, from the RTE Mode drop-down list, make your selection 


from the following: 


 Normally Open 


 Normally Closed  


4. From the Reader Function drop-down list, make your selection from the following: 


 Access Control 


 Access Control + Time & Attendance 


5. From the Message Display Supervisor drop-down list, make your selection. 


6. From the Enable Off-line Validation drop-down list, make your selection from the following: 


 Disabled—disables off-line validation. 


 Enabled—enables off-line validation. 


 


 


ImproX iTT and ImproX iTRT units connected by IP will always run in Full Off-line Validation Mode. 


ImproX iTT and ImproX iTRT units connected by RS485 will run in Full Off-line Validation Mode when 


there are 1 000 Tags or less in the System.  Once this threshold is exceeded, it will switch over to 


Cached Off-line Validation Mode.  Cached Off-line Validation Mode relies on transactions in the ImproX 


iTT and ImproX iTRT Transaction Buffer to make access control decisions. 


 


7. From the DOS Mode group, from the DOS Mode drop-down list, make your selection from 


the following: 


 Normally Closed 


 Normally Open 


8. From the DOS Usage drop-down list, make your selection from the following: 


 Normal 


 Terminate Strike 


 Inhibit 


9. Edit the Strike Duration (0.1s) textbox, the default value is 40 (0.1s).  Setting the Strike 


Duration to 55555 toggles the Relay. 


10. Edit the Open Duration(s) textbox.  By default, the Open Duration is set to 0, disabling the 


Door Open Sensor (DOS).  


 


 


It is possible to drive a single Relay or use a single Door Open Sensor (DOS) for both entry and exit 


Readers, removing the need to wire up both Relays or both Door Open Sensors for a single door.  To 


do this, set the Strike Duration or Open Duration to 0 on one Reader.  The associated Reader is then 


able to use the Relay or DOS from the opposite Door.  When using an ImproX MDTA, the Open 


Duration and Strike Duration default to 0.  Therefore, setting the Strike Duration and Open Duration on 


the associated Reader allows the MDTA to use the opposite Reader’s Relay or DOS. 
 


A practical example would be: 


A Terminal, used for a reception entry and exit, only requires one Relay to open.  The entry Reader 


(Reader 1) has the Strike Duration set accordingly. Instead of bridging the Relay for the exit Reader 


(Reader 2), set the Strike Duration to 0.  This allows both the entry and exit Readers to drive Relay 1 


when someone presents an allowed Tag to either of the Readers. The same theory applies to the Door 


Open Sensor. 
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11. Enable End-of-line Sensing by selecting the Enable End-of-line Sensing checkbox. 


 


 


End-of-line Sensing lets the System raise an alarm when somebody bypasses the Door Open Sensor.  


That is, the System distinguishes between tampering on the circuit and closure of the Door Open 


Sensor.   End-of-line sensing on the IXP220 Controller, ImproX iTT (input 1 and 3 only) and iTRT (input 


1 and 3 only) is only possible if Door Open Sensing is configured.  Set End-of-line Sensing per Door. 


 


12. From the ON VALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


13. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


14. From the ON INVALID Tag group, from the LED Action drop-down list, select the required 


LED colour state and Duration. 


15. From the Buzzer Volume drop-down list, select the Buzzer volume and Duration. 


16. Click the  button. 


  


AAdddd  aa  ZZoonnee  


1. On the Configuration Pane, select the Zone Tab. 


2. Click the  button. 


3. In the Create Zone dialog, select a Controller from the Select Controller drop-down list. 


4. In the Zone Name textbox, assign the Zone a suitable name. 


5. Select one of the APB Mode (Anti-passback Mode) radio buttons: 


 Off  


 Relaxed 


 Strict 


6. Click the  button. 


 


AAdddd  DDoooorr  MMooddee  PPaatttteerrnnss  


The IXP220 Software supports a maximum of 8 Door Mode Patterns at each Door.   


 


1. On the Configuration Pane, select the Door Mode Pattern Tab. 


2. Click the  button. 


3. In the Pattern Name textbox, assign your Door Mode Pattern a suitable name. 


4. Click the  button. 


5. From the records displayed on the left-hand side of the Configuration Pane, select the 


newly created Door Mode Pattern record. 


6. Edit the following settings for the selected record: 


 Start Time  


 End Time 


 Mode  


 Finger (B-SHO)—make a selection from the choices presented.   


 


 


Finger (B-SHO) setting examples include:  No, “+Entry”, “+Exit”, “+Both”, “or Entry”, “or Exit”, “or Both”, 


“Finger only Entry”, “Finger only Exit” or “Finger only Both”.  These are explained as follows:   


 


 Selecting “+Entry”, “+Exit” or “+Both”, calls for Tagholders to present their Tag (MIFARE® or 


DESFIRE®) and their fingerprint at the ImproX B-SHO Fingerprint Terminal.   


 Selecting “or Entry”, “or Exit” or “or Both”, calls for Tagholders to present either their Tag or 


fingerprint at the ImproX B-SHO Fingerprint Terminal.   
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 For the following options, “Finger only Entry”, “Finger only Exit” or “Finger only Both”, only 


fingerprint presentation is allowed (the tag reader is disabled). 


 


 +PIN 


 +Reason 


 +Dual Tag 


 Record 


 Denied Alarm 


 LED 


7. Click the  button. 


8. Select the Advanced Configuration radio button.  


9. On the Configuration Pane, select the Door Tab. 


10. In the Daily Door Mode Patterns group, make your selections from the Day’s Door Mode 


Pattern drop-down lists.  


11. In the Zone group, select a Zone from the drop-down list. 


12. Click the  button. 


 


AAdddd  aa  TTaagghhoollddeerr  


To add a Tagholder, proceed as follows: 


1. Select the  Page Tab. 


2. Click the  button. 


3. In the Tagholder dialog, select the General Tab. 


4. Enter the Tagholder’s First Name. 


5. Enter the Tagholder’s Last Name. 


6. From the Configuration Level group, select from the following radio buttons: 


 Standard Configuration 


 Advanced Configuration 


 


 


The instructions below continue as for an Advanced Configuration.   


 


7. In the PIN Used with Tag textbox, enter a PIN-code of up to 4 digits.  (PIN-codes range 


from 2 to 65534). 


8. From the Department drop-down list, select a department name.  


 


 


Add extra Departments as follows: 


 


1. Click the Department button.   


2. Click the  button. 


3. In the Department textbox, enter a suitable name for the Department. 


4. Click the  button. 


5. Click the  button. 


 


Click the  button to edit a Department or the  button to delete a Department. 


 


 


The Send E-Mail button lets you send Tagholder details to interested parties.  The To textbox is 


mandatory, thus requiring data entry for successful e-mail transmission.  For e-mail setup information 


please refer to the section Preference Configuration (System Notification Tab) in Part 3 – General 


Configuration. 
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9. From the Type drop-down list make your selection.   


10. Complete other personal information as necessary. 


 


 


Add a Tagholder Image as follows: 


 


1. Click the  button.   


2. At the Open dialog, select the image file.  Image formats supported include:  jpg, jpeg, gif, tif 


and tiff.  The recommended resolution is 640 x 480 pixels. 


3. Click the Open button. 


 


For more information on the Live Video Image Capture feature ( ) please see Part 5 – Advanced 


Configuration. 


 


Clicking the  button opens the Edit dialog, allowing image cropping, rotation, resizing and use of an 


image mirror effect. 


 


11. Use the Note text area when entering further information about the Tagholder. 


12. Click the  button. 


 


AAssssiiggnn  TTaaggss  ttoo  TTaagghhoollddeerrss  


A Tagholder can have up to 4 Tags assigned to them.  To assign Tags to a Tagholder, proceed 


as follows: 


 


1. In the Tagholder dialog, select the Tag Tab. 


2. Click any of the Create New Tag buttons.   


 


 
Figure 26 – Tagholder Dialog (Showing the Tag Tab) 
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3. From the Configuration Level group, select one of the following radio buttons: 


 Standard Configuration—disables advanced configuration options. 


 Advanced Configuration—enables advanced configuration options. 


 


 


The instructions that follow continue as for an Advanced Configuration.  For a Standard Configuration 


ignore references made to fields that appear greyed out.     


 


4. Select from the following tasks in order to complete the Tag assignment process: 


 


Selecting a Registration Reader 


a. From the Miscellaneous group, select the Configure Reader button. 


b. In the Configure Tag Reader dialog, from the Use Registration Reader radio buttons, 


select one of the following: 


 Yes 


 No 


c. Click the  button. 


 


5. Click the  button. 


 


Biometric Enrollment 


1. From the Configuration Level group, select the Advanced Configuration radio button. 


2. In the Number textbox, enter a number. 


 


 


This number later links to the ID field (shown in Figure 27) this is the number under which the user’s 


data is saved when his or her fingerprints are enrolled in the units. 


 


3. Click on the Biometric Enrollment button. 


 


 
Figure 27 – Biometric Enrollment Dialog 


 


4. In the Biometric Enrollment dialog, from the Device drop-down list, select the type of 


device you wish to enroll the user on, in this case BSho.  


 


 


The Template No field appears greyed out as it does not apply to B-SHO units.  The ID field is the ID 


derived from the Tag Code (Number field) and is the number under which the user’s data is saved 


when his or her fingerprints are enrolled in the units.  The Template field remains empty until the 


enrollment is completed. 
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Advanced Button Options 


1. Click on the Advanced Button. 


 


 


We recommend that you leave the Quality Threshold set at 80.  You may however adjust this setting 


based on your preferences. 


 


2. From the No. Of Enrollments drop-down list, select 2.  This figure indicates that you intend 


enrolling 2 fingers.   


3. From the Enrollment Device drop-down list, select either Suprema BioMini or B-Sho Editor. 


4. Click the  button. 


 


 


The Query Templates button collects information from the B-Sho Readers, around the site, to see how 


many templates are on the Readers. 


 


Fingerprint Placement Rules 


Figure 28 shows the area of the fingerprint that contains the most information.  Therefore, when 


enrolling Tagholders, ensure they place their fingers as shown in Figure 29.   


 


 
Figure 28 – Area of the Fingerprint Containing the most Information 
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Figure 29 – Fingerprint Placement Rules (Generic Enrollment Reader, Fingerprint Sensor Shown) 


 


 


After enrollment, ensure that Tagholders use the Fingerprint Placement Rules shown in Figure 29 each 


time they present their finger to the ImproX B-SHO Fingerprint Terminal.  


 


Enrollment procedure at the ImproX B-SHO BioMini USB Fingerprint Enrollment Reader 


1. Click on the Enroll button, thereby initiating the enrollment.  


2. Enroll Finger 1 as follows: 


a. At the Acquisition Window dialog, place Finger 1 (fingerprint down) on the Enrollment 


Reader’s fingerprint Sensor. 


b. Remove Finger 1 from the Sensor. 


c. At the Template Captured dialog, click the Yes button thus accepting the template. 


d. Place Finger 1 on the Sensor a second time.  


e. Again, remove Finger 1 from the Sensor. 


f. At the Template Captured dialog, click the Yes button thus accepting the template. 


g. At the Acquisition Window dialog, place Finger 1 on the Sensor for matching purposes. 


3. Enroll Finger 2 as follows: 


a. Place Finger 2 (fingerprint down) on the Enrollment Reader’s fingerprint Sensor. 


b. Remove Finger 2 from the Sensor. 


c. At the Template Captured dialog, click the Yes button thus accepting the template. 


d. Place Finger 2 on the Sensor a second time.  


e. Again, remove Finger 2 from the Sensor. 


f. At the Template Captured dialog, click the Yes button thus accepting the template.  


g. At the Acquisition Window dialog, place Finger 2 on the Sensor for matching purposes. 
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Once the enrollment is complete, the Template field displays the Template Number and an 


Enrollment Successful message appears in the Status Bar.   


 


Access Rights Configuration 


1. From the Site drop-down list, select the Site name. 


 


 


Alternatively, click the  button to select the Access Group for the Tagholder across all Sites. 


 


2. From the Level drop-down list make your selection from the following choices: 


 Visitor 


 Normal 


 Supervisor 


 Administrator 


3. From the Access Group drop-down list, make a selection. 


 


 


Alternatively, click the  button to create a new Access Group. 


 


 


You must assign a Tagholder Access Group for the Tag to have any access rights. 


 


Tag Expiry Configuration 


For temporary Tagholders, proceed as follows: 


 


1. From the Start Date drop-down list, select a suitable start date. 


2. In the Start Time textboxes, enter a suitable start time. 


3. From the Expiry Date drop-down list, select a suitable expiry date. 


4. In the Expiry Time textboxes, enter a suitable expiry time. 


 


Message Configuration 


 


 


For information on adding Messages, refer to the Messages section in Part 3 – General Configuration. 


 


From the Message drop-down list, select a Message for display. 


 


 


Alternatively, click the  button to create a new Message. 


 


Miscellaneous Configuration 


 Reset APB—resets the Anti-passback (APB) status for an individual Tagholder. 


 Suspend—suspends the Tag in the event the Tag is lost or no longer required. 


 Usage—stores a description of the Tag’s usage. 


 Configure Reader—lets you select the Reader for use as the Registration Reader for the 


site. 


 Configure Biometric Reader—opens the Tagholder biometric configuration and enrollment 


settings.   
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General Details 


1. Click the  button. 


2. Click the  button. 


 


If necessary, repeat the Assign Tags to Tagholders procedure for any extra Tagholders. 


UUppllooaadd  FFiinnggeerrpprriinntt  TTeemmppllaatteess  


B-SHO templates upload as added.  If however, you modified Site Configuration information, or 


you want to add a batch of templates at once, use the BSHO Full Upload (Current Site) 


option.   


 


 


After performing a Full Upload, there is a time of adjustment needed by the ImproX B-SHO Fingerprint 


Terminal.  During this time the Terminal learns the best template read process, afterwards giving 


Tagholders improved fingerprint read times. 


 


Use this option as follows: 


 


1. From the Main Menu, select Configuration>BSHO Full Upload (Current Site). 


 


 
Figure 30 – B-SHO Full Upload Dialog 


 


2. Select the records for upload. 


3. Click the  button. 


 


Troubleshooting 


1. Clicking the Enroll button (accessed from the Biometric Enrollment dialog – see Figure 27) 


displays an Error dialog with the message “Enrollment failed!”.  Possible solutions to this 


problem include:  Check and make sure the ImproX B-SHO Enrollment Reader is plugged 


into the PC.  Alternatively, if the ImproX B-SHO Enrollment Reader is plugged in, restart the 


IXP220 Base Application.   
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2. At the Acquisition dialog, while enrolling fingerprints, the IXP220 Software asks the user to 


"Please Remove Finger".   The System fails to detect that the finger is NOT positioned 


on the Enrollment Reader.  As a solution to this, ensure the Enrollment Reader’s Sensor 


area is clean.   


3. At the Acquisition dialog, while enrolling fingerprints, the IXP220 Software asks the user to 


"Please Place Your First (or Second) Finger".  The System fails to detect the finger is 


already in position on the Enrollment Reader.  Scanning can only take place when the 


Sensor area’s red LED lights up.  When this problem occurs, remove the finger from the 


sensor area, place the finger back on the sensor area only when the Sensor’s red LED 


lights up.  


4. When told by the IXP220 Software that the fingerprint quality is below threshold. Follow 


finger placement rules to achieve a higher finger threshold percentage.  If you do not notice 


an improvement, drop the threshold to a lower value. 
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NITGEN Fingerprint Terminals Use in an 
IXP220 System 


General 


This section guides you step by step through the process of setting up NITGEN Fingerprint 


Terminals to work with the IXP220 System.  The requirements for the integration are as follows: 


 


 


Ensure that you unlock your Registration Interface (by purchasing a Biometric Unlock Code). 


 


 IXP220 Access Control System. 


 IXP220 V1.86 or later installed. 


 


There are five steps in configuring the Fingerprint Terminals to work with IXP220.  These are: 


 


1. Hardware installation of the Biometric Terminals. 


2. Setting up the Enrollment Reader. 


3. Detection of the Biometric Terminals on the TCP/IP bus. 


4. Software setup of the Biometric Terminals using the Biometric Server Software. 


5. Enrolling users on the System. 


 


Principle of Operation 


 
Figure 31 – Using NITGEN Fingerprint Terminals within the IXP220 System 
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Hardware Installation of NITGEN Fingerprint Terminals  


Each NITGEN Terminal must connect to the LAN to send and receive templates from the 


IXP220 Database.  The NITGEN Terminal must also connect to an associated ImproX Terminal 


(such as the ImproX TA, iTRT or the MfT) thus facilitating communication with the Controller.  


Please install the NITGEN Terminals as follows: 


 


 
Figure 32 – NITGEN Fingkey Terminal Connected to the IXP220 Controller 
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Figure 33 – NITGEN Fingkey Terminal Connected to the ImproX iTRT Terminal 
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Figure 34 – NITGEN Fingkey Terminal Connected to the ImproX MfT Terminal 
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Figure 35 – NITGEN Fingkey Terminal Connected to the ImproX TA Terminal 
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Figure 36 – NITGEN NAC-2500 or NAC-5000 Terminal Connected to the IXP220 Controller 
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Figure 37 – NITGEN NAC-2500 or NAC-5000 Terminal Connected to the ImproX iTRT Terminal 
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Figure 38 – NITGEN NAC-2500 or NAC-5000 Terminal Connected to the ImproX MfT Terminal 
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Figure 39 – NITGEN NAC-2500 or NAC-5000 Terminal Connected to the ImproX TA Terminal 
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CCoonnnneeccttiinngg  tthhee  NNIITTGGEENN  FFiinnggeerrpprriinntt  EEnnrroollllmmeenntt  RReeaaddeerr  


1. Browse to C:\IXP220\driver\NITGEN\Hamster II_III. 


2. Run the Setup.exe file. 


3. At the Welcome screen click the Next button. 


4. At the Windows Security dialog, select the Install This Driver Software Anyway option. 


5. At the Device Status screen, plug the NITGEN Fingerprint Enrollment Reader into an 


unused USB Port on the PC. 


6. At the Install Shield Wizard Complete screen, select the Device Diagnostic Tool checkbox. 


7. Click the Finish button. 


 


NITGEN Fingerprint Terminal Internal Parameter Setup  


 


 


Navigate within the Fingerprint Terminals internal parameters using either the Up and Down arrow 


keys or the numeric keypad.  Step back or exit from menu options using the ESC or Cancel buttons.      


 


1. On the Fingerprint Reader, press the Menu button. 


2. Enter the Network selection menu by selecting menu option 5. 


3. Press the ENT (Enter) button.  


4. Set the Terminal ID by selecting menu option 1.   


5. Press the ENT (Enter) button. 


6. Enter any UNIQUE (across all NITGEN Terminals installed) number between 1 and 2 000. 


7. Press the ENT (Enter) button. 


8. Set the IP Address by selecting menu option 2.   


9. Press the ENT (Enter) button. 


10. Within the TCP/IP menu, select option 1 to Use DHCP. 


11. Select the ON option. 


12. Press the ENT (Enter) button. 


13. Select option 5 to set the Server IP. 


14. Press the ENT (Enter) button. 


15. Enter the IP Address of the Host PC (running the Biometric Server Software). 


16. Press the ENT (Enter) button. 


17. Press the ESC (Escape) button. 


18. Leave the Port Number (menu option 4) set at the default of 7332. 


 


 


When changing the Port Number from the default, ensure that you change the Port Number setting in 


the Biometric Server Software.  On the Drivers menu, select Nitgen. Thereafter on the Configuration 


menu, select Nitgen>Properties to change the Port Number. 


 


Using NITGEN Terminals within the IXP220 System 


Once you’ve connected the NITGEN Terminals and configured them internally as described in 


the previous paragraphs, use the Terminals within the IXP220 System.  This section applies to 


the following supported NITGEN Fingerprint Terminals:  the NITGEN Fingkey Access Terminal, 


the NITGEN NAC-2500 Plus Terminal and the NITGEN NAC-5000 Terminal. 
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Each NITGEN Terminal used in the Biometric Server requires its own Unlock.  For details of the 


unlocking procedure refer to the section titled NITGEN Unlock Protection on page 70. 


 


The configuration of these Terminals within IXP220 is done using the Biometric Server Software, 


as follows: 


 


1. From Windows® select Start>Programs>IXP220>IXP220 


2. Enter your Username (SYSDBA) and Password (masterkey). 


3. From the File menu, select Biometric Server. 


 


DDeetteeccttiinngg  NNIITTGGEENN  TTeerrmmiinnaallss  oonn  tthhee  TTCCPP//IIPP  BBuuss  


1. From the Drivers menu, select Nitgen. 


2. At the Message dialog, click the OK button. 


3. On the Configuration menu, select Nitgen>Properties. 


4. Confirm that the Server Port and Server IP Address appear as specified under the section 


NITGEN Fingerprint Terminal Internal Parameter Setup. 


 


 


By default the Master ID is set at 00000. 


 


5. Enter a Password (from between 1 and 8 digits in length.  By default this password is set at 


00000). 


6. Click the Apply button. 


7. Close the Biometric Server, by clicking the  button. 


8. Close the IXP220 Software, by clicking the  button. 


9. From Windows® select Start>Programs>IXP220>IXP220. 


10. Enter your Username (SYSDBA) and Password (masterkey). 


11. From the File menu, select Biometric Server. 


12. On the Configuration menu, select Nitgen>Devices. 


13. Click the Search button. 


 


 


The Search may take some time, depending on how busy the network is.  After the Search finds the 


NITGEN units, they appear as records in the table.  The displayed units appear as follows: 


 


 All newly discovered units highlight in Green. 


 All units with changed IP Addresses highlight in Orange. 


 All units that are in the Database but have been found to be off-line or missing highlight in Red. 
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Figure 40 – NITGEN Devices Dialog 


 


 


The Enabled checkbox enables or disables each individual NITGEN unit on the network.  This means 


that you can carry out repairs on a unit without affecting the rest. 


The Enable / Disable All checkbox enables or disables all the NITGEN units on the network.   


The Server will not attempt communication with a disabled NITGEN unit. 


 


 


You will also notice a  button in the dialog.  This button allows manual deletion of the NITGEN 


Terminals from the database.  Note however, reintroduction of the NITGEN Terminal requires use of 


the Unlock. 


 


 


Enabled NITGEN Terminals display with their status shown as OK.  Clicking the User ID Check button 


displays the Template Comparison dialog.  This dialog shows the first 50 missing User IDs per 


Database.  You may export the full list of missing User IDs. 


 


14. Enable the NITGEN Fingerprint Terminals as required by selecting the associated 


Fingerprint Terminal’s Enabled checkbox. 


15. Click the  button. 


16. Now click on the Start button to get the Biometric Server running and ready to upload 


templates as you enroll users. 


 


BBiioommeettrriicc  SSeerrvveerr  QQuueeuuee  


All messages to NITGEN devices queue so that each device can be processed independently.  


The Unit Details tab shows the queue status and allows you to upload to each unit individually.  


 


This tab is also useful in identifying units having communication problems. 
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Figure 41 – Unit Details Tab 


 


The queue processes automatically during normal operation (that is after you press the Start 


button).  You may perform a full upload on a specific NITGEN Reader as follows: 


 


1. Select the unit record for update. 


2. From the menu, select the Full Upload option. 


 


NNIITTGGEENN  UUnnlloocckk  PPrrootteeccttiioonn    


The Unlock supplied with third-party integrated products, shows the products have our full 


factory level approval.  This means the products work seamlessly with IXP220, with central 


enrollment taking place in the IXP220s Tagholder Enrollment screen.  The Unlock allows 


intelligent distribution of templates (uploading of templates only to Terminals where the 


Tagholder has access).  In instances where NITGEN Terminals are purchased from Impro, the 


Factory unlocks the Terminal prior to shipment.  In instances where the Terminal does not come 


from the Impro Factory, please unlock NITGEN Terminals as follows: 


 


1. At the License Information dialog, click the Unlock button. 


2. At the Device Unlock dialog, click the Import button. 


3. Select the Unlock.xml file for import (contact Impro’s Support team for further information 


on sourcing this file). 


4. Click the Open button. 


5. At the Message dialog, click the OK button. 


6. At the Device Unlock dialog, click the OK button. 


 


On unlock, the Biometric Server Software opens allowing full use of the Software. 
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EEnnrroolllliinngg  UUsseerrss  oonn  tthhee  SSyysstteemm  


Setting Truncation for Enrollment 


1. From Windows® select Start>Programs>IXP220>IXP220. 


2. From the Main Menu, select File>Preference. 


3. Select the Enrollment tab. 


4. Alongside the 3rd Party (Other) option, click the Truncation button. 


5. From the Tag Format drop-down list, select the Standard 16-bit option. 


6. Click the  button.  


7. Close the Preference Configuration dialog by clicking the  button. 


 


Tagholder Setup 


1. Select the  Page Tab. 


2. Open a new or existing Tagholder record for editing. 


3. In the Tagholder dialog, select the Tag Tab. 


4. Click one of the assigned Tag buttons (that is Tag 1, Tag 2, Tag 3 or Tag 4) or select one of 


the Create New Tag buttons. 


5. From the Configuration Level group, select the Advanced Configuration radio button. 


6. Have the Tagholder place their Tag on the Enrollment Reader. 


7. Click the Read Tag button (or just enter a number of 7 digits or less in the Number field). 


8. Set the Access Rights group options as you require. 


9. Click the  button. 


10. Click on the Biometric Enrollment but 


 


 
Figure 42 – Biometric Enrollment Dialog 


 


11. In the Biometric Enrollment dialog, from the Device drop-down list, select the type of 


device you wish to enroll the user on, in this case Nitgen.  


 


 


The Template No field will be greyed out as it does not apply to NITGEN units. Other Biometric 


Devices allow you to enroll multiple templates per user.  NITGEN units enroll two fingers and store 


them as one template, not allowing multiple templates per ID. 


 


 


The ID field is the ID derived from the Tag Code and is the number under which the user’s data is 


saved when his or her fingerprints are enrolled in the units. 
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The Template field remains empty until the enrollments completed.  


 


12. Click on the Advanced button. 


 


Advanced Settings 


Clicking the Advanced button makes the following settings available for change: 


 


 Enroll Image Quality—this is the quality setting that will be applied during the enrollment of 


the fingerprint.  By default the Enrollment Image Quality is set to 50.  Reducing this figure 


will result in a poorer quality fingerprint image.  Increasing this figure ensures a higher 


quality fingerprint image. 


 Verify Image Quality—quality level of the fingerprint image for verification.  The value 


range is from 0 to 100. The default value is 30. 


 Security Level—select from one of the following options:  Lowest, Lower, Low, Below 


Normal, Normal, Above Normal, High, Higher, Highest.  By default the Security Level is set 


at Normal.  If the level is set to a low setting, the False Acceptance Rate (FAR) increases 


and False Rejection Rate (FRR) decreases.  If set to a high setting, False Acceptance Rate 


(FAR) decreases and False Rejection Rate (FRR) increases. 


13. Click on the Enroll button, thereby initiating the enrollment.  
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Fingerprint Placement Rules 


Figure 43 shows the area of the fingerprint that contains the most information.  Therefore, when 


enrolling Tagholders, ensure they place their fingers as shown in Figure 44.  


 


 
Figure 43 – Area of the Fingerprint Containing the most Information 


 


 
Figure 44 – Fingerprint Placement Rules (Generic Enrollment Reader, Fingerprint Sensor Shown) 
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Enrollment procedure at the NITGEN Fingkey Hamster II™ 


 


 


Enrollment can take place using either a single finger or multiple fingers per user.  Regardless of the 


number of fingers enrolled, configure the Biometric Server to upload either one or two templates per 


user.  By default two templates upload. 


 


1. At the NITGEN Biometric Solutions dialog, click the Next button. 


2. Select Finger 1 for use during enrollment, by clicking on the corresponding dot above the 


fingertip. 


3. Place the corresponding Finger (fingerprint down) on the NITGEN Fingkey Hamster II™ 


fingerprint Sensor. 


4. Remove the Finger from the Sensor. 


5. Place the Finger on the Sensor a second time.  


6. Again, remove the Finger from the Sensor. 


7. Select Finger 2 for use during enrollment, by clicking on the corresponding dot above the 


fingertip. 


8. Place the corresponding Finger (fingerprint down) on the NITGEN Fingkey Hamster II™ 


fingerprint Sensor. 


9. Remove the Finger from the Sensor. 


10. Place the Finger on the Sensor a second time.  


11. Again, remove the Finger from the Sensor. 


12. Click the Next button to end the enrollment process. 


13. Click the Finish button. 


 


Once the enrollments complete, the Template field displays the Template Number and an 


Enrollment Successful message appears in the Status Bar. 


 


14. Click the  button. 


15. Click the  button.  


 


The enrollment process is now complete.  Repeat this process for each Tagholder, as required. 


 


 


With the Biometric Server running, the Server automatically uploads templates to the NITGEN 


Terminals. 


 


 


USER NOTES 


 
 


 


 


 


 


 


 


 


 


 


 


ISW300-0-0-GB-09 Issue 10 February 2012 
IXP220\Software\English Manuals Branded\LATEST 


ISSUE\P8 220-swmb-en-10.docx 
 





		PART 8 – INTEGRATION MODULES

		Contents

		Introduction

		Morpho (Sagem) Reader Use in an IXP220 System

		General

		Principle of Operation

		Hardware Installation

		Connection to the MA100, MA120, MA200, MA300, MA500 or MA520 to the IXP220 Controller

		Connection to the MA100, MA120, MA200, MA300, MA500 or MA520 to the ImproX iTRT

		Connection to the MA100, MA120, MA200, MA300, MA500 or MA520 to the ImproX MfT

		Connection to the MA100, MA120, MA200, MA300, MA500 or MA520 to the ImproX TA

		Connection to the MorphoAccess™ J-Bio or J-Dual to the IXP220 Controller

		Connection to the MorphoAccess™ J-Bio or J-Dual to the ImproX iTRT

		Connection to the MorphoAccess™ J-Bio or J-Dual to the ImproX MfT

		Connection to the MorphoAccess™ J-Bio or J-Dual to the ImproX TA



		Installation and Setup of the MSO300 Enrollment Reader and Verification Dongle

		.NET Framework Installation

		MSO300 Enrollment Device Driver Installation

		Verification Dongle Device Driver Installation

		SafeNet Dongle

		Morpho Dongle (MSO-EVerif)



		MSO300 Installation

		MSO300 Firmware Upgrade Procedure

		Verification Dongle Installation

		Morphokit Licensing Service Installation

		Creating a Data Execution Prevention Exception for Sagem Securite Licence Manager

		Morpho MSO300 Biometric Configuration

		Configure the Biometric Reader





		Morpho MA100, MA120, MA500 or J-Series Internal Parameter Setup

		USB Flash Disk Setup

		Setting up the Wiegand Configuration on an MA100, MA500 or J-Series

		Problems and Solutions





		Morpho MA200 or MA300 Internal Parameter Setup

		General

		Notes on Set-up for Morpho MA200 or MA300

		Internal Morpho Configuration Steps



		Configuration of Morpho Readers into the IXP220 System

		Detecting Morpho Readers on the TCP/IP Bus

		Biometric Server Queue

		Duplicate Search (1:N Matching)

		Enabling Matcher in the Biometric Server Software

		Enabling Duplicate Search at an Enrollment Station



		Morpho Dongle Protection using the Unlock Token

		Enrolling Users on the System

		Preference Setup

		Enrollment in the IXP220 Software

		Advanced Settings

		Fingerprint Placement Rules

		Enrollment procedure at the Sagem MSO300





		Configuration of MIFARE® Encoders into the IXP220 System

		MIFARE® Encoder Driver Installation

		SDI010 Contact (Smart) Card Reader Driver

		SDI010 Contactless Reader Driver



		MIFARE® Encoder Firmware Installation

		MIFARE® Encoder Configuration and Testing

		Key File Configuration



		Writing Templates to the MIFARE® Tag

		Editing the Biometric.properties File

		Setting Truncation for Enrollment

		Tagholder Setup

		Enrollment Procedure at the Morpho MSO300







		ImproX B-SHO Fingerprint Terminals Use in an IXP220 System

		General

		Principle of Operation

		Hardware Installation of ImproX B-SHO Fingerprint Terminals

		Connecting the ImproX B-SHO USB Fingerprint Enrollment Reader



		Configuring the Biometric Device

		Run Auto-ID to Detect your B-SHO Fingerprint Terminals

		Controller Connected to Host PC using RS485 (ImproX RS)

		Controller Connected to the Host PC using TCP/IP

		Controller Connected over a Wide Area Network (WAN)



		Assign the Fingerprint Terminals

		Entry or Exit Reader Configuration



		Add a Zone

		Add Door Mode Patterns

		Add a Tagholder

		Assign Tags to Tagholders

		Selecting a Registration Reader

		Biometric Enrollment

		Advanced Button Options

		Fingerprint Placement Rules

		Enrollment procedure at the ImproX B-SHO BioMini USB Fingerprint Enrollment Reader

		Access Rights Configuration

		Tag Expiry Configuration

		Message Configuration

		Miscellaneous Configuration

		General Details



		Upload Fingerprint Templates



		Troubleshooting



		NITGEN Fingerprint Terminals Use in an IXP220 System

		General

		Principle of Operation

		Hardware Installation of NITGEN Fingerprint Terminals

		Connecting the NITGEN Fingerprint Enrollment Reader



		NITGEN Fingerprint Terminal Internal Parameter Setup

		Using NITGEN Terminals within the IXP220 System

		Detecting NITGEN Terminals on the TCP/IP Bus

		Biometric Server Queue

		NITGEN Unlock Protection

		Enrolling Users on the System

		Setting Truncation for Enrollment

		Tagholder Setup

		Advanced Settings

		Fingerprint Placement Rules

		Enrollment procedure at the NITGEN Fingkey Hamster II™











